Personalización básica [Manual de personalización: ACG]

Personalización básica
Conceptos
Procedimientos
Referencia

    • AutoCAD® es un sistema de dibujo de propósito general basado en una arquitectura abierta que permite personalizar y ampliar sus numerosas funciones para modelar AutoCAD según las necesidades de cada usuario.

    • Presentación general de la personalización
    • Organización de archivos de programa y de soporte
      Puede modificar la estructura de directorios por defecto de los archivos de programa y de soporte para que se ajusten a sus necesidades.
    • Creación de barras de herramientas personalizadas
      Puede añadir botones a las barras de herramientas, eliminar los botones que menos utiliza y reorganizar los botones y las barras de herramientas. También puede crear sus propias barras de herramientas y crear o modificar el símbolo del botón asociado a un comando.
    • Adición de teclas de método abreviado a menús y barras de herramientas
      Puede asignar teclas de método abreviado (a veces llamadas aceleradores) a los comandos que utiliza con mayor frecuencia.
    • Personalización de una plantilla para publicar en sitio Web
      Puede crear plantillas personalizadas para utilizarlas en el Asistente para publicar en sitio Web modificando uno de los archivos de plantilla para publicar en sitio Web (PWT) suministrados. Utilice cualquier editor de HTML o de texto.
    • Definición de comandos personalizados
      Puede definir comandos externos que se ejecuten dentro de AutoCAD y crear alias de comandos para los comandos de AutoCAD en el archivo de parámetros del programa, acad.pgp, un archivo ASCII que almacena definiciones de comando.


Presentación general de la personalización [Manual de personalización: ACG]

Personalización básica
Presentación general de la personalización
Conceptos
Procedimientos
Referencia

    • AutoCAD se puede personalizar de formas muy sencillas, por ejemplo, modificando la estructura de directorios o moviendo un botón de una barra de herramientas a otra. Si desea realizar cambios más profundos en la interfaz, puede editar el archivo MNU y utilizar código del lenguaje DIESEL para crear menús con sus propios comandos.

    Asimismo, puede utilizar numerosas interfaces de programación de aplicaciones (API, Application Programming Interfaces) de gran eficacia para ampliar y modificar AutoCAD de manera que se ajuste a sus necesidades.

    La lista que aparece a continuación está organizada de forma aproximada por orden de complejidad:

    • Organización de archivos. Puede organizar los archivos de programa, de soporte y de dibujo. Por ejemplo, puede crear una carpeta distinta para cada proyecto que incluya únicamente los archivos de soporte. (Véase Organización de archivos de programa y de soporte.)
    • Modificación de la interfaz de usuario. El comando PERSONALIZAR abre cuadros de diálogo en los que es posible crear, modificar o eliminar barras de herramientas y botones de barra de herramientas, y asignar teclas de método abreviado a los comandos. (Véase Creación de barras de herramientas personalizadas y Adición de teclas de método abreviado a menús y barras de herramientas.)
    • Creación de plantillas personalizadas. Utilice plantillas para definir los parámetros comunes si publica un dibujo con ayuda del Asistente para publicar en sitio Web. (Véase Personalización de una plantilla para publicar en sitio Web.
    • Ejecución de utilidades y programas externos desde AutoCAD. Puede, por ejemplo, copiar un disco o suprimir un archivo desde AutoCAD añadiendo el comando externo adecuado al archivo de parámetros del programa (PGP), acad.pgp. (Véase Definición de comandos personalizados.)
    • Definición de alias de comandos. Es posible definir formas abreviadas o alias para los comandos que se utilizan con mayor frecuencia. Por ejemplo, puede hacer que el comando SOMBCONT se ejecute escribiendo s. (Véase Creación de alias de comandos.)
    • Creación de tipos de línea, patrones de sombreado, formas y tipos de letra de texto personalizados. Puede crear tipos de línea, patrones de sombreado, formas y tipos de letra de texto que se ajusten a los estándares y métodos de trabajo de su compañía. (Véase Tipos de línea personalizados, Patrones de sombreado personalizados y Formas y tipos de letra de formas.)
    • Edición del archivo de menús. El archivo de menús (MNU) es un archivo ASCII que controla diversos aspectos de la interfaz de usuario, incluidos el funcionamiento de los botones del dispositivo señalador y la funcionalidad y la apariencia de los menús desplegables, de tablero y de mosaico de imágenes, de las barras de herramientas y de los aceleradores. Puede editar el archivo MNU o crear uno nuevo para añadir comandos o combinarlos y asignarlos a un menú, a una barra de herramientas o a cualquier otra ubicación. (Véase Archivo de menús.)
    • Personalización de la línea de estado. Puede utilizar el lenguaje de expresión de cadena DIESEL y la variable de sistema MODEMACRO para proporcionar en la línea de estado información adicional como, por ejemplo, la fecha y la hora, los valores de las variables de sistema o información que pueda recuperarse utilizando AutoLISP®. (Véase Personalización de la línea de estado.)
    • Automatización de tareas repetitivas mediante la creación de archivos de comandos. Un archivo de comandos es un archivo de texto ASCII que contiene comandos que se procesan como un archivo por lotes cuando se ejecuta el archivo. Por ejemplo, si es necesario trazar un conjunto de dibujos de una forma concreta, puede crear un archivo de comandos que abra cada dibujo, oculte y muestre varias capas, y ejecute los comandos TRAZADOR. Puede utilizar archivos de comandos con fotos para crear presentaciones automatizadas como las que se emplean en las ferias de muestras. Una foto es una "instantánea" del área de dibujo que no se puede editar. Las fotos también se pueden utilizar en los menús de mosaico de imágenes y en los cuadros de diálogo. (Véase Fotos y archivos de comandos.)
    • Redefinición o desactivación de comandos seleccionados de AutoCAD, bien en la solicitud de comando o como parte de un programa de AutoLISP® u ObjectARX®. Puede redefinir ciertos comandos de AutoCAD para ejecutar mensajes e instrucciones adicionales o, por ejemplo, para crear un sistema de administración de dibujos en el que el comando QUITA se modifique para escribir la información de facturación en un archivo de registro antes de que finalice la sesión de edición. (Véase Introducción a las interfaces de programación.)

    Además de los métodos descritos en el Manual de personalización, existen interfaces de programación de aplicaciones (API) disponibles para la personalización de AutoCAD. En Introducción a las interfaces de programación se describen brevemente estas API y se incluyen referencias en las que se puede encontrar información adicional.

    Véase también

    Organización de archivos de programa y de soporte
    Creación de barras de herramientas personalizadas
    Adición de teclas de método abreviado a menús y barras de herramientas
    Personalización de una plantilla para publicar en sitio Web
    Definición de comandos personalizados
    Tipos de línea personalizados
    Patrones de sombreado personalizados
    Archivo de menús
    DIESEL
    Personalización de la línea de estado
    Introducción a las interfaces de programación
    Fotos y archivos de comandos


Ficha Procedimientos: Presentación general de la personalización [Manual de personalización: ACG]

Personalización básica
Presentación general de la personalización
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de la personalización [Manual de personalización: ACG]

Personalización básica
Presentación general de la personalización
Conceptos
Procedimientos
Referencia

    • Comandos

    PERSONALIZAR

    Personaliza barras de herramientas, botones, teclas de método abreviado y paletas de herramientas

    Variables de sistema

    TOOLTIPS

    Controla la visualización de las informaciones de herramientas


Organización de archivos de programa y de soporte [Manual de personalización: ACG]

Personalización básica
Organización de archivos de programa y de soporte
Conceptos
Procedimientos
Referencia

    • Puede modificar la estructura de directorios por defecto de los archivos de programa y de soporte para que se ajusten a sus necesidades.

    • Presentación general de la organización de archivos
    • Configuraciones múltiples
      Si utiliza más de un dispositivo señalador o distintos trazadores, puede crear más de un archivo de configuración para facilitar el cambio entre dispositivos.
    • Carpetas de dibujo múltiples
      Si guarda los dibujos y otros archivos relacionados en diferentes directorios, le resultará más fácil llevar a cabo las tareas sencillas de mantenimiento de archivos.


Ficha Procedimientos: Organización de archivos de programa y de soporte [Manual de personalización: ACG]

Personalización básica
Organización de archivos de programa y de soporte
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Organización de archivos de programa y de soporte [Manual de personalización: ACG]

Personalización básica
Organización de archivos de programa y de soporte
Conceptos
Procedimientos
Referencia

    • Comandos

    PERSONALIZAR

    Personaliza barras de herramientas, botones, teclas de método abreviado y paletas de herramientas

    Variables de sistema

    LOCALROOTPREFIX

    Almacena la ruta completa de la carpeta de en la que se instalaron los archivos personalizables

    ROAMABLEROOTPREFIX

    Almacena la ruta completa de la carpeta raíz en la que se instalaron los archivos personalizables

    TOOLTIPS

    Controla la visualización de las informaciones de herramientas


Ficha Procedimientos: Tipos de línea personalizados [Manual de personalización: ACG]

Tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • Para crear un tipo de línea sencillo

    Para incluir caracteres de texto en los tipos de línea


Ficha Referencia: Tipos de línea personalizados [Manual de personalización: ACG]

Tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • Comandos

    TIPOLÍN

    Carga, define y modifica tipos de línea

    Variables de sistema

    MEASUREINIT

    Define las unidades de dibujo iniciales como imperiales o métricas


Presentación general de la organización de archivos [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Presentación general de la organización de archivos
Conceptos
Procedimientos
Referencia

    • AutoCAD utiliza los archivos de la carpeta support, entre otros fines, para almacenar definiciones de menú, cargar aplicaciones de AutoLISP y ObjectARX y describir tipos de letra de texto.

    La estructura de directorios por defecto de los archivos de programa y de soporte de AutoCAD está diseñada para organizar los archivos en grupos lógicos de una forma que resulte eficiente. Si esta organización no se ajusta a sus necesidades, puede cambiarla. No obstante, algunas aplicaciones buscan determinados archivos en ubicaciones específicas, por lo que deberá comprobar que las modificaciones que desea realizar no son incompatibles con los requisitos de dichas aplicaciones. Sin la ruta completa, que incluye la unidad y el directorio, AutoCAD sólo puede encontrar los archivos ubicados en la ruta de búsqueda de biblioteca.

    La ubicación de la carpeta support cambió en AutoCAD 2004. La ubicación de los archivos personalizables locales se almacena en la variable de sistema LOCALROOTPREFIX. La ubicación de los archivos personalizables móviles se almacena en la variable de sistema ROAMABLEROOTPREFIX. Si una red admite la movilidad, los archivos personalizables del perfil móvil del usuario están disponibles en el equipo en el que se ha iniciado la sesión.

    El siguiente archivo de comandos LISP crea el comando CUSTFILES, que inicia Windows Explorer en la carpeta correcta.

    (defun c:custfiles ()
      (command "shell"
        (strcat "explorer \"" (getvar "roamablerootprefix") "\"")
      )
      (princ)
    )
    Ruta de búsqueda de biblioteca

    La ruta de búsqueda de biblioteca indica el lugar en el que el programa busca los archivos si no se ha especificado un nombre de ruta completo como se muestra a continuación:

    • Directorio actual. (Suele venir determinado por el valor "Comenzar en" del icono de acceso directo.)
    • Directorio que contiene el archivo de dibujo actual.
    • Directorios que aparecen en la ruta de búsqueda especificada en la ficha Archivos de OPCIONES. (Véase Definición de rutas de búsqueda, nombres y ubicaciones de archivos en la página 172 en el Manual del usuario.
    • Directorio que contiene los archivos de programa de AutoCAD.

    Dependiendo del entorno que se utilice, dos o más directorios pueden coincidir.

    Si un archivo no se encuentra en esta ruta de búsqueda, deberá especificar tanto el nombre de ruta como el nombre de archivo para que AutoCAD pueda encontrarlo. Por ejemplo, si desea insertar el dibujo pieza5.dwg en su dibujo actual y no se encuentra en la ruta de búsqueda de biblioteca, deberá especificar el nombre de ruta completo, como se muestra a continuación:

    Comando: insert

    Indique nombre de bloque o [?]: /archivos2/dibujsant/pieza5

    Si el dibujo existe en esa ubicación, AutoCAD le pedirá que finalice el comando INSERT de la forma habitual.

    Estructura de directorios

    AutoCAD utiliza directorios y subdirectorios con una estructura de árbol. Es recomendable no mezclar otros archivos (como aplicaciones de AutoLISP y archivos de menús) con los archivos de programa y de soporte de AutoCAD. Así resultará más sencillo localizar los posibles conflictos y actualizar cada aplicación sin alterar el resto.

    La ubicación por defecto de AutoCAD es la carpeta Archivos de programa. Puede crear un directorio nuevo en el mismo nivel, por ejemplo, /AplicsAcad, y guardar sus aplicaciones personalizadas de AutoLISP y Visual Basic, los archivos de menús y las aplicaciones de otros fabricantes en los subdirectorios del siguiente nivel. Si desea tener varios directorios de dibujos (para los distintos archivos de trabajo), puede crear un directorio como /TrabajosAcad, con subdirectorios para cada trabajo.

    Procedimiento de búsqueda de comandos

    Al escribir un comando, AutoCAD sigue una serie de pasos para evaluar la validez del nombre del comando. Existen comandos internos o variables de sistema, externos o alias definidos en el archivo acad.pgp, y comandos de AutoLISP definidos por el usuario. Los comandos también se pueden definir en las aplicaciones de ObjectARX o en un comando de controlador de dispositivo. Puede escribir los comandos en la línea de comando o seleccionarlos en el menú apropiado. Los comandos también se pueden introducir desde un archivo de comandos o mediante una aplicación de AutoLISP u ObjectARX.

    La siguiente lista describe el orden de búsqueda que AutoCAD sigue para validar un nombre de comando.

    1. Si los datos de entrada son una respuesta nula (BARRA ESPACIADORA o INTRO), AutoCAD utiliza el nombre del último comando ejecutado. AYUDA es el comando por defecto.
    2. AutoCAD compara el nombre del comando con la lista de comandos internos. Si el comando se encuentra en la lista y no va precedido de un punto (.), AutoCAD compara el comando con una lista de comandos no definidos. Si el comando no está definido, la búsqueda continúa. De lo contrario, se ejecuta el comando a no ser que exista alguna razón que lo impida. Quizá no sea posible su ejecución de forma transparente o en modo de perspectiva.
    3. AutoCAD compara el nombre del comando con los nombres de comandos definidos por un controlador de dispositivo y, a continuación, lo compara con los comandos definidos por el controlador de pantalla.
    4. AutoCAD compara el nombre del comando con los comandos externos definidos en el archivo de parámetros del programa (acad.pgp). Si el nombre del comando coincide con un comando externo definido, se ejecuta y la búsqueda se da por finalizada.
    5. AutoCAD compara el nombre del comando con la lista de comandos definidos por las aplicaciones de AutoLISP y ObjectARX. En este punto se carga un comando de carga automática.
    6. AutoCAD compara el nombre del comando con la lista de variables de sistema. Si el nombre del comando se encuentra en la lista, AutoCAD ejecuta el comando MODIVAR utilizando los datos de entrada como nombre de la variable.
    7. Si el nombre del comando coincide con el alias de un comando definido en el archivo de parámetros del programa, AutoCAD utiliza el nombre del comando ampliado y continúa con la búsqueda comenzando de nuevo con la lista de comandos internos.
    8. Si todos los pasos anteriores fallan, la búsqueda finaliza con un mensaje de advertencia sobre los nombres de comandos no válidos.

    Véase también

    Presentación general de la carga automática de AutoLISP en la página 256

    Definición de rutas de búsqueda, nombres y ubicaciones de archivos en el Manual del usuario


Ficha Procedimientos: Presentación general de la organización de archivos [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Presentación general de la organización de archivos
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de la organización de archivos [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Presentación general de la organización de archivos
Conceptos
Procedimientos
Referencia

    • Comandos

    OPCIONES

    Personaliza los parámetros de AutoCAD

    Variables de sistema

    LOCALROOTPREFIX

    Almacena la ruta completa de la carpeta de en la que se instalaron los archivos personalizables

    ROAMABLEROOTPREFIX

    Almacena la ruta completa de la carpeta raíz en la que se instalaron los archivos personalizables


Configuraciones múltiples [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Configuraciones múltiples
Conceptos
Procedimientos
Referencia

    • Al configurar AutoCAD para un dispositivo señalador y controladores de trazadores, la información facilitada por el usuario queda registrada en un archivo de configuración. La ubicación por defecto del archivo de configuración acad2004.cfg se muestra en la ficha Archivos del cuadro de diálogo Opciones (Menú, Ayuda y Nombres de archivos varios), pero puede especificar una ruta o nombre de archivo (o ambos) diferente.

    Normalmente, basta con una única configuración, pero en algunas ocasiones se necesitan varias. Por ejemplo, si casi siempre utiliza el ratón en su trabajo pero, de forma ocasional, necesita un tablero digitalizador de gran tamaño, puede modificar el sistema para que trabaje con varias configuraciones y evitar, así, tener que volver a configurar cada vez que cambie de dispositivo.

    Los valores de un gran número de variables de sistema de AutoCAD y las opciones de configuración del cuadro de diálogo Opciones se almacenan en el archivo de configuración. Si desea asignar distintos valores a las variables y los parámetros de funcionamiento, puede guardarlos en archivos de configuración diferentes. Para consultar una lista de las variables de sistema y el lugar en el que se almacenan, véase Variables de sistema en la Lista de comandos de AutoCAD.

    Si quiere utilizar la característica de configuraciones múltiples, debe configurar AutoCAD para que use distintos archivos de configuración. Utilice el conmutador /c para especificar distintos archivos de configuración en el inicio.

    Véase también

    Personalización del inicio en el Manual del usuario


Ficha Procedimientos: Configuraciones múltiples [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Configuraciones múltiples
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Configuraciones múltiples [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Configuraciones múltiples
Conceptos
Procedimientos
Referencia

    • Comandos

    OPCIONES

    Personaliza los parámetros de AutoCAD

    Variables de sistema

    No hay entradas.


Carpetas de dibujo múltiples [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Carpetas de dibujo múltiples
Conceptos
Procedimientos
Referencia

    • El uso de varios directorios de dibujo no sólo resulta más cómodo sino que, en muchas ocasiones, es imprescindible. Si guarda los dibujos y otros archivos relacionados en diferentes directorios, le resultará más fácil llevar a cabo las tareas sencillas de mantenimiento de archivos. La situación que se describe en este tema está basada en la estructura de directorios de ejemplo incluida en Presentación general de la organización de archivos, pero puede ampliarla o modificarla si lo desea para que se ajuste mejor a sus necesidades.

    Puede configurar el directorio /TrabajosAcad para que contenga los subdirectorios de dibujo. Dentro de estos subdirectorios puede haber otros subdirectorios que contienen los archivos de soporte relacionados con un trabajo o tipo de dibujo concreto. El directorio /TrabajosAcad/Trabajo1/Soporte puede contener bloques y archivos de AutoLISP específicos de los archivos de dibujo de /TrabajosAcad/Trabajo1. Especificar soporte (sin prefijo de ruta) en la ruta de soporte añade el directorio soporte del directorio actual a la ruta de soporte. Si utiliza el cuadro de diálogo Opciones para especificar un directorio, AutoCAD creará una ruta de código a ese directorio. Para utilizar la convención de nomenclatura relativa descrita anteriormente, debe especificar la ruta de soporte con el conmutador /s en la línea de comando. Véase Personalización del inicio en el Manual del usuario.

    Si se asegura de que el directorio de dibujo requerido es el directorio actual al iniciar AutoCAD, podrá acceder fácilmente a todos los archivos y subdirectorios de dicho directorio. Puede crear un icono de programa o elemento del menú Inicio que especifique el directorio de trabajo correcto de cada trabajo.

    Puede utilizar un programa de procesamiento por lotes en lugar de los menús e iconos. Estos programas permiten crear nuevos directorios de trabajo de forma automática. El siguiente programa de procesamiento por lotes comprueba que un directorio determinado existe, lo establece como actual y, a continuación, ejecuta AutoCAD.

    @echo off
    C:
    if exist \TrabajosAcad\Trabajos\%1 goto RUNACAD
    echo.
    echo *** Creando \TrabajosAcad\Trabajos\%1
    echo *** Pulse Ctrl+C para cancelar.
    echo.
    pause
    mkdir \TrabajosAcad\Trabajos\%1
    :RUNACAD
    cd \TrabajosAcad\Trabajos\%1
    start C:\AutoCAD\acad.exe

    Con el Bloc de notas o cualquier otro editor de texto ASCII, guarde este programa de procesamiento por lotes en un archivo llamado acad.bat. Asegúrese de cambiar el nombre de la unidad y del directorio para que coincidan con los de su sistema. Guarde este archivo en un directorio incluido en la ruta de búsqueda de su sistema (por ejemplo, C:\winnt). Puede ejecutar este programa de procesamiento por lotes con el comando Ejecutar del menú Inicio o haciendo doble clic en el archivo en el Explorador. Si ha guardado el archivo como acad.bat, utilice la siguiente sintaxis:

    acad nombretrabajo

    donde nombretrabajo es el nombre del directorio de trabajo que desea convertir en actual.


Ficha Procedimientos: Carpetas de dibujo múltiples [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Carpetas de dibujo múltiples
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Carpetas de dibujo múltiples [Manual de personalización: ACG]

Organización de archivos de programa y de soporte
Carpetas de dibujo múltiples
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Creación de barras de herramientas personalizadas [Manual de personalización: ACG]

Personalización básica
Creación de barras de herramientas personalizadas
Conceptos
Procedimientos
Referencia

    • Puede añadir botones a las barras de herramientas, eliminar los botones que menos utiliza y reorganizar los botones y las barras de herramientas. También puede crear sus propias barras de herramientas y crear o modificar el símbolo del botón asociado a un comando.

    • Creación, cambio de nombre y supresión de barras de herramientas
      Puede crear una barra de herramientas nueva, asignarle un nombre y añadir botones.
    • Modificación del aspecto de una barra de herramientas
      Puede ajustar la forma de la barra de herramientas, reordenar sus botones y añadir espacio entre ellos.
    • Creación y edición de botones en las barras de herramientas
      Tras crear una barra de herramientas, puede añadir botones suministrados por Autodesk o crear sus propios botones modificando los existentes.


Ficha Procedimientos: Creación de barras de herramientas personalizadas [Manual de personalización: ACG]

Personalización básica
Creación de barras de herramientas personalizadas
Conceptos
Procedimientos
Referencia

    • Para crear una barra de herramientas

    Para cambiar el nombre de una barra de herramientas

    Para borrar una barra de herramientas

    Para reordenar los botones de una barra de herramientas

    Para añadir espacio entre los botones de una barra de herramientas

    Para modificar la forma de una barra de herramientas flotante

    Para cambiar el aspecto o la accesibilidad de una barra de herramientas

    Para cambiar el comando asociado a un botón

    Para crear un icono desplegable

    Para editar o crear la imagen de un botón

    Para crear un nuevo botón para una barra de herramientas

    Para añadir un botón a una barra de herramientas

    Para borrar un botón de la barra de herramientas

    Para mover o copiar un botón desde otra barra de herramientas


Ficha Referencia: Creación de barras de herramientas personalizadas [Manual de personalización: ACG]

Personalización básica
Creación de barras de herramientas personalizadas
Conceptos
Procedimientos
Referencia

    • Comandos

    PERSONALIZAR

    Personaliza barras de herramientas, botones, teclas de método abreviado y paletas de herramientas

    Variables de sistema

    TOOLTIPS

    Controla la visualización de las informaciones de herramientas


Creación, cambio de nombre y supresión de barras de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación, cambio de nombre y supresión de barras de herramientas
Conceptos
Procedimientos
Referencia

    • Cuando cree una barra de herramientas nueva lo primero que debe hacer es asignarle un nombre. La nueva barra de herramientas se mostrará "vacía" o sin botones. Puede arrastrar a ella los botones que desee desde otras barras de herramientas o desde los comandos que aparecen en la lista de la ficha Comandos del cuadro de diálogo Personalizar.

    En el cuadro de diálogo Personalizar, en la ficha Barras de herramientas, la lista Grupos de menús muestra el grupo de menús al que está asociada la barra de herramientas seleccionada. Por ejemplo, ACAD representa al grupo de menús AutoCAD. El grupo de menús determina el archivo en el que se almacena la configuración de la barra de herramientas.

    Nota Si no ha personalizado barras de herramientas con anterioridad, intente experimentar con las nuevas barras antes de cambiar una existente.


Ficha Procedimientos: Creación, cambio de nombre y supresión de barras de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación, cambio de nombre y supresión de barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para crear una barra de herramientas

    Para cambiar el nombre de una barra de herramientas

    Para borrar una barra de herramientas


Ficha Referencia: Creación, cambio de nombre y supresión de barras de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación, cambio de nombre y supresión de barras de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    PERSONALIZAR

    Personaliza barras de herramientas, botones, teclas de método abreviado y paletas de herramientas

    Variables de sistema

    TOOLTIPS

    Controla la visualización de las informaciones de herramientas


Para crear una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación, cambio de nombre y supresión de barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para crear una barra de herramientas

    1. En el menú Herr., seleccione Personalizar y a continuación, elija Barras de herramientas.

    La ficha Barras de herramientas se seleccionará automáticamente.

    2. En la ficha Barras de herramientas, seleccione Nueva.
    3. En el cuadro de diálogo Nueva barra de herramientas, escriba el nombre que desee asignar a la barra de herramientas.
    4. En Salvar barra de herramientas en Grupos de menús, indique el grupo de menús asociado a la barra de herramientas.

    Un grupo de menús es un archivo que contiene un grupo de elementos de menú. El grupo de menús por defecto es ACAD y contiene el menú cargado por defecto en AutoCAD.

    5. Pulse Aceptar. A continuación, pulse Cerrar.

    Aparecerá una nueva barra de herramientas vacía. Ahora puede añadir botones a la barra de herramientas utilizando el método descrito en Para mover o copiar un botón desde otra barra de herramientas.

    Método rápido
    1. En el menú Herr., seleccione Personalizar y a continuación, elija Barras de herramientas.
    2. En la ficha Comandos, designe un comando de la lista y arrástrelo a un lugar vacío de la pantalla.

    Se creará automáticamente una barra de herramientas con el comando seleccionado.

    Línea de comando PERSONALIZAR


Para cambiar el nombre de una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación, cambio de nombre y supresión de barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para cambiar el nombre de una barra de herramientas

    1. En el menú Herr., seleccione Personalizar y a continuación, elija Barras de herramientas.

    La ficha Barras de herramientas se seleccionará automáticamente.

    2. En Barras de herramientas, designe la barra de herramientas cuyo nombre desee cambiar.
    3. Seleccione Cambiar nombre.
    4. En el cuadro de diálogo Cambiar nombre de barra de herramientas, introduzca un nuevo nombre.
    5. Pulse Aceptar. A continuación, pulse Cerrar.

    Línea de comando PERSONALIZAR


Para borrar una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación, cambio de nombre y supresión de barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para borrar una barra de herramientas

    1. En el menú Herr., seleccione Personalizar y a continuación, elija Barras de herramientas.

    La ficha Barras de herramientas se seleccionará automáticamente.

    2. En Barras de herramientas, designe la barra que desea suprimir.
    3. Elija Suprimir.

    Aparecerá un cuadro de confirmación.

    4. Pulse Aceptar para suprimir la barra de herramientas.
    5. Pulse Cerrar.

    Línea de comando PERSONALIZAR


Modificación del aspecto de una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Modificación del aspecto de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Puede ajustar la forma de la barra de herramientas, reordenar sus botones y añadir espacio entre ellos. A medida que vaya añadiendo o borrando botones de la barra de herramientas, ésta cambiará de tamaño automáticamente.

    También puede cambiar el tamaño de los botones y especificar la información que desea que se muestre cuando el cursor pase por encima de un botón.

    Cuando el cuadro de diálogo Personalizar está abierto, puede hacer clic con el botón derecho del ratón en cualquier botón y utilizar un menú contextual para:

    • Copiar o mover botones de una barra de herramientas a otra.
    • Editar botones.
    • Suprimir botones.
    • Reajustar las propiedades por defecto de un botón.
    • Visualizar las propiedades de los botones.


Ficha Procedimientos: Modificación del aspecto de una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Modificación del aspecto de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Para reordenar los botones de una barra de herramientas

    Para añadir espacio entre los botones de una barra de herramientas

    Para modificar la forma de una barra de herramientas flotante

    Para cambiar el aspecto o la accesibilidad de una barra de herramientas


Ficha Referencia: Modificación del aspecto de una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Modificación del aspecto de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    PERSONALIZAR

    Personaliza barras de herramientas, botones, teclas de método abreviado y paletas de herramientas

    Variables de sistema

    TOOLTIPS

    Controla la visualización de las informaciones de herramientas


Para reordenar los botones de una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Modificación del aspecto de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Para reordenar los botones de una barra de herramientas

    1. En el menú Herr., seleccione Personalizar y, a continuación, elija Barras de herramientas.

    Se visualizará el cuadro de diálogo Personalizar.

    2. Arrastre un botón a una nueva posición en cualquier barra de herramientas fija o flotante.

    Deberá arrastrar el botón hasta que cubra más de la mitad del botón que ya existía en la nueva posición.

    3. Pulse Cerrar para abandonar el cuadro de diálogo.

    Línea de comando PERSONALIZAR


Para añadir espacio entre los botones de una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Modificación del aspecto de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Para añadir espacio entre los botones de una barra de herramientas

    1. En el menú Herr., seleccione Personalizar y, a continuación, elija Barras de herramientas.

    Se visualizará el cuadro de diálogo Personalizar.

    2. En la barra de herramientas que desea modificar, arrastre el botón hacia el borde izquierdo o derecho del botón situado junto a él sin pasar del centro.
    3. Pulse Cerrar para abandonar el cuadro de diálogo.

    Línea de comando PERSONALIZAR


Para modificar la forma de una barra de herramientas flotante [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Modificación del aspecto de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Para modificar la forma de una barra de herramientas flotante

    • Para crear una barra de herramientas vertical, arrastre su borde inferior. Para crear una barra de herramientas horizontal, arrastre uno de sus bordes laterales.
    • Para crear una barra de herramientas cuadrada, arrastre una esquina hasta darle el tamaño deseado.

    Nota No es posible modificar la forma de las barras de herramientas fijas.


Para cambiar el aspecto o la accesibilidad de una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Modificación del aspecto de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Para cambiar el aspecto o la accesibilidad de una barra de herramientas

    1. En el menú Herr., seleccione Personalizar y, a continuación, elija Barras de herramientas.
    2. Configure la barra de herramientas activando o desactivando las siguientes opciones:
    • Botones grandes. Modifica el tamaño de los botones de 16 por 15 píxeles a 32 por 30 píxeles.
    • Mostrar información de herramientas. Muestra un rótulo emergente que describe cada botón cuando el cursor pasa por encima.
    • Mostrar métodos abreviados en información de herramientas. Muestra la tecla de método abreviado siempre que aparece una información de herramienta.
    3. Elija Cerrar para guardar las modificaciones que se hayan realizado.

    Para obtener más información acerca de la utilización de teclas de método abreviado para los botones, véase Adición de teclas de método abreviado a menús y barras de herramientas.

    Línea de comando PERSONALIZAR


Creación y edición de botones en las barras de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Tras crear una barra de herramientas, puede añadir botones suministrados por Autodesk o crear sus propios botones modificando los existentes.

    Creación de un icono desplegable

    Un icono desplegable es un conjunto de botones anidados bajo un botón situado en una de las barras de herramientas. Los botones de iconos desplegables presentan un triángulo negro en la esquina inferior derecha. Para crear un icono desplegable, añada una imagen de icono desplegable a un botón y asócielo a una barra de herramientas.

    Modificación de un botón

    Puede asociar botones a diferentes comandos o crear sus propios botones.

    Edición de la imagen de un botón

    AutoCAD proporciona imágenes de botones estándar para los botones que ejecutan los comandos de AutoCAD. Puede crear imágenes de botones personalizadas para ejecutar macros, modificando las imágenes de botones existentes o creando imágenes propias. Las imágenes de botones se guardan como archivos BMP. El archivo BMP debe guardarse en un directorio que se encuentre en la ruta de soporte.

    Véase también


Ficha Procedimientos: Creación y edición de botones en las barras de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para cambiar el comando asociado a un botón

    Para crear un icono desplegable

    Para editar o crear la imagen de un botón

    Para crear un nuevo botón para una barra de herramientas

    Para añadir un botón a una barra de herramientas

    Para borrar un botón de la barra de herramientas

    Para mover o copiar un botón desde otra barra de herramientas


Ficha Referencia: Creación y edición de botones en las barras de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    PERSONALIZAR

    Personaliza barras de herramientas, botones, teclas de método abreviado y paletas de herramientas

    Variables de sistema

    TOOLTIPS

    Controla la visualización de las informaciones de herramientas


Para cambiar el comando asociado a un botón [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para cambiar el comando asociado a un botón

    1. En el menú Herr., seleccione Personalizar y, a continuación, elija Barras de herramientas.
    2. Seleccione la ficha Propiedades. A continuación, elija el botón cuyo comando desee cambiar.
    3. En Macro asociada a este botón, modifique los datos del comando especificando un nuevo comando para el botón.

    En la mayoría de los comandos, se empieza con ^C^C para cancelar la ejecución y mostrar la solicitud de comando; un carácter de subrayado (_) permite que los comandos funcionen en las versiones internacionales de AutoCAD y un apóstrofo (') permite que el comando funcione de forma transparente. Siempre que asocie una serie de comandos a un botón, sepárelos con puntos y comas o espacios. El proceso de creación de macros de botones no difiere del empleado para crear macros de menús.

    Para obtener más información acerca de la utilización de comandos en macros, véase Creación de macros de menú.

    4. Pulse Aplicar. A continuación, pulse Cerrar.

    Línea de comando PERSONALIZAR


Para crear un icono desplegable [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para crear un icono desplegable

    1. En el menú Herr., seleccione Personalizar y, a continuación, elija Barras de herramientas.
    2. En el cuadro de diálogo Personalizar, seleccione la ficha Comandos.
    3. En la ficha Comandos, en Categorías, seleccione Definido por el usuario.
    4. Arrastre la imagen del icono desplegable del cuadro Comandos a la barra de herramientas de destino.

    Si no dispone de una barra de herramientas de destino, AutoCAD la creará al soltar el botón en cualquier lugar, siempre y cuando no se trate de otra barra de herramientas.

    5. En Barra de herramientas asociada a este icono desplegable, seleccione la barra de herramientas asociada.

    Los botones correspondientes a la barra de herramientas designada aparecen a la derecha del cuadro de lista. El último botón utilizado se mostrará como el botón del icono desplegable.

    6. Pulse Aplicar. A continuación, elija Cerrar o seleccione otra ficha.

    Línea de comando PERSONALIZAR


Para editar o crear la imagen de un botón [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para editar o crear la imagen de un botón

    1. En el menú Herr., haga clic en Personalizar [image] Barras de herramientas.

    La ficha Barras de herramientas se seleccionará automáticamente.

    2. En cualquier barra de herramientas, haga clic en el botón que desea modificar.

    La ficha Propiedades del botón se seleccionará automáticamente. El Editor de botones muestra la imagen del botón en la esquina superior izquierda del cuadro de diálogo.

    Nota Los botones de iconos desplegables no se pueden editar.

    3. Haga clic en Editar para abrir una vista en primer plano del botón.
    4. En el Editor de botones, seleccione una de las siguientes opciones:
    • Seleccione Rejilla para dividir la vista en una rejilla. Cada cuadro de la rejilla representa un píxel.
    • Haga clic en Abrir para abrir una imagen de botón existente.
    5. En el Editor de botones, utilice los botones Lápiz, Línea, Círculo y Borrar para crear o editar la imagen del botón. Para utilizar colores, seleccione un color de la paleta de colores o haga clic en Más para abrir la ficha Color verdadero del cuadro de diálogo Seleccionar color.
    • El botón Lápiz edita los píxeles de uno en uno en el color seleccionado. Si lo desea, puede arrastrar el dispositivo señalador para editar varios pixeles a la vez.
    • El botón Línea crea líneas del color seleccionado. Pulse el botón selector del dispositivo señalador para definir el primer punto final de la línea, arrastre para dibujar la línea y suelte el botón selector para completarla.
    • El botón Círculo crea círculos del color seleccionado. Pulse el botón selector del dispositivo señalador para definir el centro del círculo, arrastre para definir el radio y suelte el botón selector para completar el círculo.
    • El botón Borrar asigna a los píxeles el color blanco. Haga clic en Borrar para asignar a todos los píxeles el color blanco.
    6. Para almacenar el botón personalizado seleccione Guardar o utilice Guardar como para guardarlo con un nombre diferente.
    7. Haga clic en Cerrar para cerrar el Editor de botones. Para editar otro botón, selecciónelo en la lista que aparece debajo de Imagen de botón.
    8. Haga clic en Cerrar para salir del cuadro de diálogo Personalizar.

    Línea de comando PERSONALIZAR


Para crear un nuevo botón para una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para crear un nuevo botón para una barra de herramientas

    1. En el menú Herr., haga clic en Personalizar [image] Barras de herramientas.
    2. En la ficha Comandos del cuadro de diálogo Personalizar, seleccione Definido por el usuario en la lista Categoría.
    3. En Comandos, arrastre el botón definido por el usuario a una barra de herramientas existente. Para crear una barra de herramientas nueva, arrastre el botón a un espacio vacío de la pantalla.
    4. Seleccione el nuevo botón vacío para mostrar sus propiedades.

    La ficha Propiedades del botón se mostrará automáticamente.

    5. En la ficha Propiedades del botón, escriba el nuevo nombre del botón en el campo Nombre.
    6. En el campo Descripción, escriba el texto que desea que aparezca en la línea de estado.
    7. Para asociar un comando al botón, introduzca el comando correspondiente en la casilla Macro.

    En la mayoría de los comandos, se empieza con ^C^C para cancelar la ejecución y mostrar la solicitud de comando; un carácter de subrayado (_) permite que los comandos funcionen en las versiones internacionales de AutoCAD y un apóstrofo (') permite que el comando funcione de forma transparente. Siempre que asocie una serie de comandos a un botón, sepárelos con puntos y comas o espacios. El proceso de creación de macros de botones no difiere del empleado para crear macros de menús. Para obtener más información acerca de la utilización de comandos en macros, véase Creación de macros de menú.

    8. En la sección Imagen de botón, designe una imagen para el botón.
    9. Haga clic en Aplicar y cierre los cuadros de diálogo.

    Línea de comando PERSONALIZAR


Para añadir un botón a una barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para añadir un botón a una barra de herramientas

    1. Para mostrar la barra de herramientas que desea personalizar, haga clic con el botón derecho del ratón en cualquier barra de herramientas y selecciónela en la lista.
    2. En el menú Herr., haga clic en Personalizar [image] Barras de herramientas.
    3. En la ficha Comandos del cuadro de diálogo Personalizar, desactive la casilla de verificación situada junto a Mostrar imagen y nombre para que todos los símbolos de botones se muestren en Comandos.
    4. Arrastre el botón a la barra de herramientas a la que desee añadirlo.

    Observe cómo la barra de herramientas ajusta su tamaño para dar cabida a los nuevos botones que se vayan añadiendo.

    5. Haga clic en Cerrar para cerrar el cuadro de diálogo.

    Línea de comando PERSONALIZAR


Para borrar un botón de la barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para borrar un botón de la barra de herramientas

    1. En el menú Herr., haga clic en Personalizar [image] Barras de herramientas.

    La ficha Barras de herramientas se seleccionará automáticamente.

    2. Arrastre fuera de la barra de herramientas el botón que desee eliminar.
    3. Cuando aparezca el cuadro de diálogo de confirmación, haga clic en Aceptar.
    4. Haga clic en Cerrar para cerrar el cuadro de diálogo.

    Si suprime un botón suministrado por AutoCAD de una barra de herramientas, podrá restituirlo desde la ficha Comandos del cuadro de diálogo Personalizar barras de herramientas. Si suprime un botón que haya creado o personalizado usted mismo no podrá restituirlo.

    Línea de comando PERSONALIZAR


Para mover o copiar un botón desde otra barra de herramientas [Manual de personalización: ACG]

Creación de barras de herramientas personalizadas
Creación y edición de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para mover o copiar un botón desde otra barra de herramientas

    1. En el menú Herr., haga clic en Personalizar [image] Barras de herramientas.
    2. Para desplazar un botón desde una barra de herramientas a otra, arrastre el botón hacia la nueva barra.
    3. Para copiar un botón desde otra barra de herramientas, mantenga pulsada la tecla CTRL y arrastre la imagen del botón desde una barra de herramientas hasta la barra nueva.
    4. Haga clic en Cerrar para cerrar el cuadro de diálogo.

    Línea de comando PERSONALIZAR


Adición de teclas de método abreviado a menús y barras de herramientas [Manual de personalización: ACG]

Personalización básica
Adición de teclas de método abreviado a menús y barras de herramientas
Conceptos
Procedimientos
Referencia

    • Puede asignar teclas de método abreviado (a veces llamadas aceleradores) a los comandos que utiliza con mayor frecuencia. Por ejemplo, al pulsar CTRL+O se abre un archivo y al pulsar CTRL+S se guarda un archivo, tal y como ocurriría si eligiera Abrir o Guardar en el menú Archivo. Las teclas de método abreviado se pueden asociar tanto con los elementos de menú como con los botones de la barra de herramientas. Puede crear nuevas teclas de método abreviado o modificar las existentes.

    Los métodos abreviados se interpretan utilizando el estándar clásico de AutoCAD (de las versiones anteriores a Windows) o el estándar de Microsoft Windows. AutoCAD utiliza asignaciones internas de métodos abreviados cuando

    • en la ficha Preferencias de usuario del cuadro de diálogo Opciones no se ha seleccionado Aceleradores estándar de Windows
    • el archivo de menús acad.mnu no está cargado en el cuadro de diálogo Personalización de menús

    La siguiente tabla enumera las acciones por defecto para ambos tipos de configuraciones.
    Tecla(s) de método abreviado | Métodos abreviados clásicos de AutoCAD | Métodos abreviados de Windows
CTRL+A | Alterna la selección de grupos. | Designar objetos en el dibujo
CTRL+B | Alterna el modo Forzcursor. | Alterna el modo Forzcursor.
CTRL+C | Cancela el comando actual. | Copia objetos en el Portapapeles.
CTRL+D | Alterna la visualización de coordenadas. | Alterna la visualización de coordenadas.
CTRL+E | Hace un recorrido cíclico por los planos isométricos | Hace un recorrido cíclico por los planos isométricos
CTRL+F | Alterna la referencia a objetos en ejecución. | Alterna la referencia implícita a objetos.
CTRL+G | Alterna la visualización de la rejilla. | Alterna la visualización de la rejilla.
CTRL+H | (Sin asignar) | Alterna los valores de PICKSTYLE.
CTRL+J | Ejecuta el último comando. | Ejecuta el último comando.
CTRL+L | (Sin asignar) | Alterna el modo Orto.
CTRL+M | Repite el último comando. | (Sin asignar)
CTRL+N | (Sin asignar) | Crea un archivo de dibujo nuevo.
CTRL+O | Alterna el modo Orto. | Abre un dibujo existente.
CTRL+P | (Sin asignar) | Imprime el dibujo actual.
CTRL+R | (Sin asignar) | Recorre cíclicamente las ventanas de presentación
CTRL+S | (Sin asignar) | Guarda el dibujo actual.
CTRL+T | Alterna el modo Tablero. | Alterna el modo Tablero.
CTRL+V | Recorre cíclicamente las ventanas de presentación | Pega los datos del Portapapeles.
CTRL+X | Cancela la entrada actual. | Corta objetos en el Portapapeles.
CTRL+Y | (Sin asignar) | Repite la última acción.
CTRL+Z | (Sin asignar) | Invierte la última acción
CTRL+[ | Cancela el comando actual. | Cancela el comando actual.
CTRL+\ | Cancela el comando actual. | Cancela el comando actual.
F1 | Muestra el sistema de Ayuda | Muestra el sistema de Ayuda
F2 | Alterna la visualización de la ventana de texto. | Alterna la visualización de la ventana de texto.
F3 | Alterna la referencia a objetos. | Alterna la referencia a objetos.
F4 | Alterna el modo Tablero. | Alterna el modo Tablero.
F5 | Hace un recorrido cíclico por los planos isométricos. | Hace un recorrido cíclico por los planos isométricos.
F6 | Alterna la visualización de coordenadas. | Alterna la visualización de coordenadas.
F7 | Alterna la visualización de la rejilla. | Alterna la visualización de la rejilla.
F8 | Alterna el modo Orto. | Alterna el modo Orto.
F9 | Alterna el modo Forzcursor. | Alterna el modo Forzcursor.

    Véase también

    Archivo de menús


Ficha Procedimientos: Adición de teclas de método abreviado a menús y barras de herramientas [Manual de personalización: ACG]

Personalización básica
Adición de teclas de método abreviado a menús y barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para crear una tecla de método abreviado para una barra de herramientas o para un menú

    Para eliminar una tecla de método abreviado de una barra de herramientas o de un menú


Ficha Referencia: Adición de teclas de método abreviado a menús y barras de herramientas [Manual de personalización: ACG]

Personalización básica
Adición de teclas de método abreviado a menús y barras de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    PERSONALIZAR

    Personaliza barras de herramientas, botones, teclas de método abreviado y paletas de herramientas

    Variables de sistema

    TOOLTIPS

    Controla la visualización de las informaciones de herramientas


Para crear una tecla de método abreviado para una barra de herramientas o para un menú [Manual de personalización: ACG]

Personalización básica
Adición de teclas de método abreviado a menús y barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para crear una tecla de método abreviado para una barra de herramientas o para un menú

    1. En el menú Herr., seleccione Personalizar y, a continuación, elija Teclado.

    La ficha Teclado se seleccionará automáticamente.

    2. En Categorías designe la barra de herramientas o el menú que contenga el comando cuyas teclas de método abreviado desea modificar. Si no encuentra la categoría que busca, haga clic en AutoCAD Comandos para que se muestren todos los comandos de AutoCAD.
    3. En Comandos, seleccione el comando cuya combinación de teclas de método abreviado desee modificar.

    La tecla de método abreviado actual, si existe alguna, aparecerá en Teclas actuales.

    4. Haga clic dentro del cuadro Nueva tecla de método abreviado. Mantenga pulsado un modificador y, a continuación, pulse la tecla de una letra. Los modificadores pueden ser CTRL, ALT, CTRL+MAYÚS y ALT+MAYÚS.
    5. Actualmente asignada a: muestra la asignación actual (si existe) de la tecla de método abreviado. Si no desea sustituir la asignación actual, vuelva al paso 4 y utilice una tecla de método abreviado diferente.
    6. Elija Asignar y, a continuación, pulse Cerrar.

    Línea de comando PERSONALIZAR


Para eliminar una tecla de método abreviado de una barra de herramientas o de un menú [Manual de personalización: ACG]

Personalización básica
Adición de teclas de método abreviado a menús y barras de herramientas
Conceptos
Procedimientos
Referencia

    • Para eliminar una tecla de método abreviado de una barra de herramientas o de un menú

    1. En el menú Herr., seleccione Personalizar y, a continuación, elija Teclado.

    La ficha Teclado se seleccionará automáticamente.

    2. En Categorías seleccione la barra de herramientas o el menú que contenga el comando cuyas teclas de método abreviado desee suprimir. Si no encuentra la categoría que busca, haga clic en AutoCAD Comandos para que se muestren todos los comandos de AutoCAD.
    3. En Comandos, designe el comando cuya tecla de método abreviado desee suprimir.

    Nota si no encuentra el comando asociado a una tecla de método abreviado, escríbala en el cuadro Nueva tecla de método abreviado y pulse INTRO para ver qué comando tiene asignado.

    4. Elija Suprimir y, a continuación, pulse Cerrar.

    Línea de comando PERSONALIZAR


Personalización de una plantilla para publicar en sitio Web [Manual de personalización: ACG]

Personalización básica
Personalización de una plantilla para publicar en sitio Web
Conceptos
Procedimientos
Referencia

    • Puede crear plantillas personalizadas para utilizarlas en el Asistente para publicar en sitio Web modificando uno de los archivos de plantilla para publicar en sitio Web (PWT) suministrados. Utilice cualquier editor de HTML o de texto.

    Para crear una plantilla personalizada puede añadir o modificar cualquiera de los siguientes elementos:

    • Imágenes
    • Texto
    • Hipervínculos
    • Color
    • Título
    • Vídeo, animación, etc.

    Existen cuatro plantillas para publicar en sitio Web por defecto que puede personalizar:

    • Retícula de miniaturas: crea una página Web que incluye un conjunto de imágenes en miniatura.
    • Retícula y resumen: crea una página Web que contiene un conjunto de imágenes en miniatura además de información de resumen sobre cada una de ellas.
    • Lista de dibujos: crea una página Web que incluye una lista de dibujos y un marco de imagen.
    • Lista y resumen: crea una página Web que contiene una lista de dibujos, un marco de imagen e información de resumen acerca de la imagen seleccionada.

    Nota Es preciso que conozca la sintaxis HTML si necesita personalizar las plantillas para publicar en sitio Web.

    Puede realizar cambios y añadir elementos para definir el aspecto y el funcionamiento de las plantillas, pero no puede cambiar la organización de las imágenes que contienen. Por ejemplo, en la plantilla Array of Thumbnails, las imágenes están dispuestas en filas a lo largo de la página. No se puede alterar la presentación de las imágenes, pero se puede ajustar el texto y los gráficos a la tabla que contiene las imágenes.

    Advertencia Para garantizar de que no se sobrescriben los archivos de plantilla para publicar en sitio Web por defecto, haga una copia de seguridad de estos archivos antes de realizar ningún cambio en ellos.


Ficha Procedimientos: Personalización de una plantilla para publicar en sitio Web [Manual de personalización: ACG]

Personalización básica
Personalización de una plantilla para publicar en sitio Web
Conceptos
Procedimientos
Referencia

    • Para crear un acceso rápido a las plantillas para publicar en sitio Web

    Para personalizar una plantilla para publicar en sitio Web


Ficha Referencia: Personalización de una plantilla para publicar en sitio Web [Manual de personalización: ACG]

Personalización básica
Personalización de una plantilla para publicar en sitio Web
Conceptos
Procedimientos
Referencia

    • Comandos

    PUBLICARENWEB

    Crea páginas HTML en las que se incluyen imágenes de dibujos seleccionados

    Variables de sistema

    No hay entradas.


Para crear un acceso rápido a las plantillas para publicar en sitio Web [Manual de personalización: ACG]

Personalización básica
Personalización de una plantilla para publicar en sitio Web
Conceptos
Procedimientos
Referencia

    • Para crear un acceso rápido a las plantillas para publicar en sitio Web

    1. En el menú Herr., haga clic en Opciones.
    2. En la ficha Archivos del cuadro de diálogo Opciones, haga clic en el signo más situado junto a Parámetros de plantilla de dibujo y, a continuación, haga clic en el signo más situado junto a Ubicación del archivo de plantilla de dibujo.
    3. Desplace el cursor hasta el nombre de la ruta que aparece, haga clic dentro de él, pulse F2 y pulse CTRL+C para copiarla.
    4. Haga clic en Aceptar para cerrar el cuadro de diálogo Opciones.
    5. En el menú Archivo, haga clic en Abrir.
    6. En el cuadro de diálogo Seleccionar archivo, haga clic con el botón derecho del ratón en un área vacía del panel vertical situado a la izquierda y, a continuación, haga clic en Añadir en el menú contextual.
    7. Escriba un nombre en el campo Nombre de elemento (por ejemplo, Plantillas).
    8. Pulse CTRL+V para pegar la ruta en el campo Ruta del elemento y haga clic en Aceptar.

    De esta forma, podrá acceder a las carpetas de plantillas haciendo clic en el botón del panel izquierdo del cuadro de diálogo Seleccionar archivo.


Para personalizar una plantilla para publicar en sitio Web [Manual de personalización: ACG]

Personalización básica
Personalización de una plantilla para publicar en sitio Web
Conceptos
Procedimientos
Referencia

    • Para personalizar una plantilla para publicar en sitio Web

    1. En el menú Archivo, haga clic en Abrir y acceda a la carpeta de plantillas para publicar en sitio Web.

    Véase Para crear un acceso rápido a las plantillas para publicar en sitio Web.

    2. Haga doble clic en la carpeta PlantillasPTW para abrirla. Aparecerán las siguientes carpetas. Cada una de ellas contiene una plantilla para publicar en sitio Web e imágenes de vista preliminar (BMP) que puede ver al ejecutar el Asistente para publicar en sitio Web.
    • Template1. : contiene la plantilla Retícula de miniaturas (Array of Thumbnails) y una imagen de presentación preliminar
    • Template2. : contiene la plantilla Retícula y resumen (Array Plus Summary), una imagen de presentación preliminar y marcos HTML
    • Template3. : contiene la plantilla Lista de dibujos (List of Drawings), una imagen de presentación preliminar y marcos HTML
    • Template4. : contiene la plantilla Lista y resumen (List Plus Summary) , una imagen de vista preliminar y marcos HTML
    3. Haga clic con el botón derecho del ratón en la carpeta que desee utilizar y haga clic en Copiar.
    4. Pulse ALT+2, haga clic con el botón derecho del ratón en la carpeta PlantillasPTW y haga clic en Pegar.
    5. Vuelva a abrir la carpeta PlantillasPTW y haga clic con el botón derecho del ratón en la nueva carpeta para cambiarle el nombre.
    6. Haga clic con el botón derecho del ratón en la nueva carpeta y haga clic en Abrir para mostrar su contenido.
    7. Cambie el nombre del archivo de plantilla para publicar en sitio Web (PWT) con una extensión .htm o .html.
    8. Abra el archivo con un editor de HTML o de texto.

    El archivo de plantillas incluye comentarios que pueden ayudarle a determinar qué partes del código se pueden modificar para crear una nueva página Web.

    9. Revise los comentarios y haga cambios en aquellas partes de la plantilla que desee personalizar.
    10. Guarde la plantilla con la extensión .pwt. Asegúrese de guardar el archivo en la carpeta de plantillas que creó en el paso 3.

    Nota Cada carpeta de plantilla puede incluir sólo un archivo PWT. Si ha creado un archivo PWT nuevo, asegúrese de suprimir cualquier otro archivo PWT que pueda existir en la misma carpeta.

    Cuando ejecute el Asistente para publicar en sitio Web, la plantilla aparecerá en la lista de plantillas.


Definición de comandos personalizados [Manual de personalización: ACG]

Personalización básica
Definición de comandos personalizados
Conceptos
Procedimientos
Referencia

    • Puede definir comandos externos que se ejecuten dentro de AutoCAD y crear alias de comandos para los comandos de AutoCAD en el archivo de parámetros del programa, acad.pgp, un archivo ASCII que almacena definiciones de comando.

    • Definición de comandos externos
      Los comandos externos inician otros programas o utilidades mientras se ejecuta AutoCAD.
    • Creación de alias de comandos
      Un alias de comando es una forma abreviada que se escribe en la línea de comando en lugar del nombre completo del comando.


Ficha Procedimientos: Definición de comandos personalizados [Manual de personalización: ACG]

Personalización básica
Definición de comandos personalizados
Conceptos
Procedimientos
Referencia

    • Para abrir el archivo de parámetros del programa (acad.pgp)


Ficha Referencia: Definición de comandos personalizados [Manual de personalización: ACG]

Personalización básica
Definición de comandos personalizados
Conceptos
Procedimientos
Referencia

    • Comandos

    REINICIA

    Reinicia el digitalizador, los puertos de entrada y salida del digitalizador y el archivo de parámetros del programa

    Variables de sistema

    No hay entradas.


Definición de comandos externos [Manual de personalización: ACG]

Definición de comandos personalizados
Definición de comandos externos
Conceptos
Procedimientos
Referencia

    • Mientras se ejecuta AutoCAD, puede invocar otros programas o utilidades como las siguientes:

    • Utilidades y comandos de sistema de Windows, como start, type, dir o copy
    • Aplicaciones como editores o procesadores de texto
    • Administradores de bases de datos, hojas de cálculo y programas de comunicaciones
    • Programas suministrados por el usuario, como archivos de procesamiento por lotes o aplicaciones de Visual Basic

    Al escribir un comando que se sale de lo normal, AutoCAD lo busca en acad.pgp, un archivo incluido en la carpeta support de AutoCAD que almacena definiciones de comando. La primera sección de acad.pgp define los comandos externos. Puede añadir definiciones de comando editando acad.pgp en el Bloc de notas o en cualquier editor de texto que guarde archivos en formato ASCII. Para abrir el archivo PGP, en el menú Herr., haga clic en Personalizar [image] Editar archivos personalizados [image] Parámetros del programa (acad.pgp).

    Nota Antes de editar acad.pgp, es aconsejable crear una copia de seguridad para poder restaurar el archivo si es necesario.

    Al definir un comando externo, está especificando un nombre de comando que se utilizará en la solicitud de comando y una cadena de comando ejecutable que se pasa al sistema operativo. Cada línea de la sección de comandos externos tiene cinco campos delimitados por comas, como se muestra a continuación:

    comando,[ejecutable],indicadores[,[*]solicitud[,código_retorno]]

    comando

    Comando que se escribe en la solicitud de comando. Si se trata de un nombre de comando interno de AutoCAD, se pasará por alto. El nombre no distingue entre mayúsculas y minúsculas.

    ejecutable

    Cadena constante enviada al sistema operativo cuando se escribe el nombre del comando. Puede tratarse de cualquier comando que pueda ejecutarse en la solicitud de comando del sistema operativo. La cadena puede incluir conmutadores o parámetros. Dependiendo de la aplicación que se esté ejecutando, esta cadena distinguirá o no entre mayúsculas y minúsculas.

    indicadores

    Parámetro necesario con código de bits. Sume estos valores enteros en cualquier combinación para conseguir el resultado que busca.

    0 Inicia la aplicación y espera a que finalice.

    1 No espera a que finalice la aplicación.

    2 Ejecuta la aplicación minimizada.

    4 Ejecuta la aplicación "oculta".

    8 Coloca la cadena del argumento entre comillas.

    Los valores de bit 2 y 4 se excluyen mutuamente; si se especifican los dos, únicamente se utilizará el de 2 bits. Se debe evitar utilizar los valores 2 o 4 sin el valor 1, ya que AutoCAD no estará disponible hasta que la aplicación haya finalizado.

    El valor de bits 8 permite que comandos como del funcionen correctamente con los nombres de archivo que contienen espacios. Observe que esto elimina la posibilidad de pasar una lista de nombres de archivo delimitada por espacios a estos comandos. Si prefiere compatibilidad con varios archivos, no utilice el valor de bits 8.

    solicitud

    Campo opcional. Especifica la solicitud que se muestra en la línea de comando de AutoCAD. La respuesta a esta solicitud se añade a la cadena proporcionada en el campo ejecutable. Si el primer carácter del campo solicitud es un asterisco (*), la respuesta puede contener espacios y el usuario debe pulsar INTRO para finalizarla. De lo contrario, la respuesta finalizará con la BARRA ESPACIADORA o con INTRO. Si no se especifica ninguna solicitud, no se requerirá ninguna entrada; sin embargo, deberá añadir una coma si se debe proporcionar un código de retorno o si desea que la solicitud tenga un espacio a la derecha.

    código_retorno

    Parámetro con código de bits opcional. Puede sumar estos valores enteros en cualquier combinación para conseguir el resultado que busca. Por ejemplo, si se necesitan los valores 1 y 2, se utilizará 3 como código de retorno. Los valores están definidos de la siguiente manera (los códigos 0 y 4 son despreciables en un entorno de Windows y, por lo tanto, no se han incluido):

    1 Carga un archivo DXB. AutoCAD carga un archivo DXB llamado $cmd.dxb en el dibujo cuando finaliza el comando. Una vez cargado este archivo DXB, el archivo $cmd.dxb se suprime. Esta acción produce el mismo resultado que el comando CARGADXB.

    2 Construye una definición de bloque desde un archivo DXB. AutoCAD crea una definición de bloque desde el archivo DXB llamada $cmd.dxb. La respuesta del campo solicitud se utiliza como nombre del bloque. Este nombre debe ser un nombre válido de bloque que no exista en el dibujo; por ello, este modo no puede redefinir un bloque definido previamente. Cuando AutoCAD ha cargado el archivo DXB, el archivo $cmd.dxb se suprime. El nombre por defecto del comando INSERT se asigna al bloque recién definido.

    El archivo también puede contener líneas de comentarios precedidas por un punto y coma (;).

    Comandos de sistema de Windows

    Los comandos de sistema de Windows start y cmd resultan muy útiles al definir comandos externos. Si especifica una cadena ejecutable que no utilice los comandos start o cmd, AutoCAD no estará disponible hasta que se cierre dicha ventana.

    El comando start inicia una ventana distinta y ejecuta el programa o comando especificado. Si se utiliza start sin parámetros, abre una nueva ventana de solicitud de comando. El comando start dispone de varios conmutadores de línea de comando que afectan a la visualización de la nueva ventana. Para lanzar una aplicación de Windows, utilice start sin ningún conmutador. El comando start también resulta muy útil para iniciar un documento que está asociado con una aplicación. Por ejemplo, puede utilizar el comando start para abrir directamente un documento creado con un procesador de texto o un archivo HTML.

    El comando cmd abre una ventana de solicitud de comando que actúa como shell de AutoCAD. Esta ventana debe cerrarse antes de que el control vuelva a la solicitud de comando de AutoCAD. Hay dos conmutadores de línea de comando, /c y /k, que resultan de gran utilidad para los comandos externos. El conmutador /c ejecuta el comando especificado y luego se detiene (la ventana se cierra). El conmutador /k ejecuta el comando especificado y luego continúa (la ventana permanece abierta). Cuando utilice el conmutador /k, debe cerrar la ventana de comando (con el comando exit).

    En general, utilice el comando start para ejecutar una nueva ventana o aplicación que deba seguir un proceso independiente del de AutoCAD. Utilice el comando cmd para ejecutar un archivo de procesamiento por lotes o un archivo de comandos que no cree una ventana distinta, o para crear una ventana que debe cerrarse antes de que el control se transfiera de nuevo a AutoCAD. Para obtener más información acerca de la utilización de estos comandos y conmutadores, véase la documentación sobre los comandos de sistema de Windows.

    Comandos personalizados

    El siguiente ejemplo define tres comandos nuevos: RUN, LISTSET y DXB2BLK.

    RUN, cmd /c,0,*Archivo por lotes que se va a ejecutar: ,
    LISTSET,cmd /k SET,0
    DXB2BLK,cmd /c DXBCOPY,0,DXB file: ,2

    El comando RUN ejecuta un archivo de procesamiento por lotes o un archivo de comandos. El comando cmd que precede al conmutador /c abre una ventana de comando, ejecuta el archivo de procesamiento por lotes y se cierra.

    El comando LISTSET muestra los valores actuales de las variables de entorno de DOS. Como este ejemplo utiliza cmd /k y no start, la ventana de comando debe cerrarse antes de volver a AutoCAD. Si desea que esta ventana permanezca activa, utilice start /realtime. Para obtener más información acerca de la utilización de estos comandos y conmutadores, véase la documentación sobre los comandos de sistema de Windows.

    El comando DXB2BLK crea una definición de bloque desde el archivo DXB especificado. El archivo DXB convierte todos los objetos en líneas. Una de las ventajas adicionales de este procedimiento reside en que constituye un método sencillo de descomposición de objetos de texto en líneas.

    DXB2BLK transfiere el nombre de archivo DXB especificado al archivo por lotes dxbcopy, que copia este nombre de archivo en el nombre de archivo $cmd.dxb. A continuación, AutoCAD crea un bloque desde el archivo DXB especificado. El nombre proporcionado en la solicitud del archivo DXB se utiliza como nuevo nombre del bloque. Para crear el archivo dxbcopy.cmd, escriba lo siguiente en la solicitud de DOS:

    echo copy %1.dxb $cmd.dxb > dxbcopy.cmd

    Se creará el archivo dxbcopy.cmd en el directorio actual. Mueva este archivo a un directorio que se encuentre en su ruta DOS o especifique de forma explícita la ubicación del archivo en el archivo acad.pgp. Por ejemplo, si el archivo dxbcopy.cmd se encuentra en D:\cad, escriba lo siguiente en la sección de comandos externos del archivo acad.pgp.

    DXB2BLK, cmd /c D:\CAD\DXBCOPY,0,DXB file: ,2

    Para crear un archivo DXB, seleccione Archivo DXB de AutoCAD como impresora actual y, a continuación, imprima en un archivo. Para obtener más información acerca de la configuración de impresoras, véase Configuración de trazadores e impresoras en el Manual para controladores y periféricos.


Para abrir el archivo de parámetros del programa (acad.pgp) [Manual de personalización: ACG]

Definición de comandos personalizados
Definición de comandos externos
Conceptos
Procedimientos
Referencia

    • Para abrir el archivo de parámetros del programa (acad.pgp)

    • En el menú Herr., haga clic en Personalizar [image] Editar archivos personalizados [image] Parámetros del programa (aclt.pgp).


Ficha Referencia: Definición de comandos externos [Manual de personalización: ACG]

Definición de comandos personalizados
Definición de comandos externos
Conceptos
Procedimientos
Referencia

    • Comandos

    REINICIA

    Reinicia el digitalizador, los puertos de entrada y salida del digitalizador y el archivo de parámetros del programa

    Variables de sistema

    No hay entradas.


Creación de alias de comandos [Manual de personalización: ACG]

Definición de comandos personalizados
Creación de alias de comandos
Conceptos
Procedimientos
Referencia

    • Un alias de comando es una forma abreviada que se escribe en la línea de comando en lugar del nombre completo del comando.

    Por ejemplo, puede escribir c en lugar de círculo para ejecutar el comando CIRCULO. Un alias no es lo mismo que una tecla de método abreviado, que consiste en una combinación de pulsaciones, como CTRL+G para GUARDAR.

    Es posible definir un alias para cualquier comando de controlador de dispositivos, comando externo o comando de AutoCAD. La segunda sección del archivo acad.pgp de la carpeta support define los alias de comandos. Puede modificar los alias existentes o añadir otros nuevos editando acad.pgp en el Bloc de notas o en cualquier editor de texto que guarde archivos en formato ASCII. Para abrir el archivo PGP, en el menú Herr., haga clic en Personalizar [image] Editar archivos personalizados [image] Parámetros del programa (acad.pgp). El archivo también puede contener líneas de comentarios precedidas por un punto y coma (;).

    Nota Antes de editar acad.pgp, es aconsejable crear una copia de seguridad para poder restaurar el archivo si es necesario.

    Para definir un alias de comando, añada una línea a la sección de alias de comando del archivo acad.pgp utilizando la siguiente sintaxis:

    forma abreviada,*comando

    donde forma abreviada es el alias de comando que se escribe en la solicitud de comando y comando es el comando que se desea abreviar. Debe escribir un asterisco (*) antes del nombre del comando para identificar la línea como una definición de alias de comando.

    Si puede escribir un comando de forma transparente, también podrá escribir su alias de forma transparente. Cuando escriba el alias del comando, el nombre completo del comando se mostrará en la solicitud de comando y éste se ejecutará.

    Puede crear alias de comandos que incluyan como prefijo un guión especial (–), como los que se enumeran aquí, que acceden a la versión de línea de comandos de determinados comandos.

    SB, *-SOMBCONT
    CT, *-CONTORNO

    Nota No puede utilizar alias de comandos en archivos de comandos. No se recomienda utilizar alias de comandos en archivos de menús.

    Si edita acad.pgp mientras se está ejecutando AutoCAD, escriba reinicia para que se utilice el archivo revisado. Al reiniciar AutoCAD, el archivo se volverá a cargar automáticamente.

    Véase también

    Adición de teclas de método abreviado a menús y barras de herramientas


Ficha Procedimientos: Creación de alias de comandos [Manual de personalización: ACG]

Definición de comandos personalizados
Creación de alias de comandos
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de alias de comandos [Manual de personalización: ACG]

Definición de comandos personalizados
Creación de alias de comandos
Conceptos
Procedimientos
Referencia

    • Comandos

    REINICIA

    Reinicia el digitalizador, los puertos de entrada y salida del digitalizador y el archivo de parámetros del programa

    Variables de sistema

    No hay entradas.


Tipos de línea personalizados [Manual de personalización: ACG]

Tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • Puede encontrar una biblioteca de tipos de línea estándar en los archivos acad.lin y acadiso.lin. Puede utilizar los tipos de línea tal y como aparecen, modificarlos o crear nuevos tipos personalizados.

    • Presentación general de las definiciones de tipo de línea
      Los tipos de línea se definen en uno o más archivos de definición de tipos de línea con la extensión de archivo .lin.
    • Tipos de línea personalizados sencillos
      Cada tipo de línea está definido en dos líneas de un archivo de definición de tipo de línea. La primera línea contiene el nombre del tipo de línea y una descripción opcional. La segunda línea es el código que define el patrón del tipo de línea.
    • Texto en tipos de línea personalizados
      Los tipos de línea pueden incluir caracteres pertenecientes a los tipos de letra de texto.
    • Formas en tipos de línea personalizados
      Un tipo de línea complejo puede contener formas incrustadas que se almacenan en archivos de formas. Los tipos de línea complejos pueden indicar utilidades, contornos, límites, etc.


Presentación general de las definiciones de tipo de línea [Manual de personalización: ACG]

Tipos de línea personalizados
Presentación general de las definiciones de tipo de línea
Conceptos
Procedimientos
Referencia

    • El nombre y la definición del tipo de línea determinan la secuencia particular trazo-punto, las longitudes relativas de los trazos y espacios en blanco, y las características del texto y las formas presentes. Puede utilizar cualquiera de los tipos de línea estándar que proporciona AutoCAD o crear tipos de línea personalizados.

    ejemplos de tipos de línea

    Los tipos de línea se definen en uno o más archivos de definición de tipos de línea con la extensión de archivo .lin. Un archivo LIN puede contener definiciones de muchos tipos de línea simples y complejos. Puede añadir nuevos tipos de línea a un archivo LIN existente o crear uno propio. Para crear o modificar definiciones de tipo de línea, edite el archivo LIN con un editor o procesador de texto, o escriba TIPOLIN en la solicitud de comando.

    Al crear un tipo de línea, se debe cargar el tipo de línea antes de utilizarlo.

    Los archivos LIN incluidos en AutoCAD son acad.lin y acadiso.lin. Estos archivos de texto se pueden visualizar o imprimir para entender mejor la forma de crear tipos de línea.


Ficha Procedimientos: Presentación general de las definiciones de tipo de línea [Manual de personalización: ACG]

Tipos de línea personalizados
Presentación general de las definiciones de tipo de línea
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de las definiciones de tipo de línea [Manual de personalización: ACG]

Tipos de línea personalizados
Presentación general de las definiciones de tipo de línea
Conceptos
Procedimientos
Referencia

    • Comandos

    TIPOLÍN

    Carga, define y modifica tipos de línea

    Variables de sistema

    MEASUREINIT

    Define las unidades de dibujo iniciales como imperiales o métricas


Tipos de línea personalizados sencillos [Manual de personalización: ACG]

Tipos de línea personalizados
Tipos de línea personalizados sencillos
Conceptos
Procedimientos
Referencia

    • Cada tipo de línea está definido en dos líneas de un archivo de definición de tipo de línea. La primera línea contiene el nombre del tipo de línea y una descripción opcional. La segunda línea es el código que define el patrón del tipo de línea.

    La segunda línea debe comenzar por la letra A (alineación), seguida de una lista de descriptores de patrones que definen longitudes de segmentos invisibles (espacios), longitudes de segmentos visibles (trazos) y puntos. Se pueden incluir comentarios en un archivo LIN iniciando la línea con un signo de punto y coma (;).

    Formato de definición de tipo de línea

    El formato de definición del tipo de línea es

    *nombre_tipo_línea,descripción
    A,descriptor1,descriptor2, ...

    Por ejemplo, un tipo de línea llamado PUNTOTRAZO se define como

    *PUNTOTRAZO,Punto trazo __ . __ . __ . __ . __ . __ . __ . __
    A,.5,-.25,0,-.25

    Esto indica un patrón repetido que comienza con un trazo de 0.5 unidades de longitud, un espacio de 0.25 unidades de longitud, un punto y otro espacio de 0.25 unidades de longitud. Este patrón continúa a lo largo de la línea, finalizando con un trazo de 0.5 unidades de longitud. El tipo de línea se visualizaría como se muestra a continuación.

    __ . __ . __ . __ . __ . __ . __ . __

    Los archivos LIN deben guardarse en formato ASCII y se almacenan con la extensión de archivo .lin. A continuación, se ofrece información adicional sobre cada uno de los campos de una definición de tipo de línea.

    Nombre de tipo de línea

    El campo de nombre de tipo de línea comienza con un asterisco (*) y debe incluir un nombre único y descriptivo del tipo de línea.

    Descripción

    La descripción del tipo de línea debe ayudar al usuario a visualizar el tipo de línea cuando se edita el archivo LIN. La descripción también se visualiza en el Administrador de tipos de línea y en el cuadro de diálogo Cargar o volver a cargar tipos de línea.

    La descripción es opcional y puede incluir:

    • Una sencilla representación del patrón de tipo de línea en texto ASCII.
    • Una descripción extensa del tipo de línea.
    • Un comentario como "Utilice este tipo de línea con líneas ocultas".

    Si omite la descripción, no incluya una coma después del nombre del tipo de línea. La descripción no puede superar los 47 caracteres.

    Campo de alineación (A)

    El campo de alineación especifica la acción de alineación de patrones en los extremos de círculos, arcos y líneas individuales. Actualmente, AutoCAD sólo admite alineaciones de tipo A, lo que garantiza que los puntos finales de las líneas y los arcos comienzan y terminan con un trazo.

    Por ejemplo, si crea un tipo de línea denominado CENTRAL que muestra la habitual secuencia de repetición de puntos y trazos que se utiliza normalmente como línea de centro, AutoCAD ajustará esa secuencia en una línea individual, de modo que los trazos y los puntos finales de línea coincidan. El patrón ajusta la línea para que al menos la mitad del primer trazo comience y finalice la línea. Si es necesario, el primer y último trazo se alargan. Cuando la línea es demasiado corta para contener una sola secuencia de puntos y trazos, AutoCAD dibuja una línea continua entre los puntos finales. En el caso de los arcos, el patrón también se ajusta para que se dibujen trazos en los puntos finales. Los círculos carecen de puntos finales, pero AutoCAD ajusta la secuencia de puntos y trazos para crear una presentación razonable.

    Para especificar una alineación tipo A, escriba a en el campo de alineación.

    Descriptores de patrón

    Cada campo de descriptor de patrón especifica la longitud de los segmentos que componen el tipo de línea, separados mediante comas (no se admiten espacios).

    • Un número decimal positivo indica un segmento visible (trazo) de esa longitud.
    • Un número decimal negativo indica un segmento invisible (espacio) de esa longitud.
    • Una longitud de trazo definida en 0 dibuja un punto.

    Puede indicar hasta 12 especificaciones de longitud de trazo por tipo de línea, siempre que quepan en una línea de 80 caracteres en el archivo LIN. Sólo debe incluir una repetición completa del patrón de tipo de línea definido por los descriptores de patrón. Cuando se dibuja un tipo de línea, AutoCAD utiliza el primer descriptor de patrón para los trazos inicial y final. Las especificaciones de trazo de patrón se dibujan en orden entre los trazos inicial y final, comenzando con la segunda especificación de trazo y volviendo a iniciar el patrón con la primera especificación siempre que se necesite.

    La alineación de tipo A requiere que la primera longitud de trazo sea mayor o igual que 0 (un segmento visible). La segunda debe ser menor que 0 (un segmento invisible o espacio). Para esta alineación se necesitan dos especificaciones de trazo como mínimo.


Para crear un tipo de línea sencillo [Manual de personalización: ACG]

Tipos de línea personalizados
Tipos de línea personalizados sencillos
Conceptos
Procedimientos
Referencia

    • Para crear un tipo de línea sencillo

    1. En la solicitud de comando, escriba -tipolin.
    2. Escriba r de Crear.
    3. Escriba un nombre para el tipo de línea y pulse INTRO.

    Un nombre de tipo de línea puede tener una longitud de hasta 255 caracteres y contener letras, dígitos y los caracteres especiales de dólar ($), guión
    (-) y subrayado (_). Los nombres de tipo de línea no pueden incluir espacios en blanco.

    4. En el cuadro de diálogo Crear o añadir un archivo de tipos de línea, seleccione un archivo de biblioteca de tipos de línea LIN del cuadro Nombre de archivo y seleccione Guardar.

    Si selecciona un archivo existente, el nombre del nuevo tipo de línea se añadirá a los nombres que ya hay en ese archivo.

    5. Introduzca, si así lo desea, una descripción del nuevo tipo de línea (optativo).
    6. En la solicitud de introducción de patrón, especifique el patrón de la línea, teniendo en cuenta estas indicaciones:
    • Todos los tipos de línea deben empezar por un trazo.
    • Escriba ceros para los puntos.
    • Escriba números reales negativos para los espacios. El valor define la longitud del espacio en unidades de dibujo.
    • Escriba números reales positivos para los trazos. El valor define la longitud del trazo en unidades de dibujo.
    • Separe con una coma cada valor de punto, trazo o espacio del siguiente.
    • Utilice un espacio entre el punto y el trazo.
    7. Pulse INTRO para terminar el comando.

    Nota Cuando se crea un tipo de línea, no se carga automáticamente en el dibujo. Utilice la opción Cargar de TIPOLÍN.


Ficha Referencia: Tipos de línea personalizados sencillos [Manual de personalización: ACG]

Tipos de línea personalizados
Tipos de línea personalizados sencillos
Conceptos
Procedimientos
Referencia

    • Comandos

    TIPOLÍN

    Carga, define y modifica tipos de línea

    Variables de sistema

    MEASUREINIT

    Define las unidades de dibujo iniciales como imperiales o métricas


Ficha Procedimientos: Patrones de sombreado personalizados [Manual de personalización: ACG]

Patrones de sombreado personalizados
Conceptos
Procedimientos
Referencia

    • Para crear un patrón de sombreado simple

    Para crear un patrón de sombreado con líneas de trazos

    Para crear un patrón de sombreado con varias líneas


Ficha Referencia: Patrones de sombreado personalizados [Manual de personalización: ACG]

Patrones de sombreado personalizados
Conceptos
Procedimientos
Referencia

    • Comandos

    ADCENTER

    Administra e inserta contenido como bloques, refx y patrones de sombreado

    SOMBCONT

    Rellena un área cerrada o los objetos designados con un patrón de sombreado o un relleno de gradiente

    RELLENAR

    Controla el relleno de los sombreados, los sólidos bidimensionales y las polilíneas gruesas

    HATCH

    Rellena un área con un patrón de sombreado no asociativo

    EDITSOMB

    Modifica un sombreado o un relleno de gradiente existente

    SOLIDO

    Crea triángulos y cuadriláteros de relleno sólido

    Variables de sistema

    FILLMODE

    Determina si se rellenan los sombreados (incluidos rellenos sólidos), los sólidos bidimensionales y las polilíneas

    GFSHIFT

    Precisa si el patrón de un relleno de gradiente está centrado o desplazado hacia arriba y hacia la izquierda

    HPANG

    Determina el ángulo de los patrones de sombreado

    HPBOUND

    Controla el tipo de objeto creado por SOMBCONT y CONTORNO

    HPDOUBLE

    Determina el duplicado de patrones de sombreado para los patrones creados por el usuario

    HPNAME

    Establece el nombre del patrón de sombreado por defecto con un máximo de 34 caracteres y sin espacios permitidos

    HPSCALE

    Indica el factor de escala del patrón de sombreado, que debe ser un número distinto de cero

    HPSPACE

    Precisa el interlineado de los patrones de sombreado para patrones simples creados por el usuario, que debe ser un valor distinto de cero


Texto en tipos de línea personalizados [Manual de personalización: ACG]

Tipos de línea personalizados
Texto en tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • Los tipos de línea pueden incluir caracteres pertenecientes a los tipos de letra de texto. Los tipos de línea con caracteres insertados pueden indicar utilidades, contornos, límites, etc. Al igual que los tipos de línea sencillos, las líneas se dibujan de forma dinámica a medida que se especifican los vértices. Los caracteres insertados en líneas siempre se muestran en su totalidad, nunca recortados.

    Los caracteres de texto insertados se asocian al estilo de texto del dibujo. Cualquier estilo de texto asociado con un tipo de línea debe existir en el dibujo antes de cargar el tipo de línea.

    El formato de los tipos de línea que incluyen caracteres incrustados, como el de los tipos de línea sencillos, está compuesto por una lista de descriptores de patrón separados por comas.

    Formato de descriptor de carácter

    El formato para añadir caracteres de texto a una descripción de tipo de línea es el siguiente:

    ["texto",nombreestilotexto,escala,rotación,desfasex,desfasey]

    Este formato se añade como descriptor a un estilo de línea sencillo. Por ejemplo, un tipo de línea llamado SUMINISTRO_AGUA_CALIENTE se define como

    *SUMINISTRO_AGUA_CALIENTE,---- AC ---- AC ---- AC ---- AC ---- AC ----
    A,.5,-.2,["AC",STANDARD,S=.1,R=0.0,X=-0.1,Y=-.05],-.2

    Esta secuencia indica un patrón de repetición que se inicia con un trazo de 0.5 unidades de longitud, un espacio de 0.2 unidades de longitud, los caracteres AC con varios parámetros de escala y posición, y otro espacio de 0.2 unidades de longitud. Los caracteres de texto proceden del tipo de letra asignado al estilo de texto STANDARD con una escala de 0.1, una rotación relativa de 0 grados, un desfase X de -0.1 y un desfase Y de -0.05. Este patrón continúa a lo largo de la línea, finalizando con un trazo de 0.5 unidades de longitud. El tipo de línea se visualizaría como se muestra a continuación.

    Observe que la longitud total del trazo ascendente es de 0.2 + 0.2 = 0.4 y que el origen de texto se ha desfasado -.01 unidades en dirección X a partir del extremo del primer trazo ascendente. Un tipo de línea equivalente sería

    *SUMINISTRO_AGUA_CALIENTE,---- AC ---- AC ---- AC ---- AC ---- AC ----
    A,.5,-.1,["AC",STANDARD,S=.1,R=0.0,X=0.0,Y=-.05],-.3

    El trazo ascendente total sigue siendo 0.1 + 0.3 = 0.4, pero el origen de texto no tiene desfase en la dirección X.

    A continuación, se facilita información adicional sobre cada campo del descriptor de carácter. Los valores que se van a utilizar deben ser cifras decimales con signo, como 1, -17 y 0.01.

    texto

    Caracteres que deben utilizarse en el tipo de línea.

    nombre del estilo de texto

    Nombre del estilo de texto que ha de utilizarse. Si no se especifica ningún estilo, AutoCAD utiliza el estilo de texto definido actualmente.

    escala

    S=valor. Factor de escala que ha de utilizarse en el texto con respecto a la escala del tipo de línea. La altura del estilo de texto se multiplica por el factor de escala. Si la altura es 0, únicamente se utilizará como altura el valor de S=valor.

    rotación

    R=valor o A=valor. R= especifica la rotación relativa o tangencial con respecto a la línea. A= indica la rotación absoluta del texto con respecto al origen; es decir, todo el texto tiene la misma rotación, sea cual sea su posición con respecto a la línea. Al valor se le puede añadir una d de grados sexagesimales (este tipo de grados es el valor por defecto), una r de radianes o una g de grados centesimales. Si este campo se omite, se utiliza la rotación relativa 0.

    La rotación se centra entre la línea de base y la altura de mayúscula del nombre.

    desfasex

    X=valor. El desfase del texto en el eje X del tipo de línea, que recorre la línea. Si desfasex se omite o su valor es 0, el texto se crea sin desfase. Utilice este campo para controlar la distancia entre el texto y el trazo visible o invisible previo. La escala de este valor no se define a partir del factor de escala S=valor, sino a partir del tipo de línea.

    desfasey

    Y=valor. El desplazamiento del texto por el eje Y del tipo de línea, que forma un ángulo de 90 grados con respecto a la línea. Si desfasey se omite o su valor es 0, el texto se crea sin desfase. Utilice este campo para controlar la alineación vertical del texto con respecto a la línea. La escala de este valor no se define a partir del factor de escala S=valor, sino a partir del tipo de línea.


Para incluir caracteres de texto en los tipos de línea [Manual de personalización: ACG]

Tipos de línea personalizados
Texto en tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • Para incluir caracteres de texto en los tipos de línea

    1. Cree un tipo de línea sencillo, tal y como se describe en Para crear un tipo de línea sencillo.
    2. Añada el descriptor de carácter de texto en el patrón del tipo de línea utilizando el siguiente formato:

    ["texto",nombreestilotexto,escala,rotación,desfasex,desfasey]

    3. Pulse INTRO para terminar el comando TIPOLIN.


Ficha Referencia: Texto en tipos de línea personalizados [Manual de personalización: ACG]

Tipos de línea personalizados
Texto en tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • Comandos

    TIPOLÍN

    Carga, define y modifica tipos de línea

    Variables de sistema

    MEASUREINIT

    Define las unidades de dibujo iniciales como imperiales o métricas


Formas en tipos de línea personalizados [Manual de personalización: ACG]

Tipos de línea personalizados
Formas en tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • Un tipo de línea complejo puede contener formas incrustadas que se almacenan en archivos de formas. Los tipos de línea complejos pueden indicar utilidades, contornos, límites, etc.

    Al igual que los tipos de línea sencillos, las líneas complejas se dibujan de manera dinámica a medida que el usuario designa los vértices. Las formas y los objetos de texto incrustados en líneas siempre se muestran en su totalidad, nunca aparecen recortados.

    La sintaxis de los tipos de línea complejos es similar a la de los tipos de línea sencillos, ya que ambas incluyen una lista de descriptores de patrón delimitada por comas. Los tipos de línea complejos pueden contener objetos de texto y de formas como descriptores de patrón, así como descriptores de puntos y trazos.

    La sintaxis de los descriptores de objetos de formas de una descripción de tipo de línea es la siguiente:

    [nombreforma,nombrearchivoshx] o [nombreforma,nombrearchivoshx,transformación]

    donde transformación es opcional y puede ser cualquiera de las siguientes series (cada una de ellas precedida de una coma):

    R=## Rotación relativa
    A=## Rotación absoluta
    S=## Escala
    X=## Desfase X
    Y=## Desfase Y

    En esta sintaxis, ## es una cifra decimal con signo (1, –17, 0.01, etc.), la rotación se expresa en grados y las opciones restantes se miden en unidades de longitud de la escala del tipo de línea. Las letras de la transformación anterior, si es que se utilizan, deben ir seguidas de un signo igual y un número.

    La siguiente definición de tipo de línea define un tipo de línea llamado LINEACON1 y está formada por un patrón repetido de un segmento de línea, un espacio y la forma incrustada CON1 del archivo ep.shx. (El archivo ep.shx debe encontrarse en la ruta de soporte para que el ejemplo funcione correctamente).

    *LINEACON1, --- [CON1] --- [CON1] --- [CON1]
    A,1.0,-0.25,[CON1,ep.shx],-1.0

    Salvo el código entre corchetes, todo lo demás es coherente con la definición de un tipo de línea sencillo.

    Como ya se ha descrito anteriormente, es posible utilizar un total de seis campos para definir una forma como parte de un tipo de línea. Los dos primeros son obligatorios y dependen de la posición; los cuatro restantes son opcionales y su orden es arbitrario. Los dos ejemplos siguientes muestran varias entradas en el campo de definición de la forma.

    [CAP,ep.shx,S=2,R=10,X=0.5]

    El código anterior dibuja la forma CAP definida en el archivo de formas ep.shx con una escala que duplica la escala unitaria del tipo de línea, una rotación tangencial de 10 grados en sentido antihorario y un desfase X de 0.5 unidades de dibujo antes de que tenga lugar la elaboración de la forma.

    [DIP8,pd.shx,X=0.5,Y=1,R=0,S=1]

    El código anterior dibuja la forma DIP8 definida en el archivo de formas pd.shx con un desfase X de 0.5 unidades de longitud antes de que tenga lugar la elaboración de la forma y un desfase Y de una unidad de longitud sobre el tipo de línea, rotación 0 y una escala igual que la escala unitaria del tipo de línea.

    La siguiente sintaxis define una forma como parte de un tipo de línea complejo.

    [nombreforma,nombrearhivoforma,escala,girar,desfasex,desfasey]

    A continuación se muestran las definiciones de los campos de la sintaxis.

    nombreforma

    El nombre de la forma que se va a dibujar. Este campo es obligatorio. Si se omite, la definición del tipo de línea fallará. Si nombreforma no existe en el archivo de forma especificado, se podrá dibujar el tipo de línea pero no se incluirá la forma incrustada.

    nombrearchivoforma

    El nombre de un archivo de definición de forma compilado (SHX). Si se omite, la definición del tipo de línea fallará. Si nombrearchivoforma no está definido (es decir, no se ha especificado ninguna ruta), busque el archivo en la ruta de la biblioteca. Si nombrearchivoforma está correctamente definido y no se encuentra en su ubicación, elimine el prefijo y busque el archivo en la ruta de la biblioteca. Si no lo encuentra, prosiga con el dibujo del tipo de línea sin la forma incrustada.

    escala

    S=valor. La escala de la forma se utiliza como factor de escala por el que se multiplica la escala definida internamente de la forma. Si la escala definida internamente es 0, sólo se utilizará como escala S=valor.

    girar

    R=valor o A=valor. R= indica la rotación relativa o tangencial con respecto a la elaboración de las líneas. A= indica la rotación absoluta de la forma con respecto al origen; es decir, todas las formas tienen la misma rotación, sea cual sea su posición relativa con respecto a la línea. Se puede añadir al valor una d de grados (si se omite, éste es el tipo de grados por defecto), una r de radianes o una g de grados centesimales. Si este campo se omite, se utiliza la rotación relativa 0.

    desfasex

    X=valor. El desfase de la forma en el eje X del tipo de línea calculado desde el extremo del vértice de la definición del tipo de línea. Si desfasex se omite o su valor es 0, la forma se crea sin desfase. Incluya este campo si quiere una línea continua con formas. Este valor no se define a partir del factor de escala S=.

    desfasey

    Y=valor. El desfase de la forma en el eje Y del tipo de línea calculado desde el extremo del vértice de la definición del tipo de línea. Si desfasey se omite o su valor es 0, la forma se crea sin desfase. Este valor no se define a partir del factor de escala S=.

    Véase también

    Formas y tipos de letra de formas


Ficha Procedimientos: Formas en tipos de línea personalizados [Manual de personalización: ACG]

Tipos de línea personalizados
Formas en tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Formas en tipos de línea personalizados [Manual de personalización: ACG]

Tipos de línea personalizados
Formas en tipos de línea personalizados
Conceptos
Procedimientos
Referencia

    • Comandos

    TIPOLÍN

    Carga, define y modifica tipos de línea

    FORMA

    Inserta una forma

    Variables de sistema

    MEASUREINIT

    Define las unidades de dibujo iniciales como imperiales o métricas


Patrones de sombreado personalizados [Manual de personalización: ACG]

Patrones de sombreado personalizados
Conceptos
Procedimientos
Referencia

    • Puede encontrar una biblioteca de patrones de sombreado estándar en los archivos acad.pat y acadiso.pat. Puede utilizar estos patrones de sombreado tal y como aparecen, modificarlos o personalizarlos.

    • Presentación general de definiciones de patrones de sombreado
      Además de utilizar los patrones de sombreado predefinidos que se suministran, el usuario puede diseñar y crear sus propios patrones de sombreado.
    • Patrones de sombreado con líneas de trazos
      Para definir patrones de líneas de trazos, es necesario añadir elementos de longitud de trazo al final del elemento de definición de línea.
    • Patrones de sombreado con líneas múltiples
      Los patrones de sombreado complejos utilizan un origen que pasa por distintos desfases desde el origen y pueden incluir varios miembros en la familia de líneas.


Presentación general de definiciones de patrones de sombreado [Manual de personalización: ACG]

Patrones de sombreado personalizados
Presentación general de definiciones de patrones de sombreado
Conceptos
Procedimientos
Referencia

    • Además de utilizar los patrones de sombreado predefinidos que se suministran, el usuario puede diseñar y crear sus propios patrones de sombreado. Para desarrollar una definición de patrón de sombreado es necesario tener conocimientos, práctica y paciencia, y estar familiarizado con los patrones de sombreado. Por ello, se recomienda a los principiantes que se abstengan de llevar a cabo este procedimiento.

    Los patrones de sombreado incluidos en AutoCAD están almacenados en los archivos de texto acad.pat y
    acadiso.pat. Puede añadir definiciones de patrones de sombreado a este archivo o crear sus propios archivos.

    El formato de los patrones de sombreado personalizados no varía, independientemente del lugar en que se almacene la definición. Consta de una línea de encabezado con un nombre que empieza con un asterisco y no puede superar los 31 caracteres de longitud y puede incluir una descripción opcional:

    *nombredelpatrón, descripción

    También consta de uno o varios descriptores de líneas con el siguiente formato:

    ángulo, origen x,origen y, delta x,delta y,trazo 1,trazo 2, ...

    El patrón de sombreado por defecto ANSI31, que se muestra en el cuadro de diálogo Sombreado por contornos y relleno, tiene el siguiente aspecto:

    y se define como sigue:

    *ANSI31, Hierro ANSI, Ladrillo, Mampostería
    45, 0,0, 0,.125

    El nombre del patrón de la primera línea, *ANSI31, se continúa con una descripción: ANSI Hierro, Ladrillo, Mampostería. Esta definición de patrón simple especifica una línea con un ángulo de 45 grados, e indica que la primera línea de la familia de líneas de sombreado debe pasar por el origen del dibujo (0,0) y que el intervalo entre las líneas de sombreado de la familia debe ser de 0.125 unidades de longitud.

    Las definiciones de patrón de sombreado deben respetar las normas siguientes:

    • Cada línea de definición de patrón puede contener un máximo de 80 caracteres. Puede incluir letras, dígitos y los caracteres especiales de subrayado (_), guión (-) y símbolo de dólar ($). Sin embargo, la definición del patrón debe comenzar con una letra o dígito, no con un carácter especial.
    • AutoCAD pasa por alto las líneas en blanco y el texto situado a la derecha de un punto y coma.
    • Cada línea de un patrón se considera el primer miembro de una familia de líneas creada aplicando los incrementos en ambas direcciones para generar una familia infinita de líneas paralelas.
    • El valor de delta x indica el desplazamiento entre los miembros de la familia en la dirección de la línea. Sólo se utiliza para líneas de trazos.
    • El valor de delta y indica el intervalo entre los miembros de la familia; es decir, se mide en dirección perpendicular a las líneas.
    • Se considera que la longitud de una línea es infinita. Un patrón de trazos se superpone en la línea.

    El sombreado se aplica expandiendo cada línea de la definición de patrón hasta su familia infinita de líneas paralelas. Todos los objetos designados se comprueban para verificar si se cortan con dichas líneas, en cuyo caso las líneas de sombreado se activan y desactivan según el estilo de sombreado. Cada familia de líneas de sombreado se genera en paralelo a la línea inicial con un origen absoluto para garantizar la alineación apropiada.

    Si se crea un sombreado muy denso, AutoCAD puede rechazarlo y mostrar un mensaje que indica que la escala de sombreado es demasiado pequeña o que la longitud de los trazos es demasiado corta. Se puede cambiar el número máximo de líneas de sombreado modificando la variable de registro de sistema MaxHatch mediante SETENV.


Para crear un patrón de sombreado simple [Manual de personalización: ACG]

Patrones de sombreado personalizados
Presentación general de definiciones de patrones de sombreado
Conceptos
Procedimientos
Referencia

    • Para crear un patrón de sombreado simple

    1. Abra el archivo acad.pat o acadiso.pat en un editor de texto que permita guardar en formato ASCII (por ejemplo, en el Bloc de notas de Microsoft® Windows).
    2. Cree una línea de encabezado con un asterisco y un nombre de patrón. El nombre de los patrones de sombreado tiene la limitación de 31 caracteres.
    3. (Opcional) Para incluir una descripción en la línea de encabezado, escriba el texto de descripción después del nombre del patrón separado por una coma.
    4. Cree una línea de descripción que incluya:
    • Un ángulo en el que se dibuja la línea
    • Un punto de origen X,Y
    • Un delta x igual a 0
    • Un delta y de cualquier valor


Ficha Referencia: Presentación general de definiciones de patrones de sombreado [Manual de personalización: ACG]

Patrones de sombreado personalizados
Presentación general de definiciones de patrones de sombreado
Conceptos
Procedimientos
Referencia

    • Comandos

    ADCENTER

    Administra e inserta contenido como bloques, refx y patrones de sombreado

    SOMBCONT

    Rellena un área cerrada o los objetos designados con un patrón de sombreado o un relleno de gradiente

    RELLENAR

    Controla el relleno de los sombreados, los sólidos bidimensionales y las polilíneas gruesas

    HATCH

    Rellena un área con un patrón de sombreado no asociativo

    EDITSOMB

    Modifica un sombreado o un relleno de gradiente existente

    SOLIDO

    Crea triángulos y cuadriláteros de relleno sólido

    Variables de sistema

    FILLMODE

    Determina si se rellenan los sombreados (incluidos rellenos sólidos), los sólidos bidimensionales y las polilíneas

    GFSHIFT

    Precisa si el patrón de un relleno de gradiente está centrado o desplazado hacia arriba y hacia la izquierda

    HPANG

    Determina el ángulo de los patrones de sombreado

    HPBOUND

    Controla el tipo de objeto creado por SOMBCONT y CONTORNO

    HPDOUBLE

    Determina el duplicado de patrones de sombreado para los patrones creados por el usuario

    HPNAME

    Establece el nombre del patrón de sombreado por defecto con un máximo de 34 caracteres y sin espacios permitidos

    HPSCALE

    Indica el factor de escala del patrón de sombreado, que debe ser un número distinto de cero

    HPSPACE

    Precisa el interlineado de los patrones de sombreado para patrones simples creados por el usuario, que debe ser un valor distinto de cero


Patrones de sombreado con líneas de trazos [Manual de personalización: ACG]

Patrones de sombreado personalizados
Patrones de sombreado con líneas de trazos
Conceptos
Procedimientos
Referencia

    • Para definir patrones de líneas de trazos, es necesario añadir elementos de longitud de trazo al final del elemento de definición de línea.

    Para definir patrones de líneas de trazos, es necesario añadir elementos de longitud de trazo al final del elemento de definición de línea. Cada elemento de longitud de trazo especifica la longitud del segmento que compone la línea. Si esta longitud es positiva, se dibuja un segmento visible. Si la longitud es negativa, el segmento es invisible y no se dibuja. El patrón comienza en el punto de origen con el primer segmento y continúa por los demás segmentos en sentido circular. Una longitud de trazo definida en 0 dibuja un punto. Es posible especificar un máximo de seis longitudes de trazo por línea de patrón.

    El patrón de sombreado por defecto ANSI33, que se muestra en el cuadro de diálogo Sombreado por contornos y relleno, tiene el siguiente aspecto:

    y se define como sigue:

    *ANSI33, ANSI Bronce, Latón, Cobre
    45, .176776695,0, 0,.25, .125,-.0625

    Por ejemplo, para modificar un patrón para líneas de 45 grados que dibuje líneas con una longitud del trazo de 0.5 unidades y una distancia entre trazos de 0.5 unidades, la definición sería como sigue:

    *DASH45, Líneas de trazos a 45 grados
    45, 0,0, 0,.5, .5,-.5

    Esto es lo mismo que el patrón de 45 grados incluido en Presentación general de definiciones de patrones de sombreado, pero con una especificación de trazo añadida al final. La longitud visible e invisible es de 0.5 unidades, respectivamente, lo que cumple los fines especificados. Para dibujar un trazo de 0.5 unidades, un espacio de 0.25 unidades, un punto y otro espacio de 0.25 unidades antes del siguiente trazo, debe crearse una definición como ésta:

    *RPUNTO45,Patrón trazo punto trazo: 45 grados
    45, 0,0, 0,.5, .5,-.25, 0,-.25

    El siguiente ejemplo muestra el efecto de los delta x sobre las familias de líneas de trazos. Primero fíjese en la definición siguiente:

    *GOSTAK
    0, 0,0, 0,.5, .5,-.5

    Esta definición dibuja una familia de líneas separadas por 0.5 unidades de dibujo, con cada línea dividida en trazos y espacios iguales. Dado que el valor de delta x es cero, las trazos de cada familia se alinean. Un área sombreada con este patrón tiene este aspecto:

    Ahora cambie el patrón a:

    *SKEWED
    0, 0,0, .5,.5, .5,-.5

    Se trata del mismo patrón, con la diferencia de que delta x se ha definido como 0.5. Este valor desplaza cada miembro consecutivo de la familia 0.5 unidades en la dirección de la línea (en este caso, en dirección paralela al eje X). Dado que las líneas son infinitas, el patrón de trazos se desliza hacia abajo el número de veces especificado. El área sombreada tendría este aspecto:


Para crear un patrón de sombreado con líneas de trazos [Manual de personalización: ACG]

Patrones de sombreado personalizados
Patrones de sombreado con líneas de trazos
Conceptos
Procedimientos
Referencia

    • Para crear un patrón de sombreado con líneas de trazos

    1. Abra el archivo acad.pat o acadiso.pat en un editor de texto que guarde en formato ASCII (por ejemplo, en el Bloc de notas).
    2. Cree una línea de encabezado con un asterisco y un nombre de patrón. El nombre de los patrones de sombreado tiene la limitación de 31 caracteres.
    3. (Opcional) Para incluir una descripción en la línea de encabezado, escriba el texto de descripción después del nombre del patrón separado por una coma.
    4. Cree una línea de descripción que incluya:
    • Un ángulo en el que se dibuja la línea
    • Un punto de origen X,Y
    • Un delta x de cualquier valor, si desea desfasar líneas alternas en la familia de líneas
    • Un delta y de cualquier valor
    • Un valor para la longitud de trazo
    • Un valor para una longitud de punto
    • Un segundo valor opcional para una longitud de trazo diferente
    • Un segundo valor opcional para una longitud de punto diferente


Ficha Referencia: Patrones de sombreado con líneas de trazos [Manual de personalización: ACG]

Patrones de sombreado personalizados
Patrones de sombreado con líneas de trazos
Conceptos
Procedimientos
Referencia

    • Comandos

    ADCENTER

    Administra e inserta contenido como bloques, refx y patrones de sombreado

    SOMBCONT

    Rellena un área cerrada o los objetos designados con un patrón de sombreado o un relleno de gradiente

    RELLENAR

    Controla el relleno de los sombreados, los sólidos bidimensionales y las polilíneas gruesas

    HATCH

    Rellena un área con un patrón de sombreado no asociativo

    EDITSOMB

    Modifica un sombreado o un relleno de gradiente existente

    SOLIDO

    Crea triángulos y cuadriláteros de relleno sólido

    Variables de sistema

    FILLMODE

    Determina si se rellenan los sombreados (incluidos rellenos sólidos), los sólidos bidimensionales y las polilíneas

    GFSHIFT

    Precisa si el patrón de un relleno de gradiente está centrado o desplazado hacia arriba y hacia la izquierda

    HPANG

    Determina el ángulo de los patrones de sombreado

    HPBOUND

    Controla el tipo de objeto creado por SOMBCONT y CONTORNO

    HPDOUBLE

    Determina el duplicado de patrones de sombreado para los patrones creados por el usuario

    HPNAME

    Establece el nombre del patrón de sombreado por defecto con un máximo de 34 caracteres y sin espacios permitidos

    HPSCALE

    Indica el factor de escala del patrón de sombreado, que debe ser un número distinto de cero

    HPSPACE

    Precisa el interlineado de los patrones de sombreado para patrones simples creados por el usuario, que debe ser un valor distinto de cero


Ficha Procedimientos: Archivo de menús [Manual de personalización: ACG]

Archivo de menús
Conceptos
Procedimientos
Referencia

    • Para cargar un menú parcial

    Para descargar un menú parcial

    Para cargar el menú base

    Para mostrar el menú de pantalla


Ficha Referencia: Archivo de menús [Manual de personalización: ACG]

Archivo de menús
Conceptos
Procedimientos
Referencia

    • Comandos

    CAMBIA

    Cambia las propiedades de los objetos existentes

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    SACAFOTO

    Crea un archivo de foto de la ventana gráfica actual de modelo o de la presentación actual

    OPCIONES

    Personaliza los parámetros de AutoCAD

    ENCUADRE

    Desplaza la vista de la ventana gráfica actual

    DESIGNA

    Sitúa los objetos designados en el conjunto seleccionado previamente

    MODOSOMBRA

    Controla la visualización del sombreado de un objeto sólido en la ventana gráfica actua

    TABLERO

    Calibra, configura y activa o desactiva un tablero digitalizador enlazado

    BARRAHERR

    Muestra, oculta y personaliza barras de herramientas

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Variables de sistema

    MBUTTONPAN

    Controla el comportamiento del tercer botón o rueda del dispositivo señalador

    MENUCTL

    Controla la conmutación de páginas del menú de pantalla

    MENUECHO

    Define la reproducción de menús en pantalla y los bits de control de solicitudes

    PICKADD

    Controla si las designaciones posteriores sustituyen al conjunto de selección actual o se añaden a él

    PICKAUTO

    Controla la representación visual automática en la solicitud Designe objetos

    SCREENBOXES

    Almacena el número de casillas en el área del menú de pantalla del área de dibujo

    SHORTCUTMENU

    Controla si están disponibles en el área de dibujo los menús contextuales de modo Por defecto, Edición y Comando


Patrones de sombreado con líneas múltiples [Manual de personalización: ACG]

Patrones de sombreado personalizados
Patrones de sombreado con líneas múltiples
Conceptos
Procedimientos
Referencia

    • No todos los patrones de sombreado utilizan el punto de origen 0,0: los patrones de sombreado complejos pueden tener un origen establecido en distintos desfases desde el origen y pueden incluir varios miembros en la familia de líneas. Al crear patrones más complejos, el punto inicial, los desplazamientos y el patrón de trazos de cada familia de líneas deben especificarse con cuidado para construir un patrón de sombreado correcto.

    El patrón de sombreado por defecto ANSI31, que se muestra en el cuadro de diálogo Sombreado por contornos y relleno, tiene el siguiente aspecto:

    y se define como aparece a continuación, con varias líneas que describen el patrón:

    *AR-B816, Aparejo a soga de elevación de bloques 8x16
    0, 0,0, 0,8
    90, 0,0, 8,8, 8,-8

    A continuación se ilustra un patrón de U invertida con forma de cuadrado (una línea arriba, otra por encima y otra abajo). El patrón repite cada unidad, cuya altura y anchura están definidas en 0.5.

    Este patrón se definiría así:

    *IUS,U invertida
    90, 0,0, 0,1, .5,-.5
    0, 0,.5, 0,1, .5,-.5
    270, .5,.5, 0,1, .5,-.5

    La primera línea (la barra hacia arriba) es una línea de trazos sencilla cuyo origen está definido en 0,0. La segunda línea (la barra superior) debería comenzar al final de la barra anterior, de modo que su origen debe ser 0,.5. La tercera línea (la barra hacia abajo) debe comenzar al final de la barra superior, en .5,.5 en el primer elemento del patrón. Ésta debería ser la tercera línea del patrón:

    90, .5,0, 0,1, .5,-.5

    O bien

    270, .5,1, 0,1, -.5,.5

    El patrón de trazos comienza en los puntos de origen y continúa en la dirección vectorial proporcionada por la especificación de ángulo. En consecuencia, dos familias de líneas de trazos opuestas en 180 grados no son iguales, mientras que dos familias de líneas continuas sí lo son.

    El siguiente patrón crea estrellas de seis puntas.

    Este ejemplo permite mejorar el sistema de definición de patrones (Nota: 0.866 es el seno de 60 grados).

    A continuación se muestra la definición de AutoCAD de este patrón:

    *STARS,Estrella de David
    0, 0,0, 0,.866, .5,-.5
    60, 0,0, 0,.866, .5,-.5
    120, .25,.433, 0,.866, .5,-.5


Para crear un patrón de sombreado con varias líneas [Manual de personalización: ACG]

Patrones de sombreado personalizados
Patrones de sombreado con líneas múltiples
Conceptos
Procedimientos
Referencia

    • Para crear un patrón de sombreado con varias líneas

    1. Abra el archivo acad.pat o acadiso.pat en un editor de texto que permita guardar en formato ASCII (por ejemplo, en el Bloc de notas).
    2. Cree una línea de encabezado con un asterisco y un nombre de patrón. El nombre de los patrones de sombreado tiene la limitación de 31 caracteres.
    3. (Opcional) Para incluir una descripción en la línea de encabezado, escriba el texto de descripción después del nombre del patrón separado por una coma.
    4. Cree una línea de descripción que incluya:
    • Un ángulo en el que se dibuja la línea
    • Un punto de origen X,Y
    • Un delta x de cualquier valor, si desea desfasar líneas alternas en la familia de líneas
    • Un delta y de cualquier valor
    • Un valor para la longitud de trazo
    • Un valor para una longitud de punto
    • Un segundo valor opcional para una longitud de trazo diferente
    • Un segundo valor opcional para una longitud de punto diferente
    5. Cree una segunda línea que incluya todos los parámetros del paso anterior.
    6. (Opcional) Cree líneas adicionales para completar el patrón de sombreado con varias líneas.


Ficha Referencia: Patrones de sombreado con líneas múltiples [Manual de personalización: ACG]

Patrones de sombreado personalizados
Patrones de sombreado con líneas múltiples
Conceptos
Procedimientos
Referencia

    • Comandos

    ADCENTER

    Administra e inserta contenido como bloques, refx y patrones de sombreado

    SOMBCONT

    Rellena un área cerrada o los objetos designados con un patrón de sombreado o un relleno de gradiente

    RELLENAR

    Controla el relleno de los sombreados, los sólidos bidimensionales y las polilíneas gruesas

    HATCH

    Rellena un área con un patrón de sombreado no asociativo

    EDITSOMB

    Modifica un sombreado o un relleno de gradiente existente

    SOLIDO

    Crea triángulos y cuadriláteros de relleno sólido

    Variables de sistema

    FILLMODE

    Determina si se rellenan los sombreados (incluidos rellenos sólidos), los sólidos bidimensionales y las polilíneas

    GFSHIFT

    Precisa si el patrón de un relleno de gradiente está centrado o desplazado hacia arriba y hacia la izquierda

    HPANG

    Determina el ángulo de los patrones de sombreado

    HPBOUND

    Controla el tipo de objeto creado por SOMBCONT y CONTORNO

    HPDOUBLE

    Determina el duplicado de patrones de sombreado para los patrones creados por el usuario

    HPNAME

    Establece el nombre del patrón de sombreado por defecto con un máximo de 34 caracteres y sin espacios permitidos

    HPSCALE

    Indica el factor de escala del patrón de sombreado, que debe ser un número distinto de cero

    HPSPACE

    Precisa el interlineado de los patrones de sombreado para patrones simples creados por el usuario, que debe ser un valor distinto de cero


Para cargar un menú parcial [Manual de personalización: ACG]

Archivo de menús
Carga y descarga de archivos de menús
Conceptos
Procedimientos
Referencia

    • Para cargar un menú parcial

    1. En la solicitud de comando, escriba cargarmenu.
    2. En el cuadro de diálogo Personalización de menús, en la ficha Grupos de menús, introduzca el nombre del archivo de menús (o haga clic en Examinar para designar el archivo en el cuadro de diálogo Seleccionar archivo de menús).
    3. Haga clic en Cargar.
    4. Si el grupo de menús contiene menús desplegables, haga clic en la ficha Barra de menús.
    5. En Grupo de menús:, seleccione el grupo de menús que ha cargado.

    En la parte izquierda, la opción Menús: contiene los menús desplegables correspondientes al grupo de menús seleccionado. En la parte derecha, la opción Barra de menús: contiene los menús que aparecen actualmente en la barra de menús, de izquierda a derecha.

    6. En la lista Menús:, seleccione el menú que desea insertar en la barra de menús.
    7. En la lista Barra de menús:, seleccione un menú y haga clic en Insertar para colocar el nuevo menú encima del menú seleccionado en la lista.

    Si no se ha seleccionado ningún menú en la lista Barra de menús:, el menú seleccionado en la lista Menús: se sitúa al comienzo de la lista Barra de menús:.

    8. Haga clic en Cerrar.


Para descargar un menú parcial [Manual de personalización: ACG]

Archivo de menús
Carga y descarga de archivos de menús
Conceptos
Procedimientos
Referencia

    • Para descargar un menú parcial

    1. En la solicitud de comando, escriba descargarmenu.
    2. En el cuadro de diálogo Personalización de menús, en la ficha Grupo de menús, seleccione el archivo de menús que contiene los menús que desea descargar.
    3. Haga clic en Descargar.
    4. Haga clic en Cerrar.


Para cargar el menú base [Manual de personalización: ACG]

Archivo de menús
Carga y descarga de archivos de menús
Conceptos
Procedimientos
Referencia

    • Para cargar el menú base

    1. En la solicitud de comando, escriba menu.
    2. En el cuadro de diálogo Seleccionar archivo de menús, seleccione el archivo de menús que desee cargar.
    3. Haga clic en Abrir.


Archivo de menús [Manual de personalización: ACG]

Archivo de menús
Conceptos
Procedimientos
Referencia

    • El archivo de menús es un archivo TXT ubicado en la carpeta support de AutoCAD que define la mayor parte de la interfaz de usuario. Puede modificar el archivo de menús o crear otros nuevos para añadir comandos o macros a los menús (incluidos los menús contextuales, los menús de mosaico de imágenes y los menús de tablero) y a las barras de herramientas, asignar comandos a los botones del dispositivo señalador y crear y modificar métodos abreviados.

    • Presentación general de los archivos de menús
    • Carga y descarga de archivos de menús
      Antes de utilizar un archivo de menús, se debe cargar en el programa.
    • Creación de macros de menú
      Los elementos de los archivos MNU se componen de tres partes: un identificador de nombre, un rótulo y una macro de menú. La macro define la acción que se debe llevar a cabo cuando el usuario selecciona el elemento de menú.
    • Uso de AutoLISP en las macros de menú
      Puede utilizar las variables y expresiones AutoLISP para crear macros de menú que realicen tareas complejas. Para usar AutoLISP de un modo eficaz con las macros de menú, puede incluir el código AutoLISP en un archivo MNL distinto. AutoCAD carga el archivo MNL al cargar un archivo de menús con el mismo nombre.
    • Personalización de los botones de un dispositivo señalador
      El dispositivo señalador del sistema Windows utiliza los menús Aux del archivo MNU. El resto de los dispositivos usan los menús Buttons.
    • Creación de menús desplegables y contextuales
      Los menús desplegables se despliegan desde la barra de menús. Los menús contextuales se muestran en (o cerca de) los cursores en cruz o el cursor de la ventana de dibujo, la ventana de texto o de comandos, o en las áreas de las barras de herramientas. Ambos menús se definen en las secciones Pop del archivo MNU.
    • Personalización de las barras de herramientas
      En la sección Toolbars de un archivo MNU, puede crear barras de herramientas con botones, iconos desplegables y elementos de control especiales y utilizar sus propios mapas de bits para los iconos de los botones.
    • Creación de menús de mosaico de imágenes
      El objetivo principal de un menú de mosaico de imágenes es suministrar una imagen cuando el usuario debe seleccionar un símbolo gráfico en lugar de un texto.
    • Creación de menús de pantalla
      La sección del menú de pantalla del archivo MNU controla el área del menú de pantalla.
    • Creación de menús de tablero
      Se pueden configurar hasta cuatro áreas del tablero digitalizador como áreas de menús para la entrada de comandos.
    • Creación de mensajes de ayuda de la línea de estado
      Los mensajes de ayuda de la línea de estado son mensajes sencillos y descriptivos que aparecen en la línea de estado al seleccionar un elemento de menú. En la sección de menú Helpstrings se definen estos mensajes.
    • Creación de métodos abreviados
      Puede definir sus propios métodos abreviados (o aceleradores).


Presentación general de los archivos de menús [Manual de personalización: ACG]

Archivo de menús
Presentación general de los archivos de menús
Conceptos
Procedimientos
Referencia

    • El archivo de menús es un archivo TXT con formato ASCII que se compone de varias secciones en las que se define la función de las distintas partes de la interfaz de usuario (a excepción de la línea de comando), como, por ejemplo, los menús desplegables, las barras de herramientas y los botones de un dispositivo señalador.

    El archivo de menús que se establece por defecto es acad.mnu. Está ubicado en la carpeta support y se puede abrir con el Bloc de notas para ver qué aspecto tiene un archivo de menús completo. Para abrir el archivo de menús, en el menú Herr. haga clic en Personalizar [image] Editar archivos personalizados [image] Menú actual.

    Puede crear o modificar los archivos de menús para realizar una de las siguientes operaciones:

    • Añadir o cambiar menús (incluidos los menús contextuales, de mosaico de imágenes y de tablero) y barras de herramientas
    • Asignar comandos a los botones del dispositivo señalador
    • Crear y modificar métodos abreviados
    • Añadir información de herramientas
    • Proporcionar un texto de ayuda en la línea de estado

    Si, por ejemplo, desea añadir un menú nuevo, puede modificar la sección correspondiente de acad.mnu y guardarla con otro nombre o bien, puede crear un nuevo archivo de menús.

    En el siguiente ejemplo, un proyecto de dibujo requiere el uso frecuente de círculos con radios de 1, 2 y 3 unidades. Para que el trabajo sea más eficaz, puede crear un archivo de menús que defina un menú desplegable con tres opciones, cada una de las cuales dibujará un círculo con un radio distinto. Para crear el archivo de menús, escriba las líneas en el Bloc de notas (o en cualquier otro editor de texto que pueda guardar los archivos con formato ASCII) y, a continuación, guarde el archivo en la carpeta support de AutoCAD con la extensión .mnu. El archivo de menús de este ejemplo podría tener el nombre circulos.mnu.

    ***MENUGROUP=CIRCULOS
    ***POP13
    //Crea círculos con radios de 1, 2 y 3 unidades
    Circle-1 [Radius-1 ]^C^C_circle \1
    Circle-2 [Radius-2 ]^C^C_circle \2
    Circle-3 [Radius-3 ]^C^C_circle \3

    La primera línea de un archivo de menús siempre corresponde a la sección Menugroup, que asigna al menú un nombre único. En el ejemplo, el nombre de Menugroup es Círculos. El nombre de Menugroup no tiene que coincidir necesariamente con el nombre del archivo.

    La segunda línea del ejemplo corresponde al rótulo de sección. Se trata de un menú desplegable, por lo que incluye una sección Pop que contiene números del 1 al 16 (POP13). Para obtener mas información acerca de los menús desplegables y contextuales, véase Creación de menús desplegables y contextuales.

    La tercera línea, precedida por dos barras oblicuas (//), es una línea opcional de comentarios que se pasa por alto cuando se compila el menú. Los comentarios de los archivos de menús se pueden utilizar para incluir avisos de copyright, documentación o notas.

    Las tres líneas siguientes definen los elementos del menú. En el primer elemento del menú, Circle-1 corresponde al identificador de nombre que se ha asignado al elemento de menú. El texto que aparece entre corchetes, [Radius-1 ], corresponde al rótulo del elemento de menú, que define lo que se muestra en el menú para este elemento. El resto corresponde a la macro de menú, que utiliza los comandos y los caracteres especiales de AutoCAD para dibujar un círculo con un radio de 1 unidad. Para obtener más información acerca de la creación de macros de menú, véase Creación de macros de menú.

    Para poder utilizar este nuevo menú en AutoCAD, debe cargar el archivo de menús, circulos.mnu mediante el comando CARGARMENU. Para obtener más información sobre la forma de cargar los archivos de menús, véase Carga y descarga de archivos de menús.

    Estructura de los archivos de menús

    Los archivos de menús se dividen en dos secciones. La sección Menugroup siempre aparece en primer lugar y asigna al archivo de menús un nombre de grupo de menús único. El nombre de un grupo de menús es una cadena que contiene un máximo de 32 caracteres alfanuméricos, sin espacios ni signos de puntuación.

    Las siguientes secciones definen áreas específicas de la interfaz de AutoCAD y contienen elementos de menú que suelen estar compuestos de un identificador de nombre, un rótulo y una macro de menú. Para obtener información específica sobre cada una de las secciones, véase el tema correspondiente.

    Las secciones de los archivos de menús se identifican mediante rótulos de sección que utilizan el formato ***nombre_sección. Las distintas secciones Buttons, Aux, Pop y Tablet están numeradas, como por ejemplo, ***POP5.
    Rótulo de sección | Área de la interfaz de usuario
***MENUGROUP | Nombre del grupo de menús
***BUTTONSn | Menú de botones del dispositivo señalador
***AUXn | Menú del dispositivo señalador del sistema
***POPn | Menús desplegables y contextuales
***TOOLBARS | Definiciones de las barras de herramientas
***IMAGE | Menús de mosaico de imágenes
***SCREEN | Menús de pantalla
***TABLETn | Menús de tablero
***HELPSTRINGS | Texto que se muestra en la barra de estado al resaltar un elemento de un menú desplegable o contextual o al situar el cursor sobre un botón de la barra de herramientas
***ACCELERATORS | Definiciones de métodos abreviados (o aceleradores)

    No es necesario que los archivos de menús contengan todas las posibles secciones de menú. Se recomienda crear archivos de menús pequeños que se puedan cargar y descargar según se desee (mediante los comandos CARGARMENU y DESCARGARMENU). Trabajar con archivos pequeños proporciona un mayor control sobre los recursos del sistema y facilita el proceso de personalización.

    Elementos de menú

    La sintaxis empleada para crear los elementos de menú es igual para todas las secciones de menú que contienen estos elementos. Todos los elementos de menú se componen de un identificador de nombre, un rótulo y una macro de menú. (Algunas secciones no utilizan identificadores de nombre y otras no usan rótulos.)

    Identificador de nombre

    Identifica al elemento de menú. El identificador de nombre del elemento de menú es una cadena con caracteres alfanuméricos y de subrayado (_) que identifica de forma exclusiva a un elemento perteneciente a un grupo de menús.

    Rótulo

    Define el texto que se muestra o presenta al usuario. El rótulo aparece entre corchetes ([ y ]).

    Macro de menú

    Define la acción realizada por el elemento de menú. Las macros de menú también definen, por ejemplo, el aspecto y la ubicación de los botones de la barra de herramientas. Las macros de menú pueden ser registros simples de pulsaciones de teclas que efectúan una tarea o combinaciones complejas de comandos y códigos de programación.

    Un elemento de menú reside normalmente en una línea del archivo de menús y suele tener el siguiente formato:

    identificador_nombre rótulo macro_menú

    En el siguiente ejemplo de una sección Pop, ID_Quit es el identificador de nombre. El rótulo [Exit] hace que se muestre el texto "Exit" en el menú. Al seleccionar este elemento de menú, la macro de menú ^C^C_quit cancela todos los comandos en ejecución e inicia el comando QUITA.

    ID_Quit [Exit]^C^C_quit
    Rótulos de los elementos de menú

    El formato y el uso de los rótulos de los elementos de menú no son iguales para todas las secciones de menú. Las secciones de menú que no tienen interfaz para mostrar información (como las secciones Buttons, Aux y Tablet) no requieren rótulos. No obstante, se pueden utilizar rótulos para incluir notas internas. En la siguiente tabla se describe el uso de los rótulos de los elementos de menú en las distintas secciones del archivo de menús.
    Sección de menú | Uso del rótulo
POPn | Define el contenido y el formato de los menús desplegables y contextuales
TOOLBARS | Define el nombre, el estado (flotante o anclada, oculta o visible) y la posición de la barra de herramientas. También define todos los botones y sus propiedades
IMAGE | Define el texto y la imagen que se muestran en los menús de mosaico de imágenes
SCREEN | Define el texto que se muestra en los menús de pantalla
HELPSTRINGS | Define el mensaje de ayuda de la línea de estado relacionado con los elementos de menú contenidos en las secciones Pop y Toolbars
ACCELERATORS | Asocia acciones de teclado con las macros de menú

    Macros de menú

    Una macro de menú define la acción que resulta de la elección de un elemento de menú. Para crear una macro de menú se pueden emplear comandos, caracteres especiales y códigos de programación DIESEL o AutoLISP. Para incluir un comando en un elemento de menú, debe conocer la secuencia de solicitudes y las opciones por defecto de cada una de ellas.

    Nota Como AutoCAD se revisa y mejora constantemente, puede que cambie la secuencia de solicitudes correspondiente a algunos comandos (y, en ocasiones, incluso el nombre de los comandos). Por tanto, es posible que los menús personalizados requieran algunos pequeños cambios para actualizarse a una nueva versión de AutoCAD.

    Véase también

    Carga y descarga de archivos de menús
    Creación de macros de menú
    Creación de menús desplegables y contextuales
    Personalización de las barras de herramientas
    Creación de menús de mosaico de imágenes
    Creación de menús de tablero
    Creación de mensajes de ayuda de la línea de estado
    Creación de métodos abreviados
    Creación de métodos abreviados


Ficha Procedimientos: Presentación general de los archivos de menús [Manual de personalización: ACG]

Archivo de menús
Presentación general de los archivos de menús
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de los archivos de menús [Manual de personalización: ACG]

Archivo de menús
Presentación general de los archivos de menús
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Carga y descarga de archivos de menús [Manual de personalización: ACG]

Archivo de menús
Carga y descarga de archivos de menús
Conceptos
Procedimientos
Referencia

    • Antes de utilizar un archivo de menús, se debe cargar en el programa.

    El menú base se carga automáticamente cuando se inicia AutoCAD. En AutoCAD, el archivo de menús base que se ha establecido por defecto es acad.mnu y se encuentra en la carpeta support de AutoCAD. Si modifica el menú por defecto o crea un nuevo archivo de menús que desea emplear como menú base, debe utilizar el comando MENU para cargarlo. Cuando se vuelve a iniciar AutoCAD, se carga automáticamente el nuevo menú base.

    El término menú parcial hace referencia a cualquier archivo de menús que se carga después que el menú base. Puede utilizar los comandos CARGARMENU y DESCARGARMENU para cargar y descargar menús parciales a medida que se necesiten durante la sesión de AutoCAD.

    Cualquier archivo puede servir como menú base o menú parcial, pero se recomienda utilizar como archivo base un archivo de menús que incluya la mayor parte de las secciones, de forma que sólo haya que cargar archivos de menús adicionales más pequeños a medida que sean necesarios.

    Carga de archivos de menús

    Utilice CARGARMENU y DESCARGARMENU para cargar y descargar los menús parciales y para añadir o eliminar los menús desplegables de la barra de menús.

    AutoCAD almacena el nombre del último menú base cargado en el registro del sistema. Este nombre también se guarda con el dibujo, pero sólo se utiliza por motivos de compatibilidad con versiones anteriores. Cuando se inicia AutoCAD, se carga el último menú base utilizado.

    Cambio o eliminación de menús

    Realizar cambios frecuentes en el contenido de una barra de menús puede confundir al usuario. Por este motivo es recomendable no cambiar el estado de la barra de menús de forma visual, a no ser que se solicite de forma explícita. Por ejemplo, si una persona desea descargar una aplicación, se pueden eliminar también los menús a los que esa aplicación hace referencia.

    Para reinicializar por completo el menú, elimine todos los menús parciales que estén cargados actualmente. Para ello, ejecute CARGARMENU y, en el cuadro de diálogo Personalización de menús, seleccione Reemplazar todo. Este procedimiento elimina todos los menús parciales, así como las definiciones de los identificadores asociadas a ellos, y equivale a especificar un nuevo archivo de menús en la ficha Archivos del cuadro de diálogo Opciones.

    Restauración o alternancia de menús

    Puede usar un menú personalizado para algunas tareas, de forma que se pueda acceder fácilmente al menú estándar. Para cargar el menú personalizado, en la ficha Sistema del cuadro de diálogo Opciones, escriba el nombre del menú personalizado junto a Archivo de menú.

    Al emplear CARGARMENU o DESCARGARMENU para alterar los menús cargados o personalizar la barra de menús con menús contextuales y barras de herramientas, los cambios se guardan en el registro. La próxima vez que se inicie AutoCAD, se restituirán los últimos menús cargados y la configuración de la barra de menús. Puede cargar y descargar hasta 8 menús parciales y 16 menús desplegables.

    Trabajo con los distintos tipos de archivos de menús

    Cuando se edita o crea un archivo MNU, la siguiente vez que se carga, AutoCAD lo compila y genera una serie de archivos en la carpeta support de AutoCAD. El término archivo de menús se emplea para designar cualquier grupo de archivos que funcionan conjuntamente para definir la interfaz de usuario, tal como se describe en la siguiente tabla. Cuando se carga o descarga un archivo de menús, el cuadro de diálogo Seleccionar archivo de menús puede incluir archivos MNU, MNC o MNS. Puede seleccionar cualquiera de estos archivos para cargar el menú que desee.

    Los tipos de archivos de menús y sus orígenes se describen en la tabla.
    Tipo de archivo | Descripción
MNU | Archivo de menús ASCII original. Es el archivo que se suele editar o crear.
MNC | Archivo de menús compilado. Archivo binario que contiene las cadenas de comando y la sintaxis de menú que definen el funcionamiento y el aspecto del menú o de cualquier otro elemento de la interfaz. AutoCAD compila este archivo cuando carga un archivo MNU por primera vez.
MNR | Archivo de recursos de menús. Archivo binario que contiene los mapas de bits utilizados por el menú u otro elemento de la interfaz. AutoCAD genera este archivo siempre que compila un archivo MNC.
MNS | Archivo de menús fuente. Archivo ASCII idéntico al archivo MNU pero que no incluye comentarios ni formatos especiales. AutoCAD modifica este archivo siempre que cambia el contenido del archivo de menús.
MNT | Archivo de recursos de menús. Este archivo se genera únicamente cuando no está disponible el archivo MNR, como por ejemplo cuando es de sólo lectura.
MNL | Archivo de menús LISP. Contiene expresiones AutoLISP empleadas por el archivo de menús. AutoCAD carga este archivo en la memoria cuando se va a cargar un archivo de menús que tiene el mismo nombre.

    AutoCAD busca y carga el archivo especificado conforme a la siguiente secuencia. Esta misma secuencia se utiliza cuando AutoCAD carga un menú nuevo.

    1. AutoCAD busca un archivo de menús fuente (MNS) con el nombre dado, siguiendo el procedimiento de búsqueda de biblioteca.
    • Si se encuentra un archivo MNS, AutoCAD busca en el mismo directorio un archivo de menús compilado (MNC) que tenga el mismo nombre. Si AutoCAD encuentra un archivo MNC que tenga una fecha y una hora iguales o posteriores a las del archivo MNC, carga el archivo MNC. De lo contrario, AutoCAD compila el archivo MNS, genera un nuevo archivo MNC en el mismo directorio y carga ese archivo.
    • Si no se encuentra un archivo MNS, AutoCAD busca un archivo de menús compilado (MNC) con el nombre especificado, siguiendo el procedimiento de búsqueda de biblioteca. Si AutoCAD encuentra el archivo MNC, lo carga.
    • Si no se encuentra ningún archivo MNS ni MNC, AutoCAD busca en la ruta de la biblioteca un archivo de plantilla de menús (MNU) que tenga el mismo nombre. Si no se encuentra el archivo, AutoCAD compila un archivo MNC, genera un archivo MNS y, a continuación, carga el archivo MNC.
    • Si no se encuentra ningún archivo con el mismo nombre, AutoCAD muestra un mensaje de error y pide al usuario que especifique otro nombre de archivo de menús.
    2. Después de encontrar, compilar y cargar el archivo MNC, AutoCAD busca un archivo de menús LISP (MNL) siguiendo el procedimiento de búsqueda de biblioteca. Si lo encuentra, evalúa las expresiones AutoLISP de ese archivo.

    El archivo acad.mnl contiene los códigos AutoLISP que usa el archivo de menús estándar acad.mnu. El archivo acad.mnl se carga cada vez que se carga el archivo acad.mnu.

    Siempre que AutoCAD compila un archivo MNC, genera un archivo MNR (un archivo de recursos de menús que contiene los mapas de bits que usa el menú) y también un archivo MNS (un archivo ASCII que inicialmente es idéntico al archivo MNU, pero sin incluir comentarios ni formatos especiales). AutoCAD modifica el archivo MNS cada vez que, a través de la interfaz, se realizan cambios en el contenido del archivo de menús (por ejemplo, cuando se utiliza PERSONALIZAR para modificar el contenido de una barra de herramientas).

    Aunque la posición inicial de las barras de herramientas se define en el archivo MNU o MNS, los cambios realizados en el estado mostrar/ocultar y anclada/flotante o en la posición de las barras de herramientas se graban en el registro del sistema. Una vez creado el archivo MNS, éste se utiliza como fuente para generar archivos MNC y MNR posteriores. Si modifica el archivo MNU después de generar un archivo MNS, debe usar el comando OPCIONES para cargar explícitamente el archivo MNU de manera que AutoCAD genere archivos de menús nuevos y reconozca los cambios efectuados.

    Nota Si ha modificado las barras de herramientas mediante la interfaz, deberá cortar y pegar las partes editadas del archivo MNS en el archivo MNU antes de borrar el primero.


Ficha Procedimientos: Carga y descarga de archivos de menús [Manual de personalización: ACG]

Archivo de menús
Carga y descarga de archivos de menús
Conceptos
Procedimientos
Referencia

    • Para cargar un menú parcial

    Para descargar un menú parcial

    Para cargar el menú base


Ficha Referencia: Carga y descarga de archivos de menús [Manual de personalización: ACG]

Archivo de menús
Carga y descarga de archivos de menús
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    OPCIONES

    Personaliza los parámetros de AutoCAD

    Variables de sistema

    No hay entradas.


Ficha Procedimientos: DIESEL [Manual de personalización: ACG]

DIESEL
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: DIESEL [Manual de personalización: ACG]

DIESEL
Conceptos
Procedimientos
Referencia

    • Comandos

    MODIVAR

    Enumera o cambia los valores de las variables de sistema

    Variables de sistema

    MODEMACRO

    Muestra una cadena de texto en la línea de estado, como el nombre del dibujo actual, la marca de fecha y hora o los modos especiales


Creación de macros de menú [Manual de personalización: ACG]

Archivo de menús
Creación de macros de menú
Conceptos
Procedimientos
Referencia

    • Los elementos de los archivos MNU se componen de tres partes: un identificador de nombre, un rótulo y una macro de menú. La macro define la acción que se debe llevar a cabo cuando el usuario selecciona el elemento de menú.

    • Presentación general de las macros de menú
    • Pausas para las entradas de usuario en las macros de menú
      Para aceptar datos introducidos mediante el teclado o el dispositivo señalador mientras se está ejecutando una macro de menú, sitúe una barra invertida (\) en el punto en el que desea que se realice la entrada.
    • Compatibilidad internacional de idioma en las macros de menú
      Si desarrolla archivos de menús que se pueden emplear con una versión del programa cuyo idioma no es el inglés, los comandos y las opciones estándar se traducen automáticamente si cada comando u opción está precedido del carácter de subrayado (_).
    • Uso de caracteres de control especiales en las macros de menú
      Se pueden utilizar caracteres especiales, incluidos los de control, en las macros de menú.
    • Repetición de comandos en las macros de menú
      Se puede repetir un comando en una macro de menú hasta que se seleccione otro comando.
    • Uso del modo de designación de un único objeto en macros de menú
      El modo de designación de un único objeto cancela la repetición de la solicitud Designar objetos en los comandos de edición.
    • Uso de macros de menú para intercambiar menús
      Se puede reemplazar el contenido de las secciones de menú Buttons, Aux, Pop, Screen o Tablet que estén activas. El nuevo contenido del menú puede provenir de otra sección o submenú del menú base o de un menú parcial.
    • Uso de expresiones condicionales en las macros de menú
      Es posible emplear expresiones condicionales en una macro de menú utilizando un comando que introduzca las expresiones de la macro en lenguaje DIESEL.


Ficha Procedimientos: Creación de macros de menú [Manual de personalización: ACG]

Archivo de menús
Creación de macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de macros de menú [Manual de personalización: ACG]

Archivo de menús
Creación de macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    CAMBIA

    Cambia las propiedades de los objetos existentes

    DESIGNA

    Sitúa los objetos designados en el conjunto seleccionado previamente

    Variables de sistema

    MENUECHO

    Define la reproducción de menús en pantalla y los bits de control de solicitudes

    PICKADD

    Controla si las designaciones posteriores sustituyen al conjunto de selección actual o se añaden a él

    PICKAUTO

    Controla la representación visual automática en la solicitud Designe objetos


Presentación general de las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Presentación general de las macros de menú
Conceptos
Procedimientos
Referencia

    • La macro de un elemento de menú puede ser tan simple como un comando:

    Line [Line]line

    El identificador de nombre es Line, el rótulo es [Line] y la macro de menú es line, que ejecuta el comando LINEA.

    En el siguiente ejemplo de elemento de menú, la macro de menú ^C^C_circle \1, dibuja un círculo con un radio de 1 unidad.

    Circle-1 [Radius-1]^C^C_circle \1
    • Los caracteres especiales ^C^C cancelan todos los comandos que están en ejecución.
    • El carácter especial de subrayado (_) traduce automáticamente el siguiente comando a otros idiomas.
    • La entrada circle ejecuta el comando CIRCULO.
    • El cáracter especial de barra invertida (\) crea una pausa para que el usuario pueda especificar el punto central.
    • La entrada 1 es la respuesta a la solicitud para que se introduzca el valor del radio.

    Para obtener una lista de los caracteres especiales que se pueden usar en las macros de menú, véase Uso de caracteres de control especiales en las macros de menú.

    Además de los comandos y los caracteres especiales, puede utilizar DIESEL (Direct Interpretively Evaluated String Expression Language) y AutoLISP. Véase DIESEL.

    Cancelación de comandos en ejecución

    Para asegurarse de que no hay comandos de AutoCAD en curso antes de ejecutar una macro de menú, use la cadena ^C^C en el inicio de la macro de menú. Equivale a pulsar ESC dos veces. Aunque un único ^C puede cancelar la mayor parte de los comandos, es necesario escribir ^C^C para volver a la solicitud de comandos procedente de un comando de acotación, por lo que se recomienda utilizar ^C^C.

    Finalización de las macros de menú

    Todos los caracteres de una macro de menú son significativos, incluidos los espacios en blanco.

    Cuando se selecciona un elemento de menú, AutoCAD añade un espacio al final de la macro antes de procesar la secuencia de comandos. AutoCAD procesa la macro del siguiente elemento de menú como si se hubiese introducido linea y pulsado la BARRA ESPACIADORA para completar el comando:

    Line [Line]line

    En algunas situaciones, las macros requieren caracteres de finalización especiales. Algunos comandos, como por ejemplo TEXTO, se deben finalizar pulsando INTRO, no la BARRA ESPACIADORA. Para poder finalizar algunos comandos se necesita más de un espacio (o INTRO), pero algunos editores de texto no pueden crear líneas que contengan espacios en blanco al final.

    Dos convenciones especiales permiten resolver estos problemas.

    • El signo de punto y coma (;) de una macro de menú ejecuta INTRO.
    • Si una línea termina con un carácter de control, una barra invertida (\), un signo más (+) o un punto y coma (;), AutoCAD no añade un espacio en blanco detrás.

    Si el elemento de menú del siguiente ejemplo finaliza únicamente con una barra invertida (que detiene la macro para permitir que el usuario introduzca información), no podrá ejecutar el comando BORRA porque AutoCAD no añade un espacio en blanco después de la barra invertida. Por tanto, la macro de menú utiliza el punto y coma (;) para ejecutar INTRO una vez que el usuario ha introducido los datos.

    Erase 1 [Erase 1]erase \;

    Compare los siguientes elementos de menú:

    UCS [UCS ]ucs
    UCS World [UCS W ]ucs ;

    En el primer ejemplo se introduce scp en la línea de comando y se pulsa la BARRA ESPACIADORA. Aparece la siguiente solicitud de comando.

    Origen/ejeZ/3p/oBjeto/Vista/X/Y/Z/PRev/Rest/Guardar/Supr/?/ <Univ>:

    En el segundo ejemplo se introduce scp, se pulsa la BARRA ESPACIADORA y se pulsa INTRO para aceptar el valor por defecto Univ.

    Advertencia Como AutoCAD se revisa y mejora constantemente, es posible que cambie la secuencia de solicitudes correspondiente a algunos comandos (y, en ocasiones, incluso el nombre del comando). Por tanto, es posible que los menús personalizados requieran algunos pequeños cambios para actualizarse a una nueva versión.

    La mayor parte de las macros de menú funcionan bien en todas las secciones del archivo de menús.

    Supresión de ecos de comandos y solicitudes de datos en macros de menú

    Normalmente, los caracteres que se leen en una macro de menú aparecen en la ventana de comandos como si se hubiesen introducido con el teclado (es decir, con eco). Aparecen las solicitudes incluso cuando un elemento de menú proporciona las respuestas. Puede suprimir estas visualizaciones empleando la variable de sistema MENUECHO. Si se han desactivado los ecos de comandos y las solicitudes de datos en la entrada del elemento de menú, se pueden volver a activar introduciendo una cadena ^P en el elemento de menú.

    Creación de macros de menú largas

    Si un elemento de la macro de menú no cabe en una línea, puede continuar en la siguiente. Para ello, añada un signo más (+) como carácter final de la línea que desee continuar. El siguiente ejemplo, que se puede utilizar para establecer las condiciones iniciales de un dibujo nuevo, continúa en la segunda línea.

    [Setup ]layer set ground-floor;;grid on; ... ;fill off;+
    limits 0,0 12,9;status

    Los elementos de menú pueden continuar en tantas líneas como sea necesario.

    Nota Las continuaciones de línea no se conservan cuando AutoCAD crea el archivo MNS.

    Véase también

    Uso de caracteres de control especiales en las macros de menú
    Pausas para las entradas de usuario en las macros de menú
    Compatibilidad internacional de idioma en las macros de menú
    Repetición de comandos en las macros de menú
    Creación de menús desplegables y contextuales
    Personalización de las barras de herramientas
    Creación de menús de mosaico de imágenes
    Creación de menús de pantalla
    Creación de menús de tablero
    Creación de mensajes de ayuda de la línea de estado
    Creación de métodos abreviados
    DIESEL


Ficha Procedimientos: Presentación general de las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Presentación general de las macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Presentación general de las macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variable de sistema

    MENUECHO

    Define la reproducción de menús en pantalla y los bits de control de solicitudes


Pausas para las entradas de usuario en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Pausas para las entradas de usuario en las macros de menú
Conceptos
Procedimientos
Referencia

    • Para aceptar datos introducidos mediante el teclado o el dispositivo señalador mientras se está ejecutando una macro de menú, sitúe una barra invertida (\) en el punto en el que desea que se realice la entrada.

    Circle-1 [Circle-1]circle \1
    Layoff [Layoff ]-layer off \;

    La macro de menú de Circle-1 se detiene para que el usuario especifique el punto central y, a continuación, lee un radio de 1 unidad. Obsérvese que no se ha incluido un espacio detrás de la barra invertida. El elemento de menú Layoff ejecuta CAPA en la línea de comando, introduce la opción Off y se detiene para que el usuario pueda especificar un nombre de capa. A continuación, desactiva esa capa y finaliza el comando CAPA. Normalmente, CAPA solicita otra operación y sólo sale si se pulsa la BARRA ESPACIADORA o INTRO. En la macro de menú, el signo de punto y coma (;) se utiliza como INTRO.

    Habitualmente, una macro de menú se reanuda después de una entrada de usuario como, por ejemplo, la especificación de un punto. Por lo tanto, no se puede construir una macro de menú que acepte un número variable de entradas (como en la designación de objetos) y, después, continúe. Sin embargo, se produce una excepción con el comando DESIGNA: una barra invertida interrumpe el elemento de menú hasta que se ha realizado la designación de objetos. Véase el siguiente ejemplo de elemento de menú:

    Make Red [Make Red ]select \change previous ;properties color red ;

    En este elemento de menú, DESIGNA crea un conjunto de selección de uno o más objetos. A continuación, la macro ejecuta el comando CAMBIA, hace referencia a este conjunto de selección con la opción Previous y cambia el color de todos los objetos designados a rojo.

    Nota Dado que el carácter de barra invertida (\) hace que la macro de menú se detenga para que el usuario introduzca datos, no podrá usarlo en una macro de menú con ningún otro fin. Cuando especifique las rutas de directorio de archivos, utilice una barra oblicua (/) como delimitador de la ruta: por ejemplo, /direct/archivo.

    Las siguientes situaciones retrasan la reanudación de una macro de menú después de realizar una pausa:

    • Cuando se espera que se realice la introducción de la ubicación de un punto, se pueden utilizar los modos de referencia a objetos antes de especificar el punto.
    • Cuando se utilizan filtros de puntos X/Y/Z, el elemento de menú se interrumpe hasta que se define por completo el punto.
    • En el caso de DESIGNA, la macro de menú no reanuda su ejecución hasta que la designación de objetos se ha completado.
    • Cuando el usuario responde con un comando transparente, la macro de menú interrumpida permanece en este estado hasta que el comando se completa y se reciben los datos solicitados originalmente.
    • Cuando el usuario responde seleccionando otro elemento de menú (para proporcionar opciones o ejecutar un comando transparente), la macro original se interrumpe y el elemento de menú elegido se procesa en su totalidad antes de que la macro interrumpida reanude su ejecución.

    Nota Cuando la entrada del comando procede de un elemento de menú, se asume que los valores de las variables de sistema PICKADD y PICKAUTO son 1 y 0, respectivamente. Esto garantiza la compatibilidad con las versiones anteriores de AutoCAD y facilita la personalización, ya que no es necesario comprobar los valores de estas variables.


Ficha Procedimientos: Pausas para las entradas de usuario en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Pausas para las entradas de usuario en las macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Pausas para las entradas de usuario en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Pausas para las entradas de usuario en las macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    CAMBIA

    Cambia las propiedades de los objetos existentes

    DESIGNA

    Sitúa los objetos designados en el conjunto seleccionado previamente

    Variables de sistema

    PICKADD

    Controla si las designaciones posteriores sustituyen al conjunto de selección actual o se añaden a él

    PICKAUTO

    Controla la representación visual automática en la solicitud Designe objetos


Compatibilidad internacional de idioma en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Compatibilidad internacional de idioma en las macros de menú
Conceptos
Procedimientos
Referencia

    • Si desarrolla archivos de menús que se pueden emplear con una versión de AutoCAD cuyo idioma no es el AutoCADinglés, los comandos y las opciones estándar de este programa se traducen automáticamente si cada comando u opción está precedido del carácter de subrayado (_).

    El siguiente ejemplo muestra una parte de un menú contextual.

    [->Arc]
    [3-point]^C^C_arc
    [Start, Cen, End]^C^C_arc;\_c
    [Start, Cen, Angle]^C^C_arc;\_c;\_a
    [Start, Cen, Length]^C^C_arc;\_c;\_l
    [Start, End, Angle]^C^C_arc;\_e;\_a
    [Start, End, Radius]^C^C_arc;\_e;\_r

    En este ejemplo, el carácter de subrayado precede a todos los comandos u opciones que se utilizan en las macros de menú.


Ficha Procedimientos: Compatibilidad internacional de idioma en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Compatibilidad internacional de idioma en las macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Compatibilidad internacional de idioma en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Compatibilidad internacional de idioma en las macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variable de sistema

    No hay entradas.


Uso de caracteres de control especiales en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso de caracteres de control especiales en las macros de menú
Conceptos
Procedimientos
Referencia

    • Se pueden utilizar caracteres especiales, incluidos los de control, en las macros de menú. En una macro de menú, el signo de intercalación (^) corresponde a la tecla CTRL del teclado. Puede combinar el signo de intercalación con otro carácter para construir macros de menú que realicen operaciones tales como activar y desactivar la rejilla (^G) o cancelar un comando (^C). Como los corchetes ([ y ]) identifican los rótulos de menú, no se pueden emplear en las macros de menú.

    [GridFlip]^G
    [*Cancel*]^C

    Los caracteres de control no alfabéticos son los siguientes:

    ^@ (código ASCII 0)
    ^[ (código ASCII 27)
    ^\ (código ASCII 28)
    ^] (código ASCII 29)
    ^^ (código ASCII 30)
    ^_ (código ASCII 31)

    La macro del siguiente elemento de menú Address utiliza la barra invertida (\) para hacer una pausa que permita al usuario introducir datos y el signo de punto y coma (;) equivalente a INTRO.

    Address [Address ]text \.4 0 DRAFT Inc;;;Main St.;;;City, State;

    La macro ejecuta TEXTO, se detiene para que el usuario especifique un punto inicial y, a continuación, introduce la dirección en tres líneas. De los tres puntos y comas (;;;), el primero finaliza la cadena de texto, el segundo hace que se repita el comando TEXTO y el tercero acepta la posición por defecto debajo de la línea anterior.

    Puede hacer que una macro de menú introduzca uno o más caracteres sin tratarlos como entradas finales. Por ejemplo, podría crear una serie de macros de menú que actúen como teclas numéricas.

    [1]1x^H
    [2]2x^H
    [3]3x^H

    Cuando elija uno de estos elementos, se introducirá el dígito correspondiente. Le sigue otro carácter (en este caso la letra x) que ^H elimina. (CTRL+H es el código ASCII correspondiente a RETROCESO.) Todos estos elementos de menú finalizan con un carácter de control. AutoCAD no añade ningún espacio ni INTRO a estos elementos. Así, puede elegir [2], [2], [3], [1] para construir la entrada 2231. Pulse INTRO para introducir el número completo.

    Las macros de menú utilizan los caracteres especiales que se incluyen en la siguiente tabla. Los corchetes ([ y ]) identifican los rótulos de menú y no se pueden emplear en las macros de menú.
    Caracteres especiales que se utilizan en las macros de menú
Carácter | Descripción
; | Ejecuta INTRO
^M | Ejecuta INTRO
^I | Ejecuta TAB
[espacio en blanco] | Introduce un espacio. Un espacio en blanco entre secuencias de comandos en un elemento de menú equivale a pulsar la BARRA ESPACIADORA
\ | Se detiene para que el usuario introduzca datos (no se puede utilizar en la sección Accelerators)
_ | Traduce los comandos y opciones de AutoCAD a los que precede
+ | Continúa la macro de menú en la línea siguiente (si es el último carácter)
=* | Muestra el menú contextual, de imágenes o desplegable de nivel superior actual
*^C^C | Prefijo correspondiente a un elemento de repetición
$ | Carga una sección de menú o introduce una expresión de macro condicional en lenguaje DIESEL ($M=).
^B | Activa o desactiva Forzcursor (CTRL+B)
^C | Cancela un comando (ESC)
^D | Activa o desactiva Coordenadas (CTRL+D)
^E | Define el siguiente plano isométrico (CTRL+E)
^G | Activa o desactiva Rejilla (CTRL+G)
^H | Ejecuta RETROCESO
^O | Activa o desactiva Orto
^P | Activa o desactiva MENUECHO
^Q | Transmite todas las solicitudes, las listas de estado y las entradas a la impresora (CTRL+Q)
^T | Activa o desactiva Tablero (CTRL+T)
^V | Cambia la ventana actual
^Z | Carácter nulo que suprime la adición automática de la BARRA ESPACIADORA al final de un elemento de menú

    Véase también

    Códigos ASCII


Ficha Procedimientos: Uso de caracteres de control especiales en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso de caracteres de control especiales en las macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de caracteres de control especiales en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso de caracteres de control especiales en las macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variable de sistema

    No hay entradas.


Repetición de comandos en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Repetición de comandos en las macros de menú
Conceptos
Procedimientos
Referencia

    • Una vez seleccionado un nuevo comando, puede utilizarlo varias veces antes de pasar a otro comando. Se puede repetir un comando en una macro de menú hasta que se seleccione otro distinto. Sin embargo, no se puede utilizar esta función para especificar distintas opciones.

    Si una macro de menú comienza con *^C^C inmediatamente después del rótulo del elemento, la macro se guarda en la memoria. La macro responde a las sucesivas solicitudes de comandos hasta que se finaliza con ESC o se designa otro elemento de menú.

    Nota No utilice ^C (Cancelar) dentro de una macro de menú que comience con la cadena *^C^C, ya que esto cancela la repetición.

    Las macros de menú de los siguientes ejemplos repiten los comandos:

    [Move ]*^C^Cmove Single
    [Copy ]*^C^Ccopy Single
    [Erase ]*^C^Cerase Single
    [Stretch]*^C^Cstretch Single Crossing
    [Rotate ]*^C^Crotate Single
    [Scale ]*^C^Cscale Single

    Todas las macros del ejemplo inician el comando y solicitan al usuario que designe un objeto. Se muestra el resto de las solicitudes necesarias para completar el comando y, a continuación, éste finaliza y se ejecuta de nuevo. Para obtener más información acerca de Single y Single Crossing, véase Uso del modo de designación de un único objeto en macros de menú.

    La repetición de comandos no se puede utilizar en las macros de menú relacionadas con los menús de mosaico de imágenes.


Ficha Procedimientos: Repetición de comandos en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Repetición de comandos en las macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Repetición de comandos en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Repetición de comandos en las macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variable de sistema

    No hay entradas.


Uso del modo de designación de un único objeto en macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso del modo de designación de un único objeto en macros de menú
Conceptos
Procedimientos
Referencia

    • El modo de designación de un único objeto cancela la repetición de la solicitud Designar objetos en los comandos de edición. Después de designar un objeto y de responder al resto de solicitudes, finaliza el comando. Véase el siguiente ejemplo de macro de menú:

    [Erase]*^C^Cerase single

    Esta macro finaliza el comando actual y ejecuta BORRA en el modo de designación de un único objeto. Tras elegir este elemento de menú, puede designar un único objeto para estirarlo o hacer clic en un área en blanco del dibujo y especificar una ventana de designación. Los objetos designados de esta forma se borran y el elemento de menú se repite (debido al asterisco situado a la izquierda) para que se puedan borrar otros elementos adicionales.


Ficha Procedimientos: Uso del modo de designación de un único objeto en macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso del modo de designación de un único objeto en macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso del modo de designación de un único objeto en macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso del modo de designación de un único objeto en macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variable de sistema

    No hay entradas.


Uso de macros de menú para intercambiar menús [Manual de personalización: ACG]

Creación de macros de menú
Uso de macros de menú para intercambiar menús
Conceptos
Procedimientos
Referencia

    • Se pueden utilizar las macros de menú para reemplazar el contenido de las secciones de menú Buttons, Aux, Pop, Screen o Tablet que estén activas. El nuevo contenido del menú puede provenir de otra sección o submenú del menú base o de un menú parcial. La información relacionada con el intercambio de menús referente a cada sección del menú se incluye en la descripción correspondiente.

    Sólo se pueden intercambiar menús del mismo tipo: un menú Aux por otro, un menú Pop por otro y así sucesivamente. Intentar el intercambio entre tipos diferentes puede producir un funcionamiento impredecible y no deseado. No obstante, dentro de un tipo dado, se pueden realizar intercambios entre dos menús cualesquiera. El intercambio podría dar lugar a un funcionamiento extraño en el caso de los menús Tablet ya que, normalmente, no todos tienen el mismo número de macros.

    Utilice la siguiente sintaxis en una macro de menú para intercambiar menús:

    $sección=grupo_menús.nombre_menú

    A continuación se ofrecen las descripciones:

    $

    Carga una sección de menú.

    sección

    Especifica la sección de menú. Los nombres válidos son los siguientes:

    A1–A4 para los menús Aux de 1 a 4
    B1–B4 para los menús Buttons de 1 a 4
    P0–P16 para los menús Pop de 0 a 16
    I para el menú Image
    S para el menú Screen
    T1–T4 para los menús Tablet de 1 a 4

    grupo_menús

    Especifica el grupo de menús al que pertenece nombre_menú (no es necesario si nombre_menú está en el menú base).

    nombre_menú

    Especifica la sección o el submenú que se va a insertar. Se trata del alias o el rótulo principal de la sección que se va a cargar.

    Los siguientes elementos de menú ilustran la referencia a submenús:

    $S=PARTS
    $T1=EDITCMDS

    Puede activar el mecanismo de submenú mientras se ejecuta un comando sin interrumpir su ejecución. Por ejemplo, las siguientes cadenas de comando son equivalentes:

    $S=ELEMARCO ARCO
    ARCO $S=ELEMARCO

    Cada elemento de menú ejecuta el comando ARCO, cambia al submenú de pantalla ELEMARCO y espera la introducción de los parámetros del arco. La referencia al submenú debe ir seguida de un espacio para separarla de los sucesivos comandos del elemento de menú.

    Se puede incluir un menú Pop en la barra de menús o en el menú contextual activo, pero no en ambos.


Ficha Procedimientos: Uso de macros de menú para intercambiar menús [Manual de personalización: ACG]

Creación de macros de menú
Uso de macros de menú para intercambiar menús
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de macros de menú para intercambiar menús [Manual de personalización: ACG]

Creación de macros de menú
Uso de macros de menú para intercambiar menús
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variable de sistema

    No hay entradas.


Uso de expresiones condicionales en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso de expresiones condicionales en las macros de menú
Conceptos
Procedimientos
Referencia

    • Puede utilizar el comando $M= en una macro de menú para introducir expresiones de macro en lenguaje DIESEL (Direct Interpretively Evaluated String Expression Language). El formato es el siguiente:

    $M=expresión

    Si se introduce la macro mediante $M=, AutoCAD evalúa la siguiente cadena como expresión DIESEL y reconoce expresión como la expresión DIESEL.

    [Fillflip]FILLMODE $M=$(-,1,$(getvar,fillmode))

    Fillflip activa y desactiva FILLMODE sustrayendo el valor actual de FILLMODE de 1 y devolviendo el valor resultante a la variable de sistema FILLMODE. Puede usar este método para alternar las variables de sistema cuyos valores válidos son 1 o 0.

    Finalización de macros que contienen expresiones condicionales

    Si emplea el lenguaje DIESEL para realizar pruebas "if-then", puede haber situaciones en las que no desee utilizar los espacios de finalización o signos de punto y coma (equivalentes a INTRO) habituales. Si se añade ^Z al final de la macro de menú, AutoCAD no inserta automáticamente un espacio (INTRO) al final de la expresión de macro. Véase Presentación general de las macros de menú y DIESEL.

    Igual que ocurre con otros caracteres de control de los elementos de menú, la cadena ^Z que aquí se emplea está compuesta de ^ (una intercalación) y Z , y no equivale a pulsar CTRL+Z.

    En los ejemplos siguientes, ^Z se usa como carácter de finalización de una macro de menú.

    [Model]^C^C$M=$(if,$(=,$(getvar,tilemode),0),$S=mview _mspace )^Z
    [Paper]^C^C$M=$(if,$(=,$(getvar,tilemode),0),$S=mview _pspace )^Z

    Si estas macros de menú no finalizasen con ^Z, AutoCAD añadiría automáticamente un espacio (INTRO), repitiendo el último comando introducido.

    Véase también


Ficha Procedimientos: Uso de expresiones condicionales en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso de expresiones condicionales en las macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de expresiones condicionales en las macros de menú [Manual de personalización: ACG]

Creación de macros de menú
Uso de expresiones condicionales en las macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variable de sistema

    No hay entradas.


Uso de AutoLISP en las macros de menú [Manual de personalización: ACG]

Archivo de menús
Uso de AutoLISP en las macros de menú
Conceptos
Procedimientos
Referencia

    • Puede utilizar las variables y expresiones AutoLISP para crear macros de menú que realicen tareas complejas. Para usar AutoLISP de un modo eficaz con las macros de menú, puede incluir el código AutoLISP en un archivo MNL distinto. AutoCAD carga el archivo MNL al cargar un archivo de menús con el mismo nombre.

    AutoCAD acepta un máximo de 255 caracteres de código AutoLISP en las macros de menú. Para usar más caracteres, divida el código en módulos distintos separados mediante signos de punto y coma (;), de manera que AutoCAD pueda leer y ejecutar el código en bloques.

    Crear elementos de menú que utilicen AutoLISP constituye un modo más avanzado de emplear la función de menú personalizado de AutoCAD. Examine con atención los siguientes ejemplos y la información de AutoLISP Reference y de AutoLISP Developer's Guide (en el menú Ayuda, haga clic en Ayuda del desarrollador). Con un poco de experimentación y de práctica podrá utilizar esta función con eficacia.

    Ejecución de una macro de menú

    Para ejecutar una macro de menú Pop mediante el lenguaje de programación, como si la hubiese elegido el usuario, puede emplear la siguiente sintaxis:

    (menucmd "Ggrupo_menús.identificador_nombre=|")

    Sólo funciona si la macro de menú Pop forma parte de un menú Pop al que se puede acceder en la barra de menús de AutoCAD. Para obtener más información acerca de esta sintaxis, véase AutoLISP Reference.

    Valores predefinidos

    Una aplicación que utiliza valores predefinidos de inserción de bloque puede proporcionar elementos de menú como los siguientes:

    [Set WINWID ]^C^C^P(setq WWID (getreal"Enter window width: ")) ^P
    [Set WALLTHK]^C^C^P(setq WTHK (getreal"Enter wall thickness: ")) ^P
    [Insert Window]^C^C_INSERT window XScale !WWID YScale !WTHK

    Este código inserta la ventana de bloque especificada, definiendo la escala del eje X con la anchura actual de la ventana y la del eje Y con el grosor actual de la pared. En este ejemplo, los valores reales proceden de los símbolos AutoLISP WINWID y WALLTHK definidos por el usuario. El usuario decide cuál va a ser la rotación, de forma que la ventana pueda girar en la pared.

    Ajuste de tamaño de los pinzamientos

    Con los siguientes elementos de menú, el ajuste de tamaño de los pinzamientos se puede realizar directamente:

    [GRIP-up]^P(setvar"gripsize"(1+(getvar"gripsize")))(redraw)(princ)
    [GRIP-dn]^P(setvar"gripsize"(1-(getvar"gripsize")))(redraw)(princ)

    Para que la comprobación de estos elementos de menú sea válida, no se pueden utilizar para la variable de sistema GRIPSIZE valores menores que 0 y mayores que 255.

    Solicitud de entradas de usuario

    El siguiente elemento de menú solicita al usuario que especifique dos puntos y dibuja una polilínea rectangular utilizándolos como esquinas.

    [BOX  ]^P(setq a (getpoint "Enter first corner: "));\+
    (setq b (getpoint "Enter opposite corner: "));\+
    pline !a (list (car a)(cadr b)) !b (list (car b)(cadr a)) c;^P


Ficha Procedimientos: Uso de AutoLISP en las macros de menú [Manual de personalización: ACG]

Archivo de menús
Uso de AutoLISP en las macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de AutoLISP en las macros de menú [Manual de personalización: ACG]

Archivo de menús
Uso de AutoLISP en las macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variable de sistema

    No hay entradas.


Personalización de los botones de un dispositivo señalador [Manual de personalización: ACG]

Archivo de menús
Personalización de los botones de un dispositivo señalador
Conceptos
Procedimientos
Referencia

    • El dispositivo señalador del sistema Windows utiliza los menús Aux del archivo MNU. El resto de los dispositivos usan los menús Buttons.

    • Presentación general de los menús Buttons y Aux
    • Intercambio de los menús Buttons y Aux
      Si es necesario, se puede intercambiar el contenido de los menús Buttons y Aux activos con el de otra sección de menú del mismo tipo.
    • Aceptación de coordenadas en los menús Buttons
      Mediante una construcción cuidada de las macros de las secciones Buttons y Aux del archivo de menús, puede pasar por alto las coordenadas del cursor en cruz o utilizarlas con el comando activado por el botón.


Ficha Procedimientos: Personalización de los botones de un dispositivo señalador [Manual de personalización: ACG]

Archivo de menús
Personalización de los botones de un dispositivo señalador
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Personalización de los botones de un dispositivo señalador [Manual de personalización: ACG]

Archivo de menús
Personalización de los botones de un dispositivo señalador
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    MBUTTONPAN

    Controla el comportamiento del tercer botón o rueda del dispositivo señalador

    SHORTCUTMENU

    Controla si están disponibles en el área de dibujo los menús contextuales de modo Por defecto, Edición y Comando


Presentación general de los menús Buttons y Aux [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Presentación general de los menús Buttons y Aux
Conceptos
Procedimientos
Referencia

    • Las secciones Buttons (***BUTTONSn) y Aux (***AUXn) del archivo de menús presentan el mismo formato. El dispositivo señalador del sistema Windows utiliza los menús Aux y el resto de los dispositivos señaladores (por ejemplo, el cursor o el lápiz óptico de un tablero digitalizador) usan los menús Buttons. El menú BUTTONS1 funciona igual que el menú AUX1, etc.

    Las secciones de menú Buttons y Aux sólo son válidas cuando el archivo de menús se emplea como menú base. Las secciones Buttons y Aux se ignoran en los menús parciales.

    En las secciones Aux y Buttons contenidas en el archivo de menús, cada línea representa un botón. El dispositivo señalador puede reconocer tantas líneas como botones asignables tenga. Por ejemplo, en las secciones AUX1 y BUTTONS1, cada línea define lo que sucede al hacer clic en un botón determinado; y en las secciones AUX2 y BUTTONS2, cada línea define lo que sucede al pulsar MAYÚS y hacer clic en un botón.
    Secuencia de teclas y botones | Secciones de menú
Clic | AUX1 y BUTTONS1
MAYÚS + clic | AUX2 y BUTTONS2
CTRL + clic | AUX3 y BUTTONS3
CTRL + MAYÚS + clic | AUX4 y BUTTONS4

    Aunque las secciones de 1 a 4 son las únicas secciones activas, puede definir secciones adicionales y convertirlas en activas. Véase Intercambio de los menús Buttons y Aux.

    En el siguiente ejemplo, la sección AUX1 es igual a la que contiene el archivo acad.mnu estándar:

    ***AUX1
    ;
    ^C^C
    ^B
    ^O
    ^G
    ^D
    ^E
    ^T

    La primera línea que sigue al rótulo de la sección de menú ***AUX1 representa el botón que sigue al botón selector del dispositivo señalador (botón 2). El punto y coma (;) asigna INTRO al botón 2. La segunda línea que sigue al rótulo de la sección de menú asigna ESC dos veces al botón 3 y así sucesivamente.

    Nota La primera línea que sigue al rótulo de la sección de menú ***AUX1 o ***BUTTONS1 se utiliza únicamente cuando la variable de sistema SHORTCUTMENU se ha definido como 0. Si SHORTCUTMENU se ha establecido en un valor distinto de 0, se utiliza el menú integrado. De modo similar, la segunda línea que sigue al rótulo ***AUX1 o ***BUTTONS1 se utiliza sólo cuando la variable de sistema MBUTTONPAN se ha definido como 0.

    No se puede reasignar el botón selector en el archivo de menús. La asignación del botón selector está controlada por el sistema operativo o por una configuración específica del dispositivo. El botón selector por defecto puede ser diferente en cada uno de los dispositivos señaladores, dependiendo del fabricante.

    Dado que los rótulos de los menús de botones no se muestran, puede usarlos como comentarios. El ejemplo siguiente utiliza el área de rótulo para especificar el número de botón.

    ***AUX1
    [button no.2];
    [button no.3]$P0=*
    [button no.4]^C^C
    [button no.5]^B

    La macro asignada al botón número 3 del ejemplo hace que se visualice otro menú. Tiene el siguiente formato:

    $Pn=*

    El carácter $ es el código de carácter especial que sirve para cargar un área de menú, Pn especifica la sección de menú Pop, y =* muestra lo que hay cargado actualmente en el área de menú especificada.

    Por tanto, en el ejemplo de acad.mnu, al hacer clic en el botón número 3 se muestra el menú asignado a la ubicación P0. (La ubicación del menú P0 es el menú contextual que se suele ejecutar desde el menú Buttons o Aux. Las ubicaciones de P1 a P16 se sitúan de izquierda a derecha en la barra de menús.) Normalmente, la sección Pop0 del archivo de menús se asigna a la ubicación P0.

    Cada línea restante de esa sección asigna una secuencia de comandos a cada botón sucesivo del dispositivo señalador. Por ejemplo, ^C^C (ESC dos veces) se asigna al botón 4 y ^B (alternancia del modo de referencia a objetos) se asigna al botón 5.

    Véase también


Ficha Procedimientos: Presentación general de los menús Buttons y Aux [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Presentación general de los menús Buttons y Aux
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de los menús Buttons y Aux [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Presentación general de los menús Buttons y Aux
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    MBUTTONPAN

    Controla el comportamiento del tercer botón o rueda del dispositivo señalador

    SHORTCUTMENU

    Controla si están disponibles en el área de dibujo los menús contextuales de modo Por defecto, Edición y Comando


Intercambio de los menús Buttons y Aux [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Intercambio de los menús Buttons y Aux
Conceptos
Procedimientos
Referencia

    • Si es necesario, se puede intercambiar el contenido de los menús Buttons y Aux activos con el de otra sección de menú del mismo tipo. Además de las secciones estándar de AUX1 a AUX4 (y de BUTTONS1 a BUTTONS4), se pueden definir otras secciones Aux y Buttons adicionales con fines específicos.

    Nota Aunque actualmente son válidos rótulos de sección como ***AUXTEST y ***BUTTONS1-2, es más recomendable utilizar otros rótulos numerados del tipo ***AUX10 o ***BUTTONS15 para garantizar la compatibilidad con versiones futuras.

    Estas secciones adicionales pueden utilizar un alias con la sintaxis **rótulo. El rótulo debe ir entre la línea de ***sección y la línea del primer elemento de menú de dicha sección. El rótulo puede ser cualquier cadena. No es necesario que contenga ninguna palabra clave. Se pueden utilizar tantos alias como se desee para cada sección. Los rótulos de los alias, así como los rótulos de secciones, pueden utilizarse para identificar el menú con fines de intercambio. En el siguiente ejemplo, Aux12 tiene dos alias. Para identificar el menú es suficiente el rótulo de la sección o uno de los alias.

    Por ejemplo, si desea cambiar la acción estándar de un clic con el botón derecho para que AutoCAD muestre otro menú contextual, puede utilizar la siguiente sintaxis de menú.

    ***AUX2
    // Mayús + botón
    $P0=SNAP $p0=*

    ***AUX4

    // Control + Mayús + botón: cambia a A2 personalizado

    $A2=CUSTOM_A2 $A4=CUSTOM_A4 ^P(princ ">> A2 personalizado <<")(princ) ^P

    ***AUX12

    **CUSTOM_A2

    **MYPOP

    // Mayús + botón: muestra el menú MYPOP

    $P0=MYPOP $p0=*

    ***AUX14

    **CUSTOM_A4

    // Control + Mayús + botón: vuelve a cambiar a A2 por defecto

    $A2=AUX2 $A4=AUX4 ^P(princ ">> A2 por defecto <<")(princ) ^P

    El reemplazo de la definición estándar de Aux4 con la que se muestra en el ejemplo permite intercambiar el contenido de los menús A2 y A4. Una vez cargado el archivo MNU, CTRL+MAYÚS+clic carga el contenido de los menús definidos por el alias CUSTOM_A2 en la posición del menú A2 y CUSTOM_A4 en la posición A4. A continuación, si utiliza AutoLISP, AutoCAD muestra un mensaje en la línea de comando. Cuando se pulsa MAYÚS+clic, el menú MYPOP se carga en la posición del menú P0 y se usa como menú contextual. Para volver al menú P0 por defecto, se pulsa CTRL+MAYÚS+clic (que ahora ejecuta el menú CUSTOM_A4) para cargar de nuevo el menú AUX2 por defecto en la posición del menú A2 y el menú AUX4 en la posición A4.

También puede utilizar la función menucmd de AutoLISP para intercambiar los menús Aux y Buttons. Suponiendo que los ejemplos anteriores están incluidos en el archivo MNU dentro de un grupo de menús de MYGROUP, la siguiente llamada de función carga el menú CUSTOM_A2 en la posición del menú A2.

    (menucmd "A2=mygroup.custom_a2")

    Nota  Las versiones anteriores de AutoCAD permiten la sintaxis **rótulo después de los elementos de menú de una sección de menú. Se denominan submenús. AutoCAD aún acepta la sintaxis de submenú, pero en el archivo MNS se convierte en un rótulo de ***sección. No se puede garantizar que esta sintaxis sea válida en futuras versiones. Se recomienda cambiar todos los submenús de **rótulo por rótulos de ***sección. El rótulo de **alias es válido, siempre que se coloque después de un rótulo de sección y antes de cualquier elemento de menú.


Ficha Procedimientos: Intercambio de los menús Buttons y Aux [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Intercambio de los menús Buttons y Aux
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Intercambio de los menús Buttons y Aux [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Intercambio de los menús Buttons y Aux
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Aceptación de coordenadas en los menús Buttons [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Aceptación de coordenadas en los menús Buttons
Conceptos
Procedimientos
Referencia

    • Al hacer clic en uno de los botones de un dispositivo señalador de varios botones, AutoCAD no sólo lee el número del botón sino también la coordenada correspondiente al cursor en cruz en el momento de hacer clic. Mediante una construcción cuidada de las macros de las secciones Buttons y Aux del archivo de menús, puede optar por ignorar la coordenada o utilizarla en el comando activado por el botón.

    Como se describe en Pausas para las entradas de usuario en las macros de menú, puede incluir una barra invertida (\) en un elemento de menú para que se produzca una pausa que permita al usuario introducir datos. En el caso de los menús Aux y Buttons, la coordenada del cursor en cruz se proporciona como un dato introducido por el usuario al hacer clic en el botón. Esto ocurre sólo para la primera barra invertida del elemento de menú; si el elemento no contiene ninguna barra invertida, no se utiliza la coordenada del cursor en cruz. Véanse los siguientes elementos de menú:

    ***AUX2
    linea
    linea \

    El primer botón ejecuta el comando LINEA y muestra la solicitud Precise primer punto de la manera habitual. El segundo botón también ejecuta el comando LINEA, pero AutoCAD utiliza la ubicación actual del cursor en cruz en la solicitud Precise primer punto y muestra la solicitud Precise punto siguiente.


Ficha Procedimientos: Aceptación de coordenadas en los menús Buttons [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Aceptación de coordenadas en los menús Buttons
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Aceptación de coordenadas en los menús Buttons [Manual de personalización: ACG]

Personalización de los botones de un dispositivo señalador
Aceptación de coordenadas en los menús Buttons
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Creación de menús desplegables y contextuales [Manual de personalización: ACG]

Archivo de menús
Creación de menús desplegables y contextuales
Conceptos
Procedimientos
Referencia

    • Los menús desplegables se despliegan desde la barra de menús. Los menús contextuales se muestran en (o cerca de) los cursores en cruz o el cursor de la ventana de dibujo, la ventana de texto o de comandos, o en las áreas de las barras de herramientas. Ambos menús se definen en las secciones Pop del archivo MNU.

    • Presentación general de los menús desplegables y contextuales
    • Creación de menús desplegables
      Las secciones del archivo de menús de POP1 a POP499 definen los menús que se despliegan desde la barra de menús.
    • Creación de menús contextuales
      Los menús contextuales se definen en el archivo MNU utilizando la misma sintaxis que los menús desplegables. La sección de menú POP0 define el menú contextual Referencia a objetos establecido por defecto y las secciones de menú de POP500 a POP999 se utilizan en los menús de contexto.
    • Control de la visualización de los rótulos de los elementos de menú
      Puede controlar el modo en que se muestran los rótulos de los elementos. Puede hacer que aparezcan atenuados (no disponibles para el usuario) o situar junto a ellos una marca de verificación.
    • Referencia a un menú desplegable o contextual
      Usando un método parecido al empleado para activar los submenús normales, puede activar o desactivar un submenú desplegable o emergente.
    • Intercambio e inserción de menús desplegables
      Cuando se dispone de menús en cascada, no suele ser necesario intercambiarlos. Sin embargo, puede resultar oportuno insertar y eliminar un menú desplegable cuando el usuario carga o descarga una aplicación que requiere un menú adicional.


Ficha Procedimientos: Creación de menús desplegables y contextuales [Manual de personalización: ACG]

Archivo de menús
Creación de menús desplegables y contextuales
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de menús desplegables y contextuales [Manual de personalización: ACG]

Archivo de menús
Creación de menús desplegables y contextuales
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    BARRAHERR

    Muestra, oculta y personaliza barras de herramientas

    Variables de sistema

    No hay entradas.


Presentación general de los menús desplegables y contextuales [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Presentación general de los menús desplegables y contextuales
Conceptos
Procedimientos
Referencia

    • Los menús desplegables y contextuales se muestran como menús en cascada (también llamados menús por pasos o jerárquicos).

    Hay dos tipos de menús contextuales y ambos se muestran en la ubicación del cursor. Los menús de contexto, que se muestran al hacer clic con el botón derecho, proporcionan comandos adecuados para la actividad en curso o la ubicación del cursor en la pantalla. El menú de referencia a objetos, que aparece al mantener pulsada la tecla MAYÚS y hacer clic con el botón derecho, proporciona las opciones de referencia a objetos y seguimiento.

    Los menús desplegables se definen en las secciones de menú de ***POP1 a ***POP499 y los menús contextuales se definen en las secciones ***POP0 y de ***POP500 a ***POP999. Un menú desplegable puede contener hasta 999 elementos de menú. Un menú contextual puede contener hasta 499 elementos de menú. Ambos límites incluyen todos los menús de una jerarquía. Si los elementos de menú del archivo de menús exceden dichos límites, AutoCADignora los elementos sobrantes. Si un menú desplegable o contextual es más extenso que el espacio de visualización disponible, se trunca para ajustarlo.

    Los menús desplegables siempre se despliegan desde la barra de menús, pero el menú contextual siempre se muestra en (o cerca de) los cursores en cruz o el cursor del área gráfica, la ventana de texto o la ventana de comandos, o en las áreas de las barras de herramientas. La sintaxis de estas secciones de menú POPn es igual, excepto en que el título del menú contextual no se incluye en la barra de menús. El título del menú contextual no se muestra nunca (pero es necesario introducir un título ficticio).

    Al menú contextual se accede a través del comando de menú $P0=*, ejecutado por otro elemento de menú (como por ejemplo el elemento de menú BUTTONSn) o bien un programa AutoLISP u ObjectARX®. Cuando el menú contextual está activo, la barra de menús no está disponible.

    Creación de líneas de separación en los menús

    Para crear una línea horizontal entre los elementos contenidos en un menú, utilice un rótulo de elemento de menú que contenga dos guiones:

    [--]

    La anchura de cada menú desplegable y contextual viene determinada por el rótulo más largo, y la línea de separación se expande para ocupar la anchura completa del menú. (Las macros de menú situadas en líneas que contienen un rótulo de línea de separación se pasan por alto.)

    Creación de submenús en cascada

    Los rótulos de los elementos de los menús desplegables y contextuales utilizan caracteres especiales (como por ejemplo –>, <– y <–<–) para controlar la jerarquía de los menús en cascada. Estos caracteres especiales indican los submenús y los últimos elementos de los submenús y también pueden finalizar todos los menús principales. Cada cadena de caracteres especiales debe ocupar la primera posición en el rótulo de un elemento de menú.

    El carácter especial –> indica que este elemento tiene un submenú, como en el ejemplo siguiente:

    [–>&Zoom]

    Si despliega el menú Ver y hace clic en Zoom o mueve el cursor hasta el extremo derecho del elemento, aparece el submenú Zoom.

    El carácter especial <– indica que este elemento es el último del submenú, como ocurre en el siguiente ejemplo:

    [<–&Extensión]

    Los caracteres especiales <–<– indican que el elemento es el último de un submenú y también del menú principal correspondiente, como se ilustra en los siguientes ejemplos de rótulos del menú Modificar:

    [&Modificar]
    [->&Objeto]
    [->&Texto]
    [<-<-&Justificar]

    El primer ejemplo es el rótulo del menú Modificar. El rótulo de Objeto utiliza un carácter especial para indicar que contiene un submenú. Texto forma parte del submenú Objeto y contiene un submenú propio. Justificar es el último elemento del submenú Texto y también finaliza el menú Modificar.

    Los caracteres descritos en la siguiente tabla son los únicos caracteres no alfanuméricos que se pueden utilizar en el rótulo de una sección Pop. Los caracteres no alfanuméricos no incluidos en la lista están reservados para su uso futuro como caracteres especiales de menú.
    Caracteres especiales para los rótulos de las secciones de menú Pop
Carácter | Descripción
-- | Se expande para convertirse en una línea de separación en los menús desplegables y contextuales (cuando no se usa con otros caracteres).
–> | Indica que el elemento del menú desplegable o contextual contiene un submenú.
<– | Indica que el elemento del menú desplegable o contextual es el último elemento del menú o submenú.
<–<– | Indica que el elemento del menú desplegable o contextual es el último elemento del submenú y finaliza el menú principal. (Se requiere un <- para finalizar cada menú principal.)
$( | Hace que el rótulo de un elemento del menú desplegable o contextual pueda evaluar una macro de cadenas DIESEL si $( son los primeros caracteres.
~ | Hace que el elemento de menú no esté disponible.
!. | Sitúa una marca de verificación junto a un elemento de menú.
& | Colocado directamente antes de un carácter, designa dicho carácter como tecla de acceso al menú en un rótulo de menú desplegable o contextual. Por ejemplo, E&jemplo aparece como Ejemplo (con la letra j subrayada).
/c | Especifica la tecla de acceso al menú del rótulo de un menú desplegable o contextual. Por ejemplo, /jEjemplo aparece como Ejemplo (con la letra j subrayada).
\t | Desplaza hacia la derecha del menú todo el texto del rótulo que está situado a la derecha de estos caracteres.


Ficha Procedimientos: Presentación general de los menús desplegables y contextuales [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Presentación general de los menús desplegables y contextuales
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de los menús desplegables y contextuales [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Presentación general de los menús desplegables y contextuales
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Creación de menús desplegables [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Creación de menús desplegables
Conceptos
Procedimientos
Referencia

    • Las secciones del archivo de menús de POP1 a POP499 definen los menús que se despliegan desde la barra de menús.

    El siguiente ejemplo ilustra la sintaxis que se emplea para crear un menú desplegable.

    ***POP13
    **MYTOOLS
    M_Tools [Mis&Herr]
    M_Save  [&Guardar\tCtrl+G]^C^C_qsave
            [--]
    M_ShwTB [Mostrar MiBarraherr]^C^C_-toolbar mytools s
    M_HidTB [Ocultar MiBarraherr]^C^C_-toolbar mytools h
            [--]
    M_EMenu [Editar MiMenú]^C^C^P(command"notepad"(findfile"my.mnu")) ^P
    M_LMenu [Recargar MiMenú]^C^C^P(command"_menu""my.mnu") ^P
            [--]
    M_EPgp  [Editar PGP]^C^C^P(command"notepad"(findfile"acad.pgp")) ^P
    M_LPgp  [Recargar PGP]^C^C_re-init 16

    Todas las secciones de menú pueden tener uno o varios alias definidos por los rótulos **alias que aparecen tras el rótulo de la sección de menú ***POPn. En el ejemplo anterior, **MYTOOLS es el alias del menú POP13.

    Nota Las secciones de menú POPn ya no admiten la sintaxis **submenú que se utiliza en las versiones anteriores. La sintaxis **alias es válida, siempre que se coloque después de un rótulo de sección y antes de cualquier elemento.

    En las secciones de menú de POP1 a POP16, AutoCAD genera una barra de menús que contiene los títulos de esas secciones. Si no se definen secciones de POP1 a POP16, AutoCAD inserta los menús Archivo y Edición establecidos por defecto.

    Nota Si no se definen menús desplegables (de POP1 a POP16) activos, no funciona el menú contextual POP0.

    Las secciones de menú Pop con números mayores que POP16 y menores que POP500 están disponibles para insertarlas en la barra de menús mediante el comando CARGARMENU o a través del proceso de intercambio de menús.

    Definición del título de la barra de menús

    En los menús desplegables, el primer rótulo define el título que aparece en la barra de menús. El siguiente ejemplo es la parte superior de la sección del menú desplegable POP2.

    ***POP2
    ID_MnEdit [&Edición]
    ID_U [&Deshacer\tCtrl+Z]_u
    ID_Redo [&Rehacer\tCtrl+Y]^C^C_redo

    En la primera línea posterior al rótulo de la sección ***POP2, el rótulo [&Edición], hace que Edición se muestre como título de la barra de menús. Cuando el signo (&) precede a la letra E, la subraya para indicar que es la tecla de acceso. Se puede utilizar el identificador de nombre asociado con el título de menú (ID_MnEdit) para activar y desactivar todo el menú. (La línea que define el título de la barra de menús no puede contener una macro de menú.)

    Para acceder a un menú o a un elemento de menú desde el teclado, mantenga pulsada la tecla ALT y pulse la tecla de acceso. Cualquier letra del rótulo puede ser la tecla de acceso, pero ésta debe ser única en el menú o submenú que la contiene. Por ejemplo, en el menú Modificar de AutoCAD, i se utiliza en Igualar propiedades, por lo que Simetría y Desplazar deben utilizar otras letras. La letra s se puede utilizar en Simetría y Sombra porque Sombra se incluye en el submenú Objeto.

    Véase también


Ficha Procedimientos: Creación de menús desplegables [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Creación de menús desplegables
Concepts
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de menús desplegables [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Creación de menús desplegables
Concepts
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Creación de menús contextuales [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Creación de menús contextuales
Conceptos
Procedimientos
Referencia

    • Los menús contextuales se definen en el archivo MNU utilizando la misma sintaxis que los menús desplegables. La sección de menú POP0 define el menú contextual Referencia a objetos establecido por defecto y las secciones de menú de POP500 a POP999 se utilizan en los menús de contexto.

    AutoCAD hace referencia a los menús de contexto mediante los alias (por ejemplo, **GRIPS) y los emplea en situaciones concretas. El número real de POPn no es importante, pero los nombres de alias deben seguir las convenciones de nomenclatura apropiadas para poder utilizarlos. AutoCAD se reserva el uso de los siguientes alias:

    GRIPS

    El contenido de este menú define el menú contextual Pinzamiento activo (haga clic con el botón derecho en el área de dibujo mientras está designado el pinzamiento de un objeto).

    CMDEFAULT

    El contenido de este menú define el menú contextual Modo por defecto (haga clic con el botón derecho en el área de dibujo cuando no haya comandos activos ni objetos seleccionados).

    CMEDIT

    El contenido de este menú define el menú contextual Modo de edición (haga clic con el botón derecho en el área de dibujo cuando haya uno o más objetos seleccionados, no haya pinzamientos seleccionados y no haya comandos activos).

    CMCOMMAND

    El contenido de este menú define el menú Modo de comando (haga clic con el botón derecho en el área de dibujo cuando haya un comando activo). Además del contenido del menú CMCOMMAND, en este menú se insertan las opciones de la línea de comando (las palabras clave que aparecen entre corchetes).

    Menús contextuales sensibles al contexto

    Los menús contextuales CMEDIT y CMCOMMAND pueden hacerse sensibles al contexto. Además del contenido del menú CMEDIT, el menú de objeto adecuado (si existe) se inserta en este menú si hay uno o varios objetos seleccionados de un tipo de objeto concreto. Los menús de objeto utilizan la siguiente convención de nomenclatura: OBJECT_nombre_objetoo OBJECTS_nombre_objeto.

    Si sólo hay un objeto seleccionado se utiliza OBJECT_nombre_objeto y si hay más de un objeto del mismo tipo se utiliza OBJECTS_nombre_objeto. Si no hay disponible ningún menú OBJECT_nombre_objeto, AutoCAD utiliza el menú OBJECTS_nombre_objeto (si existe).

    El nombre de objeto es el nombre DXF del objeto en todos los casos, excepto para el objeto de inserción. Para distinguir entre una inserción de bloque y una referencia externa, utilice los nombres BLOCKREF y XREF.

    El siguiente código de AutoLISP® define el comando OTYPE, que informa del nombre DXF del objeto designado.

    (defun C:OTYPE()  (cdr (assoc 0 (entget (car (entsel))))))

    Por ejemplo, para poder utilizar un elemento de menú contextual específico de un objeto para una o varias referencias de bloques designadas, incluya el siguiente código:

    ***POP512
    **OBJECTS_BLOCKREF
    [menú contextual para objetos de bloque]
    ID_BLOCK [Descomponer] ^C^C_explode

    Al igual que en el menú CMEDIT, se puede añadir información sensible al contexto al menú CMCOMMAND. Todos los menús denominados COMMAND_nombre_comando se añaden al menú CMCOMMAND. El texto de nombre_comando puede ser el de cualquier comando válido de AutoCAD, incluidos los comandos definidos por el usuario y los de otros fabricantes.

    Para que este sistema funcione con los comandos precedidos por guiones (como INSERT), se debe asignar al menú un nombre del tipo COMMAND_INSERT.


Ficha Procedimientos: Creación de menús contextuales [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Creación de menús contextuales
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de menús contextuales [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Creación de menús contextuales
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Control de la visualización de los rótulos de los elementos de menú [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Control de la visualización de los rótulos de los elementos de menú
Conceptos
Procedimientos
Referencia

    • Puede controlar el modo en que se muestran los rótulos de los elementos. Puede hacer que aparezcan atenuados (no disponibles para el usuario) o situar junto a ellos una marca de verificación.

    Los rótulos también pueden contener expresiones de cadena DIESEL para modificar su contenido. De este modo se puede desactivar, marcar o cambiar de forma interactiva el texto del rótulo que se visualiza. Véase Expresiones DIESEL en macros de menú.

    Cuando desactive o marque los rótulos de los elementos de menú, asegúrese de utilizar una técnica adecuada que realice un seguimiento de los cambios que afectan al estado del rótulo.

    Desactivación de los rótulos de los elementos de menú

    Para que un elemento de menú aparezca atenuado, comience su rótulo con una tilde (~). Por convención, esto indica que el elemento está desactivado, es decir, que no se encuentra disponible. No se ejecutará ningún comando asociado con el elemento y no se podrá acceder a los submenús.

    Por ejemplo, los siguientes elementos de menú están desactivados.

    [~Línea]
    [~->Pol]

    Los rótulos de los elementos de menú pueden incluir expresiones de cadenas DIESEL que desactivan o activan de forma condicional estos rótulos cada vez que se muestran. Por ejemplo, la expresión de cadena DIESEL del siguiente rótulo de elemento de menú desactiva el elemento cuando un comando está activo.

    [$(if,$(getvar,cmdactive),~)MOVE]^C^C_move

    la función menucmd de AutoLISP se puede utilizar para desactivar y activar elementos procedentes de una macro de menú o de una aplicación. Para obtener más ejemplos, véase Referencia a un menú desplegable o contextual.

    Colocación de marcas en los rótulos de los elementos de menú

    Puede colocar a la izquierda del rótulo de un elemento de menú una marca de verificación incluyendo un signo de exclamación y un punto (!.). El marcado de elementos de menú no limita la posibilidad de escogerlos, aunque un elemento marcado puede desactivarse.

    En el ejemplo siguiente, el elemento de menú Línea tiene una marca de verificación.

    [!.Línea]

    Los rótulos de los elementos de menú pueden contener expresiones de cadena DIESEL que los marquen de forma condicional cada vez que se muestren. En el ejemplo siguiente se coloca una marca de verificación a la izquierda de los rótulos de menú cuyas variables de sistema están activadas.

    [$(if,$(getvar,orthomode),!.)Ortho]^O
    [$(if,$(getvar,snapmode),!.)Snap]^B
    [$(if,$(getvar,gridmode),!.)Grid]^G

    La función menucmd de AutoLISP se puede utilizar para marcar los rótulos procedentes de una macro de menú o de una aplicación. Para obtener más ejemplos, véase Referencia a un menú desplegable o contextual.

    Desactivación y colocación de marcas en los rótulos de los elementos de menú de manera simultánea

    Es posible marcar y desactivar al mismo tiempo elementos de menú. El formato es el siguiente:

    [~!. texto_rótulo]

    O bien

    [!.~ texto_rótulo]

    ~ es un código de carácter especial que permite desactivar un elemento de menú y !. es un código de carácter especial con el que se marca un elemento de menú.

    En el ejemplo siguiente, el elemento de menú Línea está desactivado y marcado con una marca de verificación. Al igual que los ejemplos anteriores, se puede utilizar una expresión en lenguaje DIESEL para desactivar y marcar simultáneamente el rótulo de un elemento de menú.

    [~!.Línea]

    Véase también

    Expresiones DIESEL en macros de menú


Ficha Procedimientos: Control de la visualización de los rótulos de los elementos de menú [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Control de la visualización de los rótulos de los elementos de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Control de la visualización de los rótulos de los elementos de menú [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Control de la visualización de los rótulos de los elementos de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Referencia a un menú desplegable o contextual [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Referencia a un menú desplegable o contextual
Conceptos
Procedimientos
Referencia

    • Usando un método parecido al empleado para activar los submenús normales, puede activar o desactivar un submenú desplegable o emergente.

    Existen dos métodos para hacer referencia a un menú desplegable o contextual: el relativo y el absoluto. La referencia relativa utiliza el grupo de menús y el identificador de nombre, mientras que la referencia absoluta usa la posición absoluta del elemento de menú en la jerarquía de menús. Se recomienda el método de referencia relativa debido a su carácter dinámico, que funciona correctamente con independencia del estado actual del menú.

    Referencia relativa a los elementos de los menús desplegables y contextuales

    Para hacer referencia al elemento de un menú desplegable o contextual en función del grupo de menús y del identificador de nombre, utilice la función menucmd de AutoLISP. La siguiente sintaxis hace referencia a un elemento de menú en función del identificador de nombre.

    (menucmd "Ggrupo_menús.identificador_nombre=valor")

    El siguiente ejemplo desactiva el elemento de menú ID_Line en el grupo de menú ejemplo. Funciona independientemente de la ubicación del elemento de menú en el menú.

    [Desactivar línea](menucmd "Gejemplo.ID_Line=~")

    Si el autor de un menú parcial conoce el contenido del menú base, la sintaxis de un elemento de menú puede hacer referencia a un identificador del archivo base. Un extracto del archivo base acad.mnu podría tener el siguiente aspecto:

    ***MENUGROUP=ACAD
    ***POP0         (y así sucesivamente...)
     ....
    ***POP6
    ID_MnHelp   [Ayuda]
    ID_Contents [Contenido]^C^C_HELP
    ID_About    [Acerca de]^C^C_ABOUT

    Un elemento de menú de un menú parcial se puede modificar para obtener un elemento de menú adicional que haga referencia al identificador del menú base.

    ***POP2
    [Título2]
    [Desactivar contenido de ayuda]^P(menucmd "Gacad.ID_Contents=~") ^P

    De este modo, los diversos archivos de menús parciales y determinados archivos base pueden funcionar conjuntamente. AutoCAD impone una estricta definición de los grupos de menús, de manera que dos menús no deben definir nunca el mismo grupo. De lo contrario, al cargar un menú con un grupo de menús en conflicto se puede producir la cancelación de la solicitud CARGARMENU.

    Referencia absoluta a los elementos de los menús desplegables y contextuales

    Además de hacer referencia a un elemento de menú, puede activar y desactivar un elemento de menú mediante la sintaxis Pn=xxx. El formato es el siguiente:

    Pn.i=xxx

    Pn precisa la sección de menú POPn activa (los valores válidos son de 0 a 16), i especifica el número del elemento de menú y xxx (si existe) indica una cadena que define la acción.

    El siguiente ejemplo utiliza la función menucmd de AutoLISP para hacer referencia a un elemento de menú desplegable o contextual. Como los archivos de menús de AutoCAD son dinámicos (gracias a la carga de menús parciales), la siguiente sintaxis no funciona en todos los casos.

    [Desact línea método tradicional](menucmd "P1.2=~")

    Esta sintaxis se basa en la ubicación del elemento de menú y no funciona si el autor del menú introduce un elemento nuevo en la sección POP1 o si el menú desplegable se inserta antes que POP1 mediante el comando CARGARMENU.

    Puede utilizar la sintaxis Pn=xxx procedente de una macro de menú si va precedida del comando $. El siguiente ejemplo desactiva el elemento 4 de la sección POP3.

    $P3.4=~

    El siguiente ejemplo añade una marca de verificación al elemento 1 de la sección POP7.

    $P7.1=!.

    El siguiente ejemplo elimina todos los caracteres de desactivación o con marcas a partir del elemento 1 de la sección POP7.

    $P7.1=

    La numeración de los elementos de menú es consecutiva con independencia de la jerarquía del archivo de menús. El elemento 1 es el que sigue al título.

    ***POP5
    [Asist  ]                    Título
    [Ayuda!   ]'?                Elemento 1
    [Cancelar  ]^C^C^C           Elemento 2
    [--]                         Elemento 3
    [Deshacer    ]^C^C_U         Elemento 4
    [Rehacer    ]^C^C_redo       Elemento 5
    [--]                         Elemento 6
    [->Refent ]                  Elemento 7
    [Centro  ]center             Elemento 8

    Para que un elemento pueda hacerse referencia a sí mismo con facilidad sin tener en cuenta su posición en la jerarquía de menús, utilice las siguientes formas:

    $P@.@=xxx

    Hace referencia al elemento de menú actual o al último elegido.

    $P@.n=xxx

    Hace referencia al elemento n del menú actual o del último elegido.

    Acceso de AutoLISP al estado del rótulo

    La función menucmd de AutoLISP acepta las cadenas de comandos $Pn=xxx sin el carácter $ inicial. En estas funciones, la parte xxx de la cadena de comandos puede contener valores especiales.

    Pn.i=?

    Devuelve el estado desactivado y marcado actual del elemento especificado con una cadena (por ejemplo, ~ para un elemento desactivado, !. para un elemento con una marca de verificación y "" para un elemento que no está atenuado ni marcado).

    Pn.i=#?

    Devuelve el mismo tipo de cadena que se ha descrito para Pn.i=?, pero con el prefijo Pn.i=. Resulta de gran utilidad cuando se usa junto con las formas @, porque devuelve el menú y el número de elemento reales.

    Por ejemplo, si el elemento 5 de la sección POP6 está desactivado, el siguiente código menucmd devuelve los siguientes valores de cadena.

    (menucmd "P6.5=?")     devuelve  "~"
    (menucmd "P6.5=#?")    devuelve  "P6.5=~"


Ficha Procedimientos: Referencia a un menú desplegable o contextual [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Referencia a un menú desplegable o contextual
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Referencia a un menú desplegable o contextual [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Referencia a un menú desplegable o contextual
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Intercambio e inserción de menús desplegables [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Intercambio e inserción de menús desplegables
Conceptos
Procedimientos
Referencia

    • Como los menús desplegables de AutoCAD son menús en cascada, en general no es necesario intercambiarlos. Además, el intercambio de menús puede reducir la consistencia de la interfaz de usuario. Sin embargo, resulta adecuado insertar y eliminar un menú desplegable cuando el usuario carga o descarga una aplicación que requiere un menú adicional.

    Intercambio de menús desplegables

    Si se utilizan comandos $ en las macros de menú, se pueden intercambiar los menús desplegables de ciertas ubicaciones POPn. No obstante, este método no es recomendable a menos que se pueda comprobar que el menú que se va a reemplazar es el deseado. A causa del carácter dinámico de los menús de AutoCAD, puede ocurrir que un menú insertado en la posición P6 no se encuentre realmente en esa ubicación. Si intenta intercambiar este menú con otro, es posible que no elimine el menú correcto. Un método alternativo para intercambiar menús incluye la referencia relativa (o global) (véase "Inserción y eliminación de menús desplegables"). Con este método se puede insertar un menú nuevo delante de un menú ya conocido y, a continuación, eliminar el menú conocido.

    Para el intercambio de menús, las áreas activas de los menús desplegables reciben los nombres de P1 a P16. La siguiente macro de menú reemplaza el menú de la posición P3 con el menú denominado OtroMenú del grupo de menús MIMENU.

    $P3=MiMenú.OtroMenú

    Esta misma operación se puede realizar con la función menucmd de AutoLISP del siguiente modo:

    (menucmd "P3=MiMenú.OtroMenú")

    Se puede usar el comando especial $Pn=* desde cualquier macro de menú para hacer que se muestre el menú asignado actualmente al área POPn.

    Nota El intercambio de menús desplegables no se ajusta a las directrices de interfaz de usuario de Microsoft® y no se garantiza que esté disponible en futuras versiones de AutoCAD.

    Inserción y eliminación de menús desplegables

    Puede utilizar la función menucmd de AutoLISP para insertar o eliminar un menú desplegable. La sintaxis es similar a la empleada para intercambiar menús desplegables a excepción de que la parte izquierda de la asignación es el menú desplegable delante del cual desea insertar el nuevo menú. La parte derecha de la asignación es un signo más (+), seguido del nombre del grupo de menús, de un punto y del alias del menú, como se muestra en la siguiente sintaxis:

    (menucmd "Ggrupo_menús1.nombre_menú1=+grupo_menús2.nombre_menú2")

    También puede insertar un menú con la sintaxis Pn=. La siguiente macro de menú inserta un menú detrás del menú P5. (También puede usar la función menucmd con este formato.)

    (menucmd "P5=+mimenú.nuevo3")

    Si emplea este método para insertar un menú, recuerde que no debe confiar en que se va a insertar en la posición del menú P6, como sería esperable. Existen dos motivos por los que puede que esto no ocurra:

    • Si la barra de menús actual sólo tiene tres menús, cuando se inserta un menú después del P5, la posición del nuevo menú es P4.
    • Cuando el usuario inserta o elimina un menú mediante el comando CARGARMENU o cuando otra aplicación inserta o elimina menús, es posible que la numeración de los menús deje de estar sincronizada.

    La sintaxis para eliminar un menú es la siguiente:

    (menucmd "Ggrupo_menús.nombre_menú=-")

    El siguiente ejemplo elimina el menú NUEVO3 que es miembro del grupo MiMenú.

    (menucmd "Gmimenú.nuevo3=-")

    Como es de esperar, el formato anterior es preferible al formato Pn= porque elimina únicamente el menú especificado. El siguiente ejemplo elimina el menú de la ubicación P4 (sea el que sea).

    $P4=-

    Nota Utilice la sintaxis Pn como parte de la sintaxis únicamente con las secuencias menucmd. Utilice la sintaxis $Pn con secuencias específicas de macros de menú.

    Control de las barras de herramientas a través de los menús parciales

    Para controlar las barras de herramientas a través de los menús parciales, utilice la siguiente sintaxis en la solicitud del nombre de la barra de herramientas del comando -BARRAHERR.

    grupo_menús.nombre-subsección

    Esta sintaxis proporciona acceso a la barra de herramientas identificada por grupo_menús.nombre_menú y permite utilizar todo el espectro de opciones del comando -BARRAHERR en esa barra de herramientas.

    Si el grupo de menús se deja fuera de alguno de estos comandos y funciones, AutoCAD toma los valores por defecto del menú base.

    Debe tener en cuenta lo siguiente:

    • No se puede realizar un intercambio con la posición del menú POP0. Sin embargo, puede intercambiar un menú POP0 con cualquier otra posición del menú Pop.
    • Los menús Image no se pueden intercambiar desde archivos de menús externos.
    • Sólo se pueden intercambiar menús del mismo tipo, es decir, un menú Aux por otro, un menú desplegable por otro y así sucesivamente. Si se pretende intercambiar entre tipos diferentes se puede producir un funcionamiento impredecible. No obstante, dentro de un tipo dado, se pueden realizar intercambios entre dos menús cualesquiera. Esto podría dar lugar a un funcionamiento extraño en el caso de los menús Tablet ya que, normalmente, no tienen el mismo número de macros.


Ficha Procedimientos: Intercambio e inserción de menús desplegables [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Intercambio e inserción de menús desplegables
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Intercambio e inserción de menús desplegables [Manual de personalización: ACG]

Creación de menús desplegables y contextuales
Intercambio e inserción de menús desplegables
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    BARRAHERR

    Muestra, oculta y personaliza barras de herramientas

    Variables de sistema

    No hay entradas.


Personalización de las barras de herramientas [Manual de personalización: ACG]

Archivo de menús
Personalización de las barras de herramientas
Conceptos
Procedimientos
Referencia

    • La sección Toolbars del archivo MNU especifica la disposición y el contenido por defecto de las barras de herramientas. Contiene un submenú para cada barra de herramientas definida por el menú.

    • Creación de barras de herramientas
      En la sección Toolbars de un archivo MNU, puede crear barras de herramientas con botones, iconos desplegables y elementos de control especiales y utilizar sus propios mapas de bits para los iconos de los botones.
    • Creación de botones en las barras de herramientas
      Las definiciones de los botones de las barras de herramientas utilizan la palabra clave Button seguida de una serie de opciones que aparecen entre paréntesis.
    • Creación de iconos desplegables en las barras de herramientas
      Las definiciones de los iconos desplegables de la barra de herramientas utilizan la palabra clave Flyout seguida de una serie de opciones que aparecen entre paréntesis.
    • Definición de controles de una barra de herramientas
      Las definiciones de los controles de la barra de herramientas utilizan la palabra clave Control seguida del nombre que especifica el tipo de elemento de control solicitado entre paréntesis.
    • Especificación de los mapas de bits definidos por el usuario
      Los mapas de bits definidos por el usuario se pueden utilizar en lugar de los nombres de recursos de imagen id_small e id_big correspondientes a los elementos de menú de botones y de iconos desplegables.


Ficha Procedimientos: Personalización de las barras de herramientas [Manual de personalización: ACG]

Archivo de menús
Personalización de las barras de herramientas
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Personalización de las barras de herramientas [Manual de personalización: ACG]

Archivo de menús
Personalización de las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    BARRAHERR

    Muestra, oculta y personaliza barras de herramientas

    Variables de sistema

    No hay entradas.


Creación de barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de barras de herramientas
Conceptos
Procedimientos
Referencia

    • En la sección Toolbars de un archivo MNU, puede crear barras de herramientas con botones, iconos desplegables y elementos de control especiales y utilizar sus propios mapas de bits para los iconos de los botones.

    Si sólo desea crear o cambiar las barras de herramientas o crear, reorganizar, añadir o eliminar botones e iconos desplegables, puede utilizar el comando PERSONALIZAR. Véase Creación de barras de herramientas personalizadas.

    En el siguiente ejemplo se muestra la sintaxis del elemento de menú correspondiente a la sección Toolbars del archivo MNU. Todas las líneas distintas del separador comienzan con un identificador de nombre estándar que se usa para asociar información de ayuda al elemento. En el ejemplo , la cadena **TOOLS1 constituye un submenú que utiliza el alias TOOLS1 como rótulo para hacer referencia a la definición de la barra posterior.

    ***TOOLBARS
    **TOOLS1
    TAG1 [Toolbar ("nombre_barra_herr", orient, visible, xval, yval, rows)]
    TAG2 [Button ("nombre_botón", id_small, id_large)]macro
    TAG3 [Flyout ("nombre_icono_desp", id_small, id_large, icon, alias)]macro
    TAG4 [Control (element)]
    [--]

    La primera línea de un submenú de la barra de herramientas corresponde a la definición de la barra (TAG1 en el ejemplo), que define las características de la barra de herramientas. El resto de las líneas del submenú puede constituir una mezcla del resto de los elementos de la barra de herramientas. La segunda línea del ejemplo anterior (TAG2) define un botón. La tercera línea (TAG3) define el control de un icono desplegable y en la cuarta línea (TAG4) define un elemento de control especial. La quinta línea define un separador (--).

    La definición de la barra de herramientas incluye la palabra clave Toolbar y una serie de opciones que aparecen entre paréntesis. Las opciones definen las características de visualización de la barra de herramientas.

    TAG1 [Toolbar ("nombre_barra_herr", orient, visible, xval, yval, rows)]

    Las opciones son las siguientes:

    nombre_barra_herr

    Cadena que define el nombre de la barra de herramientas. La cadena debe estar formada por caracteres alfanuméricos, sin otra puntuación que un guión (–) o un subrayado (_). Con este nombre (y su alias) se puede hacer referencia a la barra de herramientas en el código de programación.

    orient

    Orientación de la barra de herramientas. Los valores son floating, top, bottom, left y right y no distinguen entre mayúsculas y minúsculas.

    visible

    Visibilidad de la barra de herramientas. Los valores (show y hide) no distinguen entre mayúsculas y minúsculas.

    xval

    Valor numérico que especifica la coordenada X en píxeles. Este valor se mide del borde izquierdo de la pantalla al derecho de la barra de herramientas.

    yval

    Valor numérico que especifica la coordenada Y en píxeles. Este valor se mide desde el borde superior de la pantalla a la parte superior de la barra de herramientas.

    rows

    Valor numérico que especifica el número de filas.

    El siguiente ejemplo corresponde a las primeras líneas de la barra de herramientas Zoom del archivo acad.mnu:

    **TB_ZOOM
    ID_TbZoom [_Toolbar("Zoom", _Floating, _Hide, 100, 380, 1)]
    ID_ZoomWindo [Button("Ventana", ICON_16_ZOOWIN, ICON_16_ZOOWIN,)]'_zoom_w
    ID_ZoomDynam [Button("Dinámico", ICON_16_ZOODYN, ICON_16_ZOODYN,)]'_zoom_d
    ID_ZoomScale [Button("Escala", ICON_16_ZOOSCA, ICON_16_ZOOSCA,)]'_zoom_s

    Nota Todas las líneas comienzan con ID y no hay saltos de línea.

    Para controlar las barras de herramientas a través de los menús parciales, utilice la siguiente sintaxis en la solicitud del nombre de la barra de herramientas del comando - BARRAHERR.

    grupo_menús.nombre_barraherr

    El siguiente código de AutoLISP muestra la barra de herramientas MYBAR del grupo de menús MYGROUP. (Este código supone que el menú MYGROUP ya está cargado.)

    (command "toolbar" "mygroup.mybar" "show")

    Si grupo_menús no está incluido, entonces AutoCAD toma los valores por defecto del menú base.

    Véase también

    Creación de botones en las barras de herramientas
    Creación de iconos desplegables en las barras de herramientas
    Definición de controles de una barra de herramientas
    Especificación de los mapas de bits definidos por el usuario


Ficha Procedimientos: Creación de barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de barras de herramientas
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de barras de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    BARRAHERR

    Muestra, oculta y personaliza barras de herramientas

    Variables de sistema

    No hay entradas.


Creación de botones en las barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Las definiciones de los botones de las barras de herramientas del archivo MNU contienen la palabra clave Button seguida de una serie de opciones que aparecen entre paréntesis.

    TAG2 [Button ("nombre_botón", id_small, id_large)]macro

    Las opciones son las siguientes:

    nombre_botón

    Cadena que define el nombre del botón. La cadena debe estar formada por caracteres alfanuméricos, sin otra puntuación que un guión (-) o un subrayado (_). Esta cadena se muestra como una pista cuando el cursor se sitúa sobre el botón.

    id_small

    Cadena que da nombre a la cadena de identificación del recurso de imagen pequeña (mapa de bits de 16 × 15). La cadena debe estar formada por caracteres alfanuméricos, sin otra puntuación que un guión (-) o un subrayado (_). Esta cadena también puede especificar un mapa de bits creado por el usuario (véase Especificación de los mapas de bits definidos por el usuario).

    id_big

    Cadena que da nombre a la cadena de identificación del recurso de imagen pequeña (mapa de bits de 32 × 30). Si el mapa de bits especificado no es de 32 × 30, AutoCAD define la escala a ese tamaño. La cadena debe estar formada por caracteres alfanuméricos, sin otra puntuación que un guión (-) o un subrayado (_). Esta cadena también puede especificar un mapa de bits creado por el usuario (véase Especificación de los mapas de bits definidos por el usuario).

    macro

    Macro del elemento de menú. Sigue la sintaxis estándar de las macros de menú.

    Véase también

    Creación de barras de herramientas


Ficha Procedimientos: Creación de botones en las barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de botones en las barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de botones en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Creación de iconos desplegables en las barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de iconos desplegables en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Las definiciones de los iconos desplegables de la barra de herramientas del archivo MNU utilizan la palabra clave Flyout seguida de una serie de opciones que aparecen entre paréntesis.

    TAG3 [Flyout ("nombre_icono_desp", id_small, id_large, icon, alias)]macro

    Las opciones son las siguientes:

    nombre_icono_desp

    Cadena que asigna un nombre al icono desplegable. La cadena debe estar formada por caracteres alfanuméricos, sin otra puntuación que un guión (-) o un subrayado (_). Esta cadena se muestra como una pista cuando el cursor se sitúa sobre el icono desplegable.

    id_small

    Cadena que da nombre a la cadena de identificación del recurso de imagen pequeña (mapa de bits de 16 × 15). La cadena debe estar formada por caracteres alfanuméricos, sin otra puntuación que un guión (-) o un subrayado (_). Esta cadena también puede especificar un mapa de bits creado por el usuario (véase Especificación de los mapas de bits definidos por el usuario).

    id_big

    Cadena que da nombre a la cadena de identificación del recurso de imagen pequeña (mapa de bits de 32 × 30). Si el mapa de bits especificado no es de 32 × 30, AutoCAD define la escala a ese tamaño. La cadena debe estar formada por caracteres alfanuméricos, sin otra puntuación que un guión (-) o un subrayado (_). Esta cadena también puede especificar un mapa de bits creado por el usuario (véase Especificación de los mapas de bits definidos por el usuario).

    icon

    La palabra clave que controla si se muestra su propio icono o el último icono seleccionado (otro). Los valores admitidos (OwnIcon y OtherIcon) no distinguen entre mayúsculas y minúsculas.

    alias

    Referencia a la barra de herramientas que debe mostrarse como icono desplegable. El alias hace referencia a un submenú de barra de herramientas definido con la sintaxis estándar **nombre_alias.

    macro

    Macro del elemento de menú. Sigue la sintaxis estándar de las macros de menú.

    Véase también

    Creación de barras de herramientas


Ficha Procedimientos: Creación de iconos desplegables en las barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de iconos desplegables en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de iconos desplegables en las barras de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Creación de iconos desplegables en las barras de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Definición de controles de una barra de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Definición de controles de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Las definiciones de los controles de la barra de herramientas del archivo MNU utilizan la palabra clave Control seguida del nombre que especifica el tipo de elemento de control solicitado entre paréntesis. Para obtener ejemplos de los controles de color, tipo de línea y grosor de línea, véase la barra de herramientas Propiedades de AutoCAD.

    TAG4 [Control (element)]

    Los valores del parámetro element especifican los siguientes controles (estos valores no distinguen entre mayúsculas y minúsculas):

    _Color

    Elemento de control del color. Este elemento es una lista desplegable que contiene las especificaciones referentes al valor actual del color.

    _Dimstyle

    Elemento de control del estilo de cota. Este elemento es una lista desplegable que contiene las especificaciones referentes al valor actual del estilo de cota.

    _Layer

    Elemento de control de la capa. Este elemento es una lista desplegable que permite controlar las capas existentes actualmente en el dibujo.

    _Linetype

    Elemento de control del tipo de línea. Este elemento es una lista desplegable que contiene las especificaciones del tipo de línea actual.

    _Lineweight

    Elemento de control del grosor de línea. Este elemento es una lista desplegable que contiene las especificaciones referentes al grosor de línea actual.

    _PlotStyle

    Elemento de control del estilo de trazado. Este elemento es una lista desplegable que contiene las especificaciones referentes al estilo de trazado actual.

    _Refblkname

    Elemento de control del nombre de la referencia externa. Este elemento muestra el nombre de la referencia externa actual en el modo de edición.

    _UCSManager

    Elemento de control de SCP. Este elemento es una lista desplegable que contiene las especificaciones referentes al SCP actual.

    _View

    Elemento de control de la vista. Este elemento es una lista desplegable que contiene las especificaciones referentes al valor actual de las vistas 3D estándar.

    _ViewportScale

    Elemento de control de la escala de la ventana gráfica. Este elemento es una lista desplegable que contiene las especificaciones referentes a la escala de las ventanas gráficas en las presentaciones.

    Véase también

    Creación de barras de herramientas


Ficha Procedimientos: Definición de controles de una barra de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Definición de controles de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Definición de controles de una barra de herramientas [Manual de personalización: ACG]

Personalización de las barras de herramientas
Definición de controles de una barra de herramientas
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Especificación de los mapas de bits definidos por el usuario [Manual de personalización: ACG]

Personalización de las barras de herramientas
Especificación de los mapas de bits definidos por el usuario
Conceptos
Procedimientos
Referencia

    • Los mapas de bits definidos por el usuario se pueden utilizar en lugar de los nombres de recursos de imagen id_small y id_big correspondientes a los elementos de menú de botones y de iconos desplegables.

    Los mapas de bits definidos por el usuario deben tener el tamaño correcto para el parámetro id_small (16 píxeles de ancho por 15 píxeles de alto) y deben estar ubicados en la ruta de búsqueda de biblioteca. Para el parámetro id_big, si el mapa de bits especificado no es de 32 × 30, AutoCAD define la escala a ese tamaño. Especifique el mapa de bits de usuario con el nombre de archivo y la extensión .bmp, como se muestra a continuación:

    TAG34 [Button ("My Command", mycmd16.bmp, mycmd32.bmp)]^C^CMYCMD

    Véase también

    Creación de barras de herramientas


Ficha Procedimientos: Especificación de los mapas de bits definidos por el usuario [Manual de personalización: ACG]

Personalización de las barras de herramientas
Especificación de los mapas de bits definidos por el usuario
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Especificación de los mapas de bits definidos por el usuario [Manual de personalización: ACG]

Personalización de las barras de herramientas
Especificación de los mapas de bits definidos por el usuario
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Creación de menús de mosaico de imágenes [Manual de personalización: ACG]

Archivo de menús
Creación de menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • El objetivo principal de un menú de mosaico de imágenes es suministrar una imagen cuando el usuario debe seleccionar un símbolo gráfico en lugar de un texto.

    • Presentación general de los menús de mosaico de imágenes
      Puede definir un menú de mosaico de imágenes incluyendo una sección Image en el archivo de menús.
    • Preparación de las fotos para los menús de mosaico de imágenes
      La utilización correcta de las fotos en los menús de mosaico de imágenes exige una planificación cuidadosa antes de crear las fotos.


Ficha Procedimientos: Creación de menús de mosaico de imágenes [Manual de personalización: ACG]

Archivo de menús
Creación de menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de menús de mosaico de imágenes [Manual de personalización: ACG]

Archivo de menús
Creación de menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    SACAFOTO

    Crea un archivo de foto de la ventana gráfica actual de modelo o de la presentación actual

    ENCUADRE

    Desplaza la vista de la ventana gráfica actual

    MODOSOMBRA

    Controla la visualización del sombreado de un objeto sólido en la ventana gráfica actua

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Variables de sistema

    No hay entradas.


Presentación general de los menús de mosaico de imágenes [Manual de personalización: ACG]

Creación de menús de mosaico de imágenes
Presentación general de los menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • Puede definir un menú de mosaico de imágenes incluyendo una sección Image en el archivo de menús. AutoCAD muestra las imágenes en grupos de 20, junto con un cuadro de lista de desplazamiento que contiene los nombres de los archivos de fotos asociados o el texto relacionado. La longitud de los submenús de mosaico de imágenes es ilimitada. Si un submenú de mosaico de imágenes contiene más de 20 fotos, AutoCAD proporciona los botones Siguiente y Previo para que el usuario pueda pulsarlos y recorrer las páginas de imágenes.

    La sección Image utiliza submenús similares a los de las secciones Toolbars y Screen. Igual que en las secciones de menús Pop, la primera línea del submenú es el título. Éste se muestra como rótulo del cuadro de diálogo que contiene las imágenes. Los submenús deben ir separados por al menos una línea en blanco para salir de los elementos de un submenú anterior.

    Los elementos de menús de imágenes utilizan rótulos para definir el texto de la lista de desplazamiento y de la propia imagen. Los rótulos van seguidos por una macro de menú asociada. Los menús de mosaico de imágenes no pueden contener identificadores de nombre.

    Rótulos de los elementos de un menú de mosaico de imágenes

    Los rótulos de un menú de mosaico de imágenes suelen hacer referencia a nombres de archivos de foto y no a los rótulos de texto que se muestran en la pantalla. El archivo de fotos contiene la imagen que debe aparecer tras esa selección. El nombre del archivo de fotos, que puede ser una sola foto o parte de una fototeca, debe aparecer tal como se introduciría con el comando MIRAFOTO.

    Cuando se muestran fotos sucesivas que proceden de la misma fototeca, el archivo de la fototeca permanece abierto. Por tanto, el tiempo necesario para mostrar un menú de imágenes se reduce de manera significativa. La utilidad SLIDELIB se puede utilizar para combinar varios archivos de fotos en una fototeca.

    Los rótulos del menú de mosaico de imágenes se muestran en un cuadro de lista de desplazamiento que puede contener hasta 19 caracteres por rótulo. El nombre del archivo de fotos se suele mostrar; sin embargo, existen también las siguientes opciones de rótulos de menús de iconos.

    [nombre_foto]

    El nombre de foto nombre_foto se muestra en el cuadro de lista y la foto nombre_foto aparece como un símbolo.

    [nombre_foto,texto_rótulo]

    El texto texto_rótulo se muestra en el cuadro de lista y la foto nombre_foto se visualiza como imagen.

    [fototeca(nombre_foto)]

    El nombre de foto nombre_foto se muestra en el cuadro de lista y la foto nombre_foto de la fototeca fototeca aparece como una imagen.

    [fototeca(nombre_foto,texto_rótulo)]

    El texto texto_rótulo se muestra en el cuadro de lista y la foto nombre_foto de la fototeca fototeca se visualiza como una imagen.

    [en blanco]

    Si facilita el texto en blanco como rótulo de un icono, aparece una línea de separación en el cuadro de lista y se visualiza una imagen en blanco.

    [ texto_rótulo]

    Si el primer carácter de un rótulo de elemento es un espacio, el texto especificado en texto_rótulo se muestra en el cuadro de lista y no se visualiza ninguna imagen. En este caso puede incluir comandos relacionados y elementos sencillos como Salir sin necesidad de crear fotos que contengan estas palabras.

    Macros de menú de mosaico de iconos

    Las macros de los menús de mosaico de imágenes pueden realizar la misma función que otras macros de menú; sin embargo, no puede utilizarse con ellas la función de repetición de macros. Estas macros de menú pueden contener comandos de menú, incluidos los comandos $I=. Por tanto, es posible construir menús de mosaico de imágenes jerárquicos en los que una selección muestre otro menú de mosaico de imágenes y así sucesivamente. Dado que la activación de estos menús es secuencial en lugar de anidada, la complejidad de las estructuras que pueden crearse no tiene límites.

    Visualización de los menús de mosaico de imágenes

    El comando de la macro $I= hace referencia al menú de mosaico de imágenes. Antes de mostrar un menú de mosaico de imágenes debe cargarlo utilizando la siguiente sintaxis:

    $I=[grupo_menús.]nombre_menú

    El comando de macro $I=* muestra el menú de mosaico de imágenes cargado actualmente. Por ejemplo, las siguientes macros cargan y muestran el menú de mosaico de imágenes IMAGE_POLY del archivo acad.mnu.

    $I=image_poly $I=*

    El ejemplo siguiente carga y muestra el menú de mosaico de imágenes MISBLOQUES del grupo de menús MIGRUPO cargado parcialmente:

    $I=migrupo.misbloques $I=*

    También puede utilizar la función menucmd de AutoLISP para cargar los menús de mosaico de imágenes. El siguiente código produce el mismo resultado que el ejemplo anterior.

    (menucmd "I=migrupo.misbloques")
    (menucmd "I=*")

    Ejemplo de menús de mosaico de imágenes

    Este ejemplo muestra un submenú de mosaico de imágenes denominado 3DObjects.

    **3DOBJECTS
    [3D Objects]
    [acad(box3d)]^c^cai_box
    [acad(Pyramid)]^c^cai_pyramid
    [acad(Wedge)]^c^cai_wedge
    [acad(Dome)]^c^cai_dome
    [acad(Sphere)]^c^cai_sphere
    [acad(Cone)]^c^cai_cone
    [acad(Torus)]^c^cai_torus
    [acad(Dish)]^c^cai_dish
    [acad(Mesh)]^c^cai_mesh

    El resultado es una parte del menú de mosaico de imágenes.

    En el siguiente ejemplo, se utiliza un menú de mosaico de imágenes para insertar varios componentes electrónicos. El rótulo de texto es un elemento que se intercambia con otro submenú de mosaico de imágenes que contiene varias sujeciones.

    ***IMAGE
    **IPARTS
    [Electronic Parts]
    [cap]^Cinsert cap
    [res]^Cinsert res
    [neon]^Cinsert neon
    [triode]^Cinsert triode
    [tetrode]^Cinsert tetrode
    [ Fasteners]$I=ifast $I=*

    **IFAST

    [Fasteners]

    [nut632]...

    Para activar este menú de mosaico de imágenes, se puede elegir un elemento de menú como los siguientes de cualquier menú.

    [Electronic parts]$I=iparts $I=*

    En la siguiente variación, las imágenes se recuperan de una fototeca denominada elib. En el cuadro de lista aparece únicamente el nombre de las fotos.

    ***IMAGE

    **IPARTS

    [Electronic Parts]

    [elib(cap)]^Cinsert cap

    [elib(res)]^Cinsert res

    [elib(neon)]^Cinsert neon

    [elib(triode)]^Cinsert triode

    [elib(tetrode)]^Cinsert tetrode

Mostrar todo el texto oculto de esta página.


Ficha Procedimientos: Presentación general de los menús de mosaico de imágenes [Manual de personalización: ACG]

Creación de menús de mosaico de imágenes
Presentación general de los menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de los menús de mosaico de imágenes [Manual de personalización: ACG]

Creación de menús de mosaico de imágenes
Presentación general de los menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Variables de sistema

    No hay entradas.


Preparación de las fotos para los menús de mosaico de imágenes [Manual de personalización: ACG]

Creación de menús de mosaico de imágenes
Preparación de las fotos para los menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • Se pueden utilizar como imagen todas las fotos generadas por AutoCAD. Sin embargo, el uso óptimo de los menús de mosaico de imágenes requiere que se preparen las fotos que se van a utilizar como imágenes. Tenga en cuenta las siguientes recomendaciones al preparar las fotos para un menú de mosaico de imágenes.

    • Procure que la imagen sea sencilla. Cuando se muestra un menú de mosaico de imágenes, es necesario esperar a que se dibujen todas las imágenes antes de realizar una selección. Si muestra al usuario muchos símbolos complejos, haga versiones simples de las imágenes, en lugar de interpretaciones completas. Una imagen debe ser lo más sencilla posible, pero aun así reconocible de forma inmediata.
    • Rellene el cuadro. El espacio en pantalla es limitado y las imágenes ocupan partes reducidas de la pantalla completa. Cuando cree una foto para una imagen, cerciórese de que llena la pantalla con ella antes de ejecutar SACAFOTO. Si la imagen es muy ancha y corta, o larga y estrecha, el menú de mosaico de imágenes resultante quedará mejor si utiliza el comando ENCUADRE para centrar la imagen en la pantalla antes de hacer la foto.

    Las imágenes se visualizan con una relación anchura/altura de 3:2 (3 unidades de anchura por 2 unidades de altura). Si el área de dibujo tiene una relación de anchura y altura distinta, puede resultar difícil crear fotos que estén centradas en el menú de mosaico de imágenes. Si trabaja en la ventana gráfica de una presentación con una relación anchura/altura de 3:2, puede colocar la imagen con la garantía de que su aspecto será el mismo cuando se visualice en el menú de mosaico de imágenes.

    • Utilice el comando - MODOSOMBRA en las áreas con rellenos sólidos antes de generar la foto. De lo contrario, los objetos como las polilíneas anchas y los trazos se mostrarán como contornos.
    • No olvide el objetivo de estas imágenes. No utilice las imágenes para codificar los conceptos abstractos como símbolos. Los mosaicos de imágenes son útiles, principalmente, cuando el usuario debe seleccionar un símbolo gráfico.


Ficha Procedimientos: Preparación de las fotos para los menús de mosaico de imágenes [Manual de personalización: ACG]

Creación de menús de mosaico de imágenes
Preparación de las fotos para los menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Preparación de las fotos para los menús de mosaico de imágenes [Manual de personalización: ACG]

Creación de menús de mosaico de imágenes
Preparación de las fotos para los menús de mosaico de imágenes
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    SACAFOTO

    Crea un archivo de foto de la ventana gráfica actual de modelo o de la presentación actual

    ENCUADRE

    Desplaza la vista de la ventana gráfica actual

    MODOSOMBRA

    Controla la visualización del sombreado de un objeto sólido en la ventana gráfica actua

    Variables de sistema

    No hay entradas.


Creación de menús de pantalla [Manual de personalización: ACG]

Archivo de menús
Creación de menús de pantalla
Conceptos
Procedimientos
Referencia

    • La sección del menú de pantalla del archivo MNU controla el área del menú de pantalla.

    Por defecto, el menú de pantalla se encuentra desactivado. Para activarlo, haga clic en Mostrar menú de pantalla en la ficha Dibujo del cuadro de diálogo Opciones.

    En el archivo MNU, el rótulo de sección ***SCREEN representa el comienzo de los menús de pantalla de AutoCAD. El rótulo de sección de los submenús se identifica en este caso con la cadena **S. Se recomienda emplear nombres sencillos y concisos como éste cuando hay muchos elementos distintos que hacen referencia a este submenú, como se muestra en el siguiente ejemplo:
    Menú de pantalla | Sección del archivo de menús de pantalla
 | ***SCREEN **S [AutoCAD ]^C^C^P(ai_rootmenus) ^P [* * * * ]$S=ACAD.OSNAP [ARCHIVO ]$S=ACAD.01_FILE [EDICIÓN ]$S=ACAD.02_EDIT [VER 1 ]$S=ACAD.03_VIEW1 [VER 2 ]$S=ACAD.04_VIEW2 [INSERTAR ]$S=ACAD.05_INSERT [FORMATO ]$S=ACAD.06_FORMAT [HERR 1 ]$S=ACAD.07_TOOLS1 [HERR 2 ]$S=ACAD.08_TOOLS2 [DIBUJO 1 ]$S=ACAD.09_DRAW1 [DIBUJO 2 ]$S=ACAD.10_DRAW2 [ACOTAR]$S=ACAD.11_DIMENSION [MODIFICAR1 ]$S=ACAD.12_MODIFY1 [MODIFICAR2 ]$S=ACAD.13_MODIFY2 [AYUDA ]$S=ACAD.14_HELP [ASIST ]$S=ACAD.ASSIST [ULT ]$S=ACAD.

    Submenús de pantalla

    Los rótulos de los submenús de pantalla presentan el siguiente formato:

    **nombre_menú [num_inicio]

    nombre_menú es una cadena con un máximo de 33 caracteres que contiene letras, dígitos y los caracteres de dólar ($), guión (-) y subrayado (_). El rótulo del submenú se encuentra en una línea independiente del archivo de menús y no puede contener espacios en blanco insertados. Un número entero opcional num_inicio, que especifica la línea de inicio del submenú, puede seguir a nombre_menú.

    Cada submenú puede contener un número indefinido de elementos, pero el tamaño total del menú de pantalla queda limitado por el valor de la variable de sistema SCREENBOXES (normalmente definida como 28). Por ejemplo, si un submenú del menú de pantalla contiene 21 elementos, pero la pantalla sólo puede mostrar 20 elementos al mismo tiempo, no será posible acceder al último elemento del submenú.

    Cuando se activa un submenú, los elementos que éste incluye suelen reemplazar a los del menú anterior comenzando desde el principio (cuadro de menú 1) y siguiendo con el resto de los elementos del submenú. Así, un submenú puede reemplazar sólo una parte del menú anterior. Se puede añadir un número de elemento tras el rótulo de sección o submenú para especificar una sustitución que comienza con un elemento de menú que no sea el 1, como se ilustra en el siguiente ejemplo:

    **EJEMPLO 3

    Cuando se activa el submenú EJEMPLO, no se modifican los dos primeros cuadros de menú y la sustitución del submenú comienza con el cuadro de menú 3.

    Para restituir los elementos anteriores de pantalla, un elemento de menú debe incluir los siguientes códigos sin rótulo de submenú.

    $S=

    AutoCAD realiza un seguimiento de los ocho últimos submenús. Si se excede este número, se descartan los primeros menús.

    En el siguiente ejemplo de sección de menú de pantalla se muestra el uso de los submenús.
    ***SCREEN [MenúSENCILLO] [DIBUJO... ]$S=Draw_Root [EDICIÓN... ]$S=Edit_Root [Finalizar ]end [ -PRINCIPAL- ]$S=SCREEN | Línea en blanco Línea en blanco Tres líneas en blanco rellenan esta página del menú con 10 líneas y hacen desaparecer los elementos mostrados por los submenús. Como ningún submenú continúa después de esta línea, aparece en todos los menús. Llama al menú principal.
**Draw_Root 2 [Línea ]line [Círculo ]circle [Arco ]arc | El dígito 2 que sigue al nombre del submenú inicia este menú en la línea que aparece después de [MenúSENCILLO]. Al menos una línea en blanco.
**Edit_Root 2 [Borrar ]$S=Sel_obj erase [Copiar ]$S=Sel_obj copy [Desplazar ]$S=Obj_sel move | Obsérvese el uso del alias del menú. Al menos dos líneas en blanco rodean los elementos de menú Sel_obj.
**Obj_sel 2 **Sel_obj 2 [Último ]last [Anterior]previous [Ventana ]window [Captura]crossing [ -ANTERIOR- ]$S= | Se puede utilizar Obj_sel y Sel_obj para llamar a este menú. $S= llama al menú anterior.
***BUTTONS1 ; redibujar | Menú de botones del dispositivo señalador. Asigna INTRO al botón 2. Asigna el comando REDIBUJA al botón 3.

    El ejemplo anterior contiene tres submenús: Draw_Root, Edit_Root y Sel_obj.

    Draw_Root y Edit_Root se llaman desde el menú de pantalla principal al designar los elementos de menú Dibujo o Edición. El submenú Draw_Root proporciona tres elementos de selección que corresponden a los comandos de AutoCAD. El submenú Edit_Root también contiene tres elementos de designación, cada uno de los cuales llama al submenú Sel_obj antes de ejecutar el comando pertinente.

    En todos los casos, el elemento de designación –PRINCIPAL– llama al menú principal de pantalla. Un menú de pantalla sobrescribirá (borrará) únicamente el número de líneas del anterior menú de pantalla que contenga. Si un menú de pantalla contiene más elementos que cuadros en la pantalla o si un menú de botones contiene más elementos que los botones disponibles, se pasarán por alto los elementos que exceden esta cantidad.

    Puede utilizar líneas en blanco en los archivos de menús para prolongar los submenús de manera que cubran los menús anteriores. También puede insertar líneas en blanco para aumentar la legibilidad del archivo.

    Si se designa un elemento de menú denominado Zoom en el menú principal de pantalla, se puede activar un submenú que contenga las opciones del comando ZOOM.

    El siguiente ejemplo hace referencia al submenú **01_FILE perteneciente al grupo de menús ACAD.

    [ARCHIVO    ]$S=ACAD.01_FILE

    La mayor parte de los menús de pantalla del archivo acad.mnu se cargan en el cuadro de menú 3, de manera que los rótulos de menú [AutoCAD] y [* * * *] pueden permanecer en la pantalla.

    El siguiente ejemplo muestra cómo el submenú **01_FILE se muestra en la pantalla. Observe que la primera línea (correspondiente a Nuevo) se muestra en el cuadro de menú 3.
    Menú de pantalla | Sección del archivo de menús de pantalla
 | **01_FILE 3 [Nuevo ]^C^C_new [Abrir ]^C^C_open [Guardarr ]^C^C_qsave [Guardarcomo ]^C^C_saveas [Exportar ]^C^C_export [Config ]^C^C_config [Trazador ]^C^C_plot [Revisión ]^C^C_audit [Recuperar ]^C^C_recover [Limpiar ]^C^C_purge [Quitar ]^C^C_quit

    Los elementos de menú Asist y Último se muestran al final del área del menú de pantalla porque forman parte del submenú **S que no se sobrescribe con el submenú **01_FILE.

    Rótulos de los elementos de menú de pantalla

    Si un elemento de menú de pantalla no contiene un rótulo de elemento, los ocho primeros caracteres de una macro de menú aparecen en el menú de pantalla. El comando del siguiente ejemplo se mostraría como FORZCURSOR 0.0.

    FORZCURSOR 0.001

    Si se incluye el rótulo, se muestran los ocho primeros caracteres de éste en el cuadro de menú de pantalla correspondiente. Los caracteres restantes se utilizan como comentarios.

    Nota El número máximo de elementos de menú depende del sistema. Puede recuperar el número de los cuadros de menú de pantalla mediante la variable de sistema SCREENBOXES.

    Intercambio automático de los submenús de pantalla

    La variable de sistema MENUCTL controla el intercambio automático de los submenús de pantalla cuando se ejecuta el comando correspondiente. Cuando MENUCTL se define como 1 (activo) y se llama a un comando de AutoCAD desde un elemento de menú, AutoCAD ejecuta una cadena $S=nombre_comando (donde nombre_comando es el nombre del comando), que llama a un submenú de pantalla que tiene el mismo nombre que el comando. El menú acad.mnu estándar aprovecha esta función definiendo MENUCTL como 1 en el archivo acad.mnl. La definición de MENUCTL como 0 (desactivado) afecta al funcionamiento del menú estándar, pero es preferible para los menús personalizados más antiguos.


Para mostrar el menú de pantalla [Manual de personalización: ACG]

Archivo de menús
Creación de menús de pantalla
Conceptos
Procedimientos
Referencia

    • Para mostrar el menú de pantalla

    1. En el menú Herr., haga clic en Opciones.
    2. Haga clic en la ficha Visual.
    3. En Elementos de ventana, en la ficha Visual., seleccione Mostrar menú de pantalla.
    4. Pulse Aceptar.


Ficha Referencia: Creación de menús de pantalla [Manual de personalización: ACG]

Archivo de menús
Creación de menús de pantalla
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    MENUCTL

    Controla la conmutación de páginas del menú de pantalla

    SCREENBOXES

    Almacena el número de casillas en el área del menú de pantalla del área de dibujo


Creación de menús de tablero [Manual de personalización: ACG]

Archivo de menús
Creación de menús de tablero
Conceptos
Procedimientos
Referencia

    • Se pueden configurar hasta cuatro áreas del tablero digitalizador como áreas de menús para la entrada de comandos. Las secciones del archivo de menús identificadas como TABLET1 a TABLET4 definen las macros de menú asociadas a las opciones de tablero de dichas áreas.

    Los elementos de menú de las secciones Tablet usan la misma sintaxis que los de otras secciones. Los rótulos de los elementos pueden usarse como comentarios y no se muestran.

    Las áreas de menús de tablero definidas con la opción Cfg del comando TABLERO están divididas en cuadros de selección de menú de igual tamaño que vienen determinados por el número de columnas y filas especificadas en cada área. Estos cuadros de selección de menús de tablero corresponden directamente a las líneas que siguen a los rótulos de las secciones Tablet, de izquierda a derecha y de arriba a abajo (contengan o no texto).

    Por ejemplo, si configura un área de menús con cinco columnas y cuatro filas, el elemento de menú de la línea inmediatamente posterior al rótulo de sección corresponde al cuadro de selección situado más a la izquierda de la fila superior. Asimismo, el elemento de menú de la línea octava situada después del rótulo de sección corresponde al tercer cuadro por la izquierda de la segunda fila. AutoCAD puede reconocer hasta 32.766 elementos de menú en cada sección de tablero, lo cual debería ser más que suficiente para cualquier menú de tablero.

    Puede añadir sus propias macros de menú a la sección ***TABLET1 de acad.mnu. Los rótulos de los elementos de menú de esta área corresponden a los 225 cuadros de la parte superior de la plantilla del tablero (las filas comprendidas entre la A y la I, y las columnas comprendidas entre la 1 y la 25). Puede añadir su macro de menú tras el rótulo de menú [fila-columna] correspondiente, mediante la sintaxis de elemento de menú estándar.

    ***TABLET1
    [A-1]
    [A-2]
    [A-3]
    .
    .
    .
    [I-25]

    No es recomendable modificar las líneas posteriores al cuadro I25.

    Véase también

    Creación de macros de menú


Ficha Procedimientos: Creación de menús de tablero [Manual de personalización: ACG]

Archivo de menús
Creación de menús de tablero
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de menús de tablero [Manual de personalización: ACG]

Archivo de menús
Creación de menús de tablero
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    TABLERO

    Calibra, configura y activa o desactiva un tablero digitalizador enlazado

    Variables de sistema

    No hay entradas.


Creación de mensajes de ayuda de la línea de estado [Manual de personalización: ACG]

Archivo de menús
Creación de mensajes de ayuda de la línea de estado
Conceptos
Procedimientos
Referencia

    • Los mensajes de ayuda de la línea de estado son mensajes sencillos y descriptivos que aparecen en la línea de estado al seleccionar un elemento de menú. En la sección de menú Helpstrings se definen estos mensajes.

    El siguiente ejemplo muestra un archivo de menús sencillo que utiliza la sección de menú Helpstrings.

    ***MENUGROUP=sample
    ***POP1
    ID_Title  [/TTítulo]
    ID_Cancel [Comando Cancelar]^C^C
    ID_Line   [/LLínea]^C^C_line
              [Desactivar línea](menucmd "Gsample.ID_Line=~")
              [Comprobar línea](menucmd "Gsample.ID_Line=!.")
    ***POP2
    [/2Title2]
    [Otro menú desplegable](menucmd "Gsample.ID_Line=~")
    ***HELPSTRINGS
    ID_Title  [Este es el menú de título]
    ID_Cancel [Este elemento cancela el comando precedente]
    ID_Line   [Esto dibuja una línea simple]

    La sintaxis para la sección Helpstrings es un identificador de nombre seguido de un rótulo. Cuando se resalta un elemento de menú, el identificador de nombre de este elemento se comprueba para encontrar una entrada correspondiente en la sección Helpstrings. Si se encuentra, la cadena contenida en el rótulo se muestra en la línea de estado.


Ficha Procedimientos: Creación de mensajes de ayuda de la línea de estado [Manual de personalización: ACG]

Archivo de menús
Creación de mensajes de ayuda de la línea de estado
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de mensajes de ayuda de la línea de estado [Manual de personalización: ACG]

Archivo de menús
Creación de mensajes de ayuda de la línea de estado
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Creación de métodos abreviados [Manual de personalización: ACG]

Archivo de menús
Creación de métodos abreviados
Conceptos
Procedimientos
Referencia

    • Puede definir sus propios métodos abreviados (o aceleradores). A continuación se ofrece un breve ejemplo de la sección Accelerators de un archivo MNU.

    ***ACCELERATORS
    ID_Line    [MAYÚS+CONTROL+"L"]
    [CONTROL+"Q"]^C^C_quit
    [CONTROL+MAYÚS+"Z"]^C^Czoom extents

    La sección Accelerators contiene elementos de menú que se presentan en uno o dos formatos, que se ilustran en el ejemplo anterior:

    • El primer elemento de menú asigna una secuencia de teclas a un elemento de menú: ID_Line [MAYÚS+CONTROL+"L"]. El identificador de nombre (ID_Line) precede a un rótulo que contiene los modificadores: MAYÚS+CONTROL+. Los modificadores preceden a una cadena de teclas de un solo carácter (en el ejemplo L) o a una cadena de teclas virtuales especiales (como F12) que aparece entre comillas. Cuando se reconoce una secuencia de teclas especial, el elemento de menú asociado con el identificador de nombre se ejecuta como si lo hubiese elegido el usuario.
    • El segundo y el tercer elemento de menú asignan una secuencia de teclas a una macro de menú, no a un elemento de menú. Un rótulo que contiene un modificador y una cadena de teclas (CONTROL+"Q") precede a una macro de menú (^C^C_quit ). La macro de menú utiliza el formato y los caracteres especiales estándar, con la excepción de que no se puede utilizar el carácter de barra invertida (\) para intercalar pausas que permitan al usuario introducir datos.

    Si desea intercalar una pausa para permitir la introducción de datos por parte del usuario, utilice el primer método para asignar una secuencia de teclas al elemento de menú que incluye la pausa deseada.

    Puede concatenar los modificadores utilizando el signo más (+), como en los ejemplos primero y tercero. Los modificadores válidos son CONTROL (la tecla CTRL) y MAYÚS (la tecla MAYÚS).

    La siguiente tabla contiene las teclas virtuales especiales que se pueden emplear con los modificadores. Las letras y los números del teclado estándar y estas teclas virtuales especiales deben aparecer entre comillas.

    Cadena

    Descripción

    Excepciones

    F1

    Tecla F1

    No es recomendable asignar una macro de menú a la tecla F1, porque ésta se suele asociar a la Ayuda. Esta tecla se puede utilizar con un modificador.

    F2

    Tecla F2

    Sin modificar, cambia el estado de la ventana de texto.

    F3

    Tecla F3

    Sin modificar, ejecuta REFENT.

    F4

    Tecla F4

    Sin modificar, activa o desactiva TABMODE.

    F5

    Tecla F5

    Sin modificar, activa o desactiva ISOPLANO.

    F6

    Tecla F6

    Sin modificar, activa o desactiva COORDS.

    F7

    Tecla F7

    Sin modificar, activa o desactiva GRIDMODE.

    F8

    Tecla F8

    Sin modificar, activa o desactiva ORTHOMODE.

    F9

    Tecla F9

    Sin modificar, activa o desactiva SNAPMODE.

    F10

    Tecla F10

    Sin modificar, activa o desactiva el rastreo polar.

    F11

    Tecla F11

    Sin modificar, activa o desactiva el rastreo de referencia a objetos.

    F12

    Tecla F12

    Ninguno

    INSERT

    Tecla INSERT

    Se debe utilizar con el modificador CONTROL.

    SUPRIMIR

    Tecla DEL

    Se debe utilizar con el modificador CONTROL.

    ESCAPE

    Tecla ESC

    No es recomendable asignar una macro de menú a la tecla ESC, porque ésta se suele asociar a Cancelar. No se puede asignar CONTROL+ESCAPE y CONTROL+MAYÚS+ESCAPE a una macro de menú, porque Windows controla estas secuencias. La tecla MAYÚS se puede utilizar como modificador con esta tecla.

    ARRIBA

    Tecla FLECHA ARRIBA

    Se debe utilizar con el modificador CONTROL.

    ABAJO

    Tecla FLECHA ABAJO

    Se debe utilizar con el modificador CONTROL.

    IZQUIERDA

    Tecla FLECHA IZQUIERDA

    Se debe utilizar con el modificador CONTROL.

    DERECHA

    Tecla FLECHA DERECHA

    Se debe utilizar con el modificador CONTROL.

    NUMPAD0

    Tecla 0

    Ninguno

    NUMPAD1

    Tecla 1

    Ninguno

    NUMPAD2

    Tecla 2

    Ninguno

    NUMPAD3

    Tecla 3

    Ninguno

    NUMPAD4

    Tecla 4

    Ninguno

    NUMPAD5

    Tecla 5

    Ninguno

    NUMPAD6

    Tecla 6

    Ninguno

    NUMPAD7

    Tecla 7

    Ninguno

    NUMPAD8

    Tecla 8

    Ninguno

    NUMPAD9

    Tecla 9

    Ninguno

    Entrada de coordenadas mediante métodos abreviados (Ejemplo)

    Los usuarios que hacen un uso extensivo de la introducción de coordenadas encontrarán de utilidad la siguiente mejora del menú.

    ["NUMPAD5"]@x^h
    ["NUMPAD6"]<0
    ["NUMPAD9"]<45
    ["NUMPAD8"]<90
    ["NUMPAD7"]<135
    ["NUMPAD4"]<180
    ["NUMPAD1"]<-135
    ["NUMPAD2"]<-90
    ["NUMPAD3"]<-45

    Si se añade este código a la sección Accelerators, el teclado numérico se modificará del siguiente modo: la tecla INTRO introduce el símbolo @ y el resto de las teclas numéricas introducen el símbolo menor que (<), seguido del valor angular representado por su ubicación en el teclado. Por ejemplo, si desea dibujar un cuadrado con un lado de 3 unidades, debe introducir lo siguiente:

    Comando: linea

    Hasta el punto (especifique el punto inicial):

    Hasta el punto: (pulse el número 5) 3 (pulse el número 6)

    Hasta el punto: (pulse el número 5) 3 (pulse el número 2)

    Hasta el punto: (pulse el número 5) 3 (pulse el número 4)

    Hasta el punto: c

    Mostrar todo el texto oculto de esta página.


Ficha Procedimientos: Creación de métodos abreviados [Manual de personalización: ACG]

Archivo de menús
Creación de métodos abreviados
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Creación de métodos abreviados [Manual de personalización: ACG]

Archivo de menús
Creación de métodos abreviados
Conceptos
Procedimientos
Referencia

    • Comandos

    MENU

    Carga un archivo de menú

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales

    Variables de sistema

    No hay entradas.


DIESEL [Manual de personalización: ACG]

DIESEL
Conceptos
Procedimientos
Referencia

    • Las expresiones DIESEL (Direct Interpretively Evaluated String Expression Language) aceptan cadenas como entrada y generan resultados de cadena. Puede utilizar DIESEL en macros de menú o para mostrar texto en la línea de estado.

    • Personalización de la línea de estado
      Puede utilizar la variable de sistema MODEMACRO para mostrar información en la línea de estado.
    • Expresiones DIESEL en macros de menú
      Es posible incluir expresiones de cadena de DIESEL en archivos de menús como método adicional de creación de macros.
    • Catálogo de funciones DIESEL
    • Mensajes de error en DIESEL


Personalización de la línea de estado [Manual de personalización: ACG]

DIESEL
Personalización de la línea de estado
Conceptos
Procedimientos
Referencia

    • Puede utilizar la variable de sistema MODEMACRO para mostrar información en la línea de estado.

    • Presentación general de la variable de sistema MODEMACRO
    • Definición de los valores de MODEMACRO
      Puede utilizar cadenas de texto y lenguaje DIESEL para mostrar mensajes en la sección de la línea de estado definida por el usuario.
    • Establecimiento de MODEMACRO con AutoLISP
      Otra manera de establecer los valores de MODEMACRO es utilizar AutoLISP.


Ficha Procedimientos: Personalización de la línea de estado [Manual de personalización: ACG]

DIESEL
Personalización de la línea de estado
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Personalización de la línea de estado [Manual de personalización: ACG]

DIESEL
Personalización de la línea de estado
Conceptos
Procedimientos
Referencia

    • Comandos

    MODIVAR

    Enumera o cambia los valores de las variables de sistema

    Variables de sistema

    MODEMACRO

    Muestra una cadena de texto en la línea de estado, como el nombre del dibujo actual, la marca de fecha y hora o los modos especiales


Presentación general de la variable de sistema MODEMACRO [Manual de personalización: ACG]

Personalización de la línea de estado
Presentación general de la variable de sistema MODEMACRO
Conceptos
Procedimientos
Referencia

    • Esta línea de estado puede proporcionar al usuario información importante sin interrumpir el flujo de trabajo. La variable de sistema MODEMACRO controla el área definida por el usuario de la línea de estado. El valor calculado de la variable de sistema MODEMACRO se visualiza en un panel alineado a la izquierda en la barra de estado, en la parte inferior de la ventana de AutoCAD. Esta variable está definida como una cadena nula al iniciar AutoCAD. Su valor no se almacena en el dibujo, en el archivo de configuración ni en ningún otro lugar.

    El número de caracteres mostrados en la línea de estado sólo se ve limitado por el tamaño de la ventana de AutoCAD (y por el monitor). Los paneles por defecto se desplazan a la derecha a medida que aumenta el contenido del panel de MODEMACRO. Es posible hacer desaparecer fuera de la pantalla los paneles por defecto (si lo desea).

    Puede utilizar la variable de sistema MODEMACRO para mostrar en la línea de estado la mayor parte de los datos conocidos por AutoCAD. Las funciones de cálculo, decisión y edición permiten ajustar la línea de estado a las especificaciones concretas de cada usuario.

    MODEMACRO es una variable de cadena del usuario. Puede tomar cualquier valor de texto. Una cadena con una longitud máxima de 460 caracteres debería funcionar en todos los sistemas. Puede definir MODEMACRO con MODIVAR o escribiendo modemacro en la solicitud de comando. Si modifica el valor de MODEMACRO, podrá experimentar con diferentes formatos de línea de estado; sin embargo, el número máximo de caracteres que pueden escribirse de este modo es 255.

    Si define MODEMACRO como una cadena nula escribiendo un punto (.), AutoCAD muestra la línea de estado estándar.


Ficha Procedimientos: Presentación general de la variable de sistema MODEMACRO [Manual de personalización: ACG]

Personalización de la línea de estado
Presentación general de la variable de sistema MODEMACRO
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de la variable de sistema MODEMACRO [Manual de personalización: ACG]

Personalización de la línea de estado
Presentación general de la variable de sistema MODEMACRO
Conceptos
Procedimientos
Referencia

    • Comandos

    MODIVAR

    Enumera o cambia los valores de las variables de sistema

    Variables de sistema

    MODEMACRO

    Muestra una cadena de texto en la línea de estado, como el nombre del dibujo actual, la marca de fecha y hora o los modos especiales


Ficha Procedimientos: Fotos y archivos de comandos [Manual de personalización: ACG]

Fotos y archivos de comandos
Conceptos
Procedimientos
Referencia

    • Para hacer una foto

    Para ver una foto:

    Para crear una fototeca

    Para ver una foto de una fototeca

    Para crear un archivo de comandos que modifique los valores de un dibujo

    Para ejecutar un archivo de comandos en el inicio

    Para ejecutar presentaciones de fotos desde archivos de comandos

    Para crear un archivo de comandos que precargue fotos


Ficha Referencia: Fotos y archivos de comandos [Manual de personalización: ACG]

Fotos y archivos de comandos
Conceptos
Procedimientos
Referencia

    • Comandos

    RETARDA

    Proporciona una pausa de duración establecida dentro de un archivo de comandos

    PANTGRAF

    Permite cambiar de la ventana de texto al área de dibujo

    SACAFOTO

    Crea un archivo de foto de la ventana gráfica actual de modelo o de la presentación actual

    REDIBUJA

    Renueva la visualización en la ventana gráfica activa

    REANUDA

    Reanuda un archivo de comandos interrumpido

    RSCRIPT

    Repite el archivo de comandos

    SCRIPT

    SCRIPT ejecuta una secuencia de comandos desde un archivo de comandos

    PANTTEXT

    Abre la ventana de texto

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Utilidades

    SLIDELIB

    Recopila los archivos de fotos que se muestran en un archivo en formato ASCII y los inserta en un archivo de fototeca

    Variables de sistema

    FILEDIA

    Suprime la visualización de los cuadros de diálogo de archivo


Definición de los valores de MODEMACRO [Manual de personalización: ACG]

Personalización de la línea de estado
Definición de los valores de MODEMACRO
Conceptos
Procedimientos
Referencia

    • El valor de MODEMACRO determina lo que se muestra en la línea de estado de modo. El valor más simple y el menos útil de MODEMACRO consiste en texto constante. Por ejemplo, para ver el nombre de una compañía en la línea de estado, podría escribir lo siguiente:

    Comando: modemacro

    Indique nuevo valor para MODEMACRO o . para ninguno <"">: Pizzería Roma

    Este valor de MODEMACRO siempre muestra el mismo texto; la línea de estado no refleja los cambios en el estado interno de AutoCAD. No cambiará hasta que modifique MODEMACRO.

    Para que la línea de estado refleje el estado actual de AutoCAD, escriba expresiones de macro empleando el lenguaje DIESEL con el siguiente formato:

    $(unafunc, arg1, arg2, ...)

    En la expresión de macro, unafunc es el nombre de la función DIESEL (parecido al nombre de una función AutoLISP) y arg1, arg2, etc., son los argumentos de la función, interpretados conforme a la definición de la función. Al contrario de lo que ocurre con AutoLISP, las expresiones de macro de DIESEL sólo tienen un tipo de dato: cadenas. Las macros que operan con números expresan los números como cadenas y las convierten de forma bidireccional según se necesite.

    Para obtener descripciones de las funciones DIESEL, véase Catálogo de funciones DIESEL.

    Defina ahora una línea de estado más interesante; por ejemplo, una que muestre el nombre del estilo de texto actual:

    Comando: modemacro

    Indique nuevo valor para MODEMACRO o . para ninguno <"">: Style: $(getvar, textstyle)

    • Style: es una cadena de texto que se muestra en la línea de estado.
    • $(getvar,textstyle) es una función DIESEL (getvar) y el argumento que recupera el valor actual de la variable de sistema TEXTSTYLE.

    Nota Los ejemplos de este tema demuestran que la cadena MODEMACRO es algo más que una línea de texto. Se escribe como una cadena larga en la solicitud de comando.

    Cualquier variable de sistema se puede recuperar escribiendo $(getvar, varname). El valor actual de la variable de sistema sustituirá a la expresión de la macro en la línea de estado. Cuando cambie de estilo de texto, por ejemplo, MODEMACRO volverá a evaluarse. Si cambia, el nombre del nuevo estilo de texto se visualiza en la línea de estado.

    Se pueden anidar expresiones, que pueden ser tan complejas como se desee. El siguiente ejemplo muestra el valor y el ángulo (en grados) actual de la resolución en la línea de estado. En él, se utilizan expresiones anidadas para convertir el ángulo de referencia de radianes a grados y se trunca el valor a un número entero.

    Comando: modemacro

    Indique nuevo valor para MODEMACRO o . para ninguno <"">: Snap: $(getvar, snapunit) $(fix,$(*,$(getvar,snapang),$(/,180,3.14159)))

    También puede mostrar los valores en los modos de unidades lineales y angulares actuales.

    Comando: modemacro

    Indique nuevo valor para MODEMACRO o . para ninguno <"">: Snap: $(rtos,$(index,0,
    $(getvar,snapunit))),$(rtos,$(index,1,$(getvar,snapunit)))$(angtos,
    $(getvar,snapang))

    DIESEL copia sus datos de entrada directamente en la salida hasta que llega al signo del dólar ($) o a una cadena entre comillas. Puede emplear las cadenas entrecomilladas para suprimir la evaluación de secuencias de caracteres que, de otra forma, serían interpretadas como funciones de DIESEL. Se pueden incluir comillas en secuencias ya entrecomilladas utilizando dos comillas adyacentes. En el ejemplo siguiente, la capa actual se ha definido como PRESENTACIÓN y MODEMACRO se ha definido como la cadena.

    Comando: modemacro

    Indique nuevo valor para MODEMACRO o . para ninguno <"">: "$(getvar,clayer)= """$(getvar,clayer)""""

    En la línea de estado aparece lo siguiente:

    $(getvar,clayer)="LAYOUT"


Ficha Procedimientos: Definición de los valores de MODEMACRO [Manual de personalización: ACG]

Personalización de la línea de estado
Definición de los valores de MODEMACRO
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Definición de los valores de MODEMACRO [Manual de personalización: ACG]

Personalización de la línea de estado
Definición de los valores de MODEMACRO
Conceptos
Procedimientos
Referencia

    • Comandos

    MODIVAR

    Enumera o cambia los valores de las variables de sistema

    Variables de sistema

    MODEMACRO

    Muestra una cadena de texto en la línea de estado, como el nombre del dibujo actual, la marca de fecha y hora o los modos especiales


Establecimiento de MODEMACRO con AutoLISP [Manual de personalización: ACG]

Personalización de la línea de estado
Establecimiento de MODEMACRO con AutoLISP
Conceptos
Procedimientos
Referencia

    • Otra manera de establecer los valores de MODEMACRO es utilizar AutoLISP. Puede almacenar los códigos de ejemplo incluidos aquí como archivos de texto en formato ASCII y cargarlos con la función load de AutoLISP.

    El siguiente comando de AutoLISP define una cadena de MODEMACRO que proporciona información similar a la de la línea de estado interna. Como AutoLISP no puede continuar las cadenas entre línea y línea, es preciso utilizar la función strcat de AutoLISP para crear la cadena completa MODEMACRO a partir de cadenas más pequeñas.

    (defun  C:ACADMODE ( )
                (setvar "modemacro"
                    (strcat
                     "Layer $(substr,$(getvar,clayer),1,8)"
                     "$(if,$(getvar,orthomode), Ortho)"
                     "$(if,$(getvar,snapmode), Snap)"
                     "$(if,$(getvar,tabmode), Tablet)"
                     "$(if,$(=,$(getvar,tilemode),0),"
                       "$(if,$(=,$(getvar,cvport),1), P)"
                     ")"
                  )
                )
    )

    Guarde esta rutina de AutoLISP en un archivo llamado acadmode.lsp. Cuando cargue la rutina y la ejecute, mostrará información en la línea de estado. Esta no es la aplicación más útil de esta función; se ofrece únicamente como ejemplo.

    El siguiente archivo de ejemplo acad.lsp utiliza la función S::STARTUP para establecer la variable MODEMACRO en una cadena definida por el archivo mode1.lsp de AutoLISP.

    ;;; Archivo ACAD.LSP de ejemplo que utiliza S::STARTUP para cargar
    ;;; el archivo MODE1.LSP, que define una cadena de MODEMACRO
    (defun S::STARTUP ()
                (load "mode1")
                (princ)
    )
    ;;; También se pueden definir o cargar aquí archivos
    ;;; adicionales de AutoLISP

    Cuando se carga el archivo (mode1.lsp) de AutoLISP, utiliza la variable de sistema MODEMACRO para definir una línea de estado que muestra L: seguido de los ocho primeros caracteres del nombre de la capa, el nombre del dibujo y una parte de la ruta, y la primera letra de cada nombre de los modos activos en ese momento. La posición del nombre del dibujo no varía, independientemente de la longitud del nombre de la capa.

    ;;; MODE1.LSP
    ;;;
    (setvar "modemacro"
      (strcat
        "L:$(substr,$(getvar,clayer),1,30)"
        "$(substr,        ,1,$(-,30,$(strlen,$(getvar,clayer)))) "
    ;;            ^^^^^^^^ Observe los 8 espacios que se introducen aquí
        "<.."
          "$(if,$(eq,$(getvar,dwgname),UNNAMED),UNNAMED,"
            "$(substr,$(getvar,dwgname),"
              "$(if,$(>,$(strlen,$(getvar,dwgprefix)),29),"
                "$(-,$(strlen,$(getvar,dwgprefix)),29),1"
              "),"
              "$(strlen,$(getvar,dwgname))"
            ")"
          ")"
        ">"
        "$(if,$(getvar,orthomode), O, )"
        "$(if,$(getvar,snapmode), S, )"
        "$(if,$(getvar,tabmode), T, )"
        "$(if,$(and,"
          "$(=,$(getvar,tilemode),0),$(=,$(getvar,cvport),1)),P)"
      )
    )

    La sangría del código mejora la lectura de los archivos de AutoLISP y de las cadenas DIESEL.


Ficha Procedimientos: Establecimiento de MODEMACRO con AutoLISP [Manual de personalización: ACG]

Personalización de la línea de estado
Establecimiento de MODEMACRO con AutoLISP
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Establecimiento de MODEMACRO con AutoLISP [Manual de personalización: ACG]

Personalización de la línea de estado
Establecimiento de MODEMACRO con AutoLISP
Conceptos
Procedimientos
Referencia

    • Comandos

    MODIVAR

    Enumera o cambia los valores de las variables de sistema

    Variables de sistema

    MODEMACRO

    Muestra una cadena de texto en la línea de estado, como el nombre del dibujo actual, la marca de fecha y hora o los modos especiales


Expresiones DIESEL en macros de menú [Manual de personalización: ACG]

DIESEL
Expresiones DIESEL en macros de menú
Conceptos
Procedimientos
Referencia

    • Es posible incluir expresiones de cadena de DIESEL en archivos de menús y utilizarlas como método adicional de creación de macros. Estas expresiones pueden devolver valores de cadena (cadenas de texto) como respuesta a los comandos estándar de AutoCAD, a las rutinas de AutoLISP y ObjectARX™, y a otras macros de menú. Pueden también devolver valores de cadena al menú mismo, alterando, por tanto, la apariencia o el contenido de un rótulo de menú.

    Una expresión DIESEL utilizada en una opción de menú debe seguir el formato $sección=submenú, donde el nombre de la sección es M y el submenú es la expresión DIESEL que se desee. A menudo, resulta más fácil incluir una macro de menú con AutoLISP.

    Los siguientes ejemplos muestran dos elementos de menú que generan el mismo resultado: uno utiliza DIESEL y el otro, AutoLISP.

    Este elemento de menú utiliza la expresión DIESEL:

    [Ps/Ms]^C^C^P$M=$(if,$(=,$(getvar,cvport),1),mspace,pspace)

    Este elemento de menú utiliza la expresión AutoLISP:

    [-Ps/Ms-]^C^C^P(if (= (getvar "cvport") 1)(command "mspace")+
    (command "pspace"))(princ) ^P

    Ambos elementos de menú proporcionan una manera de alternar entre el espacio papel y el espacio modelo (si TILEMODE se ha definido como 0), pero la expresión DIESEL es más corta y se evalúa de manera transparente sin necesidad de llamar a la función princ de AutoLISP. Si el carácter especial ^P (que activa y desactiva MENUECHO) se omite en ambos casos, la expresión DIESEL muestra sólo el comando ejecutado, mientras que la expresión AutoLISP muestra toda la línea de código.

    Como el valor devuelto por una expresión DIESEL es una cadena de texto, puede utilizarse como respuesta a una llamada a la función getxxx de AutoLISP. Esta funcionalidad permite que los elementos de menú evalúen las condiciones actuales del dibujo y devuelvan un valor a una rutina de AutoLISP.

    El ejemplo siguiente se basa en cuatro supuestos:

    • La rutina de AutoLISP está cargada en memoria.
    • El extracto de menú se incluye en el menú actual.
    • Los símbolos que se van a insertar tienen una unidad de altura por una de anchura.
    • La variable DIMSCALE se establece en el factor de escala del dibujo (es decir, un dibujo que se trace con una escala de 1" = 10' tendrá un factor de escala de 120 y un dibujo con escala 1/4" = 1' tendrá un factor de escala de 48).

    Si carga y ejecuta la rutina de ejemplo de AutoLISP, AutoCAD insertará el símbolo con el tamaño y en la ubicación que haya especificado. Los símbolos se trazarán con el tamaño indicado (si el dibujo se traza a la escala especificada en DIMSCALE).

    A continuación se muestra una rutina de ejemplo de AutoLISP.

    (defun C:SYMIN ( )
      (setq sym
        (getstring
          "\nEnter symbol name: ")   ; Solicita un nombre de símbolo
      )
      (menucmd "s=symsize")          ; Cambia el menú de pantalla
                                     ;  al submenú symsize
      (setq
        siz (getreal
          "\nSelect symbol size: ")  ; Solicita el tamaño del símbolo
        p1 (getpoint
          "\nInsertion point: ")     ; Solicita el punto de inserción
      )
      (command "insert"              ; Ejecuta el comando INSERT
        sym                          ;  utilizando el punto de inserción
        p1 siz siz 0)                ;  y el tamaño del símbolo deseado
      (menucmd "s=")                 ; Cambia al menú
                                     ;  de pantalla anterior
      (princ)                        ; Sale de forma silenciosa
    )

    Nota Las rutinas de AutoLISP que se utilizan regularmente deben incluir comprobación de errores para verificar la validez de los datos introducidos por el usuario.

    Las expresiones DIESEL del siguiente archivo de menús multiplican el valor actual de DIMSCALE por el valor especificado y devuelven un factor de escala apropiado. Esto no se puede hacer con código similar de AutoLISP; un valor devuelto por una expresión de AutoLISP no se puede utilizar normalmente como respuesta a una llamada a la función getxxx (como, por ejemplo, la función getreal del ejemplo anterior).

    A continuación se muestra un fragmento de archivo de menús.

    **symsize 3
    [ SIZES ]

    [ 3/8" ]$M=$(*,$(getvar,dimscale),0.375)

    [ 1/2" ]$M=$(*,$(getvar,dimscale),0.5)

    [ 5/8" ]$M=$(*,$(getvar,dimscale),0.625)

Las expresiones DIESEL pueden también devolver valores de cadena para rótulos de elementos de menús desplegables, con lo que se puede hacer que los menús no estén disponibles o alterar la forma en que se muestran. Para utilizar una expresión DIESEL en un rótulo de menú desplegable, asegúrese de que el primer carácter es $.

    En el ejemplo siguiente, se define la capa actual como BASE y la siguiente expresión DIESEL se utiliza como la parte de rótulo de una sección ***POPn en un archivo de menús.

    [$(eval,"Current layer: " $(getvar,clayer))]

    El resultado es que el menú desplegable apropiado se visualiza y se actualiza siempre que se cambia la capa actual.

    Current layer:  BASE

    También puede utilizar este método para cambiar de forma interactiva el texto que se muestra en un menú desplegable. Para ello, debe usar una rutina de AutoLISP que establece las variables de sistema

USERS1-5 en el texto seleccionado, que puede recuperarse con una macro DIESEL en un rótulo de menú.

    Nota

La anchura de los menús desplegables y contextuales se define al cargar el archivo de menús. Los títulos de menús generados o cambiados con expresiones DIESEL después de cargar un menú se truncan para que quepan dentro de la anchura del menú existente.

Si se prevé que el rótulo del menú generado por DIESEL será demasiado ancho, se puede utilizar el ejemplo siguiente para garantizar que la anchura del menú se ajustará a los rótulos. Este ejemplo muestra los 10 primeros caracteres del valor actual de la variable de sistema USERS3 (

USERS1-5).

    [$ (eval,"Current value: " $(getvar,users3))+

     $(if, $(eq,$(getvar,users3),""), 10 espacios )]^C^Cusers3

    No se pueden usar espacios a la derecha en un rótulo de menú para incrementar la anchura del menú, porque los espacios a la derecha se ignoran mientras se carga el menú. Cualquier espacio que se utilice para aumentar la anchura de un rótulo de menú debe estar dentro de una expresión DIESEL.

En el siguiente ejemplo se utiliza la misma expresión DIESEL que en el rótulo y una parte del elemento de menú. Proporciona una forma práctica de escribir el día y la fecha actuales en un dibujo.

        [$(edtime,$(getvar,date),DDD", "D MON YYYY)]^C^Ctext +

    \\\ $M=$(edtime,$(getvar,date),DDD", "D MON YYYY);

    También se puede utilizar una macro de DIESEL para marcar los rótulos de menús desplegables o hacer que no estén disponibles. El siguiente rótulo de menú desplegable muestra

BORRAR como no disponible mientras un comando está activo. El texto aparece de forma normal cuando un comando no se encuentra activo.

    [ $(if,$(getvar,cmdactive),~)ERASE]erase

    Se puede utilizar un método similar para colocar una marca junto a un elemento del menú desplegable o para cambiar de forma interactiva el carácter utilizado en la marca.


Ficha Procedimientos: Expresiones DIESEL en macros de menú [Manual de personalización: ACG]

DIESEL
Expresiones DIESEL en macros de menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Expresiones DIESEL en macros de menú [Manual de personalización: ACG]

DIESEL
Expresiones DIESEL en macros de menú
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    MENUECHO

    Define la reproducción de menús en pantalla y los bits de control de solicitudes

    USERS1-5

    Se utilizan para almacenar y recuperar datos de cadenas de texto


Catálogo de funciones DIESEL [Manual de personalización: ACG]

DIESEL
Catálogo de funciones DIESEL
Conceptos
Procedimientos
Referencia

    • La recuperación, el cálculo y la visualización del estado se realizan por medio de funciones DIESEL. Todas las funciones tienen un límite de 10 parámetros, entre los que se incluye el nombre de la función. Si se sobrepasa el límite, aparece un mensaje de error de DIESEL.

    • + (suma)
    • – (resta)
    • * (multiplicación)
    • / (división)
    • = (igual que)
    • < (menor que)
    • > (mayor que)
    • != (distinto de)
    • <= (menor o igual que)
    • >= (mayor o igual que)
    • y
    • angtos
    • edtime
    • eq
    • eval
    • fix
    • getenv
    • getvar
    • if
    • index
    • nth
    • or
    • rtos
    • strlen
    • substr
    • upper
    • xor


Ficha Procedimientos: Catálogo de funciones DIESEL [Manual de personalización: ACG]

DIESEL
Catálogo de funciones DIESEL
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Catálogo de funciones DIESEL [Manual de personalización: ACG]

DIESEL
Catálogo de funciones DIESEL
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


+ (suma) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
+ (suma)
Conceptos
Procedimientos
Referencia

    • Devuelve la suma de los números val1, val2, ..., val9.

    $(+, val1 [, val2, ..., val9])

    Si la altura actual de objeto se ha definido como 5, la cadena siguiente en lenguaje DIESEL devolverá 15.

    $(+, $(getvar,thickness),10)


Ficha Procedimientos: + (suma) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
+ (suma)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: + (suma) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
+ (suma)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


– (resta) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
– (resta)
Conceptos
Procedimientos
Referencia

    • Devuelve el resultado de restar los números val2 a val9 de val1.

    $(–, val1 [, val2 , ..., val9])


Ficha Procedimientos: – (resta) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
– (resta)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: – (resta) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
– (resta)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


* (multiplicación) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
* (multiplicación)
Conceptos
Procedimientos
Referencia

    • Devuelve el resultado de multiplicar los números val1, val2, ..., val9.

    $(*, val1 [, val2, ..., val9])


Ficha Procedimientos: * (multiplicación) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
* (multiplicación)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: * (multiplicación) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
* (multiplicación)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


/ (división) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
/ (división)
Conceptos
Procedimientos
Referencia

    • Devuelve el resultado de dividir el número val1 entre val2, ..., val9.

    $(/, val1 [, val2, ..., val9])


Ficha Procedimientos: / (división) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
/ (división)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: / (división) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
/ (división)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


= (igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
= (igual que)
Conceptos
Procedimientos
Referencia

    • Si los números val1 y val2 son iguales, la cadena devuelve 1; de lo contrario, devuelve 0.

    $(=, val1, val2)


Ficha Procedimientos: = (igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
= (igual que)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: = (igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
= (igual que)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


< (menor que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
< (menor que)
Conceptos
Procedimientos
Referencia

    • Si el número val1 es menor que val2, la cadena devuelve 1; de lo contrario, devuelve 0.

    $(< , val1, val2)

    La siguiente expresión obtiene el valor actual de la variable de sistema HPANG; si el valor es menor que el almacenado en la variable de sistema USERR1, devuelve 1. Si el valor almacenado en USERR1 es 10.0 y el valor actual de HPANG es 15.5, la siguiente cadena devuelve 0.

    $(<, $(getvar,hpang),$(getvar,userr1))


Ficha Procedimientos: < (menor que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
< (menor que)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: < (menor que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
< (menor que)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


> (mayor que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
> (mayor que)
Conceptos
Procedimientos
Referencia

    • Si el número val1 es mayor que val2, la cadena devuelve 1; de lo contrario, devuelve 0.

    $(>, val1, val2)


Ficha Procedimientos: > (mayor que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
> (mayor que)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: > (mayor que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
> (mayor que)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


!= (distinto de) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
!= (distinto de)
Conceptos
Procedimientos
Referencia

    • Si los números val1 y val2 no son iguales, la cadena devuelve 1; de lo contrario, devuelve 0.

    $(!=, val1, val2)


Ficha Procedimientos: != (distinto de) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
!= (distinto de)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: != (distinto de) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
!= (distinto de)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


<= (menor o igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
<= (menor o igual que)
Conceptos
Procedimientos
Referencia

    • Si el número val1 es menor o igual que val2, la cadena devuelve 1; de lo contrario, devuelve 0.

    $(<=, val1, val2)


Ficha Procedimientos: <= (menor o igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
<= (menor o igual que)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: <= (menor o igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
<= (menor o igual que)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


>= (mayor o igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
>= (mayor o igual que)
Conceptos
Procedimientos
Referencia

    • Si el número val1 es mayor o igual que val2, la cadena devuelve 1; de lo contrario, devuelve 0.

    $(>=, val1, val2)


Ficha Procedimientos: >= (mayor o igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
>= (mayor o igual que)
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: >= (mayor o igual que) [Manual de personalización: ACG]

Catálogo de funciones DIESEL
>= (mayor o igual que)
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


y [Manual de personalización: ACG]

Catálogo de funciones DIESEL
y
Conceptos
Procedimientos
Referencia

    • Devuelve el valor de la función lógica de tipo binario AND de los números enteros de val1 a val9.

    $(and, val1 [, val2,..., val9])


Ficha Procedimientos: y [Manual de personalización: ACG]

Catálogo de funciones DIESEL
y
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: y [Manual de personalización: ACG]

Catálogo de funciones DIESEL
y
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


angtos [Manual de personalización: ACG]

Catálogo de funciones DIESEL
angtos
Conceptos
Procedimientos
Referencia

    • Devuelve el valor angular con el formato y la precisión especificados.

    $(angtos, value [, mode, precision])

    Edita el valor value dado como ángulo con el formato especificado por mode y precision, tal y como se definen para la función análoga de AutoLISP. (Los valores de mode se incluyen en la tabla siguiente). Si se omiten mode y precision, se utilizan los valores actuales seleccionados con el comando UNIDADES.
    Valor de modo | Formato de cadena
0 | Grados
1 | Grados/minutos/segundos
2 | Grados centesimales
3 | Radianes
4 | Unidades geodésicas


Ficha Procedimientos: angtos [Manual de personalización: ACG]

Catálogo de funciones DIESEL
angtos
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: angtos [Manual de personalización: ACG]

Catálogo de funciones DIESEL
angtos
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


edtime [Manual de personalización: ACG]

Catálogo de funciones DIESEL
edtime
Conceptos
Procedimientos
Referencia

    • Devuelve una fecha y una hora con formato basadas en una imagen dada.

    $(edtime, time, picture)

    Edita la fecha juliana de AutoCAD dada por time (obtenida, por ejemplo, de $(getvar,date) de acuerdo con la imagen picture dada). La imagen picture consta de frases de formato sustituidas por representaciones específicas de la fecha y hora. Los caracteres no interpretables como frases de formato se copian literalmente en el resultado de $(edtime). Las frases de formato se definen como se muestra en la siguiente tabla. Se asume que la fecha y hora es sábado, 5 de septiembre de 1998, 4:53:17.506.
    Formato | Resultado | Formato | Resultado
D | 5 | H | 4
DD | 05 | HH | 04
DDD | Sáb | MM | 53
DDDD | Sábado | SS | 17
M | 9 | MSEC | 506
MO | 09 | AM/PM | AM
MON | Sep | am/pm | am
MONTH | Septiembre | A/P | A
YY | 98 | a/p | a
YYYY | 1998 |  |

    Escriba la expresión AM/PM completa igual que en la tabla anterior; si se utiliza sólo AM, la A se leerá literalmente y la M devolverá el mes actual.

    Si aparece cualquier expresión AM/PM en la imagen, H y HH editarán la hora de acuerdo con el reloj de 12 horas (12:00–12:59 1:00–11:59), en lugar de hacerlo con el reloj de 24 horas (00:00–23:59).

    En el ejemplo siguiente se utilizan la fecha y la hora de la tabla anterior. Nótese que la coma debe aparecer entre comillas, ya que se lee como separador de argumentos.

    $(edtime, $(getvar,date),DDD"," DD MES AAAA - H:MMam/pm)

    devuelve lo siguiente:

    Sáb, 5 Sep 1998 - 4:53am

    Si time es 0, se utilizan la fecha y hora correspondientes al momento en que se ejecutó la macro más externa. Esto evita las múltiples y largas llamadas a $(getvar,date) y garantiza que todas las cadenas compuestas de múltiples macros $(edtime) usan la misma hora.


Ficha Procedimientos: edtime [Manual de personalización: ACG]

Catálogo de funciones DIESEL
edtime
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: edtime [Manual de personalización: ACG]

Catálogo de funciones DIESEL
edtime
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


eq [Manual de personalización: ACG]

Catálogo de funciones DIESEL
eq
Conceptos
Procedimientos
Referencia

    • Si las cadenas val1 y val2 son idénticas, la cadena devuelve 1; de lo contrario, devuelve 0.

    $(eq, val1, val2)

    La siguiente expresión obtiene el nombre de la capa actual; si el nombre coincide con el valor de cadena almacenado en la variable de sistema USERS1 ( USERS1-5), devuelve 1. Se asume que la cadena "PARTE12" se almacena en USERS1 y que la capa actual es la misma.

    $(eq, $(getvar,users1),$(getvar,clayer))    Devuelve 1


Ficha Procedimientos: eq [Manual de personalización: ACG]

Catálogo de funciones DIESEL
eq
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: eq [Manual de personalización: ACG]

Catálogo de funciones DIESEL
eq
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


eval [Manual de personalización: ACG]

Catálogo de funciones DIESEL
eval
Conceptos
Procedimientos
Referencia

    • Pasa la cadena str al evaluador de DIESEL y devuelve el resultado de la evaluación.

    $(eval, str)


Ficha Procedimientos: eval [Manual de personalización: ACG]

Catálogo de funciones DIESEL
eval
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: eval [Manual de personalización: ACG]

Catálogo de funciones DIESEL
eval
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


fix [Manual de personalización: ACG]

Catálogo de funciones DIESEL
fix
Conceptos
Procedimientos
Referencia

    • Trunca el número real value a un entero descartando la parte fraccionaria.

    $(fix, value)


Ficha Procedimientos: fix [Manual de personalización: ACG]

Catálogo de funciones DIESEL
fix
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: fix [Manual de personalización: ACG]

Catálogo de funciones DIESEL
fix
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


getenv [Manual de personalización: ACG]

Catálogo de funciones DIESEL
getenv
Conceptos
Procedimientos
Referencia

    • Devuelve el valor de la variable de entorno varname.

    $(getenv, varname)

    Si no se define ninguna variable con ese nombre, devuelve una cadena vacía.


Ficha Procedimientos: getenv [Manual de personalización: ACG]

Catálogo de funciones DIESEL
getenv
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: getenv [Manual de personalización: ACG]

Catálogo de funciones DIESEL
getenv
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


getvar [Manual de personalización: ACG]

Catálogo de funciones DIESEL
getvar
Conceptos
Procedimientos
Referencia

    • Devuelve el valor de la variable de sistema con el nombre varname dado.

    $(getvar, varname)


Ficha Procedimientos: getvar [Manual de personalización: ACG]

Catálogo de funciones DIESEL
getvar
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: getvar [Manual de personalización: ACG]

Catálogo de funciones DIESEL
getvar
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


if [Manual de personalización: ACG]

Catálogo de funciones DIESEL
if
Conceptos
Procedimientos
Referencia

    • Evalúa expresiones condicionalmente.

    $(if, expr, dotrue [, dofalse])

    Si expr no es cero, se evalúa y devuelve verdad. De lo contrario, se evalúa y devuelve falso. Observe que la rama que no se elige con expr no se evalúa.


Ficha Procedimientos: if [Manual de personalización: ACG]

Catálogo de funciones DIESEL
if
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: if [Manual de personalización: ACG]

Catálogo de funciones DIESEL
if
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


index [Manual de personalización: ACG]

Catálogo de funciones DIESEL
index
Conceptos
Procedimientos
Referencia

    • Devuelve el miembro especificado de una cadena delimitada por comas.

    $(index, which, string)

    Asume que el argumento string contiene uno o varios valores delimitados por el carácter separador de argumentos de la macro, la coma. El argumento which selecciona uno de estos valores para su extracción, con el primer elemento numerado como 0. Esta función se utiliza frecuentemente para extraer los valores de las coordenadas X, Y o Z a partir de las coordenadas de puntos devueltas por $(getvar).

    Las aplicaciones pueden utilizar esta función para recuperar valores almacenados como cadenas delimitadas por comas a partir de las variables de sistema USERS1-5.


Ficha Procedimientos: index [Manual de personalización: ACG]

Catálogo de funciones DIESEL
index
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: index [Manual de personalización: ACG]

Catálogo de funciones DIESEL
index
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


nth [Manual de personalización: ACG]

Catálogo de funciones DIESEL
nth
Conceptos
Procedimientos
Referencia

    • Evalúa y devuelve el argumento seleccionado con which.

    $(nth, which, arg0 [, arg1,..., arg7])

    Si which es 0, nth devuelve arg0 y lo mismo sucede para los demás valores. Obsérvese la diferencia entre $(nth) y $(index); $(nth) devuelve a la función un solo valor de una serie de argumentos, mientras que $(index) extrae un valor de la cadena delimitada por comas pasada como un único argumento. Los argumentos no seleccionados por which no se evalúan.


Ficha Procedimientos: nth [Manual de personalización: ACG]

Catálogo de funciones DIESEL
nth
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: nth [Manual de personalización: ACG]

Catálogo de funciones DIESEL
nth
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


or [Manual de personalización: ACG]

Catálogo de funciones DIESEL
or
Conceptos
Procedimientos
Referencia

    • Devuelve el valor de la función lógica de tipo binario OR de los números enteros de val1 a val9.

    $(or, val1 [, val2,..., val9])


Ficha Procedimientos: or [Manual de personalización: ACG]

Catálogo de funciones DIESEL
or
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: or [Manual de personalización: ACG]

Catálogo de funciones DIESEL
or
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


rtos [Manual de personalización: ACG]

Catálogo de funciones DIESEL
rtos
Conceptos
Procedimientos
Referencia

    • Devuelve el valor real con el formato y la precisión especificados.

    $(rtos, value [, mode, precision])

    Edita el valor value dado como número real con el formato especificado por mode y precision, tal y como se definen para la función análoga de AutoLISP. Si se omiten mode y precision, se utilizan los valores actuales seleccionados con el comando UNIDADES.


Ficha Procedimientos: rtos [Manual de personalización: ACG]

Catálogo de funciones DIESEL
rtos
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: rtos [Manual de personalización: ACG]

Catálogo de funciones DIESEL
rtos
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


strlen [Manual de personalización: ACG]

Catálogo de funciones DIESEL
strlen
Conceptos
Procedimientos
Referencia

    • Devuelve la longitud de la cadena string en caracteres.

    $(strlen, string)


Ficha Procedimientos: strlen [Manual de personalización: ACG]

Catálogo de funciones DIESEL
strlen
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: strlen [Manual de personalización: ACG]

Catálogo de funciones DIESEL
strlen
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


substr [Manual de personalización: ACG]

Catálogo de funciones DIESEL
substr
Conceptos
Procedimientos
Referencia

    • Devuelve la subcadena de la cadena string, empezando en el carácter start y extendiéndose a los caracteres length.

    $(substr, string, start [, length])

    Los caracteres de la cadena se numeran a partir de 1. Si se omite length, devuelve toda la longitud restante de la cadena.


Ficha Procedimientos: substr [Manual de personalización: ACG]

Catálogo de funciones DIESEL
substr
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: substr [Manual de personalización: ACG]

Catálogo de funciones DIESEL
substr
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


upper [Manual de personalización: ACG]

Catálogo de funciones DIESEL
upper
Conceptos
Procedimientos
Referencia

    • Devuelve la cadena string convertida a mayúsculas según las reglas de los valores locales actuales.

    $(upper, string)


Ficha Procedimientos: upper [Manual de personalización: ACG]

Catálogo de funciones DIESEL
upper
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: upper [Manual de personalización: ACG]

Catálogo de funciones DIESEL
upper
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


xor [Manual de personalización: ACG]

Catálogo de funciones DIESEL
xor
Conceptos
Procedimientos
Referencia

    • Devuelve el valor de la función lógica de tipo binario XOR de los números enteros de val1 a val9.

    $(xor, val1 [, val2,..., val9])


Ficha Procedimientos: xor [Manual de personalización: ACG]

Catálogo de funciones DIESEL
xor
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: xor [Manual de personalización: ACG]

Catálogo de funciones DIESEL
xor
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Mensajes de error en DIESEL [Manual de personalización: ACG]

DIESEL
Mensajes de error en DIESEL
Conceptos
Procedimientos
Referencia

    • Generalmente, si se comete un error en una expresión en lenguaje DIESEL, la causa del fallo resultará obvia. Según la naturaleza del error, DIESEL incluye una indicación de error en la secuencia de salida.
    Mensaje de error | Descripción
$? | Error de sintaxis (normalmente falta un paréntesis de cierre o hay una cadena expandida)
$(func,??) | Argumentos incorrectos para func
$(func)?? | Función func desconocida
$(++) | Cadena de salida demasiado larga: evaluación truncada


Ficha Procedimientos: Mensajes de error en DIESEL [Manual de personalización: ACG]

DIESEL
Mensajes de error en DIESEL
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Mensajes de error en DIESEL [Manual de personalización: ACG]

DIESEL
Mensajes de error en DIESEL
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Fotos y archivos de comandos [Manual de personalización: ACG]

Fotos y archivos de comandos
Conceptos
Procedimientos
Referencia

    • Las fotos son instantáneas de archivos de dibujo que se pueden utilizar de muchas maneras. Un archivo de comandos lee y ejecuta comandos desde un archivo de texto. Una forma de utilizar un archivo de comandos es crear una presentación de fotos.

    • Creación de fotos
      Las fotos son instantáneas de archivos de dibujo. Puede utilizar las fotos para realizar presentaciones, crear menús de mosaico de imágenes personalizados y visualizar una imagen de otro dibujo mientras trabaja.
    • Creación de archivos de comandos
      Un archivo de comandos es un archivo de texto que contiene una serie de comandos. Los archivos de comandos se suelen emplear para personalizar el inicio y ejecutar presentaciones de fotos.


Creación de fotos [Manual de personalización: ACG]

Fotos y archivos de comandos
Creación de fotos
Conceptos
Procedimientos
Referencia

    • Las fotos son instantáneas de archivos de dibujo. Puede utilizar las fotos para realizar presentaciones, crear menús de mosaico de imágenes personalizados y visualizar una imagen de otro dibujo mientras trabaja.

    • Presentación general de las fotos
      Una foto es una instantánea de un dibujo. Aunque contiene una imagen del dibujo en un instante determinado, no se considera un archivo de dibujo.
    • Visualización de fotos
      El comando MIRAFOTO permite visualizar las fotos de una en una. Si desea visualizar un conjunto de fotos en una presentación, emplee un archivo de comandos.
    • Creación y visualización de fototecas
      Una fototeca es un archivo que contiene una o varias fotos. Los archivos de fototeca se utilizan para crear menús de mosaico de imágenes personalizados y para combinar varios archivos de fotos con el fin de administrarlos cómodamente.


Ficha Procedimientos: Creación de fotos [Manual de personalización: ACG]

Fotos y archivos de comandos
Creación de fotos
Conceptos
Procedimientos
Referencia

    • Para hacer una foto

    Para ver una foto:

    Para crear una fototeca

    Para ver una foto de una fototeca

    No existen para este tema.


Ficha Referencia: Creación de fotos [Manual de personalización: ACG]

Fotos y archivos de comandos
Creación de fotos
Conceptos
Procedimientos
Referencia

    • Comandos

    SACAFOTO

    Crea un archivo de foto de la ventana gráfica actual de modelo o de la presentación actual

    REDIBUJA

    Renueva la visualización en la ventana gráfica activa

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Utilidades

    SLIDELIB

    Recopila los archivos de fotos que se muestran en un archivo en formato ASCII y los inserta en un archivo de fototeca

    Variables de sistema

    FILEDIA

    Suprime la visualización de los cuadros de diálogo de archivo


Presentación general de las fotos [Manual de personalización: ACG]

Creación de fotos
Presentación general de las fotos
Conceptos
Procedimientos
Referencia

    • Una foto es una instantánea de un dibujo. Aunque contiene una imagen del dibujo en un instante determinado, no se considera un archivo de dibujo. AutoCAD no permite la importación de archivos de fotos en el dibujo actual ni la edición o impresión de fotos. Sólo permite su visualización.

    El empleo de los archivos de foto está especialmente indicado para:

    • Realizar presentaciones con AutoCAD
    • Visualizar una instantánea de un dibujo mientras se trabaja en otro
    • Crear menús de mosaicos de imágenes dentro de un cuadro de diálogo

    Una foto se crea guardando la vista actual en formato de foto. Una foto creada en el espacio modelo sólo muestra la ventana gráfica actual, mientras que una foto creada en el espacio papel muestra todas las ventanas gráficas visibles y su contenido. Las fotos muestran sólo aquellas partes que son visibles, no muestran objetos de capas desactivadas o inutilizadas, ni objetos de ventanas gráficas desactivadas.

    Al mostrar en pantalla un archivo de foto, éste sustituye de forma temporal a los objetos que figuran en la pantalla. Puede dibujar encima de él, pero, al modificar la vista (ya sea al redibujarla, encuadrarla, ampliarla o reducirla), el archivo de foto desaparece y AutoCAD vuelve a mostrar solamente lo que se ha dibujado y los objetos que ya existían.

    Puede visualizar las fotos de una en una o utilizar un archivo de comandos para visualizar las fotos de forma secuencial. Las fotos también se pueden utilizar en menús personalizados: por ejemplo, si crea archivos de comandos que insertan bloques que contienen piezas mecánicas utilizadas frecuentemente, puede diseñar un menú de mosaico de imágenes personalizado que muestre una foto de cada pieza para que así, cuando haga clic en la imagen de la foto del menú, AutoCAD inserte el bloque en el dibujo.

    Una fototeca es un archivo que contiene una o varias fotos. Los archivos de fototeca se utilizan para crear menús de mosaico de imágenes personalizados y para combinar varios archivos de fotos con el fin de administrarlos cómodamente.

    No se puede editar una foto. Para modificarla, tiene que editar el dibujo original y volver a hacerla. Si utiliza un monitor gráfico de baja resolución al crear un archivo de foto y, más tarde, decide emplear un monitor con una resolución más alta, podrá seguir mostrando la foto en pantalla ya que AutoCAD ajusta la imagen en función de la resolución; sin embargo, la foto no aprovecha las características del nuevo monitor hasta que el usuario regenera el archivo de foto partiendo del dibujo original.


Para hacer una foto [Manual de personalización: ACG]

Creación de fotos
Presentación general de las fotos
Conceptos
Procedimientos
Referencia

    • Para hacer una foto

    1. Muestre la vista que desea utilizar para la foto.
    2. En la solicitud de comando, escriba sacafoto.
    3. Especifique un nombre y una ubicación para la foto en el cuadro de diálogo Crear archivo de foto.

    AutoCAD propone el nombre actual del dibujo como nombre por defecto para la foto y le añade automáticamente la extensión de archivo .sld.

    4. Pulse Guardar.

    El dibujo actual permanece en la pantalla, mientras que el archivo de foto se guarda en la carpeta especificada.


Ficha Referencia: Presentación general de las fotos [Manual de personalización: ACG]

Creación de fotos
Presentación general de las fotos
Conceptos
Procedimientos
Referencia

    • Comandos

    SACAFOTO

    Crea un archivo de foto de la ventana gráfica actual de modelo o de la presentación actual

    REDIBUJA

    Renueva la visualización en la ventana gráfica activa

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Utilidades

    SLIDELIB

    Recopila los archivos de fotos que se muestran en un archivo en formato ASCII y los inserta en un archivo de fototeca

    Variables de sistema

    FILEDIA

    Suprime la visualización de los cuadros de diálogo de archivo


Visualización de fotos [Manual de personalización: ACG]

Creación de fotos
Visualización de fotos
Conceptos
Procedimientos
Referencia

    • El comando MIRAFOTO permite visualizar las fotos de una en una. Si desea visualizar un conjunto de fotos en una presentación, emplee un archivo de comandos.

    Tenga cuidado al utilizar los comandos de edición mientras se muestra una foto, que tiene un aspecto similar a un dibujo normal. Los comandos de edición afectan al dibujo actual situado debajo de la foto y no a la foto.

    Algunos comandos pueden provocar el redibujado, lo que hace que la foto desaparezca de la pantalla.


Para ver una foto: [Manual de personalización: ACG]

Creación de fotos
Visualización de fotos
Conceptos
Procedimientos
Referencia

    • Para ver una foto:

    1. En la solicitud de comando, escriba mirafoto.
    2. Designe la foto que desea visualizar en el cuadro de diálogo Seleccionar archivo de foto y haga clic en Aceptar.

    La imagen de la foto aparecerá en el área de dibujo.

    3. En el menú Ver, haga clic en Redibujar vista.

    Desaparecerá así la imagen de la foto.


Ficha Referencia: Visualización de fotos [Manual de personalización: ACG]

Creación de fotos
Visualización de fotos
Conceptos
Procedimientos
Referencia

    • Comandos

    REDIBUJA

    Renueva la visualización en la ventana gráfica activa

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Variables de sistema

    No hay entradas.


Creación y visualización de fototecas [Manual de personalización: ACG]

Creación de fotos
Creación y visualización de fototecas
Conceptos
Procedimientos
Referencia

    • Una fototeca es un archivo que contiene una o varias fotos. Los archivos de fototeca se utilizan para crear menús de mosaico de imágenes personalizados y para combinar varios archivos de fotos con el fin de administrarlos cómodamente.

    Puede crear fototecas a partir de los archivos de fotos con la utilidad SLIDELIB. Una vez que haya definido una fototeca, podrá visualizar las fotos especificando el nombre de la fototeca y el de la foto.

    No suprima las fotos originales una vez creada la fototeca. La utilidad SLIDELIB no puede actualizar una fototeca después de haberla creado. Si desea añadir o suprimir una foto, actualice el archivo de lista de fotos y vuelva a crear la fototeca con SLIDELIB. Cuando rehaga la fototeca, deberán estar disponibles todos los archivos de fotos que desee incluir.


Ficha Procedimientos: Creación y visualización de fototecas [Manual de personalización: ACG]

Creación de fotos
Creación y visualización de fototecas
Conceptos
Procedimientos
Referencia

    • Para crear una fototeca

    Para ver una foto de una fototeca


Ficha Referencia: Creación y visualización de fototecas [Manual de personalización: ACG]

Creación de fotos
Creación y visualización de fototecas
Conceptos
Procedimientos
Referencia

    • Comandos

    SACAFOTO

    Crea un archivo de foto de la ventana gráfica actual de modelo o de la presentación actual

    REDIBUJA

    Renueva la visualización en la ventana gráfica activa

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Utilidades

    SLIDELIB

    Recopila los archivos de fotos que se muestran en un archivo en formato ASCII y los inserta en un archivo de fototeca

    Variables de sistema

    No hay entradas.


Para crear una fototeca [Manual de personalización: ACG]

Creación de fotos
Creación y visualización de fototecas
Conceptos
Procedimientos
Referencia

    • Para crear una fototeca

    1. Use un editor de texto ASCII de Windows para crear una lista de los archivos de fotos que desea incluir en la fototeca. Los siguientes ejemplos muestran posibles archivos de fotos:

    entrada.sld

    vestibulo.sld

    escaleras.sld

    estudio.sld

    balcon.sld

    2. Asigne un nombre al archivo y guárdelo como archivo de texto con la extensión .txt.
    3. En el menú Inicio de Windows, haga clic en Programas. A continuación, elija MS-DOS.
    4. Cambie al directorio de AutoCAD.
    5. En la ventana de MS-DOS, use la siguiente sintaxis para crear la fototeca:

    slidelib nombre fototeca<lista.txt

    Por ejemplo, si ha guardado un archivo de texto con el nombre zonas.txt, puede crear una fototeca denominada casa.slb escribiendo slidelib casa<zonas.txt. La utilidad SLIDELIB añade automáticamente la extensión .slb al nombre de archivo de la fototeca.


Para ver una foto de una fototeca [Manual de personalización: ACG]

Creación de fotos
Creación y visualización de fototecas
Conceptos
Procedimientos
Referencia

    • Para ver una foto de una fototeca

    1. En la solicitud de comando, establezca el valor 0 para la variable de sistema FILEDIA.
    2. En la solicitud de comando, escriba mirafoto.
    3. Escriba fototeca (nombre de foto) para especificar la foto que desea visualizar.

    Por ejemplo, escriba casa (balcon) para abrir la foto balcon que se almacena en el archivo de fototeca casa.

    4. En el menú Ver, haga clic en Redibujar vista para eliminar la foto de la pantalla.


Creación de archivos de comandos [Manual de personalización: ACG]

Fotos y archivos de comandos
Creación de archivos de comandos
Conceptos
Procedimientos
Referencia

    • Un archivo de comandos es un archivo de texto que contiene una serie de comandos. Los archivos de comandos se suelen emplear para personalizar el inicio y ejecutar presentaciones de fotos.

    • Presentación general de los archivos de comandos
      Un archivo de comandos es un archivo de texto con un comando en cada línea.
    • Ejecución de archivos de comandos en el inicio
      Un archivo de comandos que se ejecuta al iniciar la aplicación puede abrir un dibujo y modificar sus valores.
    • Ejecución de presentaciones de fotos desde archivos de comandos
      Los archivos de comandos son de gran utilidad para crear presentaciones de fotos.


Ficha Procedimientos: Creación de archivos de comandos [Manual de personalización: ACG]

Fotos y archivos de comandos
Creación de archivos de comandos
Conceptos
Procedimientos
Referencia

    • Para crear un archivo de comandos que modifique los valores de un dibujo

    Para ejecutar un archivo de comandos en el inicio

    Para ejecutar presentaciones de fotos desde archivos de comandos

    Para crear un archivo de comandos que precargue fotos


Ficha Referencia: Creación de archivos de comandos [Manual de personalización: ACG]

Fotos y archivos de comandos
Creación de archivos de comandos
Conceptos
Procedimientos
Referencia

    • Comandos

    RETARDA

    Proporciona una pausa de duración establecida dentro de un archivo de comandos

    PANTGRAF

    Permite cambiar de la ventana de texto al área de dibujo

    REANUDA

    Reanuda un archivo de comandos interrumpido

    RSCRIPT

    Repite el archivo de comandos

    SCRIPT

    SCRIPT ejecuta una secuencia de comandos desde un archivo de comandos

    PANTTEXT

    Abre la ventana de texto

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Variables de sistema

    No hay entradas.


Presentación general de los archivos de comandos [Manual de personalización: ACG]

Creación de archivos de comandos
Presentación general de los archivos de comandos
Conceptos
Procedimientos
Referencia

    • Un archivo de comandos es un archivo de texto con un comando en cada línea.

    Puede invocar un archivo de comandos en el inicio o puede hacerlo desde AutoCAD mediante el comando SCRIPT. Un archivo de comandos proporciona una forma sencilla de crear pantallas de ejecución continua para demostraciones de productos y ferias de muestras.

    Fuera de AutoCAD, puede crear archivos de comandos utilizando un editor de texto (como el Bloc de notas de Microsoft® Windows) o un procesador de texto (como Microsoft® Word) que permitan guardar el archivo en formato ASCII. La extensión del archivo debe ser scr.

    Cada línea del archivo de comandos contiene un comando. Cada espacio en blanco de un archivo de comandos es significativo: AutoCAD acepta un espacio o INTRO como comando o como terminador de campo de datos. Es necesario estar familiarizado con la secuencia de solicitudes de AutoCAD para facilitar la secuencia adecuada de respuestas en el archivo de comandos.

    Nota Recuerde que las solicitudes y los nombres de comandos de AutoCAD pueden cambiar en futuras versiones, por lo que es posible que deba revisar sus archivos de comandos al actualizar a una versión posterior de AutoCAD. Por motivos similares, recomendamos no utilizar abreviaturas: los comandos que se añadan en el futuro podrían crear ambigüedades.

    Un archivo de comandos puede ejecutar cualquier comando en la solicitud de comandos a excepción de aquéllos que abren un cuadro de diálogo. AutoCAD proporciona versiones de línea de comandos de los comandos de los cuadros de diálogo.

    Los archivos de comandos pueden incluir comentarios. Cualquier línea que comience por un punto y coma (;) se considera un comentario, y AutoCAD lo pasa por alto cuando procesa el archivo. La última línea del archivo debe estar en blanco.

    Todas las referencias a los nombres largos de archivos que contengan espacios incrustados deben estar entre comillas dobles. Por ejemplo, para abrir el dibujo mi casa.dwg desde un archivo de comandos, es necesario utilizar la siguiente sintaxis:

    open "mi casa"

    Los siguientes comandos son útiles en archivos de comandos:

    ' RETARDA

    Proporciona una pausa de duración establecida dentro de un archivo de comandos (en milisegundos)

    ' PANTGRAF

    Permite cambiar de la ventana de texto al área de dibujo

    REANUDA

    Reanuda un archivo de comandos interrumpido

    RSCRIPT

    Repite el archivo de comandos

    ' PANTTEXT

    Cambia a la ventana de texto

    Cuando una entrada de comando procede de un archivo de comandos, AutoCAD considera que los valores de las variables de sistema PICKADD y PICKAUTO son 1 y 0, respectivamente; por tanto, no tendrá que comprobar estos valores.

    AutoCAD considera que un archivo de comandos es un grupo, una unidad de comandos, reversible mediante un solo comando H. No obstante, cada comando del archivo produce una entrada en el registro de la función deshacer, lo que puede ralentizar el procesado del archivo de comandos. Si lo desea, puede utilizar Control DESHACER Ninguna para desactivar la función Deshacer antes de ejecutar el archivo de comandos o puede escribirlo al principio del propio archivo de comandos. Es necesario activarlo de nuevo (Control DESHACER Todas) una vez finalizado el archivo de comandos.

    El archivo de comandos que se esté ejecutando se detendrá cuando se ejecute otro comando del archivo de comandos.


Para crear un archivo de comandos que modifique los valores de un dibujo [Manual de personalización: ACG]

Creación de archivos de comandos
Presentación general de los archivos de comandos
Conceptos
Procedimientos
Referencia

    • Para crear un archivo de comandos que modifique los valores de un dibujo

    Este archivo de comandos activa la rejilla, establece la escala global del tipo de línea en 3.0 y define la capa 0 como la capa actual, con el color rojo.

    1. En un editor de texto, escriba grid on.
    2. En la siguiente línea, escriba escalalt 3.0.
    3. En la siguiente línea, escriba capa set 0 color red.
    4. Añada una línea en blanco.
    5. Guarde el archivo como texto ASCII (archivo TXT), con la extensión de archivo .scr.

    El archivo de comandos puede contener comentarios como los siguientes:

    ; Activa la rejilla
    grid on
    ; Establece la escala de los tipos de línea
    escalalt 3.0
    ; Define la capa actual y su color
    capa set 0 color red

    ; Línea anterior en blanco para finalizar el comando CAPA


Ficha Referencia: Presentación general de los archivos de comandos [Manual de personalización: ACG]

Creación de archivos de comandos
Presentación general de los archivos de comandos
Conceptos
Procedimientos
Referencia

    • Comandos

    RETARDA

    Proporciona una pausa de duración establecida dentro de un archivo de comandos

    PANTGRAF

    Permite cambiar de la ventana de texto al área de dibujo

    REANUDA

    Reanuda un archivo de comandos interrumpido

    RSCRIPT

    Repite el archivo de comandos

    SCRIPT

    SCRIPT ejecuta una secuencia de comandos desde un archivo de comandos

    PANTTEXT

    Abre la ventana de texto

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Variables de sistema

    No hay entradas.


Ejecución de archivos de comandos en el inicio [Manual de personalización: ACG]

Creación de archivos de comandos
Ejecución de archivos de comandos en el inicio
Conceptos
Procedimientos
Referencia

    • Un archivo de comandos que se ejecuta al iniciar la aplicación puede abrir un dibujo y modificar sus valores.

    Supongamos que cada vez que se empieza un dibujo nuevo se activa la rejilla, se establece la escala global de tipo de línea en 3.0 y se define la capa 0 como la capa actual, con el color rojo. Puede llevar a cabo estas acciones utilizando un dibujo de plantilla, o bien, como alternativa, crear el siguiente archivo de comandos y guardarlo en un archivo llamado setup.scr.

    grid on
    escalalt 3.0
    layer set 0 color red 0

    La primera línea activa la rejilla. La segunda línea establece la escala global para los tipos de línea. La tercera línea establece como capa actual la capa 0 y define su color por defecto en rojo. AutoCAD supone que en un archivo de comandos se utilizará la versión de línea de comando de CAPA en lugar de la versión del cuadro de diálogo. El resultado es equivalente a escribir -capa en la línea de comando. La cuarta línea está en blanco, para finalizar el comando CAPA.

    Puede ejecutar este archivo de comandos en el inicio para abrir un dibujo utilizando la siguiente sintaxis en el cuadro de diálogo Ejecutar:

    acad nombre_dibujo /b setup

    Todos los nombres de archivos que contienen espacios incrustados deben estar entre comillas dobles, por ejemplo, "albergue juvenil". También puede especificar la vista que se mostrará cuando se abra el dibujo utilizando el conmutador /v y el nombre de la vista. El conmutador /b y el archivo de comandos deben ser los últimos parámetros de la lista.

    Puede incluir, si lo desea, las extensiones de archivo .exe, .dwg, .dwt y .scr. Si AutoCAD no encuentra el archivo de AutoCADcomandos, informará de que no puede abrir el archivo.

    Para ejecutar el mismo archivo de comandos en el inicio y crear un nuevo dibujo utilizando el archivo MiPlantilla.dwt como plantilla, escriba lo siguiente en el cuadro de diálogo Ejecutar:

    acad /t MiPlantilla /b setup

    Este comando crea un nuevo dibujo y ejecuta una secuencia de comandos de inicio desde el archivo setup.scr. Cuando termine de ejecutarse el archivo de comandos, aparecerá la solicitud de comando. Si quiere utilizar la plantilla por defecto para el nuevo dibujo, puede omitir el conmutador /t y el nombre del archivo de plantilla.

    Nota No puede utilizar este método para iniciar un nuevo dibujo y asignarle un nombre. Asigne un nombre al dibujo cuando lo guarde.


Para ejecutar un archivo de comandos en el inicio [Manual de personalización: ACG]

Creación de archivos de comandos
Ejecución de archivos de comandos en el inicio
Conceptos
Procedimientos
Referencia

    • Para ejecutar un archivo de comandos en el inicio

    1. En el menú Inicio de Windows, haga clic en Ejecutar.
    2. En el cuadro de diálogo Ejecutar, escriba acad nombre_dibujo /b nombre_archivo_comandos.

    Para ejecutar un nuevo archivo, en lugar de escribir el nombre de un archivo de dibujo, escriba el conmutador /t y el nombre de un archivo de plantilla: /t dibujo_plantilla.

    Para abrir un dibujo en una vista concreta, escriba el conmutador /v y el nombre de la vista después del nombre del dibujo: /v nombre_vista.

    El nombre del archivo de comandos debe ser el último parámetro de la lista. Las extensiones de archivo son opcionales.

    3. Pulse Aceptar.

    AutoCAD abre el dibujo y ejecuta los comandos del archivo de comandos. Cuando termine de ejecutarse el archivo de comandos, aparecerá la solicitud de comando.


Ficha Referencia: Ejecución de archivos de comandos en el inicio [Manual de personalización: ACG]

Creación de archivos de comandos
Ejecución de archivos de comandos en el inicio
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Ejecución de presentaciones de fotos desde archivos de comandos [Manual de personalización: ACG]

Creación de archivos de comandos
Ejecución de presentaciones de fotos desde archivos de comandos
Conceptos
Procedimientos
Referencia

    • Los archivos de comandos son de gran utilidad para crear presentaciones de fotos. Normalmente, la velocidad de visualización de las fotos está limitada por el número de veces que AutoCAD debe acceder al disco para leer el archivo de fotos. Es posible, sin embargo, cargar previamente la siguiente foto del disco en la memoria mientras el público asimila la foto actual y, a continuación, mostrar la nueva foto almacenada en la memoria.

    Para precargar una foto, se coloca un asterisco delante del nombre del archivo en el comando MIRAFOTO. El comando MIRAFOTO siguiente detecta que se ha precargado una foto y la muestra sin solicitar el nombre de archivo.

    El tiempo de acceso a disco para cargar la siguiente foto se solapa con el tiempo de visualización de la foto actual. Se pueden definir retrasos adicionales con el comando RETARDA. Cada unidad de retraso es igual a un milisegundo.

    Para detener un archivo de comandos de repetición pulse ESC. Puede reanudarlo con REANUDA.

    Si el archivo de comandos va a ejecutarse durante mucho tiempo, es recomendable utilizar Control DESHACER Ninguna para desactivar el archivo de registro de Deshacer.


Ficha Procedimientos: Ejecución de presentaciones de fotos desde archivos de comandos [Manual de personalización: ACG]

Creación de archivos de comandos
Ejecución de presentaciones de fotos desde archivos de comandos
Conceptos
Procedimientos
Referencia

    • Para ejecutar presentaciones de fotos desde archivos de comandos

    Para crear un archivo de comandos que precargue fotos


Ficha Referencia: Ejecución de presentaciones de fotos desde archivos de comandos [Manual de personalización: ACG]

Creación de archivos de comandos
Ejecución de presentaciones de fotos desde archivos de comandos
Conceptos
Procedimientos
Referencia

    • Comandos

    RETARDA

    Proporciona una pausa de duración establecida dentro de un archivo de comandos

    PANTGRAF

    Permite cambiar de la ventana de texto al área de dibujo

    REANUDA

    Reanuda un archivo de comandos interrumpido

    RSCRIPT

    Repite el archivo de comandos

    SCRIPT

    SCRIPT ejecuta una secuencia de comandos desde un archivo de comandos

    PANTTEXT

    Abre la ventana de texto

    MIRAFOTO

    Muestra un archivo de foto de imagen en la ventana gráfica actual

    Variables de sistema

    No hay entradas.


Para ejecutar presentaciones de fotos desde archivos de comandos [Manual de personalización: ACG]

Creación de archivos de comandos
Ejecución de presentaciones de fotos desde archivos de comandos
Conceptos
Procedimientos
Referencia

    • Para ejecutar presentaciones de fotos desde archivos de comandos

    1. Cree un archivo de fototeca tal y como se describe en Para crear una fototeca.
    2. Cree un archivo de comandos utilizando un editor de texto ASCII, tal y como se describe en Para crear un archivo de comandos que precargue fotos.
    3. En la línea de comando, escriba script.
    4. En el cuadro de diálogo Seleccionar archivo de comandos, seleccione uno y elija Abrir.


Para crear un archivo de comandos que precargue fotos [Manual de personalización: ACG]

Creación de archivos de comandos
Ejecución de presentaciones de fotos desde archivos de comandos
Conceptos
Procedimientos
Referencia

    • Para crear un archivo de comandos que precargue fotos

    En este ejemplo de un archivo de comandos que muestra tres fotos (archivos foto1.sld, foto2.sld y foto3.sld), el tiempo que se tarda en acceder a la unidad de disco y cargar la foto en memoria se solapa con el tiempo de visualización de la foto actual.

    1. En la primera línea del archivo de comandos, escriba mirafoto foto1.

    La primera línea inicia la presentación de fotos y carga foto1.

    2. En la segunda línea, escriba mirafoto *foto2.

    El asterisco (*) que precede al nombre de la foto en la segunda línea precarga la foto2.

    3. En la tercera línea, escriba retarda 2000.

    La tercera línea especifica un retraso de 2000 milisegundos para permitir que el público vea la foto1.

    4. En la cuarta línea, escriba mirafoto. En la quinta línea, escriba mirafoto *foto3. En la sexta línea, escriba retarda 2000.

    En las líneas cuarta, quinta y sexta se muestra la foto2, se precarga la foto3 y se especifica el retraso para visualizar la foto2.

    5. En la séptima línea, escriba mirafoto. En la octava línea, escriba retarda 3000.

    En las líneas séptima y octava se muestra la foto3 y se especifica un retraso para visualizar la foto3.

    6. En la última línea, escriba rscript para repetir el archivo de comandos.
    7. Para detener un archivo de comandos de repetición pulse ESC. Para continuar con el archivo de comandos, escriba reanuda.

    El archivo de comandos puede incluir comentarios como los siguientes:

    ; Inicia la presentación de fotos, carga la FOTO1
    MIRAFOTO FOTO1
    ; Precarga la FOTO2
    MIRAFOTO *FOTO2
    ; Muestra al público la FOTO1
    RETARDA 2000
    ; Muestra la FOTO2
    MIRAFOTO
    ; Precarga la FOTO3
    MIRAFOTO *FOTO3
    ; Muestra al público la FOTO2
    RETARDA 2000
    ; Muestra la FOTO3
    MIRAFOTO
    ; Muestra al público la FOTO3
    RETARDA 3000
    ; Activa el ciclo
    RSCRIPT


Introducción a las interfaces de programación [Manual de personalización: ACG]

Introducción a las interfaces de programación
Conceptos
Procedimientos
Referencia

    • Además de las interfaces de menús y líneas de comando, AutoCAD® proporciona interfaces de programación de aplicaciones (API) que se pueden utilizar para controlar los dibujos y las bases de datos. El tipo de interfaz que se utilice dependerá de las necesidades de la aplicación y de la experiencia en programación de cada usuario.

    • ActiveX Automation
      ActiveX Automation es una tecnología desarrollada por Microsoft® y basada en la arquitectura COM (Component Object Model, Modelo de objetos componentes). Puede usarse para personalizar AutoCAD, compartir los datos de dibujo con otras aplicaciones y automatizar tareas.
    • AutoCAD VBA
      Microsoft Visual Basic para aplicaciones (VBA) es un entorno de programación basado en objetos diseñado para proporcionar amplias capacidades de desarrollo. La principal diferencia entre VBA y VB (Visual Basic) es que VBA se ejecuta en el mismo espacio de procesos que AutoCAD, con lo que proporciona un entorno de programación adaptado a AutoCAD y muy rápido.
    • AutoLISP y Visual LISP
      AutoLISP se basa en el lenguaje de programación LISP, sencillo de aprender y muy eficaz. AutoCAD incluye un intérprete de LISP integrado, de manera que puede introducir el código de AutoLISP en la línea de comando o cargarlo desde archivos externos. Visual LISP (VLISP) es una herramienta de software diseñada para agilizar el desarrollo de programas en AutoLISP.
    • ObjectARX
      La tecnología ObjectARX proporciona la base que permite que las aplicaciones de software de diseño compartan datos de objeto inteligentes. Puede ejecutar aplicaciones ObjectARX de otros fabricantes o escribir las que necesite.


Ficha Procedimientos: Introducción a las interfaces de programación [Manual de personalización: ACG]

Introducción a las interfaces de programación
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Introducción a las interfaces de programación [Manual de personalización: ACG]

Introducción a las interfaces de programación
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    ARX

    Carga, descarga y proporciona información sobre las aplicaciones ObjectARX

    CARGARMENU

    Carga archivos de menús parciales

    VBAIDE

    Muestra el Editor de Visual Basic

    VBALOAD

    Carga un proyecto VBA global en la sesión actual de AutoCAD

    VBAMAN

    Carga, descarga, guarda, crea, inserta y extrae proyectos VBA

    VBARUN

    Ejecuta una macro VBA

    VBAENUN

    Ejecuta una secuencia VBA en la línea de comando de AutoCAD

    VBDESCARGAR

    Descarga un proyecto VBA global

    Variables de sistema

    ACADLSPASDOC

    Controla si AutoCAD debe cargar el archivo acad.lsp en todos los dibujos o sólo en el primer dibujo abierto en una sesión de AutoCAD

    CMDECHO

    Controla si AutoCAD muestra solicitudes y entrada de datos durante la función command de AutoLISP

    ERRNO

    Muestra el número del código de error apropiado cuando una función de AutoLISP causa un error que detecta AutoCAD

    LISPINIT

    Controla la inicialización de las funciones y variables definidas con AutoLISP cuando está activada la interfaz de un solo documento

    PICKADD

    Controla si las designaciones posteriores sustituyen al conjunto de selección actual o se añaden a él

    PICKAUTO

    Controla la representación visual automática en la solicitud Designe objetos

    SDI

    Controla si AutoCAD se ejecuta en una interfaz de un solo documento o de múltiples documentos


ActiveX Automation [Manual de personalización: ACG]

Introducción a las interfaces de programación
ActiveX Automation
Conceptos
Procedimientos
Referencia

    • ActiveX Automation es una tecnología desarrollada por Microsoft® y basada en la arquitectura COM (Component Object Model, Modelo de objetos componentes). Puede usarse para personalizar AutoCAD, compartir los datos de dibujo con otras aplicaciones y automatizar tareas.

    • Presentación general de ActiveX
      Puede crear y manipular objetos de AutoCAD desde cualquier aplicación que funcione como controlador de Automation. Al hacerlo, Automation activa la programación de macros en todas las aplicaciones. Esta función no existe en AutoLISP.
    • Definición de un comando para iniciar la aplicación
      Puede utilizar el archivo acad.pgp para definir un nuevo comando de AutoCAD que ejecute un comando externo para iniciar la aplicación.
    • Inicio de una aplicación desde un menú
      Después de definir un nuevo comando para iniciar la aplicación, puede incluir dicho comando en un menú o una barra de herramientas para se pueda acceder a él fácilmente.


Ficha Procedimientos: ActiveX Automation [Manual de personalización: ACG]

Introducción a las interfaces de programación
ActiveX Automation
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: ActiveX Automation [Manual de personalización: ACG]

Introducción a las interfaces de programación
ActiveX Automation
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    Variables de sistema

    No hay entradas.


Presentación general de ActiveX [Manual de personalización: ACG]

ActiveX Automation
Presentación general de ActiveX
Conceptos
Procedimientos
Referencia

    • Por medio de Automation, AutoCAD expone los objetos programables, descritos por AutoCAD Object Model, que se pueden crear, editar y manipular desde otras aplicaciones. Cualquier aplicación que pueda acceder a AutoCAD Object Model es un controlador de Automation y la herramienta que se utiliza con más frecuencia para manipular otra aplicación con Automation es Visual Basic para aplicaciones (VBA). Esta versión de Visual Basic puede encontrarse como componente en muchas aplicaciones de Microsoft Office. Puede utilizar estas aplicaciones u otros controladores de Automation, como Visual Basic y Delphi, para controlar AutoCAD.

    La implementación de una interfaz ActiveX para AutoCAD ofrece dos ventajas:

    • El acceso a los dibujos de AutoCAD por medio del código permite el uso de muchos nuevos entornos de programación. Antes de la incorporación de ActiveX Automation, los desarrolladores sólo disponían de las interfaces de AutoLISP y C++.
    • El uso compartido de datos con otras aplicaciones de Windows, como Microsoft® Excel y Microsoft® Word, resulta mucho más sencillo.

    Supongamos, por ejemplo, que desea solicitar la introducción de datos, definir preferencias, crear un conjunto de selección u obtener datos de dibujo. Puede decidir qué controlador se debe utilizar, en función del tipo de manipulación que se va a llevar a cabo.

    Si trabaja con Automation, puede crear y manipular objetos de AutoCAD desde cualquier aplicación que funcione como controlador de Automation. Al hacerlo, Automation activa la programación de macros en todas las aplicaciones, una función que no existe en AutoLISP. Automation permite combinar las funciones de diversas aplicaciones en una sola.

    Los objetos mostrados se denominan objetos de Automation. Los objetos de Automation permiten acceder a los métodos y las propiedades. Los métodos son funciones que llevan a cabo una acción sobre un objeto. Las propiedades son funciones que definen u obtienen información sobre el estado de un objeto.

    Prácticamente todos los tipos de aplicaciones pueden tener acceso a los objetos de Automation mostrados en AutoCAD. Estas aplicaciones pueden ser ejecutables independientes, archivos de biblioteca de enlace dinámico (DLL) y macros de programas como Microsoft Word o Microsoft Excel. De estas alternativas, la más habitual es el ejecutable independiente. Si trabaja con aplicaciones creadas por desarrolladores, siga sus instrucciones para la instalación y utilización de esos productos.

    Véase también

    Manual del desarrollador de ActiveX y VBA
    Manual ActiveX and VBA Reference


Ficha Procedimientos: Presentación general de ActiveX [Manual de personalización: ACG]

ActiveX Automation
Presentación general de ActiveX
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de ActiveX [Manual de personalización: ACG]

ActiveX Automation
Presentación general de ActiveX
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Definición de un comando para iniciar la aplicación [Manual de personalización: ACG]

ActiveX Automation
Definición de un comando para iniciar la aplicación
Conceptos
Procedimientos
Referencia

    • Puede utilizar el archivo acad.pgp para definir un nuevo comando de AutoCAD que ejecute un comando externo para iniciar la aplicación. El siguiente ejemplo define el comando EJECUTARAPL1, que ejecuta la aplicación apl1.exe del directorio c:\apsvb\. (Añada este código a la sección de comandos externos del archivo acad.pgp.)

    EJECUTARAPL1, start c:\apsvb\apl1, 0

    Si la aplicación requiere parámetros de línea de comando, utilice el código siguiente:

    EJECUTARAPL2, start c:\apsvb\apl2, 0 *Parameters: ,

    Este ejemplo define el comando EJECUTARAPL2, que solicita la introducción de parámetros y los traspasa a la aplicación.

    También puede usar la función startapp de AutoLISP para iniciar una aplicación que utilice Automation. Una vez que AutoLISP ha iniciado la aplicación externa, deja de tener control sobre sus acciones. No obstante, puede utilizar AutoLISP para buscar y ejecutar diversas aplicaciones en función de determinados parámetros.

    Véase también

    Creación de alias de comandos en la página


Ficha Procedimientos: Definición de un comando para iniciar la aplicación [Manual de personalización: ACG]

ActiveX Automation
Definición de un comando para iniciar la aplicación
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Definición de un comando para iniciar la aplicación [Manual de personalización: ACG]

ActiveX Automation
Definición de un comando para iniciar la aplicación
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Inicio de una aplicación desde un menú [Manual de personalización: ACG]

ActiveX Automation
Inicio de una aplicación desde un menú
Conceptos
Procedimientos
Referencia

    • Después de definir un nuevo comando para iniciar la aplicación, puede incluir dicho comando en un menú o una barra de herramientas para se pueda acceder a él fácilmente.

    La macro de menú se puede invocar desde un elemento de menú de cualquier sección del archivo de menús (MNU). Si sólo utiliza una o dos aplicaciones, puede añadirlas a uno de los menús desplegables estándar. Si tiene un grupo de aplicaciones, puede añadir un menú desplegable o una barra de herramientas que se haya creado específicamente para esas aplicaciones.

    El ejemplo siguiente muestra un archivo de menús completo que define un nuevo menú desplegable llamado MisAps. El archivo de menús define el grupo de menús MISAPS y dos grupos de elementos de menú. Los tres primeros elementos de menú utilizan la función startapp de AutoLISP para iniciar la aplicación asociada, y los dos últimos asumen que los comandos APL4 y APL5 se han definido previamente (en el archivo acad.pgp).

    Este archivo también incluye una sección de cadenas de ayuda, Helpstrings, que proporciona ayuda en la barra de estado cuando se selecciona un elemento de menú. La sección Accelerators define las teclas de aceleración que ejecutan las macros de los menús. Estas secciones de los menús utilizan identificadores de nombre (como ID_App1) para vincular las acciones asociadas.

    // Menú Misaps
    //
    ***MENUGROUP=MISAPS

    // Esta sección define el nuevo menú desplegable

    ***POP1

    ID_MyAppsMnu [Mis&aps]

    ID_MyApp1    [Apl1   ]^C^C^P(startapp "apl1")(princ) ^P

    ID_MyApp2    [Apl2   ]^C^C^P(startapp "apl2")(princ) ^P

    ID_MyApp3    [Apl3   ]^C^C^P(startapp "apl3")(princ) ^P

                 [--]

    ID_MyApp4    [Apl4   ]^C^CAPL4

    ID_MyApp5    [Apl5   ]^C^CAPL5

    // Esta sección define los mensajes de la línea de estado que se

    // muestran cuando se resalta un elemento de menú asociado

    ***HELPSTRINGS

    ID_MyApp1    [Aplicación APL1]

    ID_MyApp2    [Aplicación APL2]

    ID_MyApp3    [Aplicación APL3]

    ID_MyApp4    [Aplicación APL4]

    ID_MyApp5    [Aplicación APL5]

    // Esta sección define las teclas de aceleración que ejecutan las

    // macros de menú de los menús desplegables asociados

    ***ACCELERATORS

    ID_MyApp1    [CONTROL+SHIFT+"1"]

    ID_MyApp2    [CONTROL+SHIFT+"2"]

    ID_MyApp3    [CONTROL+SHIFT+"3"]

    ID_MyApp4    [CONTROL+SHIFT+"4"]

    ID_MyApp5    [CONTROL+SHIFT+"5"]

    Después de guardar este código en un archivo llamado misaps.mnu, utilice el comando

CARGARMENU para añadir el menú a la barra de menús. Cuando cargue el archivo por primera vez, tendrá que especificar el tipo de archivo MNU (.mnu).

    Véase también

Archivo de menús


Ficha Procedimientos: Inicio de una aplicación desde un menú [Manual de personalización: ACG]

ActiveX Automation
Inicio de una aplicación desde un menú
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Inicio de una aplicación desde un menú [Manual de personalización: ACG]

ActiveX Automation
Inicio de una aplicación desde un menú
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    Variables de sistema

    No hay entradas.


AutoCAD VBA [Manual de personalización: ACG]

Introducción a las interfaces de programación
AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • Microsoft Visual Basic para aplicaciones (VBA) es un entorno de programación basado en objetos diseñado para proporcionar amplias capacidades de desarrollo. La principal diferencia entre VBA y VB (Visual Basic) es que VBA se ejecuta en el mismo espacio de procesos que AutoCAD, con lo que proporciona un entorno de programación adaptado a AutoCAD y muy rápido.

    • Presentación general de AutoCAD VBA
    • Uso de las aplicaciones de AutoCAD VBA
      Para cargar un proyecto de VBA debe utilizar el comando VBACARGAR. Una vez cargado, sus módulos y macros estarán disponibles en el cuadro de diálogo Macros.
    • Carga y ejecución automáticas de los proyectos de VBA
      Puede cargar los proyectos de VBA automáticamente cada vez que ejecute AutoCAD.


Ficha Procedimientos: AutoCAD VBA [Manual de personalización: ACG]

Introducción a las interfaces de programación
AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: AutoCAD VBA [Manual de personalización: ACG]

Introducción a las interfaces de programación
AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    VBAIDE

    Muestra el Editor de Visual Basic

    VBALOAD

    Carga un proyecto VBA global en la sesión actual de AutoCAD

    VBAMAN

    Carga, descarga, guarda, crea, inserta y extrae proyectos VBA

    VBARUN

    Ejecuta una macro VBA

    VBAENUN

    Ejecuta una secuencia VBA en la línea de comando de AutoCAD

    VBDESCARGAR

    Descarga un proyecto VBA global

    Variables de sistema

    No hay entradas.


Presentación general de AutoCAD VBA [Manual de personalización: ACG]

AutoCAD VBA
Presentación general de AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • VBA hace posible la integración de las aplicaciones con otras aplicaciones que admiten VBA. Esto significa que AutoCAD, con otras bibliotecas de objetos de aplicación, puede funcionar como controlador de Automation para otras aplicaciones como Microsoft Word o Excel.

    Las ediciones de desarrollo de Visual Basic independientes, que se venden por separado, complementan AutoCAD VBA con componentes adicionales como un motor para bases de datos externas y funciones de creación de informes.

    Desarrollo con AutoCAD VBA

    VBA envía mensajes a AutoCAD a través de la interfaz AutoCAD ActiveX Automation. AutoCAD VBA hace posible que el entorno Visual Basic se ejecute a la vez que AutoCAD y permite controlar AutoCAD por medio de la programación a través de la interfaz ActiveX Automation. Esta asociación de AutoCAD, ActiveX Automation y VBA proporciona una interfaz de gran eficacia desde la que no sólo es posible controlar los objetos de AutoCAD, sino también intercambiar datos con otras aplicaciones.

    La integración de VBA en AutoCAD genera una herramienta visual de fácil uso para la personalización de AutoCAD. Por ejemplo, puede crear una aplicación que extraiga automáticamente la información sobre atributos, inserte directamente los resultados en una hoja de cálculo de Excel y lleve a cabo todas las transformaciones de datos requeridas.

    La programación con VBA en AutoCAD viene definida por tres elementos esenciales. El primero de ellos es AutoCAD, que dispone de un extenso conjunto de objetos entre los que se incluyen entidades, datos y comandos de AutoCAD. AutoCAD es una aplicación de arquitectura abierta con varios niveles de interfaz. Para utilizar VBA de manera eficaz, es recomendable estar familiarizado con la programación en AutoCAD. Descubrirá, no obstante, que el sistema basado en objetos de VBA difiere bastante del de AutoLISP.

    El segundo elemento es la interfaz AutoCAD ActiveX Automation, que intercambia mensajes (establece una comunicación) con los objetos de AutoCAD. La programación en VBA requiere comprender los fundamentos de ActiveX Automation. Puede encontrar una descripción de la interfaz AutoCAD ActiveX Automation en el Manual del desarrollador de ActiveX y VBA (en el menú Ayuda de AutoCAD, haga clic en Ayuda del desarrollador).

    El tercer elemento que define la programación en este entorno es VBA. Incluye su propio conjunto de objetos, palabras clave, constantes, etc., que proporcionan el flujo de programación y funciones de control, limpieza y ejecución. AutoCAD VBA incluye un sistema de ayuda exhaustivo de Microsoft para VBA.

    La interfaz AutoCAD ActiveX/VBA ofrece varias ventajas con respecto a otros entornos API de AutoCAD:

    • Velocidad. Cuando se realiza una ejecución en proceso con VBA, las aplicaciones de ActiveX son más rápidas que las de AutoLISP.
    • Facilidad de uso. El lenguaje de programación y el entorno de desarrollo son fáciles de utilizar y se suministran instalados con AutoCAD.
    • Funcionamiento conjunto con Windows. ActiveX y VBA están diseñados para su uso con otras aplicaciones de Windows y constituyen una excelente vía para la comunicación de información entre distintas aplicaciones.
    • Rápida creación de prototipos. El rápido desarrollo de interfaz de VBA proporciona el entorno perfecto para las aplicaciones de creación de prototipos, incluso si esas aplicaciones se van a desarrollar en otros lenguajes.
    • Base para programadores. Millones de programadores de todo el mundo ya utilizan Visual Basic. AutoCAD ActiveX/VBA ofrece posibilidades de desarrollo de aplicaciones y personalización de AutoCAD tanto a estos programadores como a todos aquellos que aprenderán Visual Basic en el futuro.


Ficha Procedimientos: Presentación general de AutoCAD VBA [Manual de personalización: ACG]

AutoCAD VBA
Presentación general de AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de AutoCAD VBA [Manual de personalización: ACG]

AutoCAD VBA
Presentación general de AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • Comandos

    VBAIDE

    Muestra el Editor de Visual Basic

    VBALOAD

    Carga un proyecto VBA global en la sesión actual de AutoCAD

    VBAMAN

    Carga, descarga, guarda, crea, inserta y extrae proyectos VBA

    VBARUN

    Ejecuta una macro VBA

    VBAENUN

    Ejecuta una secuencia VBA en la línea de comando de AutoCAD

    VBDESCARGAR

    Descarga un proyecto VBA global

    Variables de sistema

    No hay entradas.


Uso de las aplicaciones de AutoCAD VBA [Manual de personalización: ACG]

AutoCAD VBA
Uso de las aplicaciones de AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • Aunque las aplicaciones de Microsoft Office 97 almacenan los programas, macros y proyectos de VBA en un documento concreto, AutoCAD utiliza un archivo independiente con la extensión .dvb. De esta forma, VBA se comunica con AutoCAD de manera similar a la que utilizan AutoLISP y ObjectARX. Dado que los proyectos de VBA se guardan en un archivo independiente, un proyecto de VBA puede abrir y cerrar diferentes dibujos de AutoCAD durante una sesión de este programa.

    Nota Los proyectos de AutoCAD VBA no tienen el mismo patrón binario que los proyectos independientes de Visual Basic (archivos VBP). Sin embargo, los formularios, los módulos y las clases se pueden intercambiar entre proyectos diferentes utilizando los comandos IMPORT y EXPORT de VBA en el entorno de desarrollo integrado (IDE, Integrated Development Environment) de VBA.

    Para cargar un proyecto de VBA debe utilizar el comando VBACARGAR. Una vez cargado, sus módulos y macros estarán disponibles en el cuadro de diálogo Macros. Para ejecutar el módulo VBA, use el comando VBAEJECUTAR. Si no se ha cargado ningún proyecto de VBA, las opciones no estarán disponibles. Los procedimientos incluidos en la lista del cuadro Nombre de macro presentan la siguiente sintaxis:

    módulo.macro

    En el cuadro de diálogo Macros, elija el valor de ámbito de macro y seleccione uno de los módulos de la lista.

    Uso de la línea de comando para ejecutar una macro de VBA

    Existen equivalentes de la solicitud de la línea de comando de AutoCAD a los que se puede acceder por medio del comando –VBAEJECUTAR (que incluye un guión delante del comando VBAEJECUTAR). Las macros de VBA se pueden ejecutar desde la línea de comando, los archivos de comandos y otros entornos de programación de AutoCAD. El único argumento del comando es el nombre del módulo de Visual Basic escrito con la sintaxis módulo.macro. La sintaxis es la siguiente:

    –vbaejecutar <módulo.macro>

    Dado que diferentes módulos pueden incluir macros con el mismo nombre, la sintaxis módulo.macro permite distinguir la macro y realizar una selección única.


Ficha Procedimientos: Uso de las aplicaciones de AutoCAD VBA [Manual de personalización: ACG]

AutoCAD VBA
Uso de las aplicaciones de AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de las aplicaciones de AutoCAD VBA [Manual de personalización: ACG]

AutoCAD VBA
Uso de las aplicaciones de AutoCAD VBA
Conceptos
Procedimientos
Referencia

    • Comandos

    VBAIDE

    Muestra el Editor de Visual Basic

    VBALOAD

    Carga un proyecto VBA global en la sesión actual de AutoCAD

    VBAMAN

    Carga, descarga, guarda, crea, inserta y extrae proyectos VBA

    VBARUN

    Ejecuta una macro VBA

    VBAENUN

    Ejecuta una secuencia VBA en la línea de comando de AutoCAD

    VBDESCARGAR

    Descarga un proyecto VBA global

    Variables de sistema

    No hay entradas.


Carga y ejecución automáticas de los proyectos de VBA [Manual de personalización: ACG]

AutoCAD VBA
Carga y ejecución automáticas de los proyectos de VBA
Conceptos
Procedimientos
Referencia

    • Si ha creado diversos proyectos de VBA, puede cargarlos automáticamente cada vez que ejecute AutoCAD. Las macros de estos proyectos quedarán disponibles inmediatamente. Además, el comando APPLOAD proporciona una opción Cargar al inicio que carga automáticamente las aplicaciones especificadas.

    acvba.arx: carga automática de VBA

    No podrá cargar VBA hasta que haya ejecutado un comando de AutoCAD VBA. Si desea cargar VBA automáticamente cada vez que inicie AutoCAD, incluya la línea siguiente en el archivo acad.rx:

    acvba.arx

    Puede ejecutar automáticamente una macro en el archivo acad.dvb denominándola AcadStartup. Las macros del archivo acad.dvb con este nombre se ejecutan de manera automática cuando se carga VBA.

    acad.dvb: carga automática de un proyecto de VBA

    El archivo acad.dvb resulta útil si se desea cargar un proyecto de VBA que contiene macros cada vez que se inicia AutoCAD. Cada vez que se inicia una nueva sesión de dibujo en AutoCAD, la aplicación busca el archivo acad.dvb y lo carga.

    Si desea que una macro del archivo acad.dvb se ejecute cada vez que se inicia un dibujo nuevo o se abre uno ya existente, añada el siguiente código al archivo acaddoc.lsp:

    (defun S::STARTUP ()
      (command "_-vbaejecutar" "actualizarbloquetítulo")
    )

    El nombre del proyecto del ejemplo es actualizarbloquetítulo.


Ficha Procedimientos: Carga y ejecución automáticas de los proyectos de VBA [Manual de personalización: ACG]

AutoCAD VBA
Carga y ejecución automáticas de los proyectos de VBA
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Carga y ejecución automáticas de los proyectos de VBA [Manual de personalización: ACG]

AutoCAD VBA
Carga y ejecución automáticas de los proyectos de VBA
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    VBAIDE

    Muestra el Editor de Visual Basic

    VBALOAD

    Carga un proyecto VBA global en la sesión actual de AutoCAD

    VBAMAN

    Carga, descarga, guarda, crea, inserta y extrae proyectos VBA

    VBARUN

    Ejecuta una macro VBA

    VBAENUN

    Ejecuta una secuencia VBA en la línea de comando de AutoCAD

    VBDESCARGAR

    Descarga un proyecto VBA global

    Variables de sistema

    No hay entradas.


AutoLISP y Visual LISP [Manual de personalización: ACG]

Introducción a las interfaces de programación
AutoLISP y Visual LISP
Conceptos
Procedimientos
Referencia

    • AutoLISP se basa en el lenguaje de programación LISP, sencillo de aprender y muy eficaz. AutoCAD incluye un intérprete de LISP integrado, de manera que puede introducir el código de AutoLISP en la línea de comando o cargarlo desde archivos externos. Visual LISP (VLISP) es una herramienta de software diseñada para agilizar el desarrollo de programas en AutoLISP.

    • Presentación general de AutoLISP y Visual LISP
    • Uso de las aplicaciones de AutoLISP
      Las aplicaciones de AutoLISP se almacenan en archivos de texto ASCII que se pueden editar. Para utilizar una aplicación de AutoLISP, debe cargarse primero.
    • Carga y ejecución automáticas de las rutinas de AutoLISP
      Puede cargar las rutinas de AutoLISP cada vez que ejecute AutoCAD. También puede cargar ciertos comandos o funciones en momentos concretos de una sesión de dibujo.


Ficha Procedimientos: AutoLISP y Visual LISP [Manual de personalización: ACG]

Introducción a las interfaces de programación
AutoLISP y Visual LISP
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: AutoLISP y Visual LISP [Manual de personalización: ACG]

Introducción a las interfaces de programación
AutoLISP y Visual LISP
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    Variables de sistema

    ACADLSPASDOC

    Controla si AutoCAD debe cargar el archivo acad.lsp en todos los dibujos o sólo en el primer dibujo abierto en una sesión de AutoCAD

    CMDECHO

    Controla si AutoCAD muestra solicitudes y entrada de datos durante la función command de AutoLISP

    ERRNO

    Muestra el número del código de error apropiado cuando una función de AutoLISP causa un error que detecta AutoCAD

    LISPINIT

    Controla la inicialización de las funciones y variables definidas con AutoLISP cuando está activada la interfaz de un solo documento

    PICKADD

    Controla si las designaciones posteriores sustituyen al conjunto de selección actual o se añaden a él

    PICKAUTO

    Controla la representación visual automática en la solicitud Designe objetos

    SDI

    Controla si AutoCAD se ejecuta en una interfaz de un solo documento o de múltiples documentos


Presentación general de AutoLISP y Visual LISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Presentación general de AutoLISP y Visual LISP
Conceptos
Procedimientos
Referencia

    • AutoLISP se ha mejorado con la incorporación de Visual LISP (VLISP), que ofrece un entorno de desarrollo integrado (IDE) con herramientas de compilación, limpieza y desarrollo que ayudan a aumentar la productividad. VLISP añade nuevas funciones y amplía el lenguaje para permitir la interacción con objetos a través de ActiveX. VLISP también activa en AutoLISP la respuesta a eventos por medio de reactores de objetos.

    A diferencia de lo que ocurre en ObjectARX o VBA, cada documento abierto en el entorno de múltiples diseños (MDE, Multiple Design Environment) tiene su propio espacio de nombre y entorno de Visual LISP. Un espacio de nombre es un entorno aislado que impide que las rutinas de AutoLISP específicas de un documento tengan conflictos de valor o nombre de variable o de símbolo con las de otros documentos. Por ejemplo, la línea de código siguiente establece un valor diferente del símbolo a para los distintos documentos.

    (setq a (getvar "DWGNAME"))

    Visual LISP proporciona mecanismos para cargar los símbolos y variables de un espacio en otro. Para obtener más información sobre los espacios de nombre, véase AutoLISP Developer's Guide (en el menú Ayuda de AutoCAD, haga clic en Ayuda del desarrollador).

    Las aplicaciones o rutinas de AutoLISP pueden interactuar con AutoCAD de muchas formas. Pueden pedir al usuario que introduzca información, acceder directamente a los comandos integrados de AutoCAD, y modificar o crear objetos en la base de datos de dibujo. Mediante la creación de rutinas de AutoLISP pueden añadirse a AutoCAD comandos específicos para cada disciplina. Algunos de los comandos estándar de AutoCAD son en realidad aplicaciones de AutoLISP.

    Visual LISP ofrece tres opciones de formato de archivo para las aplicaciones de AutoLISP:

    • Lectura de un archivo LSP (.lsp), un archivo de texto ASCII que contiene el código de programa de AutoLISP.
    • Lectura de un archivo FAS (.fas), versión binaria compilada de un único archivo de programa LSP.
    • Lectura de un archivo VLX (.vlx), un conjunto compilado de uno o varios archivos LSP o DCL (Dialog Control Language, Lenguaje de control de diálogos).

    Nota Los archivos de aplicación de AutoLISP con nombres similares se cargan en función del sello horario modificado; se carga el archivo LSP, FAS o VLX con el sello horario más reciente a menos que se especifique el nombre de archivo completo (incluida la extensión).

    Puesto que AutoCAD puede leer el código de AutoLISP directamente, no se requiere compilación. Aunque Visual LISP proporciona un IDE, puede probar a introducir el código en la solicitud de comandos, que permite ver los resultados inmediatamente. Estas características hacen de AutoLISP un lenguaje fácil de utilizar, con independencia de la experiencia en programación de cada usuario.

    Incluso si no necesita escribir aplicaciones en AutoLISP, el paquete de AutoCAD incluye muchas rutinas de utilidad. Algunas compañías de desarrollo de software también ponen otras rutinas a disposición de los usuarios a través de su shareware. Aprender a cargar y utilizar estas rutinas puede aumentar su productividad.

    Nota Cuando la entrada de comandos se hace por medio de la función command de AutoLISP, se asume que los valores de las variables de sistema PICKADD y PICKAUTO son 1 y 0, respectivamente. Esto garantiza la compatibilidad con las versiones anteriores de AutoCAD y facilita la personalización (porque no es necesario comprobar los valores de esas variables).

    Para obtener información sobre la programación en AutoLISP, véase AutoLISP Developer's Guide, y para obtener información sobre las funciones de AutoLISP y Visual LISP, véase AutoLISP Reference (en el menú Ayuda de AutoCAD, haga clic en Ayuda del desarrollador). Los programas de AutoLISP pueden utilizar cuadros de diálogo con sus aplicaciones. Los cuadros de diálogo programables sólo se describen en AutoLISP Developer's Guide.


Ficha Procedimientos: Presentación general de AutoLISP y Visual LISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Presentación general de AutoLISP y Visual LISP
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de AutoLISP y Visual LISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Presentación general de AutoLISP y Visual LISP
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    PICKADD

    Controla si las designaciones posteriores sustituyen al conjunto de selección actual o se añaden a él

    PICKAUTO

    Controla la representación visual automática en la solicitud Designe objetos


Uso de las aplicaciones de AutoLISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Uso de las aplicaciones de AutoLISP
Conceptos
Procedimientos
Referencia

    • Las aplicaciones de AutoLISP se almacenan en archivos de texto ASCII con la extensión .lsp. Normalmente, estos archivos tienen una porción de encabezado que describe la rutina y su uso y proporciona instrucciones específicas. Este encabezado también puede incluir comentarios con el nombre del autor e información legal sobre la utilización de la rutina. Los comentarios comienzan con un punto y coma (;). Es posible visualizar y editar estos archivos con un editor o procesador de texto que pueda generar un archivo de texto ASCII.

    Para utilizar una aplicación de AutoLISP, debe cargarse primero. Puede utilizar el comando APPLOAD o la función load de AutoLISP para cargar una aplicación. Al cargar una aplicación de AutoLISP, el código de AutoLISP del archivo LSP se carga en la memoria del sistema.

    Para cargar una aplicación con la función load es necesario introducir el código de AutoLISP en la solicitud de comandos. Si la función load se ejecuta correctamente, muestra el valor de la última expresión del archivo en la línea de comando. Éste suele corresponder al nombre de la última función definida en el archivo o a instrucciones sobre el uso de la función que se acaba de cargar. Si load falla, devuelve un mensaje de error de AutoLISP. load puede fallar a causa de un código incorrecto en el archivo o de la introducción de un nombre de archivo erróneo en la línea de comando. La sintaxis de la función load es

    (load nombrearchivo [onfailure])

    Esta sintaxis indica que la función load tiene dos argumentos: nombrearchivo, que es obligatorio, y onfailure, que es opcional. Cuando se carga un archivo de AutoLISP en la línea de comando, se proporciona normalmente el argumento nombrearchivo. En el ejemplo siguiente se carga el archivo de AutoLISP nuevoarchivo.lsp.

    Comando: (load "nuevoarchivo")

    No es necesario incluir la extensión .lsp. Este formato sirve para todos los archivos LSP de la ruta de biblioteca actual.

    Para cargar un archivo de AutoLISP que no está en la ruta de biblioteca, debe indicar el nombre completo y la ruta de archivo como argumento nombrearchivo.

    Comando: (load "d:/archivos/maslisp/nuevoarchivo")

    Nota Al especificar la ruta de un directorio, debe utilizar una barra oblicua (/) o dos barras invertidas (\\) como separador, ya que una única barra invertida tiene un significado concreto en AutoLISP.

    Véase también

    Presentación general de la organización de archivos


Ficha Procedimientos: Uso de las aplicaciones de AutoLISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Uso de las aplicaciones de AutoLISP
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de las aplicaciones de AutoLISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Uso de las aplicaciones de AutoLISP
Conceptos
Procedimientos
Referencia

    • Comandos
APPLOAD | Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar
Variables de sistema
No hay entradas. |


Carga y ejecución automáticas de las rutinas de AutoLISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Carga y ejecución automáticas de las rutinas de AutoLISP
Conceptos
Procedimientos
Referencia

    • Puede cargar las rutinas de AutoLISP cada vez que ejecute AutoCAD. También puede cargar ciertos comandos o funciones en momentos concretos de una sesión de dibujo.

    • Presentación general de la carga automática de AutoLISP
    • El archivo acad.lsp
      El archivo acad.lsp resulta útil si desea cargar determinadas rutinas de AutoLISP cada vez que inicie AutoCAD. Cuando se inicia AutoCAD, el programa busca un archivo acad.lsp en la ruta de biblioteca. Si lo encuentra, lo carga en la memoria.
    • El archivo acaddoc.lsp
      El archivo acaddoc.lsp está asociado con la inicialización de cada documento o dibujo. Este archivo resulta útil si se desea cargar una biblioteca de rutinas de AutoLISP para que estén disponibles cada vez que se inicie un nuevo dibujo o se abra uno existente.
    • El archivo MNL de un menú de AutoLISP
      Cuando AutoCAD carga un archivo de menús, busca un archivo MNL con el mismo nombre de archivo. Si lo encuentra, lo carga en la memoria. Esta función garantiza que AutoCAD carga las funciones de AutoLISP necesarias para el correcto funcionamiento del menú.
    • Prevención de los errores de AutoLISP al cargar archivos de inicio
      Si se produce un error de AutoLISP mientras se está cargando un archivo de inicio, el resto del archivo se pasa por alto y no se carga.
    • Función S::STARTUP: ejecución posterior a la inicialización
      Puede definir una función S::STARTUP para llevar a cabo las operaciones de configuración requeridas tras la inicialización de un dibujo.


Ficha Procedimientos: Carga y ejecución automáticas de las rutinas de AutoLISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Carga y ejecución automáticas de las rutinas de AutoLISP
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Carga y ejecución automáticas de las rutinas de AutoLISP [Manual de personalización: ACG]

AutoLISP y Visual LISP
Carga y ejecución automáticas de las rutinas de AutoLISP
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    Variables de sistema

    ACADLSPASDOC

    Controla si AutoCAD debe cargar el archivo acad.lsp en todos los dibujos o sólo en el primer dibujo abierto en una sesión de AutoCAD


Presentación general de la carga automática de AutoLISP [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Presentación general de la carga automática de AutoLISP
Conceptos
Procedimientos
Referencia

    • AutoCAD carga automáticamente el contenido de tres archivos que puede definir el usuario: acad.lsp, acaddoc.lsp y el archivo MNL asociado con el menú actual. Por defecto, el archivo acad.lsp sólo se carga una vez al iniciarse AutoCAD, mientras que acaddoc.lsp se carga con cada documento o dibujo. Esto permite asociar la carga del archivo acad.lsp con el inicio de la aplicación, y la de acaddoc.lsp con el del documento o dibujo. El método por defecto para cargar estos archivos de inicio se puede modificar cambiando el valor de la variable de sistema ACADLSPASDOC.

    Si uno de estos archivos define una función del tipo especial S::STARTUP, esta rutina se ejecuta inmediatamente después de completar la inicialización del dibujo. Como alternativa, el comando APPLOAD proporciona una opción Cargar al inicio que carga las aplicaciones especificadas sin necesidad de editar ningún archivo.

    Los archivos de inicio acad.lsp y acaddoc.lsp no se suministran con AutoCAD. El usuario puede crear y mantener estos archivos si lo desea.

    Command Autoloader

    Cuando se carga automáticamente un comando utilizando las funciones load o command, la definición del comando ocupa memoria tanto si el comando se usa como si no. La función autoload de AutoLISP permite acceder a los comandos sin cargar las rutinas completas en la memoria. Al añadir el código siguiente al archivo acaddoc.lsp, se cargan automáticamente los comandos CMD1, CMD2 y CMD3 del archivo cmds.lsp y el comando NUEVOCMD del archivo nuevocmd.lsp.

    (autoload "CMDS" '("CMD1" "CMD2" "CMD3"))
    (autoload "NUEVOCMD" '("NUEVOCMD"))

    La primera vez que se introduce un comando cargado automáticamente en la solicitud de comandos, AutoLISP carga la definición completa del comando desde el archivo asociado. AutoLISP también proporciona la función autoarxload para las aplicaciones ObjectARX. Véase autoload y autoarxload en AutoLISP Reference (en el menú Ayuda de AutoCAD, haga clic en Ayuda del desarrollador).

    Nota Los archivos de inicio de AutoLISP con nombres similares se cargan en función del sello horario modificado; se carga el archivo LSP con el sello horario más reciente a menos que se especifique el nombre de archivo completo (incluida la extensión).

    Véase también


Ficha Procedimientos: Presentación general de la carga automática de AutoLISP [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Presentación general de la carga automática de AutoLISP
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de la carga automática de AutoLISP [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Presentación general de la carga automática de AutoLISP
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    Variables de sistema

    ACADLSPASDOC

    Controla si AutoCAD debe cargar el archivo acad.lsp en todos los dibujos o sólo en el primer dibujo abierto en una sesión de AutoCAD


El archivo acad.lsp [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo acad.lsp
Conceptos
Procedimientos
Referencia

    • El archivo acad.lsp resulta útil si desea cargar determinadas rutinas de AutoLISP cada vez que inicie AutoCAD. Cuando se inicia AutoCAD, el programa busca un archivo acad.lsp en la ruta de biblioteca. Si lo encuentra, lo carga en la memoria.

    El archivo acad.lsp se carga en cada inicio de sesión de dibujo cuando AutoCAD se inicia desde el escritorio de Windows. Como el archivo acad.lsp se ha creado para su uso en rutinas de inicio específicas de las aplicaciones, las funciones y variables definidas en un archivo acad.lsp sólo están disponibles en el primer dibujo. Puede mover aquellas rutinas que deban estar disponibles en todos los documentos del archivo acad.lsp al archivo acaddoc.lsp.

    El funcionamiento recomendado de acad.lsp y acaddoc.lsp se puede modificar con la variable de sistema ACADLSPASDOC. Si la variable de sistema ACADLSPASDOC se define como 0 (el valor por defecto), el archivo acad.lsp sólo se carga una vez: en el inicio de la aplicación. Si ACADLSPASDOC tiene el valor 1, el archivo acad.lsp se vuelve a cargar con cada nuevo dibujo.

    La variable de sistema ACADLSPASDOC se pasa por alto en el modo SDI (Single Document Interface, Interfaz de documento único). Cuando se asigna a la variable de sistema SDI el valor 1, la variable de sistema LISPINIT controla la reinicialización de AutoLISP entre dibujos. Cuando LISPINIT tiene el valor 1, las funciones y variables de AutoLISP sólo son válidas para el dibujo actual; cada vez que inicie un nuevo dibujo o abra uno existente, se borrarán de la memoria todas las funciones y variables, y se volverá a cargar el archivo acad.lsp. Si se cambia el valor de LISPINIT cuando la variable de sistema SDI tiene el valor 0, no se produce ningún efecto.

    El archivo acad.lsp puede contener código de AutoLISP para una o varias rutinas, o sólo un conjunto de llamadas a la función load. Es preferible emplear el último método porque facilita la modificación. Si guarda el siguiente código como un archivo acad.lsp, los archivos mysessionapp1.lsp, databasesynch.lsp y drawingmanager.lsp se cargan cada vez que se inicia AutoCAD.

    (load "mysessionapp1")
    (load "databasesynch")
    (load "drawingmanager")

    Advertencia No modifique el archivo reservado acad2000.lsp. Autodesk suministra el archivo acad2000.lsp, que contiene las funciones definidas en AutoLISP requeridas por AutoCAD. Este archivo se carga en la memoria inmediatamente antes de cargar el archivo acad.lsp.

    Véase también


Ficha Procedimientos: El archivo acad.lsp [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo acad.lsp
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: El archivo acad.lsp [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo acad.lsp
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    Variables de sistema

    ACADLSPASDOC

    Controla si AutoCAD debe cargar el archivo acad.lsp en todos los dibujos o sólo en el primer dibujo abierto en una sesión de AutoCAD

    LISPINIT

    Controla la inicialización de las funciones y variables definidas con AutoLISP cuando está activada la interfaz de un solo documento

    SDI

    Controla si AutoCAD se ejecuta en una interfaz de un solo documento o de múltiples documentos


El archivo acaddoc.lsp [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo acaddoc.lsp
Conceptos
Procedimientos
Referencia

    • Cada vez que se abre un dibujo, AutoCAD busca un archivo acaddoc.lsp en la ruta de biblioteca. Si lo encuentra, lo carga en la memoria. El archivo acaddoc.lsp se carga siempre con cada dibujo con independencia de los valores de ACADLSPASDOC y LISPINIT.

    La mayoría de los usuarios tiene un único archivo acaddoc.lsp para todas las rutinas de AutoLISP basadas en documentos. AutoCAD realiza la búsqueda del archivo acaddoc.lsp en el orden definido por la ruta de biblioteca; por tanto, con esta función se puede tener un archivo acaddoc.lsp diferente en cada directorio de dibujo, con lo que se cargarán rutinas específicas de AutoLISP para ciertos tipos de dibujos o trabajos.

    El archivo acaddoc.lsp puede contener el código de AutoLISP para una o varias rutinas, o sólo un conjunto de llamadas a la función load. Es preferible emplear el último método porque facilita la modificación. Si guarda el siguiente código como un archivo acaddoc.lsp, los archivos mydocumentapp1.lsp, build.lsp y counter.lsp se cargan cada vez que se abre un nuevo documento.

    (load "mydocumentapp1")
    (load "build")
    (load "counter")

    AutoCAD realiza la búsqueda de acaddoc.lsp en el orden definido por la ruta de biblioteca; por tanto, se puede tener un archivo acaddoc.lsp diferente en cada directorio de dibujo. De esta forma, puede cargar rutinas de AutoLISP específicas para ciertos tipos de dibujos o trabajos.

    Advertencia No modifique el archivo reservado acad2000doc.lsp. Autodesk suministra el archivo acad2000doc.lsp, que contiene las funciones definidas en AutoLISP requeridas por AutoCAD. Este archivo se carga en la memoria inmediatamente antes de cargar el archivo acaddoc.lsp.

    Véase también


Ficha Procedimientos: El archivo acaddoc.lsp [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo acaddoc.lsp
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: El archivo acaddoc.lsp [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo acaddoc.lsp
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    Variables de sistema

    ACADLSPASDOC

    Controla si AutoCAD debe cargar el archivo acad.lsp en todos los dibujos o sólo en el primer dibujo abierto en una sesión de AutoCAD

    LISPINIT

    Controla la inicialización de las funciones y variables definidas con AutoLISP cuando está activada la interfaz de un solo documento


El archivo MNL de un menú de AutoLISP [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo MNL de un menú de AutoLISP
Conceptos
Procedimientos
Referencia

    • El otro tipo de archivo que AutoCAD carga automáticamente acompaña al archivo de menús actual y tiene la extensión .mnl. Cuando AutoCAD carga un archivo de menús, busca un archivo MNL con el mismo nombre de archivo. Si lo encuentra, lo carga en la memoria.

    Esta función garantiza que AutoCAD carga las funciones de AutoLISP necesarias para el correcto funcionamiento del menú. Por ejemplo, el menú de AutoCAD por defecto, acad.mnu, depende del archivo acad.mnl, que define numerosas funciones de AutoLISP utilizadas por el menú. El archivo MNL se carga después del archivo acaddoc.lsp.

    Nota Si un archivo de menús se carga con la función command de AutoLISP, con una sintaxis similar a (command "menú" "nuevomenu"), el archivo MNL asociado no se carga hasta que se termina de ejecutar la rutina de AutoLISP.

    Por ejemplo, si crea un menú personalizado denominado nuevomenu.mnu y necesita cargar tres archivos de AutoLISP (nuevo1.lsp, nuevo2.lsp y nuevo3.lsp) para que el menú funcione correctamente, debe crear un archivo de texto ASCII con el nombre nuevomenu.mnl de la manera siguiente:

    (load "nuevo1")
    (load "nuevo2")
    (load "nuevo3")
    (princ "\nUtilidades de Nuevomenu... cargadas.")
    (princ)

    En este ejemplo, las llamadas a la función princ se pueden utilizar para mostrar mensajes de estado. La primera llamada a princ muestra el texto siguiente en la línea de comando:

    Utilidades de Nuevomenu... cargadas.

    La 12. Sin esta segunda llamada a princ, el mensaje se mostraría dos veces. Como ya se ha mencionado, se puede incluir el argumento onfailure, que llama a la función load como medida de precaución adicional.


Ficha Procedimientos: El archivo MNL de un menú de AutoLISP [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo MNL de un menú de AutoLISP
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: El archivo MNL de un menú de AutoLISP [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
El archivo MNL de un menú de AutoLISP
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Prevención de los errores de AutoLISP al cargar archivos de inicio [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Prevención de los errores de AutoLISP al cargar archivos de inicio
Conceptos
Procedimientos
Referencia

    • Si se produce un error de AutoLISP mientras se está cargando un archivo de inicio, el resto del archivo se pasa por alto y no se carga.

    Si un archivo de inicio hace referencia a archivos que no existen o que no se encuentran en la ruta de biblioteca de AutoCAD, suelen producirse errores. Por esta razón, puede ser aconsejable utilizar el argumento onfailure con la función load. El siguiente ejemplo utiliza el argumento onfailure:

    (princ (load "mydocapp1" "\nEl archivo MYDOCAPP1.LSP no está cargado."))
    (princ (load "build" "\nEl archivo BUILD.LSP no está cargado."))
    (princ (load "counter" "\nEl archivo COUNTER.LSP no está cargado."))
    (princ)

    Si la llamada a la función load se completa correctamente, devuelve el valor de la última expresión del archivo (generalmente el nombre de la última función definida o un mensaje sobre el uso de dicha función). Si se produce un error durante la llamada, devuelve el valor del argumento onfailure. En el ejemplo anterior, el valor devuelto por la función load se pasa a la función princ y se muestra en la línea de comando.

    Por ejemplo, si se produce un error mientras AutoCAD carga el archivo mydocapp1.lsp, la función princ muestra el siguiente mensaje y AutoCAD continúa con la carga de los dos archivos restantes:

    El archivo MYDOCAPP1.LSP no está cargado.

    Si utiliza la función command en un archivo acad.lsp, acaddoc.lsp o MNL, sólo se debe invocar desde una secuencia defun. Utilice la función S::STARTUP para definir los comandos que deben ejecutarse inmediatamente cuando se inicia una sesión de dibujo.

    Véase también

    Función S::STARTUP: ejecución posterior a la inicialización


Ficha Procedimientos: Prevención de los errores de AutoLISP al cargar archivos de inicio [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Prevención de los errores de AutoLISP al cargar archivos de inicio
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Prevención de los errores de AutoLISP al cargar archivos de inicio [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Prevención de los errores de AutoLISP al cargar archivos de inicio
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Función S::STARTUP: ejecución posterior a la inicialización [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Función S::STARTUP: ejecución posterior a la inicialización
Conceptos
Procedimientos
Referencia

    • Los archivos LISP de inicio (acad.lsp, acaddoc.lsp y MNL) se cargan en la memoria antes de que el dibujo se haya inicializado por completo. Normalmente esto no causa ningún problema, a menos que se desee utilizar la función command, que podría no funcionar si el dibujo no ha terminado de inicializarse.

    Si la función definida por el usuario S::STARTUP está incluida en un archivo acad.lsp, acaddoc.lsp o MNL, se invoca cuando se accede a un dibujo nuevo o se abre uno existente. Por tanto, puede incluir una definición de S::STARTUP en el archivo de inicio de LISP para realizar las operaciones de configuración requeridas.

    Por ejemplo, si desea modificar el comando SOMBREA añadiendo un mensaje y cambiando al comando SOMBCONT, utilice un archivo acaddoc.lsp con el siguiente código:

    (defun C:SOMBREA ( )
      (alert "Se está usando el comando SOMBCONT.")
      (princ "\nIntroduzca OLDHATCH para ir al auténtico comando SOMBREA.\n")
      (command "SOMBCONT")
      (princ)
    )
    (defun C:OLDHATCH ( )
      (command ".SOMBREA")
      (princ)
    )
    (defun-q S::STARTUP ( )
      (command "undefine" "sombrea")
      (princ "\nSOMBREA redefinido como SOMBCONT.\n")
    )

    Antes de que se inicialice el dibujo, se establecen nuevas definiciones de SOMBREA y OLDHATCH con la función defun. Tras la inicialización del dibujo, se llama a la función S::STARTUP y se anula la definición estándar de SOMBREA.

    Nota Para que se añada, la función S::STARTUP debe haberse definido con la función defun-q en lugar de con defun.

    Dado que una función S::STARTUP se puede definir en varios lugares (un archivo acad.lsp, acaddoc.lsp o MNL, o cualquier otro archivo de AutoLISP cargado a partir de ellos), es posible sobrescribir una función S::STARTUP previamente definida. El siguiente ejemplo muestra un método para garantizar que la función de inicio sirve para otras funciones.

    (defun-q MIINICIO ( )

    ... su función de inicio ...

    )
    (setq S::STARTUP (append S::STARTUP MIINICIO))

    El código anterior añade su función de inicio a la de la función S::STARTUP existente y redefine S::STARTUP para que incluya su código de inicio. Este procedimiento funciona correctamente con independencia de la existencia previa de una función S::STARTUP.


Ficha Procedimientos: Función S::STARTUP: ejecución posterior a la inicialización [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Función S::STARTUP: ejecución posterior a la inicialización
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Función S::STARTUP: ejecución posterior a la inicialización [Manual de personalización: ACG]

Carga y ejecución automáticas de las rutinas de AutoLISP
Función S::STARTUP: ejecución posterior a la inicialización
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


ObjectARX [Manual de personalización: ACG]

Introducción a las interfaces de programación
ObjectARX
Conceptos
Procedimientos
Referencia

    • La tecnología ObjectARX proporciona la base que permite que las aplicaciones de software de diseño compartan datos de objeto inteligentes. Puede ejecutar aplicaciones ObjectARX de otros fabricantes o escribir las que necesite.

    • Presentación general de ObjectARX
    • Uso de las aplicaciones de ObjectARX
      Para cargar una aplicación de ObjectARX, utilice la función Load del comando ARX. Tras la carga, todos los comandos definidos por esta aplicación están disponibles en la solicitud de comandos.
    • Carga automática de aplicaciones de ObjectARX
      Algunos ejemplos de ObjectARX contienen un archivo acad.rx, que incluye una lista de los archivos de programa de ObjectARX que se cargan de manera automática cuando se inicia AutoCAD.


Ficha Procedimientos: ObjectARX [Manual de personalización: ACG]

Introducción a las interfaces de programación
ObjectARX
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: ObjectARX [Manual de personalización: ACG]

Introducción a las interfaces de programación
ObjectARX
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    ARX

    Carga, descarga y proporciona información sobre las aplicaciones ObjectARX

    Variables de sistema

    No hay entradas.


Presentación general de ObjectARX [Manual de personalización: ACG]

ObjectARX
Presentación general de ObjectARX
Conceptos
Procedimientos
Referencia

    • ObjectARXTM (AutoCAD Runtime Extension, Extensión de tiempo de ejecución) es un entorno de programación en lenguaje compilado para el desarrollo de aplicaciones de AutoCAD. El entorno de programación ObjectARX incluye diversas bibliotecas de enlace dinámico (DLL) que se ejecutan en el mismo espacio de direcciones que AutoCAD y funcionan directamente con el código y las estructuras de datos esenciales de AutoCAD. Estas bibliotecas aprovechan las ventajas de la arquitectura abierta de AutoCAD y proporcionan acceso directo a las estructuras de bases de datos, al sistema de gráficos y al motor de geometría de AutoCAD con el fin de ampliar las clases y capacidades de AutoCAD durante la ejecución. Además, puede usar las DLL para crear comandos nuevos que funcionen exactamente igual que los comandos originales de AutoCAD.

    Puede utilizar las bibliotecas de ObjectARX en combinación con otras interfaces de programación de AutoCAD, como AutoLISP o VBA, lo que permite la integración de las distintas API.

    El entorno de programación ObjectARX se describe en ObjectARX Developer's Guide. La documentación forma parte de ObjectARX Software Development Kit, que se puede descargar de la sección Development Tools del sitio Web de Autodesk. Para obtener más información, haga clic en Ayuda del desarrollador en el menú Ayuda y, a continuación, haga clic en ObjectARX.


Ficha Procedimientos: Presentación general de ObjectARX [Manual de personalización: ACG]

ObjectARX
Presentación general de ObjectARX
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Presentación general de ObjectARX [Manual de personalización: ACG]

ObjectARX
Presentación general de ObjectARX
Conceptos
Procedimientos
Referencia

    • Comandos

    No hay entradas.

    Variables de sistema

    No hay entradas.


Uso de las aplicaciones de ObjectARX [Manual de personalización: ACG]

ObjectARX
Uso de las aplicaciones de ObjectARX
Conceptos
Procedimientos
Referencia

    • Para cargar una aplicación de ObjectARX, utilice la función Load del comando ARX. Tras la carga, todos los comandos definidos por esta aplicación están disponibles en la solicitud de comandos.

    Algunas aplicaciones de ObjectARX utilizan grandes cantidades de memoria del sistema. Si ha terminado de usar una aplicación y desea eliminarla de la memoria, utilice la opción Unload de ARX.

    También puede cargar una aplicación de ObjectARX con la función arxload de AutoLISP. La sintaxis de la función arxload es prácticamente idéntica a la de la función load utilizada con los archivos de AutoLISP. Si la función arxload carga correctamente el programa de ObjectARX, devuelve el nombre del programa. La sintaxis de la función arxload es la siguiente:

    (arxload nombrearchivo [onfailure])

    Los dos argumentos de la función arxload son nombrearchivo y onfailure. Como ocurre con la función load, el argumento nombrearchivo es necesario y debe incluir la descripción del nombre de ruta completo del archivo de programa de ObjectARX que se desea cargar. El argumento onfailure es opcional y no se suele utilizar cuando los programas de ObjectARX se cargan desde la línea de comando. El siguiente ejemplo carga la aplicación de ObjectARX miapl.arx.

    (arxload "miapl")

    Al igual que en los archivos de AutoLISP, AutoCAD busca el archivo especificado en la ruta de biblioteca. Si necesita cargar un archivo que no está en la ruta de biblioteca, especifique la descripción del nombre de ruta completo del archivo.

    Nota Al especificar la ruta de un directorio, debe utilizar una barra oblicua (/) o dos barras invertidas (\\) como separador, ya que una única barra invertida tiene un significado concreto en AutoLISP.

    Al intentar cargar una aplicación que ya se ha cargado se produce un error. Antes de usar arxload, emplee la función arx para comprobar qué aplicaciones están cargadas actualmente.

    Para descargar una aplicación con AutoLISP, utilice la función arxunload. El ejemplo siguiente descarga la aplicación miapl.

    (arxunload "miapl")

    La función arxunload no sólo elimina la aplicación de la memoria, también elimina las definiciones de comandos asociadas con esa aplicación.

    Véase también

    Presentación general de la organización de archivos en la página


Ficha Procedimientos: Uso de las aplicaciones de ObjectARX [Manual de personalización: ACG]

ObjectARX
Uso de las aplicaciones de ObjectARX
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de las aplicaciones de ObjectARX [Manual de personalización: ACG]

ObjectARX
Uso de las aplicaciones de ObjectARX
Conceptos
Procedimientos
Referencia

    • Comandos

    ARX

    Carga, descarga y proporciona información sobre las aplicaciones ObjectARX

    Variables de sistema

    No hay entradas.


Carga automática de aplicaciones de ObjectARX [Manual de personalización: ACG]

ObjectARX
Carga automática de aplicaciones de ObjectARX
Conceptos
Procedimientos
Referencia

    • Algunos ejemplos de ObjectARX contienen un archivo acad.rx, que incluye una lista de los archivos de programa de ObjectARX que se cargan de manera automática cuando se inicia AutoCAD.

    Puede crear o editar este archivo con un editor o procesador de texto que genere archivos de texto en formato ASCII, añadiendo o suprimiendo parte de su contenido para permitir el acceso a los programas de ObjectARX adecuados. Como alternativa, el comando APPLOAD proporciona una opción Cargar al inicio que carga las aplicaciones especificadas sin necesidad de editar ningún archivo.

    Como AutoCAD realiza la búsqueda del archivo acad.rx en el orden especificado por la ruta de biblioteca, puede haber un archivo acad.rx diferente en cada directorio de dibujo. De esta forma, determinados programas de ObjectARX estarán disponibles para ciertos tipos de dibujos. Por ejemplo, puede guardar los dibujos 3D en un directorio denominado TrabajosAcad/dibs_3d. Si ese directorio se ha establecido como directorio actual, puede copiar en él el archivo acad.rx y modificarlo de la siguiente forma:

    miapl1
    otrasapl

    Si guarda este nuevo archivo acad.rx en el directorio TrabajosAcad/dibs_3d e inicia AutoCAD con ese directorio como actual, estos nuevos programas de ObjectARX se cargan y se puede acceder a ellos desde la línea de comando de AutoCAD. Como el archivo acad.rx original sigue en el directorio con los archivos de programa de AutoCAD, el archivo acad.rx por defecto se cargará si se inicia AutoCAD desde otro directorio que no contenga un archivo acad.rx.

    Puede cargar los programas de ObjectARX desde un archivo MNL utilizando la función arxload. Esto garantiza que un programa de ObjectARX, requerido para el correcto funcionamiento de un menú, se cargará cuando se haya cargado el archivo de menús.

    También puede cargar automáticamente los comandos de AutoCAD definidos en ObjectARX. Véase autoarxload en AutoLISP Reference (en el menú Ayuda de AutoCAD, haga clic en Ayuda del desarrollador).

    Véase también

    Presentación general de la carga automática de AutoLISP


Ficha Procedimientos: Carga automática de aplicaciones de ObjectARX [Manual de personalización: ACG]

ObjectARX
Carga automática de aplicaciones de ObjectARX
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Carga automática de aplicaciones de ObjectARX [Manual de personalización: ACG]

ObjectARX
Carga automática de aplicaciones de ObjectARX
Conceptos
Procedimientos
Referencia

    • Comandos

    APPLOAD

    Carga y descarga aplicaciones y define las aplicaciones que se van a cargar al iniciar

    Variables de sistema

    No hay entradas.


Códigos ASCII [Manual de personalización: ACG]

Códigos ASCII

    • La siguiente lista enumera los códigos ASCII estándar. El valor octal es útil para constantes de caracteres o cadenas con el formato \nnn. Su sistema puede definir códigos adicionales en el conjunto ampliado de 256 caracteres (los códigos adicionales son los que están por encima de 127). Determinados sistemas también redefinen algunos de los códigos ASCII menos utilizados, como 1–6 y 14–26.

    Para ver los caracteres del sistema con los códigos en formato decimal y octal, utilice el comando ASCII de AutoLISP® (descrito en ASCII Code Conversion en AutoLISP Developer's Guide). Los caracteres se muestran en una tabla en la pantalla y se almacenan en un archivo denominado ascii.txt.

    Dec. | Oct. | Hex. | Carácter | Dec. | Oct. | Hex. | Carácter
0 | 000 | 00 | NUL | 23 | 027 | 17 | ETB
1 | 001 | 01 | SOH | 24 | 030 | 18 | CAN
2 | 002 | 02 | STX | 25 | 031 | 19 | EM
3 | 003 | 03 | ETX | 26 | 032 | 1A | SUB
4 | 004 | 04 | EOT | 27 | 033 | 1B | ESC (escape)
5 | 005 | 05 | ENQ | 28 | 034 | 1C | FS
6 | 006 | 06 | ACK | 29 | 035 | 1D | GS
7 | 007 | 07 | BEL (campana) | 30 | 036 | 1E | RS
8 | 010 | 08 | BS (retroceso) | 31 | 037 | 1F | US
9 | 011 | 09 | HT | 32 | 040 | 20 | (espacio)
10 | 012 | 0A | LF (avance de línea) | 33 | 041 | 21 | !
11 | 013 | 0B | VT | 34 | 042 | 22 | "
12 | 014 | 0C | FF | 35 | 043 | 23 | #
13 | 015 | 0D | CR (retorno) | 36 | 044 | 24 | $
14 | 016 | 0E | SO | 37 | 045 | 25 | %
15 | 017 | 0F | SI | 38 | 046 | 26 | &
16 | 020 | 10 | DLE | 39 | 047 | 27 | `
17 | 021 | 11 | DC1 | 40 | 050 | 28 | (
18 | 022 | 12 | DC2 | 41 | 051 | 29 | )
19 | 023 | 13 | DC3 | 42 | 052 | 2A | *
20 | 024 | 14 | DC4 | 43 | 053 | 2B | +
21 | 025 | 15 | NAK | 44 | 054 | 2C | ,
22 | 026 | 16 | SYN | 45 | 055 | 2D | -
46 | 056 | 2E | . | 69 | 105 | 45 | E
47 | 057 | 2F | / | 70 | 106 | 46 | F
48 | 060 | 30 | 0 | 71 | 107 | 47 | G
49 | 061 | 31 | 1 | 72 | 110 | 48 | H
50 | 062 | 32 | 2 | 73 | 111 | 49 | I
51 | 063 | 33 | 3 | 74 | 112 | 4A | J
52 | 064 | 34 | 4 | 75 | 113 | 4B | K
53 | 065 | 35 | 5 | 76 | 114 | 4C | L
54 | 066 | 36 | 6 | 77 | 115 | 4D | M
55 | 067 | 37 | 7 | 78 | 116 | 4E | N
56 | 070 | 38 | 8 | 79 | 117 | 4F | O
57 | 071 | 39 | 9 | 80 | 120 | 50 | P
58 | 072 | 3A | : | 81 | 121 | 51 | Q
59 | 073 | 3B | ; | 82 | 122 | 52 | R
60 | 074 | 3C | < | 83 | 123 | 53 | S
61 | 075 | 3D | = | 84 | 124 | 54 | T
62 | 076 | 3E | > | 85 | 125 | 55 | U
63 | 077 | 3F | ? | 86 | 126 | 56 | V
64 | 100 | 40 | @ | 87 | 127 | 57 | W
65 | 101 | 41 | A | 88 | 130 | 58 | X
66 | 102 | 42 | B | 89 | 131 | 59 | Y
67 | 103 | 43 | C | 90 | 132 | 5A | Z
68 | 104 | 44 | D | 91 | 133 | 5B | [
92 | 134 | 5C | \ | 115 | 163 | 73 | s
93 | 135 | 5D | ] | 116 | 164 | 74 | t
94 | 136 | 5E | ^ | 117 | 165 | 75 | u
95 | 137 | 5F | _ | 118 | 166 | 76 | v
96 | 140 | 60 | ` | 119 | 167 | 77 | w
97 | 141 | 61 | a | 120 | 170 | 78 | x
98 | 142 | 62 | b | 121 | 171 | 79 | y
99 | 143 | 63 | c | 122 | 172 | 7A | z
100 | 144 | 64 | d | 123 | 173 | 7B | {
101 | 145 | 65 | e | 124 | 174 | 7C | |
102 | 146 | 66 | f | 125 | 175 | 7D | }
103 | 147 | 67 | g | 126 | 176 | 7E | ~
104 | 150 | 68 | h | 127 | 177 | 7F | DEL (suprimir)
105 | 151 | 69 | i |  |  |  |
106 | 152 | 6A | j |  |  |  |
107 | 153 | 6B | k |  |  |  |
108 | 154 | 6C | l |  |  |  |
109 | 155 | 6D | m |  |  |  |
110 | 156 | 6E | n |  |  |  |
111 | 157 | 6F | o |  |  |  |
112 | 160 | 70 | p |  |  |  |
113 | 161 | 71 | q |  |  |  |
114 | 162 | 72 | r |  |  |  |


Formas y tipos de letra de formas [Manual de personalización: ACG]

Formas y tipos de letra de formas
Conceptos
Procedimientos
Referencia

    • Puede definir las formas que desee utilizar como símbolos de dibujo y tipos de letra de texto. En esta sección se describe la manera de crear y compilar archivos de tipo de letra y forma.

    • Presentación general de los archivos de forma
    • Creación de archivos de definición de forma
      Los archivos de tipo de letra y forma de AutoCAD (SHX) se compilan a partir de archivos de definición de forma (SHP). Los archivos de definición de forma se pueden crear o modificar con un editor o procesador de texto que permita guardar los archivos en formato ASCII.


Ficha Procedimientos: Formas y tipos de letra de formas [Manual de personalización: ACG]

Formas y tipos de letra de formas
Conceptos
Procedimientos
Referencia

    • Para compilar un archivo de forma o tipo de letra

    Para usar los archivos de ejemplo

    Para añadir definiciones de superíndice y subíndice a un tipo de letra


Ficha Referencia: Formas y tipos de letra de formas [Manual de personalización: ACG]

Formas y tipos de letra de formas
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Presentación general de los archivos de forma [Manual de personalización: ACG]

Formas y tipos de letra de formas
Presentación general de los archivos de forma
Conceptos
Procedimientos
Referencia

    • Las formas son objetos que se usan de manera similar a los bloques. En primer lugar, utilice el comando CARGA para cargar el archivo de forma compilado que contiene la definición de la forma. A continuación, use el comando FORMA para insertar las formas del archivo en el dibujo. Puede especificar la escala y la rotación que desea utilizar para cada forma en el momento de añadirla. Un tipo de letra SHP de AutoCAD® es un tipo especial de archivo de forma y se define de manera idéntica a éstos.

    Los bloques son más versátiles y fáciles de utilizar y aplicar que las formas. Sin embargo, AutoCAD almacena y dibuja las formas de una manera más eficiente. Las formas definidas por el usuario resultan útiles cuando se necesita insertar una pieza simple muchas veces y cuando la velocidad es un factor relevante.

    Compilación de archivos de forma y tipo de letra

    La descripción de las formas se debe introducir en un archivo de texto con un formato especial y con la extensión de archivo .shp. Para crear el archivo, utilice un editor o procesador de texto que permita guardar en formato ASCII, y a continuación, compile el archivo ASCII guardado. La compilación de un archivo de definición de forma (SHP) genera un archivo de forma compilado (SHX).

    El archivo compilado tiene el mismo nombre que el archivo de definición de forma con la extensión SHX. Si el archivo de definición de forma define un tipo de letra, utilice el comando ESTILO para establecer un estilo de texto. A continuación, utilice uno de los comandos de ubicación de texto ( TEXTO o TEXTOM) para situar los caracteres en el dibujo. Si el archivo de definición de forma define formas, utilice el comando CARGA para cargar el archivo de forma en el dibujo. A continuación, use el comando FORMA para colocar las formas individuales en el dibujo (este proceso es similar al del comando INSERT).

    Compilación de tipos de letra PostScript

    Para utilizar un tipo de letra PostScript® de tipo 1 en AutoCAD, compílela primero para convertirla en un archivo de forma de AutoCAD. El comando COMPILA acepta la introducción de archivos SHP y PFB, y genera un archivo SHX. Las versiones compiladas de los tipos de letra PostScript pueden ocupar una cantidad considerable de espacio en disco. Por esta razón, es aconsejable compilar solamente aquellos tipos de letra que se usen con frecuencia.

    AutoCAD no puede compilar y cargar todos los tipos de letra de tipo 1. Las funciones de tipos de letra PostScript de AutoCAD están diseñadas para procesar un subconjunto de tipos de letra Adobe. Si se produce un error durante la compilación de un tipo de letra PostScript, es posible que el archivo SHX resultante (si ha llegado a generarse uno) no se cargue en AutoCAD.

    Para obtener más información sobre el formato de tipo de letra Adobe Type 1, véase Adobe Type 1 Font Format Version 1.1. Cuando haya comprado e instalado estos tipos de letra, podrá empezar a utilizarlos con AutoCAD.

    Nota Asegúrese de entender la información de copyright relativa a los tipos de letra PostScript que utilice. En general, estas mismas restricciones de copyright son aplicables al formato SHX de los tipos de letra compilados.


Para compilar un archivo de forma o tipo de letra [Manual de personalización: ACG]

Formas y tipos de letra de formas
Presentación general de los archivos de forma
Conceptos
Procedimientos
Referencia

    • Para compilar un archivo de forma o tipo de letra

    • En la línea de comando, escriba compila.

    En el cuadro de diálogo Seleccionar archivo de forma, puede seleccionar un archivo de definición de forma (SHP) o un archivo de tipo de letra PostScript (PFB). La compilación comienza en cuanto se selecciona el nombre de archivo. Si AutoCAD detecta un error en las descripciones de las formas, aparece un mensaje en el que se indica el tipo de error y el número de línea. Una vez completada la compilación, aparecen los siguientes mensajes:

    Compilación completada.

    El archivo de salida nombre.shx contiene nnn bytes.


Ficha Referencia: Presentación general de los archivos de forma [Manual de personalización: ACG]

Formas y tipos de letra de formas
Presentación general de los archivos de forma
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Creación de archivos de definición de forma [Manual de personalización: ACG]

Formas y tipos de letra de formas
Creación de archivos de definición de forma
Conceptos
Procedimientos
Referencia

    • Los archivos de tipo de letra y forma de AutoCAD (SHX) se compilan a partir de archivos de definición de forma (SHP). Los archivos de definición de forma se pueden crear o modificar con un editor o procesador de texto que permita guardar los archivos en formato ASCII.

    • Descripciones de formas
      Los archivos de tipo de letra y forma de AutoCAD (SHX) se compilan a partir de archivos de definición de forma (SHP). Los archivos de definición de forma se pueden crear o modificar con un editor o procesador de texto que permita guardar los archivos en formato ASCII.
    • Código de longitud y dirección del vector
      Un byte de especificación de forma simple contiene la longitud y la dirección del vector codificadas en un byte de especificación.
    • Códigos especiales
      Además de definir vectores, un byte de especificación puede utilizar códigos especiales para crear formas adicionales y especificar determinadas acciones.
    • Descripciones de tipo de letra de texto
      Los tipos de letra de texto deben incluir un número de forma especial, 0, que proporciona información sobre el tipo de letra.
    • Archivos de ejemplo
      Este tema contiene archivos de ejemplo que ayudan a ampliar los caracteres de tipo de letra proporcionados con AutoCAD.
    • Descripciones de tipos de letra grandes
      Algunos idiomas, como el japonés, utilizan tipos de letra con miles de caracteres que no pertenecen al código ASCII. A fin de que los dibujos puedan incluir este tipo de texto, AutoCAD admite un formato especial de archivo de definición de forma denominado archivo de tipo de letra grande.
    • Descripciones de tipos de letra Unicode
      Los archivos de definición de formas Unicode son prácticamente idénticos a los archivos de definición de formas de AutoCAD normales en cuanto a formato y sintaxis. La principal diferencia radica en la sintaxis del encabezado del tipo de letra.
    • Superíndices y subíndices en los archivos SHX
      Puede modificar los archivos de definición de forma para mejorar la visualización de los superíndices y subíndices.


Ficha Procedimientos: Creación de archivos de definición de forma [Manual de personalización: ACG]

Formas y tipos de letra de formas
Creación de archivos de definición de forma
Conceptos
Procedimientos
Referencia

    • Para usar los archivos de ejemplo

    Para añadir definiciones de superíndice y subíndice a un tipo de letra


Ficha Referencia: Creación de archivos de definición de forma [Manual de personalización: ACG]

Formas y tipos de letra de formas
Creación de archivos de definición de forma
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Descripciones de formas [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de formas
Conceptos
Procedimientos
Referencia

    • La sintaxis de la descripción de forma para cada forma o carácter es la misma con independencia del uso final (como forma o tipo de letra) de esa descripción. Si un archivo de definición de forma se va a utilizar como archivo de tipo de letra, la primera entrada del archivo describe el tipo de letra, en lugar de una forma del archivo. Si esta entrada inicial describe una forma, el archivo se utilizará como archivo de forma.

    Conocer la manera de crear definiciones de formas resulta de gran utilidad. Recuerde, no obstante, que se trata de un tema complejo cuyo aprendizaje requiere paciencia.

    Cada línea de un archivo de definición de forma puede tener un máximo de 128 caracteres. No es posible compilar líneas más largas. Puesto que AutoCAD pasa por alto las líneas en blanco y el texto situado a la derecha de los signos de punto y coma, puede insertar comentarios en los archivos de definición de forma.

    Cada descripción de forma incluye una línea de encabezado con el siguiente formato seguida por una o varias líneas con bytes de especificación separados por comas que terminan con un 0.

    *shapenumber,defbytes,shapename
    specbyte1,specbyte2,specbyte3,...,0

    A continuación, se definen los campos de una descripción de forma:

    shapenumber

    Un número, único para cada archivo, comprendido entre 1 y 258 ( 32768 en los tipos de letra Unicode), y precedido por un asterisco (*). Los archivos cuyos tipos de letra no son Unicode utilizan los números de forma 256, 257 y 258 para los identificadores de símbolos Degree_Sign, Plus_Or_Minus_Sign y Diameter_Symbol. En los tipos de letra Unicode, estos caracteres aparecen en los números de forma U+00B0, U+00B1 y U+2205, y son parte del subconjunto "Latino ampliado-A".

    Los tipos de letra de texto (archivos que contienen las definiciones de forma de cada carácter) requieren números específicos correspondientes al valor de cada carácter en el código ASCII; las otras formas pueden tener asignado cualquier número.

    defbytes

    Número de bytes de datos (specbytes) requeridos para describir la forma, incluido el 0 final. Hay un límite de 2.000 bytes por forma.

    shapename

    Nombre de la forma. Los nombres de formas deben escribirse en mayúsculas para que se reconozcan. Los nombres con caracteres en minúsculas se pasan por alto y se suelen emplear para asignar un rótulo a las definiciones de formas de tipos de letra.

    specbyte

    Byte de especificación de forma. Cada byte de especificación es un código que define la longitud y dirección de un vector, o uno de los varios códigos especiales posibles. Un byte de especificación se puede expresar en el archivo de definición de forma como un valor decimal o hexadecimal. Esta sección utiliza valores de bytes de especificación decimales y hexadecimales en sus ejemplos (como muchos de los archivos de definición de forma). Si el primer carácter de un byte de especificación es 0 (cero), los dos caracteres siguientes se interpretan como valores hexadecimales.


Ficha Procedimientos: Descripciones de formas [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de formas
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Descripciones de formas [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de formas
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Código de longitud y dirección del vector [Manual de personalización: ACG]

Creación de archivos de definición de forma
Código de longitud y dirección del vector
Conceptos
Procedimientos
Referencia

    • Un byte de especificación de forma simple contiene la longitud y la dirección del vector codificadas en un byte de especificación (un campo specbyte). Cada código de longitud y dirección de vector es una cadena de tres caracteres. El primer carácter debe ser un 0, que indica a AutoCAD que los dos caracteres siguientes se tienen que interpretar como valores hexadecimales. El segundo carácter especifica la longitud del vector en unidades. Los valores hexadecimales válidos están comprendidos entre 1 (una unidad) y F (15 unidades). El tercer carácter especifica la dirección del vector. La figura siguiente muestra los códigos de dirección.

    Todos los vectores de la figura anterior se han dibujado con la misma especificación de longitud. Los vectores diagonales se estiran para ajustarse al desplazamiento X o Y del vector ortogonal más cercano, de manera similar a la acción de la rejilla de forzado de AutoCAD.

    El ejemplo siguiente construye una forma denominada CDIAG con el número de forma 230, asignado arbitrariamente.

    *230,6,CDIAG
    014,010,01C,018,012,0

    La secuencia anterior de bytes de especificación define un cuadro de una unidad de alto por una de ancho con una línea diagonal que va de la esquina inferior izquierda a la esquina superior derecha. Tras guardar el archivo como cdiag.shp, utilice el comando COMPILA para generar el archivo cdiag.shx. Use el comando CARGA para cargar el archivo de forma que contiene esta definición y, a continuación, emplee el comando FORMA de la manera siguiente:

    Comando: forma

    Indique nombre de forma o [?]: cdiag

    Precise punto de inserción: 1,1

    Precise altura <actual>: 2

    Precise ángulo de rotación <actual>: 0

    La forma resultante se muestra en la siguiente ilustración.


Ficha Procedimientos: Código de longitud y dirección del vector [Manual de personalización: ACG]

Creación de archivos de definición de forma
Código de longitud y dirección del vector
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Código de longitud y dirección del vector [Manual de personalización: ACG]

Creación de archivos de definición de forma
Código de longitud y dirección del vector
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Códigos especiales [Manual de personalización: ACG]

Creación de archivos de definición de forma
Códigos especiales
Conceptos
Procedimientos
Referencia

    • Además de definir vectores, un byte de especificación puede utilizar códigos especiales para crear formas adicionales y especificar determinadas acciones. Para usar un código especial, el segundo carácter de la cadena de tres caracteres (la especificación de la longitud del vector) debe ser 0. También puede especificar únicamente el número del código. Por ejemplo, tanto 008 como 8 son especificaciones válidas.

    • Códigos 0, 1 y 2: controles de modo de dibujo y fin de forma
    • Códigos 3 y 4: control del tamaño
    • Códigos 5 y 6: almacenamiento y restauración de la ubicación
    • Código 7: subforma
    • Códigos 8 y 9: desplazamientos X-Y
    • Código 00A: arco de octante
    • Código 00B: arco fraccional
    • Códigos 00C y 00D: arcos especificados por la curvatura


Ficha Procedimientos: Códigos especiales [Manual de personalización: ACG]

Creación de archivos de definición de forma
Códigos especiales
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Códigos especiales [Manual de personalización: ACG]

Creación de archivos de definición de forma
Códigos especiales
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Códigos 0, 1 y 2: controles de modo de dibujo y fin de forma [Manual de personalización: ACG]

Códigos especiales
Códigos 0, 1 y 2: controles de modo de dibujo y fin de forma
Conceptos
Procedimientos
Referencia

    • El código 0 marca el final de la definición de forma.

    Los códigos 1 y 2 controlan el modo de dibujo. Este modo se activa al principio de cada forma. Cuando el modo de dibujo está activado (código 1), los vectores hacen que se dibujen las líneas. Cuando está desactivado (código 2), los vectores se mueven a una nueva ubicación sin dibujar.


Ficha Procedimientos: Códigos 0, 1 y 2: controles de modo de dibujo y fin de forma [Manual de personalización: ACG]

Códigos especiales
Códigos 0, 1 y 2: controles de modo de dibujo y fin de forma
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Códigos 0, 1 y 2: controles de modo de dibujo y fin de forma [Manual de personalización: ACG]

Códigos especiales
Códigos 0, 1 y 2: controles de modo de dibujo y fin de forma
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Códigos 3 y 4: control del tamaño [Manual de personalización: ACG]

Códigos especiales
Códigos 3 y 4: control del tamaño
Conceptos
Procedimientos
Referencia

    • Los códigos 3 y 4 controlan el tamaño relativo de cada vector. La altura especificada con el comando FORMA se considera inicialmente la longitud de un único vector ortogonal (direcciones 0, 4, 8 o C). El código 3 divide las longitudes de vector por el siguiente byte. El código 4 multiplica las longitudes de vector por el siguiente byte. Los códigos 3 y 4 van seguidos de un byte de especificación que contiene un factor de escala entero (entre 1 y 255). Si desea que la altura de la forma determine todas las dimensiones de ésta y utiliza 10 longitudes de vector para dibujarla, puede usar 3,10 para establecer la escala de la especificación de la altura. El factor de escala de una forma es acumulativo; es decir, si se multiplica por 2 y, después, por 6, el factor de escala resultante tiene el valor 12. En general, debe invertirse el efecto de los factores de escala al final de la forma, especialmente en el caso de las subformas y de las formas de tipo de letra de texto. AutoCAD no restablece el factor de escala.


Ficha Procedimientos: Códigos 3 y 4: control del tamaño [Manual de personalización: ACG]

Códigos especiales
Códigos 3 y 4: control del tamaño
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Códigos 3 y 4: control del tamaño [Manual de personalización: ACG]

Códigos especiales
Códigos 3 y 4: control del tamaño
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Códigos 5 y 6: almacenamiento y restauración de la ubicación [Manual de personalización: ACG]

Códigos especiales
Códigos 5 y 6: almacenamiento y restauración de la ubicación
Conceptos
Procedimientos
Referencia

    • El código 5 inserta (guarda) y el código 6 extrae (restaura) la posición actual de las coordenadas mientras se dibuja una forma, de manera que se pueda volver a ella desde un punto de la forma dibujado posteriormente. Todo lo que se guarda debe restaurarse. La pila de posiciones tiene un alcance máximo de cuatro ubicaciones. Si se produce un desbordamiento de la pila a causa de una acumulación excesiva de inserciones o de la falta de demasiadas extracciones, aparecerá el siguiente mensaje cuando se dibuje la forma.

    Exceso de flujo de pila de posiciones en forma nnn

    De manera análoga, si intenta extraer más ubicaciones de las que ha insertado en la pila, aparecerá este mensaje.

    Falta de flujo de pila de posiciones en forma nnn


Ficha Procedimientos: Códigos 5 y 6: almacenamiento y restauración de la ubicación [Manual de personalización: ACG]

Códigos especiales
Códigos 5 y 6: almacenamiento y restauración de la ubicación
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Códigos 5 y 6: almacenamiento y restauración de la ubicación [Manual de personalización: ACG]

Códigos especiales
Códigos 5 y 6: almacenamiento y restauración de la ubicación
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Código 7: subforma [Manual de personalización: ACG]

Códigos especiales
Código 7: subforma
Conceptos
Procedimientos
Referencia

    • El código 7 dibuja el número de la subforma que se indica en el siguiente byte. En un tipo de letra que no sea Unicode, el byte de especificación que sigue al código 7 es un número de forma comprendido entre 1 y 255. En un tipo de letra Unicode, tras el código 7 aparece un número de forma Unicode comprendido entre 1 y 65535. Los números de forma Unicode deben contarse como dos bytes. Para obtener información específica sobre las diferencias entre los tipos de letra Unicode y no Unicode, véase Descripciones de tipos de letra Unicode). La forma con ese número (del mismo archivo de forma) se dibuja en este momento. El modo de dibujo no se restablece para la nueva forma. Una vez completada la subforma, se continúa con el dibujo de la forma actual.


Ficha Procedimientos: Código 7: subforma [Manual de personalización: ACG]

Códigos especiales
Código 7: subforma
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Código 7: subforma [Manual de personalización: ACG]

Códigos especiales
Código 7: subforma
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Códigos 8 y 9: desplazamientos X-Y [Manual de personalización: ACG]

Códigos especiales
Códigos 8 y 9: desplazamientos X-Y
Conceptos
Procedimientos
Referencia

    • Los bytes de especificación de los vectores normales sólo dibujan en 16 direcciones predefinidas y la longitud más larga es 15. Estas restricciones, impuestas para hacer más eficiente la definición de formas, resultan a veces limitantes. Los códigos 8 y 9 permiten dibujar vectores no estándar con los desplazamientos XY. El código 8 especifica el desplazamiento X-Y definido por los dos bytes siguientes. El código 8 debe ir seguido por dos bytes de especificación con el formato:

    8,desplazamiento X,desplazamiento Y

    Los desplazamientos XY pueden estar comprendidos entre –128 y +127. El signo + es opcional y se pueden utilizar paréntesis para facilitar la lectura. El siguiente ejemplo da como resultado un vector que dibuja (o mueve) 10 unidades a la izquierda y tres unidades hacia arriba.

    8,(-10,3)

    Tras los dos bytes de especificación de desplazamiento, la forma vuelve al modo de vector normal.

    Puede utilizar el código 9 para dibujar una secuencia de vectores no estándar. El código 9 especifica cualquier número de pares de desplazamiento XY. La secuencia de códigos termina con un par (0,0). El siguiente ejemplo dibuja tres vectores no estándar y devuelve al modo de vector normal.

    9,(3,1),(3,2),(2,-3),(0,0)

    Debe terminar la secuencia de pares de desplazamiento XY con un par (0,0) para que AutoCAD pueda reconocer los vectores normales o códigos especiales que haya a continuación.


Ficha Procedimientos: Códigos 8 y 9: desplazamientos X-Y [Manual de personalización: ACG]

Códigos especiales
Códigos 8 y 9: desplazamientos X-Y
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Códigos 8 y 9: desplazamientos X-Y [Manual de personalización: ACG]

Códigos especiales
Códigos 8 y 9: desplazamientos X-Y
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Código 00A: arco de octante [Manual de personalización: ACG]

Códigos especiales
Código 00A: arco de octante
Conceptos
Procedimientos
Referencia

    • El código especial 00A (o 10) utiliza los dos bytes de especificación siguientes para definir un arco. Éste se denomina arco de octante porque abarca uno o varios octantes de 45 grados, empezando y terminando en el contorno de un octante. Los octantes están numerados en sentido antihorario a partir de la posición de las 3 en punto, tal como se muestra en la siguiente ilustración.

    La especificación del arco es

    10,radius,(–)0SC

    El radio puede ser cualquier valor entre 1 y 255. El segundo byte de especificación indica la dirección del arco (en sentido antihorario si es positivo y horario si es negativo), el octante inicial (s, un valor entre 0 y 7), y el número de octantes que abarca (c, un valor entre 0 y 7, en el que 0 es igual a ocho octantes, un círculo completo). Puede utilizar paréntesis para facilitar la lectura. Por ejemplo, considere el siguiente fragmento de la definición de una forma:

    ...012,10,(1,-032),01E,...

    Este código dibuja un vector de una unidad hacia arriba y a la derecha, un arco en sentido horario desde el octante 3 (con un radio de una unidad y a lo largo de dos octantes) y, por último, un vector de una unidad hacia abajo y a la derecha, como se muestra en la siguiente ilustración.


Ficha Procedimientos: Código 00A: arco de octante [Manual de personalización: ACG]

Códigos especiales
Código 00A: arco de octante
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Código 00A: arco de octante [Manual de personalización: ACG]

Códigos especiales
Código 00A: arco de octante
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Código 00B: arco fraccional [Manual de personalización: ACG]

Códigos especiales
Código 00B: arco fraccional
Conceptos
Procedimientos
Referencia

    • El código especial 00B (11) dibuja un arco que no empieza y termina necesariamente en el contorno de un octante. La definición utiliza cinco bytes de especificación.

    11,start_offset,end_offset,high_radius,radius,(-)0SC

    start_offset y end_offset representan la distancia entre el contorno del octante y el punto en el que comienza o finaliza el arco. high_radius representa los ocho bits más significativos del radio; este valor será igual a 0 a menos que radius sea mayor de 255 unidades. Multiplique el valor de high_radius por 256 y sume ese valor al de radius para generar un radio de arco mayor que 255. radius y el byte de especificación final son iguales que los de la especificación del arco de octante (código 00A, descrito anteriormente).

    start offset se determina calculando la diferencia en grados entre el contorno del octante inicial (un múltiplo de 45 grados) y el inicio del arco. A continuación, multiplique esta diferencia por 256 y divídala por 45. Si el arco comienza en el contorno de un octante, start offset es igual a 0.

    end offset se calcula de una manera similar, pero utilizando el número de grados entre el último contorno de octante atravesado y el final del arco. Si el arco termina en el contorno de un octante, end offset es igual a 0.

    Por ejemplo, un arco fraccional que va desde 55 grados hasta 95 grados con un radio de 3 unidades tendría el siguiente código:

    11,(56,28,0,3,012)

    La explicación es la siguiente:

    start_offset     = 56 porque ((55 - 45) * 256 / 45) = 56
    end_offset       = 28 porque ((95 - 90) * 256 / 45) = 28
    high_radius      = 0  porque (radius < 255)
    radius           = 3
    octante inicial  = 1  porque el arco comienza en el octante de 45 grados
    octante final    = 2  porque el arco finaliza en el octante de 90 grados


Ficha Procedimientos: Código 00B: arco fraccional [Manual de personalización: ACG]

Códigos especiales
Código 00B: arco fraccional
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Código 00B: arco fraccional [Manual de personalización: ACG]

Códigos especiales
Código 00B: arco fraccional
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Códigos 00C y 00D: arcos especificados por la curvatura [Manual de personalización: ACG]

Códigos especiales
Códigos 00C y 00D: arcos especificados por la curvatura
Conceptos
Procedimientos
Referencia

    • Los códigos especiales 00C y 00D (12 y 13) proporcionan otro mecanismo para incluir segmentos de arco en las descripciones de formas. Son similares a los códigos 8 y 9, ya que se pueden utilizar para especificar desplazamientos XY. Sin embargo, los códigos 00C y 00D dibujan arcos aplicando un factor de curvatura al vector de desplazamiento. El código 00C dibuja un segmento de arco, mientras que el código 00D dibuja varios segmentos de arco (poliarcos) hasta que termina con un desplazamiento (0,0).

    El código 00C debe estar seguido de tres bytes que describen el arco:

    0C,X-displacement,Y-displacement,Bulge

    Tanto los desplazamientos X e Y como la curvatura, que especifica la curvatura del arco, pueden variar entre –127 y +127. Si el segmento de línea especificado por el desplazamiento tiene la longitud D y la distancia perpendicular desde el punto medio de ese segmento tiene la altura H, la magnitud de la curvatura es ((2 * H / D) * 127). El signo es negativo si el arco descrito desde la ubicación actual hasta la nueva posición tiene sentido horario.

    Un semicírculo tiene la curvatura 127 (o –127) y es el mayor arco que se puede representar como un segmento de arco simple utilizando estos códigos (use dos segmentos de arco consecutivos para obtener arcos más grandes). Una especificación de curvatura de 0 es válida y representa un segmento de línea recta. Tenga en cuenta, sin embargo, que utilizar el código 8 para un segmento de línea recta ahorra un byte en la descripción de la forma.

    El código de poliarco (00D o 13) va seguido de 0 o por más tríos de segmentos de arco, y termina con un desplazamiento (0,0). No se especifica un valor de la curvatura después del desplazamiento final. Por ejemplo, la letra S se puede definir con la siguiente secuencia:

    13,(0,5,127),(0,5,-127),(0,0)

    Los segmentos de curvatura cero resultan útiles en los poliarcos para representar los segmentos rectos; son más eficientes que terminar el poliarco, insertar un segmento recto e iniciar, por último, otro poliarco.

    El número –128 no se puede utilizar en las definiciones de segmentos de arco y poliarcos.


Ficha Procedimientos: Códigos 00C y 00D: arcos especificados por la curvatura [Manual de personalización: ACG]

Códigos especiales
Códigos 00C y 00D: arcos especificados por la curvatura
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Códigos 00C y 00D: arcos especificados por la curvatura [Manual de personalización: ACG]

Códigos especiales
Códigos 00C y 00D: arcos especificados por la curvatura
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Código 00E: comando indicador de texto vertical [Manual de personalización: ACG]

Códigos especiales
Código 00E: comando indicador de texto vertical
Conceptos
Procedimientos
Referencia

    • El código especial 00E (14) sólo se utiliza en las descripciones de tipo de letra de texto de orientación doble, en las que el tipo de letra se puede usar tanto en la orientación vertical como en la horizontal. Cuando se llega a este código especial en una definición de carácter, el siguiente código se procesa o se pasa por alto dependiendo de la orientación. Si la orientación es vertical, el código siguiente se procesa; si es horizontal, se omite.

    En el texto horizontal, el punto de inicio de cada carácter es el extremo izquierdo de la línea base. En el texto vertical, se asume que el punto de inicio está en el centro de la parte superior del carácter. Al final de cada carácter, se dibuja normalmente un segmento invisible para situar el punto de inicio del siguiente carácter. En el texto horizontal, se encuentra a la derecha; en el vertical, debajo. El código especial 00E (14) se utiliza principalmente para ajustar las diferencias en los puntos iniciales y finales, permitiendo que la misma definición de forma de carácter se utilice en la dirección horizontal y vertical. Por ejemplo, la siguiente definición de una D mayúscula se puede utilizar tanto en el texto horizontal como en el vertical.

    *68,22,ucd
    2,14,8,(-2, 6),1,030,012,044,016,038,2,010,1,06C,2,050,
    14,8,(-4,-3),0


Ficha Procedimientos: Código 00E: comando indicador de texto vertical [Manual de personalización: ACG]

Códigos especiales
Código 00E: comando indicador de texto vertical
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Código 00E: comando indicador de texto vertical [Manual de personalización: ACG]

Códigos especiales
Código 00E: comando indicador de texto vertical
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Descripciones de tipo de letra de texto [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipo de letra de texto
Conceptos
Procedimientos
Referencia

    • AutoCAD se suministra con un gran número de tipos de letra. Puede utilizar el comando ESTILO para aplicar acciones de expansión, compresión o inclinación a cualquiera de estos tipos de letra con el fin de crear caracteres que se adapten a sus necesidades. Con estos tipos de letra, puede dibujar texto de cualquier altura, en cualquier ángulo de la línea base y con orientación horizontal o vertical.

    Si desea crear sus propios tipos de letra de texto, estudie el archivo txt.shp y los otros tipos de letra que se incluyen con AutoCAD. Proporcionan ejemplos prácticos de los temas que se analizan aquí.

    Para obtener más información, véase Archivos de ejemplo.

    Los tipos de letra de texto de AutoCAD son archivos de definiciones de forma con números de forma que corresponden al código ASCII de cada caracter. Para obtener una lista de códigos ASCII, véase Códigos ASCII.

    Los códigos comprendidos entre el 1 y el 31 corresponden a los caracteres de control, sólo uno de los cuales se utiliza en los tipos de letra de texto de AutoCAD:

    10 (LF)

    El avance de línea (LF) baja una línea sin dibujar. Se utiliza cuando se emplea repetidamente el comando TEXT, para colocar líneas adicionales debajo de la primera.

    *10,5,lf
    2,8,(0,-10),0

    Puede modificar el intervalo entre líneas ajustando el movimiento hacia abajo especificado en la definición de forma LF.

    Los tipos de letra de texto deben incluir un número de forma especial, 0, que proporciona información sobre el tipo de letra. El formato tiene la sintaxis siguiente:

    *0,4,font-name
    above,below,modes,0

    El valor de above especifica el número de longitudes de vector por encima de la línea base que ocupan las letras mayúsculas y el de below indica la distancia que las minúsculas ocupan por debajo de la línea base. El concepto de línea base es similar a las líneas del papel para escribir. Estos valores definen el tamaño de carácter básico y se usan como factores de escala para la altura especificada en el comando TEXTO.

    El byte modes debe ser 0 para los tipos de letra orientados horizontalmente y 2 para los tipos con orientación doble (horizontal o vertical). El código de comando especial 00E (14) sólo se aplica cuando modes tiene el valor 2.

    Los tipos de letra estándar suministrados con AutoCAD incluyen algunos caracteres adicionales requeridos para la función de acotación de AutoCAD.

    %%d Símbolo de grado (º)
    %%p Simbolo de tolerancia más/menos (±)
    %%c Símbolo de acotación del diámetro de un círculo

    Puede usar estos símbolos y las secuencias de control %%nnn, tal y como se describe en TEXT en la Lista de comandos de AutoCAD.

    Nota AutoCAD dibuja los caracteres de texto utilizando sus códigos ASCII (números de forma) y no su nombre. Para ahorrar memoria, especifique la parte del nombre de forma de cada definición de forma de texto en minúsculas, como se muestra en el siguiente ejemplo. (Los nombres en minúsculas no se guardan en la memoria.)

    *65,11,uca
    024,043,04d,02c,2,047,1,040,2,02e,0

    Como el nombre de forma uca contiene letras minúsculas, AutoCAD no guarda el nombre en la memoria. Sin embargo, puede utilizar el nombre como referencia cuando edite el archivo de definición de forma. En este ejemplo, uca indica A mayúscula.


Ficha Procedimientos: Descripciones de tipo de letra de texto [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipo de letra de texto
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Descripciones de tipo de letra de texto [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipo de letra de texto
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Archivos de ejemplo [Manual de personalización: ACG]

Creación de archivos de definición de forma
Archivos de ejemplo
Conceptos
Procedimientos
Referencia

    • Este tema contiene archivos de ejemplo que ayudan a ampliar los caracteres de tipo de letra proporcionados con AutoCAD.

    • Extended Simplex Roman


Para usar los archivos de ejemplo [Manual de personalización: ACG]

Creación de archivos de definición de forma
Archivos de ejemplo
Conceptos
Procedimientos
Referencia

    • Para usar los archivos de ejemplo

    1. Ejecute el Bloc de notas o el editor de texto ASCII que prefiera.
    2. Haga clic en el vínculo correspondiente y elija Copiar en el menú Edición.
    3. Pegue el texto en el editor de texto y guarde el archivo.


Ficha Referencia: Archivos de ejemplo [Manual de personalización: ACG]

Creación de archivos de definición de forma
Archivos de ejemplo
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Ficha Procedimientos: Extended Simplex Roman [Manual de personalización: ACG]

Archivos de ejemplo
Extended Simplex Roman
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Extended Simplex Roman [Manual de personalización: ACG]

Archivos de ejemplo
Extended Simplex Roman
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Ficha Procedimientos: Extended Standard Font for UNICODE [Manual de personalización: ACG]

Archivos de ejemplo
Extended Standard Font for UNICODE
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Extended Standard Font for UNICODE [Manual de personalización: ACG]

Archivos de ejemplo
Extended Standard Font for UNICODE
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Descripciones de tipos de letra grandes [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipos de letra grandes
Conceptos
Procedimientos
Referencia

    • Algunos idiomas, como el japonés, utilizan tipos de letra con miles de caracteres que no pertenecen al código ASCII. A fin de que los dibujos puedan incluir este tipo de texto, AutoCAD admite un formato especial de archivo de definición de forma denominado archivo de tipo de letra grande.

    • Definición de un tipo de letra grande
      Los códigos especiales que aparecen en la primera línea de un archivo de tipo de letra grande especifican cómo se deben leer los códigos hexadecimales de dos bytes.
    • Definición de un archivo de tipo de letra grande ampliado
      Para reducir el tamaño de los caracteres Kanji compuestos, puede definir un archivo de tipo de letra grande ampliado. Los tipos de letra grandes ampliados utilizan el código de subforma seguido por un 0.
    • Uso de texto de tipo de letra grande en un dibujo
      Si desea usar un tipo de letra grande para dibujar texto, defina un estilo de texto y, a continuación, especifique el nombre del archivo de tipo de letra grande.
    • Uso de un tipo de letra grande para ampliar un tipo de letra
      Para incluir símbolos especiales en las cadenas de texto, puede utilizar un tipo de letra grande en lugar de ampliar un tipo de letra estándar.


Ficha Procedimientos: Descripciones de tipos de letra grandes [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipos de letra grandes
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Descripciones de tipos de letra grandes [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipos de letra grandes
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Definición de un tipo de letra grande [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Definición de un tipo de letra grande
Conceptos
Procedimientos
Referencia

    • Los códigos especiales que aparecen en la primera línea de un archivo de tipo de letra grande especifican cómo se deben leer los códigos hexadecimales de dos bytes.

    Un tipo de letra con cientos o miles de caracteres se trata de una forma diferente a un tipo de letra que contiene un conjunto ASCII de un máximo de 256 caracteres. Además de emplear técnicas más complejas para buscar en el archivo, AutoCAD necesita una forma de representar los caracteres con códigos de dos bytes, al igual que para representar códigos de un byte. En ambos casos, se recurre al uso de códigos especiales al principio de un archivo de tipo de letra grande.

    La primera línea de una definición de forma de tipo de letra grande debe tener el siguiente formato:

    *BIGFONT nchars,nranges,b1,e1,b2,e2,...

    donde nchars es el número aproximado de definiciones de caracteres de este conjunto; si el margen de error es superior a un 10 por ciento, aproximadamente, se produce un efecto negativo en la velocidad o en el tamaño del archivo. Puede utilizar el resto de la línea para enumerar los códigos de caracteres especiales (códigos de escape) que indican el inicio de un código de dos bytes. Por ejemplo, en los equipos japoneses, los caracteres Kanji comienzan con códigos hexadecimales en los rangos 90-AF o E0-FF. Cuando el sistema operativo ve uno de estos códigos, lee el siguiente byte y lo combina con el anterior para formar el código de un carácter Kanji. En la línea *BIGFONT, nranges indica cuántos rangos de números contiguos se utilizan como códigos de escape; b1, e1, b2, e2, etc., definen los códigos de inicio y finalización de cada rango. Por tanto, el encabezado de un archivo de tipo de letra grande para el idioma japonés tendrá el siguiente aspecto:

    *BIGFONT 4000,2,090,0AF,0E0,0FF

    Tras la línea *BIGFONT, la definición del tipo de letra es como la de cualquier tipo de letra normal de AutoCAD, excepto en que los códigos de caracteres (números de forma) pueden tener valores de hasta 65535.


Ficha Procedimientos: Definición de un tipo de letra grande [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Definición de un tipo de letra grande
Conceptos
Procedimientos
Referencia


Ficha Referencia: Definición de un tipo de letra grande [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Definición de un tipo de letra grande
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Definición de un archivo de tipo de letra grande ampliado [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Definición de un archivo de tipo de letra grande ampliado
Conceptos
Procedimientos
Referencia

    • Para reducir el tamaño de los caracteres Kanji compuestos, puede definir un archivo de tipo de letra grande ampliado. Los tipos de letra grandes ampliados utilizan el código de subforma seguido por un 0.

    La primera línea de un archivo de tipo de letra grande ampliado es igual que la de un archivo de tipo de letra grande normal. Éste es el formato de las siguientes líneas del archivo:

    *0,5,font-name
    character-height, 0, modes, character-width,0
                .
                .
                .
    *shape-number,defbytes,shape-name
                .
    code,0,primitive#,basepoint-x,basepoint-y,width,height,
                .
                .
    code,0,primitive#,basepoint-x,basepoint-y,width,height,
                .
    terminator

    La lista siguiente describe los campos de un archivo de definición de tipo de letra grande:

    character height

    Se utiliza junto con el campo de anchura del carácter para indicar el número de unidades que definen los caracteres del tipo de letra.

    character width

    Se utiliza junto con el campo de altura del carácter para indicar el número de unidades que definen los caracteres del tipo de letra. Los valores de character-height y character-width se utilizan para definir la escala de los primitivos del tipo de letra. En este contexto, los primitivos son los puntos, líneas, polígonos o cadenas de caracteres del tipo de letra orientados geométricamente en el espacio tridimensional. Un carácter Kanji se compone de varios primitivos que se utilizan repetidamente en varias escalas y combinaciones.

    modes

    El byte modes debe tener el valor 0 para un tipo de letra con orientación horizontal y 2 para un tipo de letra con orientación doble (horizontal o vertical). El código del comando especial 00E (14) sólo se aplica cuando el campo modes tiene el valor 2.

    shape-number

    Código de carácter.

    defbytes

    Tamaño del byte. Siempre es igual a 2 bytes y se compone de un código hexadecimal o de una combinación de códigos decimales y hexadecimales.

    shape-name

    Nombre del carácter.

    code

    Código especial de descripción de la forma. Siempre es igual a 7, con lo que puede usar la función de subforma.

    primitive#

    Referencia al número de subforma. Siempre es igual a 2.

    basepoint-x

    Origen X del primitivo.

    basepoint-y

    Origen Y del primitivo.

    width

    Escala de la anchura del primitivo.

    height

    Escala de la altura del primitivo.

    terminator

    Indicador de final de archivo de la definición de la forma. Siempre tiene el valor 0.

    Para llegar al factor de escala, AutoCAD define la escala del primitivo en una unidad cuadrada y, a continuación, la multiplica por la altura y la anchura para obtener la forma del carácter. Los códigos de carácter (números de forma) del archivo de definición de forma de tipo de letra grande pueden tener valores de hasta 65535. La tabla siguiente describe los campos del archivo de tipo de letra grande ampliado.
    Variable | Valor | Tamaño de byte | Descripción
shape-number | xxxx | 2 bytes | Código de carácter
code | 7,0 | 2 bytes | Definición de tipo de letra ampliado
primitive# | xxxx | 2 bytes | Véase número de subforma
basepoint-x |  | 1 byte | Origen X del primitivo
basepoint-y |  | 1 byte | Origen Y del primitivo
width |  | 1 byte | Escala de la anchura del primitivo
height |  | 1 byte | Escala de la altura del primitivo
terminator | 0 | 1 byte | Fin de la definición de forma

    La siguiente figura muestra una matriz de 16 × 16 puntos que se puede utilizar para diseñar un tipo de letra grande ampliado, como un carácter Kanji. En el ejemplo, la distancia entre cada dos puntos es de una unidad. La referencia muestra una unidad cuadrada.

    La figura siguiente muestra ejemplos de caracteres Kanji. Cada carácter ocupa una matriz M × N, (las matrices no son necesariamente cuadradas) similar a la de la figura anterior. Los números situados sobre cada figura son los números de forma asociados.

    La figura siguiente muestra los primitivos Kanji.

    Nota No todos los tipos de letra se definen en una matriz cuadrada; algunos se definen en matrices rectangulares.

    Ejemplo: archivo de definición de forma para un tipo de letra grande ampliado

    *BIGFONT 50,1,080,09e
    *0,5,Extended Font
    15,0,2,15,0
    *08D91,31,unspecified
    2,0e,8,-7,-15,
    7,0,08cfb,0,0,16,16,7,0,08bca,2,3,12,9,
    2,8,18,0,2,0e,8,-11,-3,0
    *08CD8,31,unspecified
    2,0e,8,-7,-15,
    7,0,08be0,0,0,8,16,7,0,08cc3,8,0,8,16,
    2,8,18,0,2,0e,8,-11,-3,0
    *08ADF,31,unspecified
    2,0e,8,-7,-15,
    7,0,089a4,0,0,8,16,7,0,08cb3,8,0,8,16,
    2,8,18,0,2,0e,8,-11,-3,0
    *08CE8,39,unspecified
    2,0e,8,-7,-15,
    7,0,089a4,0,1,5,14,7,0,08cc3,5,2,5,14,7,0,08c8e,9,0,7,
    16,2,8,18,0,2,0e,8,-11,-3,0
    *089A4,39,primitive
    2,0e,8,-7,-15,2,8,1,14,1,0c0,
    2,8,-11,-6,1,0a0,2,8,-12,-7,1,
    0e0,2,8,-7,13,1,0dc,2,8,11,-1,
    2,0e,8,-11,-3,0
    *08BCA,41,primitive
    2,0e,8,-7,-15,2,8,1,14,1,0c0,
    2,8,-11,-6,1,0a0,2,8,-12,-8,1,
    0e0,2,0e5,1,0ec,2,063,1,8,
    2,-3,2,06f,2,0e,8,-11,-3,0
    *08BE0,81,primitive
    2,0e,8,-7,-15,2,8,3,9,1,080,
    2,8,-10,-4,1,0c0,2,8,-13,-5,1,
    0e0,2,8,-7,9,1,09c,2,8,-1,14,
    1,8,-6,-5,2,8,8,5,1,8,6,-5,
    2,8,-11,-6,1,8,1,-3,2,8,7,3,
    1,8,-1,-3,2,8,-3,15,1,01a,2,
    012,1,01e,2,8,10,-14,2,0e,8,
    -11,-3,0
    *08C8E,44,primitive
    2,0e,8,-7,-15,2,8,3,15,1,090,0fc,038,
    2,8,-6,11,1,090,2,8,-9,-5,1,
    090,2,096,1,0ac,8,-1,-3,01a,01a,2,8,
    18,0,2,0e,8,-11,-3,0
    *08CB3,61,primitive
    2,0e,8,-7,-15,2,042,1,02b,02a,018,2,
    0d0,1,012,034,2,069,1,01e,040,2,8,
    -8,6,1,02b,2,8,4,5,1,08c,2,8,
    -3,8,1,03c,2,8,-5,3,1,0e0,2,8,
    -12,5,1,0a0,2,8,6,-14,2,0e,8,
    -11,-3,0
    *08CC3,34,primitive
    2,0e,8,-7,-15,2,0c1,1,06c,0a8,064,0a0,2,8,
    -5,9,1,09c,2,8,-7,5,1,0e0,2,8,
    4,-11,2,0e,8,-11,-3,0
    *08CFB,22,primitive
    2,0e,8,-7,-15,2,0d2,1,0cc,0c8,0c4,0c0,2,8,
    5,-13,2,0e,8,-11,-3,0
    Mostrar todo el texto oculto de esta página.


Ficha Procedimientos: Definición de un archivo de tipo de letra grande ampliado [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Definición de un archivo de tipo de letra grande ampliado
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Definición de un archivo de tipo de letra grande ampliado [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Definición de un archivo de tipo de letra grande ampliado
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Uso de texto de tipo de letra grande en un dibujo [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Uso de texto de tipo de letra grande en un dibujo
Conceptos
Procedimientos
Referencia

    • Si desea usar un tipo de letra grande para dibujar texto, defina un estilo de texto con el comando ESTILO y, a continuación, especifique el nombre del archivo de tipo de letra grande. El mismo estilo de texto puede utilizar también un tipo de letra ASCII normal; escriba sólo los dos nombres de archivo separados por una coma. El siguiente ejemplo utiliza la versión de línea de comando del comando ESTILO. Para activar los tipos de letra grandes desde el cuadro de diálogo Estilo de texto, elija la opción Usar tipos de letra grandes.

    Comando: –estilo

    Indique nombre de estilo de texto o [?] <actual>: nombre_estilo

    Precise nombre completo de tipo de letra o nombre de archivo de tipos de letra (TTF o SHX): txt,greek

    AutoCAD asume que el primer nombre es el tipo de letra normal y el segundo, el tipo de letra grande.

    Si sólo escribe un nombre, AutoCAD asume que se trata del tipo de letra normal y elimina los tipos de letra grandes asociados.

    El empleo de una coma a la izquierda o a la derecha al especificar los nombres del archivo del tipo de letra le permite cambiar un tipo de letra sin por ello afectar a los demás, tal y como queda ilustrado en la tabla siguiente.
    Datos de entrada | Resultado
normal, grande | Tipos de letra normal y grande especificados
normal, | Únicamente tipo de letra normal (no se modifica el tipo de letra grande)
,grande | Únicamente tipo de letra grande (no se modifica el tipo de letra normal)
normal | Únicamente tipo de letra normal (si es necesario, se elimina el tipo de letra grande)
INTRO (respuesta nula) | Ningún cambio

    Cuando utilice el comando ESTILO para mostrar una lista de estilos o revisar un estilo existente, AutoCAD muestra el archivo de tipo de letra normal, una coma y el archivo de tipo de letra grande. Si el estilo sólo tiene un archivo de tipo de letra grande, aparece precedido de una coma, como en, ,greek.

    Para cada carácter de una cadena de texto, AutoCAD inicia la búsqueda en el archivo de tipo de letra grande. Si no encuentra ahí el carácter, prosigue la búsqueda en el archivo de tipo de letra normal.


Ficha Procedimientos: Uso de texto de tipo de letra grande en un dibujo [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Uso de texto de tipo de letra grande en un dibujo
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de texto de tipo de letra grande en un dibujo [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Uso de texto de tipo de letra grande en un dibujo
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Uso de un tipo de letra grande para ampliar un tipo de letra [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Uso de un tipo de letra grande para ampliar un tipo de letra
Conceptos
Procedimientos
Referencia

    • En algunos campos del dibujo, pueden aparecer muchos símbolos especiales en las cadenas de texto. Los tipos de letra de texto estándar de AutoCAD se pueden ampliar para incluir símbolos especiales. No obstante, la ampliación de los tipos de letra de texto estándar tiene algunas limitaciones:

    • Se admite un máximo de 255 formas por archivo de tipo de letra.
    • El conjunto estándar de caracteres utiliza casi la mitad de los números de formas disponibles. Sólo quedan libres los códigos comprendidos entre el 1 y el 9, el 11 y el 31, y el 130 y el 255.
    • Los tipos de letra de texto múltiples requieren la duplicación de las definiciones de símbolos en cada tipo de letra.
    • En el caso de los símbolos especiales es necesario introducir %%nnn, donde nnn es el número de forma del símbolo.

    El método del tipo de letra grande evita estos problemas. Puede seleccionar uno o varios de los caracteres que se utilizan con menos frecuencia, como la tilde (~) o la barra vertical (|), como códigos de escape, y utilizar el siguiente carácter para seleccionar el símbolo especial adecuado. Por ejemplo, puede utilizar el siguiente archivo de tipo de letra grande para dibujar letras griegas introduciendo una barra vertical (|, código ASCII 124) seguida de la letra equivalente del alfabeto latino. Como el primer byte de cada carácter es 124, los códigos de carácter están condicionados por 124 × 256, o 31744.

    *BIGFONT 60,1,124,124
    *0,4,Greek
    above, below, modes, 0
    *31809,n,uca
    . . .   definición de una letra alfa mayúscula, invocada por "|A"
    *31810,n,ucb
    . . .   definición de una letra beta mayúscula, invocada por "|B"
    *31841,n,lca
    . . .   definición de una letra alfa minúscula, invocada por "|a"
    *31842,n,lcb
    . . .   definición de una letra beta minúscula, invocada por "|b"
    *31868,n,vbar
    . . .   definición de la barra vertical, invocada por "||"
    . . .


Ficha Procedimientos: Uso de un tipo de letra grande para ampliar un tipo de letra [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Uso de un tipo de letra grande para ampliar un tipo de letra
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Uso de un tipo de letra grande para ampliar un tipo de letra [Manual de personalización: ACG]

Descripciones de tipos de letra grandes
Uso de un tipo de letra grande para ampliar un tipo de letra
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Descripciones de tipos de letra Unicode [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipos de letra Unicode
Conceptos
Procedimientos
Referencia

    • Los tipos de letra estándar de AutoCAD corresponden a la asignación de caracteres utilizada por el sistema operativo instalado. Esto se debe a que los caracteres se almacenan directamente en la base de datos con el formato en el que se obtienen desde el teclado. Los mismos códigos de carácter se utilizan para generar los tipos de letra. Esto puede plantear un problema cuando se utilizan caracteres acentuados (de 8 bits), para los que existen muchos estándares diferentes de codificación de caracteres.

    A causa de las limitaciones existentes en la asignación de caracteres, AutoCAD proporciona un conjunto de tipos de letra Unicode para las diversas páginas de código que utiliza AutoCAD. Estos tipos de letra, aunque en esencia son iguales, tienen algunos caracteres situados en lugares diferentes, dependiendo de la página de código para la que se han definido. Si la codificación de tipo de letra utilizada no coincide con la del texto del dibujo, podrían dibujarse caracteres erróneos.

    Con los tipos de letra Unicode, las cadenas de texto se convierten a Unicode antes de dibujarse, con lo que se evita la necesidad de proporcionar tipos de letra adicionales para otros idiomas o plataformas. Un único tipo de letra Unicode, gracias a su extenso conjunto de caracteres, puede admitir todos los idiomas y plataformas. Esta función resulta transparente al usuario porque los dibujos se convierten, si es necesario a causa de diferencias en las páginas de códigos, a la página de códigos del sistema AutoCAD durante la carga. Los dibujos siempre se guardan en la página de códigos del sistema AutoCAD.

    Nota Unicode no admite todos los idiomas asiáticos, por lo que algunas de las versiones asiáticas, si no todas, siguen empleando los tipos de letra grandes.

    Los archivos de definición de formas Unicode son prácticamente idénticos a los archivos de definición de formas de AutoCAD normales en cuanto a formato y sintaxis. La principal diferencia radica en la sintaxis del encabezado del tipo de letra, tal como se muestra en el siguiente código:

    *UNIFONT,6,font-name
    above,below,modes,encoding,type,0

    Los parámetros font-name, above, below y modes son iguales a los de los tipos de letra normales. Los dos últimos parámetros se definen del modo siguiente:

    encoding

    Codificación del tipo de letra. Utiliza uno de los siguientes valores enteros.

    0 Unicode
    1 Multibyte comprimido 1
    2 Archivo de forma

    type

    Información sobre la incrustación del tipo de letra. Indica si el tipo de letra tiene licencia. Los tipos de letra con licencia no se deben modificar ni intercambiar. Se pueden añadir valores con códigos de bits.

    0 El tipo de letra se puede incrustar
    1 El tipo de letra no se puede incrustar
    2 La incrustación es de sólo lectura

    Otra diferencia importante que puede causar confusión es el tratamiento de la referencia de la subforma con código 7. Si una descripción de forma incluye una referencia de subforma con código 7, los datos que siguen al código 7 se interpretan como un valor de 2 bytes. Esto afecta al número total de bytes de datos (defbytes) del encabezado de la descripción de la forma. Por ejemplo, la siguiente descripción de forma se encuentra en el archivo romans.shp:

    *00080,4,keuroRef
    7,020AC,0

    El segundo campo del encabezado representa el número total de bytes de la descripción de la forma. Si no está acostumbrado a trabajar con descripciones de tipos de letras Unicode, puede sentirse inclinado a usar 3 bytes en lugar de 4, pero esto causaría un error durante la compilación del archivo SHP. Esto es cierto incluso si el número de forma al que se hace referencia no se encuentra en el rango de dos bytes (por debajo de 255); el compilador siempre utiliza dos bytes para este valor, lo que se debe tener en cuenta en el encabezado.

    La única diferencia adicional entre las definiciones de forma Unifont y las definiciones de forma normales radica en los números de forma. Las definiciones de forma Unifont que proporciona AutoCAD utilizan números de forma hexadecimales, en lugar de valores decimales. Aunque no es obligatorio emplear números hexadecimales, su uso facilita la correspondencia entre los números de forma y los valores de carácter de control \U+.


Ficha Procedimientos: Descripciones de tipos de letra Unicode [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipos de letra Unicode
Conceptos
Procedimientos
Referencia

    • No existen para este tema.


Ficha Referencia: Descripciones de tipos de letra Unicode [Manual de personalización: ACG]

Creación de archivos de definición de forma
Descripciones de tipos de letra Unicode
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Superíndices y subíndices en los archivos SHX [Manual de personalización: ACG]

Creación de archivos de definición de forma
Superíndices y subíndices en los archivos SHX
Conceptos
Procedimientos
Referencia

    • Los tipos de letra SHX de AutoCAD tienen una capacidad limitada para mostrar los superíndices y subíndices. Sin embargo, es relativamente fácil modificar los archivos de definición de forma para mejorar la presentación de estos elementos.

    La creación de los superíndices y subíndices requiere dos pasos. En primer lugar, la "plumilla imaginaria" que crea el texto, vector a vector, en la pantalla debe subirse o bajarse. A continuación, es necesario reducir la "escala" del tipo de letra. Además, se debe llevar a cabo el proceso inverso para volver al tipo de letra normal. El tipo de letra debe reconocer cuatro nuevas claves: dos para los superíndices y dos para los subíndices. Para evitar que se alteren las definiciones de tipos de letras existentes, se puede acceder a ellas con el teclado numérico.


Para añadir definiciones de superíndice y subíndice a un tipo de letra [Manual de personalización: ACG]

Creación de archivos de definición de forma
Superíndices y subíndices en los archivos SHX
Conceptos
Procedimientos
Referencia

    • Para añadir definiciones de superíndice y subíndice a un tipo de letra

    Este procedimiento de ejemplo está basado en el archivo de tipo de letra Romans de AutoCAD, aunque el procedimiento es similar para los otros tipos de letra de AutoCAD. El procedimiento añade cuatro nuevas definiciones de forma a un tipo de letra: super_on, super_off, sub_on y sub_off, que controlan la posición y el tamaño de los caracteres que siguen. Para mayor facilidad, en este ejemplo se reemplazan los corchetes izquierdo y derecho ([ y ]) y las llaves izquierda y derecha ({ y }) con los nuevos caracteres. Puede optar por reemplazar otros caracteres o utilizar un número de forma del rango ampliado (códigos ASCII desde el 128 hasta el 256). Si utiliza un número de forma ampliado, debe usar el método %%nnn (donde nnn es el valor ASCII del carácter) para insertar los nuevos caracteres. (Véase Códigos ASCII.)

    1. Edite el archivo SHP (en este caso romans.shp) con un editor de texto ASCII. Puede crear un nuevo archivo denominado romanss.shp en lugar de modificar el archivo original. El archivo romans.shp puede encontrarse en el CD de AutoCAD.
    2. Busque las definiciones de forma de los caracteres que desee reemplazar. Para introducir comentarios en esas definiciones, de manera que las nuevas definiciones las reemplacen, inserte un signo de punto y coma antes de cada línea de la definición de forma. La definición de forma puede ocupar tantas líneas como sea necesario.

    Los caracteres de corchete izquierdo y derecho tienen los valores ASCII 91 y 93 (valores hexadecimales 05B y 05D, si el tipo de letra es Unicode). Los caracteres de llave derecha e izquierda tienen los valores ASCII 123 y 125 (valores hexadecimales 07B y 07D).

    3. Añada el primer y el segundo valor en la segunda línea de la definición y divida el total entre 2 como se muestra en el siguiente ejemplo:
    *UNIFONT,6,Extended Simplex Roman para UNICODE
    21,7,2,0 21 + 7 = 28, y 28 / 2 = 14. Este número se utiliza más adelante.
    4. Añada las siguientes líneas al final del archivo SHP:
    *91,8,super_on
    2,8,(0,14),003,2,1,0
    *93,8,super_off
    2,004,2,8,(0,-14),1,0
    *123,8,sub_on
    2,8,(0,-14),003,2,1,0
    *125,8,sub_off
    2,004,2,8,(0,14),1,0

    Obsérvense los valores 14 y –14 de las líneas anteriores. Son los desfases en el eje Y de la plumilla imaginaria. El valor 14 es la mitad de la altura máxima de un carácter en este tipo de letra, que es la aproximación correcta para los superíndices y subíndices. Este valor se debe calcular para cada archivo de tipo de letra, pero se puede modificar como se desee.

    5. Guarde el archivo.
    6. Utilice el comando COMPILA para compilar el archivo SHP.

    Una vez que se ha compilado la forma y se ha definido un estilo adecuado, se puede acceder a los nuevos comandos para insertar segmentos visibles e invisibles introduciendo los caracteres [, ],
    { y }. El carácter [ inicia el superíndice y el carácter ] vuelve del superíndice al tipo de letra normal. El carácter { inicia el subíndice y el carácter } vuelve del subíndice al tipo de letra normal.


Ficha Referencia: Superíndices y subíndices en los archivos SHX [Manual de personalización: ACG]

Creación de archivos de definición de forma
Superíndices y subíndices en los archivos SHX
Conceptos
Procedimientos
Referencia

    • Comandos

    CARGARMENU

    Carga archivos de menús parciales

    DESCARGARMENU

    Descarga archivos de menús parciales


Información de versión de la Ayuda


Comentarios

Mediante este formulario podrá enviar sus comentarios al grupo Autodesk Technical Publications, responsable de la publicación de esta documentación.

Título del tema y ubicación (sin modificar):
Nombre (opcional):
         Correo electrónico (opcional):
Comentarios:

Nota: este formulario no se ha creado para que usted reciba comentarios o asistencia técnica. La información que nos proporcione se utilizará para mejorar las próximas actualizaciones que se lleven a cabo en la documentación. ¡Gracias!


Ficha Procedimientos: Personalización básica [Manual de personalización: ACG]

Personalización básica
Conceptos
Procedimientos
Referencia

    • Para crear una barra de herramientas

    Para cambiar el nombre de una barra de herramientas

    Para borrar una barra de herramientas

    Para reordenar los botones de una barra de herramientas

    Para añadir espacio entre los botones de una barra de herramientas

    Para modificar la forma de una barra de herramientas flotante

    Para cambiar el aspecto o la accesibilidad de una barra de herramientas

    Para cambiar el comando asociado a un botón

    Para crear un icono desplegable

    Para editar o crear la imagen de un botón

    Para crear un nuevo botón para una barra de herramientas

    Para añadir un botón a una barra de herramientas

    Para borrar un botón de la barra de herramientas

    Para mover o copiar un botón desde otra barra de herramientas

    Para crear una tecla de método abreviado para una barra de herramientas o para un menú

    Para eliminar una tecla de método abreviado de una barra de herramientas o de un menú

    Para crear un acceso rápido a las plantillas para publicar en sitio Web

    Para personalizar una plantilla para publicar en sitio Web

    Para abrir el archivo de parámetros del programa (acad.pgp)


Ficha Referencia: Personalización básica [Manual de personalización: ACG]

Personalización básica
Conceptos
Procedimientos
Referencia

    • Comandos

    PERSONALIZAR

    Personaliza barras de herramientas, botones, teclas de método abreviado y paletas de herramientas

    Variables de sistema

    LOCALROOTPREFIX

    Almacena la ruta completa de la carpeta de en la que se instalaron los archivos personalizables

    ROAMABLEROOTPREFIX

    Almacena la ruta completa de la carpeta raíz en la que se instalaron los archivos personalizables

    TOOLTIPS

    Controla la visualización de las informaciones de herramientas


AnswerWorks®


Consejos para las búsquedas

Los siguientes consejos le pueden ayudar a obtener resultados más útiles en sus consultas.

  • Filtre la búsqueda seleccionando sólo aquellos componentes de la documentación en los que haya más probabilidades de que se encuentre el tipo de información que esté buscando. Seleccione un libro o un conjunto de libros de la lista de elementos de documentación para buscar.
  • Asegúrese de que la pregunta no contiene errores tipográficos. Es posible que las palabras más importantes se pasen por alto si éstas no se pueden reconocer.
  • Escriba su consulta en forma de pregunta (¿Cómo se desactivan los cuadros de diálogo?), de locución (desactivación de diálogos) o de palabra clave (diálogos). En cada uno de estos casos se obtendrán resultados ligeramente distintos.
  • Escriba menos palabras. Con frecuencia, al emplear menos palabras se obtienen mejores resultados.
    Por ejemplo, máximo de ventanas dará como resultado una lista de temas diferentes a los encontrados con ¿Cómo se puede incrementar el número máximo de ventanas visibles?
  • Ordene las palabras de modo distinto. El orden de las palabras puede influir en los resultados.
    Por ejemplo, número máximo de ventanas se interpreta de forma distinta a número de ventanas máximo.
  • Utilice palabras o términos diferentes, aunque relacionados, en las consultas.
    Por ejemplo, dibujar círculos mostrará temas ligeramente diferentes a los que encontrará crear círculos.
    Del mismpo modo, si busca cuadros de diálogo, encontrará temas distintos que si busca diálogos.
  • No utilice signos de puntuación. Use la ficha Búsqueda si necesita encontrar términos que incluyan signos de puntuación.
    Por ejemplo, al introducir nombres de archivos tales como acad.pat, se podrían obtener resultados poco fiables.
  • No escriba palabras que contengan números.
    Por ejemplo, si incluye 3D en un término, los resultados pueden ser poco fiables. La búsqueda será más precisa si desarrolla el término con la palabra tridimensional.
  • No escriba palabras que aparezcan con mucha frecuencia en los temas de ayuda.
    Por ejemplo, si introduce dibujo o línea, probablemente desviará los resultados. Elimine estas palabras de la consulta o combínelas con otras más específicas.


zz [Tema en blanco]

Tema en blanco

Este tema se dejó en blanco intencionadamente.