Formato DXF [Manual de referencia de DXF: DXF]

Formato DXF

    • El formato DXF™ es una representación de datos identificados de toda la información que pueda incluirse en un archivo de dibujo de AutoCAD® . Datos identificados significa que cada elemento de datos del archivo va precedido de un número entero denominado código de grupo. El valor del código de grupo indicará el tipo de elemento de datos que sigue y su significado en relación con un tipo de objeto (o registro) dado. Casi toda la información que el usuario especifique en un archivo de dibujo puede representarse en formato DXF.

    Temas de esta sección:

    • Organización de este manual de referencia
    • Revisiones del Manual de referencia de DXF
    • Convenciones de formato de este manual de referencia
    • Códigos de objeto y de entidad
    • Tipos de valores de códigos de grupo
    • Códigos de grupo en orden numérico


Organización de este manual de referencia [Manual de referencia de DXF: DXF]

Formato DXF
Organización de este manual de referencia

    • En el Manual de referencia de DXF se explican los códigos de grupo presentes en los archivos DXF™ y que pueden encontrarse también en aplicaciones AutoLISP® y ObjectARX™. En este capítulo se describen las convenciones DXF de carácter general. En los capítulos restantes se muestran listas de códigos de grupo organizadas por tipo de objeto. Los códigos de grupo se presentan en el orden en que se encuentran en un archivo DXF y cada capítulo se denomina de acuerdo con la sección asociada de un archivo DXF. Aunque el formato de archivo DXF se utiliza como base para la organización de este manual de referencia, la información especifica sobre el formato de este tipo de archivos se encuentra en Formatos de archivo de intercambio de dibujos. Los conceptos avanzados relacionados con los códigos de grupo DXF, en cuanto a su pertenencia tanto a aplicaciones como a archivos DXF, se tratan en Conceptos avanzados de DXF.

    Para obtener descripciones de las funciones de AutoLISP que utilizan códigos de grupo, véase "Using AutoLISP to Manipulate AutoCAD Objects" en AutoLISP Developer's Guide.


Revisiones del Manual de referencia de DXF [Manual de referencia de DXF: DXF]

Formato DXF
Revisiones del Manual de referencia de DXF

    • En este tema se presentan las revisiones efectuadas al Manual de referencia de DXF desde su última actualización. El número de versión de este Manual de referencia de DXF es u18.1.01.

    Sección HEADER

    Se han añadido variables con códigos de grupo y descripciones a Códigos de grupo de la sección HEADER.


Convenciones de formato de este manual de referencia [Manual de referencia de DXF: DXF]

Formato DXF
Convenciones de formato de este manual de referencia

    • Todos los códigos de grupo que se muestran en este manual de referencia se presentan mediante un valor de código de grupo numérico y una descripción. Todos los códigos de grupo son válidos para archivos DXF™, para aplicaciones (AutoLISP u ObjectARX) o para ambos. Cuando la descripción de un código sea diferente para las aplicaciones y los archivos DXF (o sólo sea válida para unas u otros), la descripción vendrá precedida de los siguientes indicadores:

    • APL. Descripción específica para aplicaciones.
    • DXF. Descripción específica para archivos DXF.

    Si la descripción es común para los archivos DXF y las aplicaciones, no se proporcionará ningún indicador.

    Los códigos opcionales se señalan como "opcional" en la descripción.


Códigos de objeto y de entidad [Manual de referencia de DXF: DXF]

Formato DXF
Códigos de objeto y de entidad

    • En el formato DXF™, la definición de objetos es diferente a la de entidades: los objetos, a diferencia de las entidades, no tienen representación gráfica. Por ejemplo, los diccionarios son objetos y no entidades. Asimismo, a las entidades también se las conoce como objetos gráficos, mientras que a los objetos se les conoce como objetos no gráficos.

    Las entidades aparecen en las secciones BLOCKS y ENTITIES del archivo DXF. El uso de los códigos de grupo en ambas secciones es idéntico.

    Algunos códigos de grupo que definen una entidad aparecen siempre, mientras que otros son opcionales y sólo aparecen si sus valores no son los valores por defecto.

    No deben escribirse programas basados en el orden que aquí se facilita. El final de una entidad viene indicado por el siguiente grupo 0, donde comienza la siguiente entidad o se indica el final de la sección.

    Nota La adaptación de archivos DXF de futuras versiones de AutoCAD® será más sencilla si se escribe el programa procesador de DXF en forma de tabla, se ignoran los códigos de grupo no definidos y no se hacen suposiciones acerca del orden de los códigos de grupo en una entidad. En cada nueva versión de AutoCAD se añaden nuevos códigos de grupo a las entidades para adaptar funciones adicionales.


Tipos de valores de códigos de grupo [Manual de referencia de DXF: DXF]

Formato DXF
Tipos de valores de códigos de grupo

    • Los códigos de grupo definen el tipo de valor asociado como un número entero, un número de coma flotante o una cadena, según la siguiente tabla de rangos de códigos de grupo. Para obtener información sobre las abreviaturas y el formato que se utiliza en esta tabla, véase Convenciones de formato de este manual de referencia.
    Tipos de valores de códigos de grupo
Rango de código | Tipo de valor de grupo
0–9 | Cadena (Con la introducción de nombres de símbolos extendidos en AutoCAD 2000, el límite de 255 caracteres se ha rebasado. No obstante, aunque no haya un límite explícito para el número de bytes por línea, se debe respetar el máximo de 2049 bytes en la mayoría de los casos.)
10–39 | Valor de punto 3D de doble precisión
40–59 | Valor de coma flotante de doble precisión
60–79 | Valor entero de 16 bits
90–99 | Valor entero de 32 bits
100 | Cadena (con un límite máximo de 255 caracteres; inferior para las cadenas Unicode)
102 | Cadena (con un límite máximo de 255 caracteres; inferior para las cadenas Unicode)
105 | Cadena que representa un valor de identificador hexadecimal (hex)
110–119 | Valor de coma flotante de doble precisión
120–129 | Valor de coma flotante de doble precisión
130–139 | Valor de coma flotante de doble precisión
140–149 | Valor de coma flotante escalar de doble precisión
170–179 | Valor entero de 16 bits
210–239 | Valor de coma flotante de doble precisión
270–279 | Valor entero de 16 bits
280–289 | Valor entero de 16 bits
290–299 | Valor de indicador booleano
300–309 | Cadena de texto arbitraria
310–319 | Cadena que representa el valor hexadecimal de un bloque binario
320–329 | Cadena que representa un valor de identificador hexadecimal
330–369 | Cadena que representa identificadores de objeto hexadecimales
370–379 | Valor entero de 16 bits
380–389 | Valor entero de 16 bits
390–399 | Cadena que representa un valor de identificador hexadecimal
400–409 | Valor entero de 16 bits
410–419 | Cadena
420-429 | Valor entero de 32 bits
430-439 | Cadena
440-449 | Valor entero de 32 bits
450-459 | Largo
460-469 | Valor de coma flotante de doble precisión
470-479 | Cadena
999 | Comentario (cadena)
1000–1009 | Cadena (con los mismos límites indicados para el rango de código 0-9)
1010–1059 | Valor de coma flotante de doble precisión
1060–1070 | Valor entero de 16 bits
1071 | Valor entero de 32 bits


Códigos de grupo en orden numérico [Manual de referencia de DXF: DXF]

Formato DXF
Códigos de grupo en orden numérico

    • En la tabla siguiente figura el código de grupo o el rango de códigos de grupo junto con una explicación de sus valores. En esta tabla, los códigos de grupo marcados con el término "fijo" tienen siempre la misma finalidad. Si un código de grupo no es "fijo", su finalidad dependerá del contexto. Para obtener información sobre las abreviaturas y el formato que se utiliza en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo por número
Código de grupo | Descripción
–5 | APL: cadena de reactivo permanente
–4 | APL: operador condicional (empleado sólo con ssget)
–3 | APL: centinela de datos extendidos (DATOSEX) (fijo)
–2 | APL: referencia a nombre de entidad (fijo)
–1 | APL: nombre de entidad. Cambia cada vez que se abre un dibujo. Nunca se guarda (fijo).
0 | Cadena de texto que indica el tipo de entidad (fijo)
1 | Valor de texto principal de una entidad
2 | Nombre (identificador de atributos, nombre de bloque, etc.)
3–4 | Otros valores de nombre o de texto
5 | Identificador de entidad; cadena de texto de hasta 16 dígitos hexadecimales (fija)
6 | Nombre de tipo de línea (fijo)
7 | Nombre de estilo de texto (fijo)
8 | Nombre de capa (fijo)
9 | DXF: identificador de nombre de variable (empleado sólo en la sección HEADER del archivo DXF)
10 | Punto principal; se trata del punto de inicio de una línea o de una entidad de texto, el centro de un círculo, etc. DXF: valor X del punto principal (seguido de los códigos de valor 20 y 30 de Y y Z) APL: punto 3D (lista de tres números reales)
11–18 | Otros puntos DXF: valor X de otros puntos (seguido de los códigos de valor 21 a 28 de Y y los códigos de valor 31 a 38 de Z ) APL: punto 3D (lista de tres números reales)
20, 30 | DXF™: valores Y y Z del punto principal
21–28, 31–37 | DXF: valores Y y Z de otros puntos
38 | DXF: elevación de la entidad si el valor es distinto de cero
39 | Altura de la entidad si su valor es distinto de cero (fijo)
40–48 | Valores de coma flotante de doble precisión (altura del texto, factores de escala, etc.)
48 | Escala del tipo de línea; valor escalar de coma flotante de doble precisión; el valor por defecto se define para todos los tipos de entidad
49 | Valor de coma flotante de doble precisión repetido. Varios grupos 49 pueden aparecer en una entidad para tablas de longitudes variables (como las longitudes de trazo de la tabla LTYPE). Un grupo 7x aparece siempre antes que el primer grupo 49 para especificar la longitud de la tabla.
50–58 | Ángulos (salida en grados a archivos DXF y en radianes a través de las aplicaciones AutoLISP y ObjectARX)
60 | Visibilidad de la entidad; valor entero; ausencia o 0 indica visibilidad; 1 indica invisibilidad.
62 | Número de color (fijo)
66 | Indicador de que las entidades siguen (fijo)
67 | Espacio: modelo o papel (fijo)
68 | APL: identifica si la ventana gráfica está activada pero no se ve en pantalla, si no está activa o si está desactivada.
69 | APL: número de identificación de la ventana gráfica
70–78 | Valores enteros, como número de repeticiones, bits indicadores o modos
90–99 | Valores enteros de 32 bits
100 | Marcador de datos de subclase (con nombre de clase derivado como cadena). Necesario para todos los objetos y clases de entidad que se deriven de otra clase determinada. Este marcador separa los datos definidos por clases diferentes en la cadena de herencia para el mismo objeto. Se exige además el requisito de nombres DXF para cada clase concreta distinta derivada de ObjectARX (véase Marcadores Subclass).
102 | Cadena de control, seguida de "{<nombre arbitrario>" o "}". De manera similar al código de grupo de datoseX 1002, salvo en el caso de que la cadena comience por "{", puede ir seguida de una cadena arbitraria cuya interpretación depende de la aplicación. La única cadena de control admisible además de ésta es "}" como finalizador de grupo. AutoCAD no interpreta estas cadenas salvo durante las operaciones de revisión. Su uso se reserva a las aplicaciones.
105 | Identificador de objetos para la entrada en la tabla de símbolos DIMVAR
110 | Origen del SCP (sólo aparece si el código 72 tiene el valor 1) DXF: valor X; APL: punto 3D
111 | Eje X de SCP (sólo aparece si el código 72 tiene el valor 1) DXF: valor X; APL: vector 3D
112 | Eje Y de SCP (sólo aparece si el código 72 tiene el valor 1) DXF: valor X; APL: vector 3D
120–122 | DXF: valor Y del origen del SCP, eje X del SCP y eje Y del SCP
130–132 | DXF: valor Z del origen del SCP, eje X del SCP y eje Y del SCP
140–149 | Valores de coma flotante de doble precisión (comas, elevación y parámetros de DIMSTYLE, por ejemplo)
170–179 | Valores enteros de 16 bits, como bits indicadores que representan los parámetros de DIMSTYLE
210 | Dirección de la extrusión (fija) DXF: valor X de la dirección de extrusión APL: vector de dirección de extrusión 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión
270–279 | valores enteros de 16 bits
280–289 | valores enteros de 16 bits
290–299 | Valor de indicador booleano
300–309 | Cadenas de texto arbitrarias
310–319 | Bloques binarios arbitrarios con la misma representación y los mismos límites que los códigos de grupo 1004: las cadenas hexadecimales de hasta 254 caracteres representan bloques de datos de hasta 127 bytes.
320–329 | Identificadores de objetos arbitrarios; valores de identificadores que se toman "tal cual". No se traducen durante las operaciones INSERT y REFX.
330–339 | Identificadores de dispositivos señaladores suaves; dispositivos señaladores suaves y arbitrarios de otros objetos dentro del mismo dibujo o archivo DXF. Se traducen durante las operaciones INSERT y REFX.
340–349 | Identificadores de dispositivos señaladores duros; dispositivos señaladores duros y arbitrarios de otros objetos dentro del mismo dibujo o archivo DXF. Se traducen durante las operaciones INSERT y REFX.
350–359 | Identificadores de propietarios suaves; vínculos de propiedad suaves y arbitrarios de otros objetos dentro del mismo dibujo o archivo DXF. Se traducen durante las operaciones INSERT y REFX.
360–369 | Identificadores de propietarios duros; vínculos de propiedad duros y arbitrarios de otros objetos dentro del mismo dibujo o archivo DXF. Se traducen durante las operaciones INSERT y REFX.
370–379 | Valor de enumeración de grosor de línea (AcDb::LineWeight). Se guarda y se mueve como número entero de 16 bits. Los objetos personalizados que no son entidades pueden utilizar el rango completo, pero las clases de entidades sólo pueden utilizar los códigos de grupo DXF 371–379 en su representación, porque en AutoCAD® y AutoLISP se asume que el código 370 corresponde al grosor de línea de la entidad. Esto permite que el código 370 se comporte igual que otros campos de entidad "ordinarios".
380–389 | Enumeración de tipo de PlotStyleName (AcDb::PlotStyleNameType). Se guarda y se mueve como número entero de 16 bits. Los objetos personalizados que no son entidades pueden utilizar el rango completo, pero las clases de entidades sólo pueden utilizar los códigos de grupo DXF 381–389 en su representación, por la misma razón que la citada anteriormente para el rango de grosor de línea.
390–399 | Cadena que representa valores de identificadores del objeto PlotStyleName, básicamente un dispositivo señalador duro, pero que tiene un rango distinto para facilitar la compatibilidad retroactiva. Se guarda y se mueve como un ID de objeto (identificador en archivos DXF) y como un tipo especial en AutoLISP. Los objetos personalizados que no son entidades pueden utilizar el rango completo, pero las clases de entidades sólo pueden utilizar los códigos de grupo DXF 391–399 en su representación, por la misma razón que la citada anteriormente para el rango de grosor de línea.
400–409 | Enteros de 16 bits
410–419 | Cadena
420-427 | Valor entero de 32 bits. Cuando se utiliza con color verdadero, un entero de 32 bits que representa un valor de color de 24 bits. El byte más significativo (8 bits) es 0, el byte menos significativo es un carácter sin signo que representa el valor de azul (0-255), a continuación el valor de verde y el siguiente al byte más significativo es el valor de rojo. La conversión de este valor entero a hexadecimal produce la siguiente máscara de bits: 0x00RRGGBB. Por ejemplo, un color verdadero con Rojo==200, Verde==100 y Azul==50 es 0x00C86432, y en DXF, en decimal, es 13132850.
430-437 | Cadena; cuando se utiliza para color verdadero, una cadena que representa el nombre del color.
440-447 | Valor entero de 32 bits. Cuando se utiliza para color verdadero, el valor de transparencia.
450-459 | Largo
460-469 | Valor de coma flotante de doble precisión
470-479 | Cadena
999 | DXF: el código de grupo 999 indica que la línea siguiente es una cadena de comentario. Mediante GUARDARCOMO no se incluyen tales grupos en un archivo de salida DXF, pero ABRE los toma en consideración e ignora los comentarios. Se puede utilizar el grupo 999 para incluir comentarios en un archivo DXF editado por el usuario.
1000 | Cadena ASCII (de 255 bytes como máximo) en datos extendidos
1001 | Nombre de aplicación registrado (cadena ASCII de 31 bytes como máximo) para datos extendidos
1002 | Cadena de control de datos extendidos ("{" o "}")
1003 | Nombre de capa de datos extendidos
1004 | Bloque de bytes (127 bytes como máximo) en datos extendidos
1005 | Identificador de entidad en datos extendidos; cadena de texto de hasta 16 dígitos hexadecimales
1010 | Punto en datos extendidos DXF: valor X (seguido de los grupos 1020 y 1030) APL: punto 3D
1020, 1030 | DXF: valores Y y Z de un punto
1011 | Posición en el espacio universal 3D en datos extendidos DXF: valor X (seguido de los grupos 1021 y 1031) APL: punto 3D
1021, 1031 | DXF: valores Y y Z de una posición en el espacio universal
1012 | Desplazamiento del espacio universal 3D en datos extendidos DXF: valor X (seguido de los grupos 1022 y 1032) APL: vector 3D
1022, 1032 | DXF: valores Y y Z de un desplazamiento del espacio universal
1013 | Dirección en el espacio universal 3D en datos extendidos DXF: valor X (seguido de los grupos 1022 y 1032) APL: vector 3D
1023, 1033 | DXF: valores Y y Z de una dirección del espacio universal
1040 | Valor de coma flotante de doble precisión en datos extendidos
1041 | Valor de distancia en datos extendidos
1042 | Factor de escala en datos extendidos
1070 | Entero de 16 bits con signo en datos extendidos
1071 | Entero largo de 32 bits con signo en datos extendidos


Sección HEADER [Manual de referencia de DXF: DXF]

Sección HEADER

    • Los códigos de grupo que se describen en este capítulo pertenecen sólo a los archivos DXF™. La sección HEADER de los archivos DXF contiene los parámetros de variables asociadas con el dibujo. Cada variable se precisa mediante un código de grupo 9 que proporciona el nombre de la variable seguido de grupos que suministran su valor. En este capítulo aparecerán sólo las variables que se guardan en el archivo de dibujo.

    Temas de esta sección:

    • Códigos de grupo de la sección HEADER


Códigos de grupo de la sección HEADER [Manual de referencia de DXF: DXF]

Sección HEADER
Códigos de grupo de la sección HEADER

    • En la tabla siguiente se describen las variables que están representadas en la sección HEADER de un archivo DXF™. Para obtener información sobre las abreviaturas y el formato que se utiliza en esta tabla, véase Convenciones de formato de este manual de referencia.

    Variables de encabezamiento DXF

    Variable

    Código de grupo

    Descripción

    $ACADMAINTVER

    70

    Número de la versión de mantenimiento (debe ignorarse).

    $ACADVER

    1

    Número de versión de la base de datos de dibujos de AutoCAD®:
    AC1006 = R10; AC1009 = R11 y R12;
    AC1012 = R13; AC1014 = R14; AC1015 = AutoCAD 2000;
    AC1018 = AutoCAD 2004

    $ANGBASE

    50

    Dirección 0 de ángulo

    $ANGDIR

    70

    1 = Ángulos en el sentido de las agujas del reloj
    0 = Ángulos en sentido contrario a las agujas del reloj

    $ATTMODE

    70

    Visibilidad del atributo:
    0 = Ninguna
    1 = Normal
    2 = Todo

    $AUNITS

    70

    Formato de unidades para ángulos

    $AUPREC

    70

    Precisión de unidades para ángulos

    $CECOLOR

    62

    Número de color de la entidad actual:
    0 = BYBLOCK; 256 = BYLAYER

    $CELTSCALE

    40

    Escala de tipo de línea de la entidad actual

    $CELTYPE

    6

    Nombre de tipo de línea de la entidad, BYBLOCK o BYLAYER

    $CELWEIGHT

    370

    Grosor de línea de objetos nuevos

    $CEPSNID

    390

    Identificador de estilo de trazado de objetos nuevos; si CEPSNTYPE es 3, este valor indica el identificador.

    $CEPSNTYPE

    380

    Tipo de estilo de trazado de objetos nuevos:
    0 = Estilo de trazado por capa
    1 = Estilo de trazado por bloque
    2 = Estilo de trazado por valor por defecto del diccionario
    3 = Estilo de trazado por ID/identificador de objeto

    $CHAMFERA

    40

    Distancia al primer chaflán

    $CHAMFERB

    40

    Distancia al segundo chaflán

    $CHAMFERC

    40

    Longitud de chaflán

    $CHAMFERD

    40

    Ángulo de chaflán

    $CLAYER

    8

    Nombre de la capa actual

    $CMLJUST

    70

    Justificación de la línea múltiple actual:
    0 = Superior; 1 = Medio; 2 = Inferior

    $CMLSCALE

    40

    Escala de la línea múltiple actual

    $CMLSTYLE

    2

    Nombre de estilo de la línea múltiple actual

    $DIMADEC

    70

    Número de puestos de precisión mostrados en las cotas angulares

    $DIMALT

    70

    Acotación de unidades alternativas si su valor es distinto de cero

    $DIMALTD

    70

    Posiciones decimales de unidades alternativas

    $DIMALTF

    40

    Factor de escala de unidades alternativas

    $DIMALTRND

    40

    Determina el redondeo de las unidades alternativas

    $DIMALTTD

    70

    Número de espacios decimales para los valores de tolerancia de las cotas de unidades alternativas

    $DIMALTTZ

    70

    Controla la supresión de ceros para los valores de tolerancia alternativos:
    0 = Suprime pies cero y pulgadas cero
    1 = Incluye pies cero y pulgadas cero
    2 = Incluye pies cero y suprime pulgadas cero
    3 = Incluye pulgadas cero y suprime pies cero

    $DIMALTU

    70

    Formato de unidad para las unidades alternativas de todos los miembros de la gama de estilos de cotas excepto el angular:
    1 = Científicas; 2 = Decimales; 3 = Pies y pulgadas I;
    4 = Pies y pulgadas II (apiladas); 5 = Fraccionarias (apiladas);
    6 = Pies y pulgadas II; 7 = Fraccionarias

    $DIMALTZ

    70

    Controla la supresión de ceros en los valores de cota de las unidades alternativas:
    0 = Suprime pies cero y pulgadas cero
    1 = Incluye pies cero y pulgadas cero
    2 = Incluye pies cero y suprime pulgadas cero
    3 = Incluye pulgadas cero y suprime pies cero

    $DIMAPOST

    1

    Sufijo de acotación alternativa

    $DIMASO

    70

    1 = Crea acotación asociativa
    0 = Dibuja entidades individuales

    $DIMASSOC

    280

    Controla la asociatividad de objetos de cota.

    0 = Crea cotas descompuestas; no hay asociación entre los elementos de la cota, y las líneas, arcos, extremos de cotas y texto se dibujan como objetos independientes.
    1 = Crea objetos de cota no asociativos; los elementos de la cota forman un único objeto y si se mueve el punto de definición del objeto, se actualiza el valor de la cota.
    2 = Crea objetos de cota asociativos; los elementos de la cota forman un único objeto y uno o más puntos de definición de la cota se unen a los puntos de asociación de los objetos geométricos.

    $DIMASZ

    40

    Tamaño de flecha de acotación

    $DIMATFIT

    70

    Controla la ubicación del texto de cota y las flechas cuando no hay espacio suficiente para colocar ambos dentro de las líneas de referencia:
    0 = Sitúa el texto y las flechas fuera de las líneas de referencia
    1 = Desplaza primero las flechas y luego el texto
    2 = Desplaza primero el texto y luego las flechas
    3 = Desplaza el texto o las flechas, según cual se ajuste mejor
    AutoCAD añade una directriz al texto de cota desplazado cuando DIMTMOVE está establecido en 1.

    $DIMAUNIT

    70

    Formato de ángulo para cotas angulares:
    0 = Grados decimales; 1 = Grados/minutos/segundos;
    2 = Gradianes; 3 = Radianes; 4 = Unidades topográficas

    $DIMAZIN

    70

    Controla la supresión de ceros para cotas angulares:
    0 = Muestra todos los ceros a la izquierda y a la derecha
    1 = Suprime los ceros a la izquierda en cotas decimales
    2 = Suprime los ceros a la derecha en cotas decimales
    3 = Suprime los ceros a la izquierda y a la derecha

    $DIMBLK

    1

    Nombre de bloque de flecha

    $DIMBLK1

    1

    Primer nombre de bloque de flecha

    $DIMBLK2

    1

    Segundo nombre de bloque de flecha

    $DIMCEN

    40

    Tamaño de marcas y líneas centrales

    $DIMCLRD

    70

    Color de línea de cota:
    el rango es 0 = BYBLOCK; 256 = BYLAYER

    $DIMCLRE

    70

    Color de línea de referencia de cota:
    el rango es 0 = BYBLOCK; 256 = BYLAYER

    $DIMCLRT

    70

    Color de texto de cota:
    el rango es 0 = BYBLOCK; 256 = BYLAYER

    $DIMDEC

    70

    Número de decimales para los valores de tolerancia de una cota de unidades principales

    $DIMDLE

    40

    Extensión de línea de cota.

    $DIMDLI

    40

    Incremento de línea de cota

    $DIMDSEP

    70

    Separador decimal de un solo carácter utilizado en la creación de cotas con formato decimal de unidades

    $DIMEXE

    40

    Extensión de línea de referencia

    $DIMEXO

    40

    Desfase de línea de referencia

    $DIMFAC

    40

    Factor de escala utilizado para calcular la altura del texto de fracciones y tolerancias de cota. AutoCAD multiplica DIMTXT por DIMTFAC para definir la altura del texto fraccional o de tolerancia.

    $DIMGAP

    40

    Espacio de la línea de cota

    $DIMJUST

    70

    Posición horizontal del texto de cota:
    0 = Sobre la línea de cota y centrado entre las líneas de referencia
    1 = Sobre la línea de cota y junto a la primera línea de referencia
    2 = Sobre la línea de cota y junto a la segunda línea de referencia
    3 = Sobre la primera línea de referencia y centrado en ella
    4 = Sobre la segunda línea de referencia y centrado en ella

    $DIMLDRBLK

    1

    Nombre del bloque de flecha para las directrices

    $DIMLFAC

    40

    Factor de escala de medidas lineales

    $DIMLIM

    70

    Genera límites de cota si su valor es distinto de cero

    $DIMLUNIT

    70

    Establece las unidades de todos los tipos de cota excepto Angular:
    1 = Científicas; 2 = Decimales; 3 = Pies y pulgadas I;
    4 = Pies y pulgadas II; 5 = Fraccionarias; 6 = Escritorio de Windows

    $DIMLWD

    70

    Grosor de la línea de cota:
    –3 = Estándar
    –2 = PorCapa
    –1 = PorBloque
    0–211 = Entero que representa la centésima parte de 1 mm

    $DIMLWE

    70

    Grosor de la línea de referencia:
    –3 = Estándar
    –2 = PorCapa
    –1 = PorBloque
    0–211 = Entero que representa la centésima parte de 1 mm

    $DIMPOST

    1

    Sufijo de acotación general

    $DIMRND

    40

    Valor de redondeo para las distancias de cota

    $DIMSAH

    70

    Utilice bloques de fecha distintos si su valor es distinto de cero

    $DIMSCALE

    40

    Factor de escala de acotación global

    $DIMSD1

    70

    Supresión de la primera línea de referencia:
    0 = No suprimida; 1 = Suprimida

    $DIMSD2

    70

    Supresión de la segunda línea de referencia:
    0 = No suprimida; 1 = Suprimida

    $DIMSE1

    70

    Primera línea de referencia suprimida si su valor es distinto de cero

    $DIMSE2

    70

    Segunda línea de referencia suprimida si su valor es distinto de cero

    $DIMSHO

    70

    1 = Vuelve a calcular las cotas durante el arrastre
    0 = Arrastra la imagen original

    $DIMSOXD

    70

    Suprime las líneas de cota de las extensiones externas si su valor es distinto de cero

    $DIMSTYLE

    2

    Nombre de estilo de cota

    $DIMTAD

    70

    Texto sobre línea de cota si su valor es distinto de cero

    $DIMTDEC

    70

    Número de decimales para ver los valores de tolerancia

    $DIMTFAC

    40

    Factor de escala de visualización de tolerancia de cota

    $DIMTIH

    70

    Texto dentro de la horizontal si su valor es distinto de cero

    $DIMTIX

    70

    Fuerza el texto dentro de las extensiones cuando su valor sea distinto de cero

    $DIMTM

    40

    Tolerancia menos.

    $DIMTMOVE

    70

    Reglas para el desplazamiento del texto de cota:
    0 = Desplaza la línea de cota con el texto de cota
    1 = Añade una directriz al desplazar el texto de cota
    2 = Permite desplazar el texto libremente sin una directriz

    $DIMTOFL

    70

    Si el texto está fuera de las extensiones, fuerza las extensiones de línea entre extensiones cuando su valor es distinto de cero

    $DIMTOH

    70

    Texto fuera de la horizontal si su valor es distinto de cero

    $DIMTOL

    70

    Genera tolerancias de cota si su valor es distinto de cero

    $DIMTOLJ

    70

    Justificación vertical para valores de tolerancia:
    0 = Superior; 1 = Medio; 2 = Inferior

    $DIMTP

    40

    Tolerancia más

    $DIMTSZ

    40

    Tamaño del trazo de acotación:
    0 = Sin trazos

    $DIMTVP

    40

    Posición vertical del texto

    $DIMTXSTY

    7

    Estilo de texto de cota

    $DIMTXT

    40

    Altura de texto de cota

    $DIMTZIN

    70

    Controla la supresión de ceros para los valores de tolerancia:
    0 = Suprime pies cero y pulgadas cero
    1 = Incluye pies cero y pulgadas cero
    2 = Incluye pies cero y suprime pulgadas cero
    3 = Incluye pulgadas cero y suprime pies cero

    $DIMUPT

    70

    Funcionalidad del cursor para texto insertado por el usuario:
    0 = Controla únicamente la ubicación de la línea de cota
    1 = Controla la posición del texto y la ubicación de la línea de cota

    $DIMZIN

    70

    Controla la supresión de ceros en los valores de las unidades principales:
    0 = Suprime pies cero y pulgadas cero
    1 = Incluye pies cero y pulgadas cero
    2 = Incluye pies cero y suprime pulgadas cero
    3 = Incluye pulgadas cero y suprime pies cero

    $DISPSILH

    70

    Controla la visualización de las curvas de siluetas de objetos de cuerpo en modo de estructura alámbrica:
    0 = Desactivado; 1 = Activado

    $DWGCODEPAGE

    3

    Página de códigos del dibujo; se establece en la página de códigos del sistema cuando se crea un dibujo nuevo, aunque AutoCAD no la mantiene de ninguna otra forma.

    $ELEVATION

    40

    Elevación actual especificada por el comando ELEV

    $ENDCAPS

    280

    Parámetro de remates de grosor de línea para objetos nuevos:
    0 = ninguno; 1 = redondo; 2 = ángulo; 3 = cuadrado

    $EXTMAX

    10, 20, 30

    Valores X, Y y Z de la esquina superior derecha de la extensión del dibujo (en SCU)

    $EXTMIN

    10, 20, 30

    Valores X, Y y Z de la esquina inferior izquierda de la extensión del dibujo (en SCU)

    $EXTNAMES

    290

    Controla la asignación de nombres en las tablas de símbolos:
    0 = Compatibilidad con la versión R14. Limita los nombres a 31 caracteres de longitud. Los nombres pueden incluir letras de la A a la Z, números del 0 al 9 y los caracteres especiales dólar ($), subrayado (_) y guión (–).
    1 = AutoCAD 2000. Los nombres pueden tener una longitud de hasta 255 caracteres e incluir letras de la A a la Z, números del 0 al 9 y espacios y caracteres especiales no utilizados para otros fines por Microsoft Windows o AutoCAD.

    $FILLETRAD

    40

    Radio de empalme

    $FILLMODE

    70

    Modo de relleno activado si su valor es distinto de cero

    $FINGERPRINTGUID

    2

    Se define en el momento de creación e identifica de forma exclusiva un dibujo particular

    $HALOGAP

    280

    Especifica el hueco que se debe mostrar donde un objeto queda oculto por otro; el valor se especifica como un porcentaje de una unidad y es independiente del nivel de zoom. Una línea hueca se acorta en el punto donde queda oculta cuando se utiliza OCULTA o la opción Oculto de MODOSOMBRA.

    $HANDSEED

    5

    Siguiente identificador disponible

    $HIDETEXT

    290

    Especifica la variable de sistema HIDETEXT:
    0 = OCULTA ignora los objetos de texto al generar la vista oculta
    1 = OCULTA no ignora los objetos de texto

    $HYPERLINKBASE

    1

    Ruta para todos los hipervínculos relativos del dibujo. Si el valor es nulo, se utiliza la ruta del dibujo.

    $INDEXCTL

    280

    Controla si los índices de capas y espacial se crean y se guardan en archivos de dibujo:
    0 = No se crean índices
    1 = Se crea el índice de capas
    2 = Se crea el índice espacial
    3 = Se crean los índices de capas y espacial

    $INSBASE

    10, 20, 30

    Punto base de inserción determinado por el comando BASE (en SCU)

    $INSUNITS

    70

    Unidades de dibujo por defecto para los bloques de AutoCAD DesignCenter:
    0 = Sin unidad; 1 = Pulgadas; 2 = Pies; 3 = Millas; 4 = Milímetros;
    5 = Centímetros; 6 = Metros; 7 = Kilómetros; 8 = Micropulgadas;
    9 = Milipulgadas; 10 = Yardas; 11 = Angstroms; 12 = Nanómetros;
    13 = Micrómetros; 14 = Decímetros; 15 = Decámetros;
    16 = Hectómetros; 17 = Gigámetros; 18 = Unidades astronómicas;
    19 = Años luz; 20 = Parsecs

    $INTERSECTIONCOLOR

    70

    Especifica el color de entidad de las polilíneas de intersección:
    Los valores del 1 al 255 designan un índice de colores de AutoCAD (ACI).
    0 = Color BYBLOCK
    256 = Color BYLAYER
    257 = Color BYENTITY

    $INTERSECTIONDISPLAY

    290

    Especifica la visualización de las polilíneas de intersección:
    0 = Desactiva la visualización de polilíneas de intersección
    1 = Activa la visualización de polilíneas de intersección

    $JOINSTYLE

    280

    Parámetro de unión de grosor de línea para objetos nuevos:
    0 = ninguno; 1 = redondo; 2 = ángulo; 3 = plano

    $LIMCHECK

    70

    Distinto de cero si la comprobación de límites está activada

    $LIMMAX

    10, 20

    Valores XY de la esquina superior derecha de los límites del dibujo (en SCU)

    $LIMMIN

    10, 20

    Valores XY de la esquina inferior izquierda de los límites del dibujo (en SCU)

    $LTSCALE

    40

    Escala global del tipo de línea

    $LUNITS

    70

    Formato de las unidades para coordenadas y distancias

    $LUPREC

    70

    Precisión de las unidades para coordenadas y distancias

    $LWDISPLAY

    290

    Controla la visualización de grosores de línea en las fichas Modelo o Presentación:
    0 = No se muestra el grosor de línea
    1 = Se muestra el grosor de línea

    $MAXACTVP

    70

    Establece el número máximo de ventanas gráficas generables

    $MEASUREMENT

    70

    Establece las unidades de dibujo: 0 = Inglesas; 1 = Métricas

    $MENU

    1

    Nombre del archivo de menús

    $MIRRTEXT

    70

    Refleja el texto en simetría si su valor es distinto de cero

    $OBSCOLOR

    70

    Especifica el color de las líneas oscuras. Una línea oscurecida es una línea oculta que se ha hecho visible al cambiar el color o el tipo de línea y que sólo está visible cuando se utilizan los comandos OCULTA o MODOSOMBRA. El parámetro OBSCUREDCOLOR sólo es visible si se activa OBSCUREDLTYPE mediante su establecimiento en un valor distinto de 0.
    0 y 256 = Color de entidad
    1-255 = Índice de colores de AutoCAD (ACI)

    $OBSLTYPE

    280

    Define el tipo de línea de las líneas oscuras. A diferencia de los tipos de líneas normales de AutoCAD, los tipos de líneas oscuras son independientes del nivel de zoom. El valor por defecto 0 desactiva la visualización de las líneas oscuras. Los valores del tipo de línea se definen de la siguiente manera:
    0 = Desactivado
    1 = Sólido
    2 = Trazo
    3 = Punto
    4 = Trazo corto
    5 = Trazo medio
    6 = Trazo largo
    7 = Trazo corto doble
    8 = Trazo medio doble
    9 = Trazo largo doble
    10 = Trazo medio largo
    11 = Punto separado

    $ORTHOMODE

    70

    Modo Orto activado si su valor es distinto de cero

    $PDMODE

    70

    Modo de visualización de puntos

    $PDSIZE

    40

    Tamaño de visualización de los puntos

    $PELEVATION

    40

    Elevación del espacio en el papel actual

    $PEXTMAX

    10, 20, 30

    Extensiones X, Y y Z máximas para el espacio papel

    $PEXTMIN

    10, 20, 30

    Extensiones X, Y y Z mínimas para el espacio papel

    $PINSBASE

    10, 20, 30

    Punto base de inserción en espacio papel

    $PLIMCHECK

    70

    Comprobación de los límites en espacio papel si su valor es distinto de cero

    $PLIMMAX

    10, 20

    Límites X e Y máximos en el espacio papel

    $PLIMMIN

    10, 20

    Límites X e Y mínimos en el espacio papel

    $PLINEGEN

    70

    Controla la generación de patrones de tipo de línea alrededor de los vértices de una polilínea 2D:
    1 = El tipo de línea se genera en un patrón continuo alrededor de los vértices de la polilínea.
    0 = Cada segmento de la polilínea empieza y termina con un trazo.

    $PLINEWID

    40

    Anchura de polilínea por defecto

    $PROJECTNAME

    1

    Asigna un nombre de proyecto al dibujo actual. Se utiliza si una referencia externa o una imagen no se encuentran en la ruta original. El nombre del proyecto apunta a una sección del registro que pueda contener una o varias rutas de búsqueda por cada nombre de proyecto definido. Los nombres de proyecto y los directorios de búsqueda se crean desde la ficha Archivos del cuadro de diálogo Opciones.

    $PROXYGRAPHICS

    70

    Controla el almacenamiento de las imágenes de objetos proxy

    $PSLTSCALE

    70

    Controla las escalas de tipo de línea en el espacio papel:
    1 = Sin escala especial de tipo de línea
    0 = La escala de ventana gráfica determina la escala de tipo de línea

    $PSTYLEMODE

    290

    Indica si el dibujo actual está en modo de estilos de trazados dependientes de color o de estilos de trazado guardados.
    0 = Utiliza tablas de estilos de trazado guardados en el dibujo actual
    1 = Utiliza tablas de estilos de trazado dependientes de color en el dibujo actual

    $PSVPSCALE

    40

    Factor de escala de vista para las ventanas gráficas nuevas:
    0 = Ajustar escala
    >0 = Factor de escala (un valor real positivo)

    $PUCSBASE

    2

    Nombre del SCP que define el origen y la orientación de parámetros SCP ortogonales (sólo en espacio papel)

    $PUCSNAME

    2

    Nombre del SCP actual en el espacio papel

    $PUCSORG

    10, 20, 30

    Origen del SCP actual en el espacio papel

    $PUCSORGBACK

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio papel a POSTERIOR si PUCSBASE está definida como UNIVERSAL.

    $PUCSORGBOTTOM

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio papel a INFERIOR si PUCSBASE está definida como UNIVERSAL.

    $PUCSORGFRONT

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio papel a FRONTAL si PUCSBASE está definida como UNIVERSAL.

    $PUCSORGLEFT

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio papel a IZQUIERDA si PUCSBASE está definida como UNIVERSAL.

    $PUCSORGRIGHT

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio papel a DERECHA si PUCSBASE está definida como UNIVERSAL.

    $PUCSORGTOP

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio papel a SUPERIOR si PUCSBASE está definida como UNIVERSAL.

    $PUCSORTHOREF

    2

    Si el SCP en espacio papel es ortogonal (PUCSORTHOVIEW es distinto de 0), éste es el nombre del SCP al que se refiere el SCP ortogonal. Si está en blanco, el SCP se refiere a UNIVERSAL.

    $PUCSORTHOVIEW

    70

    Tipo de vista ortogonal del SCP en el espacio papel:
    0 = El SCP no es ortogonal;
    1 = Superior; 2 = Inferior;
    3 = Frontal; 4 = Posterior;
    5 = Izquierda; 6 = Derecha

    $PUCSXDIR

    10, 20, 30

    Eje X del SCP en el espacio papel actual

    $PUCSYDIR

    10, 20, 30

    Eje Y del SCP en el espacio papel actual

    $QTEXTMODE

    70

    Modo Texto rápido activado si su valor es distinto de cero

    $REGENMODE

    70

    Modo REGENAUTO activado si su valor es distinto de cero

    $SHADEDGE

    70

    0 = Caras sombreadas, aristas no resaltadas
    1 = Caras sombreadas, aristas resaltadas en negro
    2 = Caras no rellenas, aristas en color de entidad
    3 = Caras en color de entidad, aristas en negro

    $SHADEDIF

    70

    Porcentaje de luz difusa/ambiental; rango 1–100; valor por defecto 70

    $SKETCHINC

    40

    Incremento de registros de boceto

    $SKPOLY

    70

    0 = Líneas de boceto; 1 = Polilíneas de boceto

    $SORTENTS

    280

    Controla los métodos para ordenar objetos; disponible en la ficha Preferencias de usuario del cuadro de diálogo Opciones. SORTENTS utiliza los siguientes códigos binarios:
    0 = Desactiva SORTENTS
    1 = Ordena por selección de objetos
    2 = Ordena por referencia a objetos
    4 = Ordena por redibujo
    8 = Ordena por creación de fotos mediante el comando SACAFOTO
    16 = Ordena por comandos REGEN
    32 = Ordena por trazados
    64 = Ordena por salida PostScript

    $SPLFRAME

    70

    Visualización del polígono de control de Spline: 1 = Act; 0 = Des

    $SPLINESEGS

    70

    Número de segmentos de línea por segmento Spline

    $SPLINETYPE

    70

    Tipo de curva Spline para EDITPOL Spline

    $SURFTAB1

    70

    Número de tabulaciones de malla en primera dirección

    $SURFTAB2

    70

    Número de tabulaciones de malla en segunda dirección

    $SURFTYPE

    70

    Tipo de superficie para EDITPOL Amoldar superficie

    $SURFU

    70

    Densidad de superficie (para EDITPOL Amoldar superficie) en la dirección M

    $SURFV

    70

    Densidad de superficie (para EDITPOL Amoldar superficie) en la dirección N

    $TDCREATE

    40

    Fecha/hora local de creación del dibujo (véase Gestión especial de variables de fecha y hora).

    $TDINDWG

    40

    Tiempo de edición acumulado para este dibujo (véase Gestión especial de variables de fecha y hora).

    $TDUCREATE

    40

    Fecha/hora universal de creación del dibujo (véase Gestión especial de variables de fecha y hora).

    $TDUPDATE

    40

    Fecha/hora local de la última actualización del dibujo (véase Gestión especial de variables de fecha y hora).

    $TDUSRTIMER

    40

    Período del cronómetro del usuario

    $TDUUPDATE

    40

    Fecha/hora universal de la última actualización/guardado (véase Gestión especial de variables de fecha y hora).

    $TEXTSIZE

    40

    Altura del texto por defecto

    $TEXTSTYLE

    7

    Nombre del estilo de texto actual.

    $THICKNESS

    40

    Anchura actual establecida por el comando ELEV

    $TILEMODE

    70

    1 para el modo de compatibilidad con la versión anterior; 0 en el caso contrario

    $TRACEWID

    40

    Anchura del trazado por defecto

    $TREEDEPTH

    70

    Precisa la profundidad máxima del índice espacial

    $UCSBASE

    2

    Nombre del SCP que define el origen y orientación de los parámetros del SCP ortogonal

    $UCSNAME

    2

    Nombre del SCP actual

    $UCSORG

    10, 20, 30

    Origen del SCP actual (en SCU)

    $UCSORGBACK

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio modelo a POSTERIOR si UCSBASE está definida como UNIVERSAL.

    $UCSORGBOTTOM

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio modelo a INFERIOR si UCSBASE está definida como UNIVERSAL.

    $UCSORGFRONT

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio modelo a FRONTAL si UCSBASE está definida como UNIVERSAL.

    $UCSORGLEFT

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio modelo a IZQUIERDA si UCSBASE está definida como UNIVERSAL.

    $UCSORGRIGHT

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio modelo a DERECHA si UCSBASE está definida como UNIVERSAL.

    $UCSORGTOP

    10, 20, 30

    Punto que se convierte en el nuevo origen del SCP después de cambiar el valor de SCP en el espacio modelo a SUPERIOR si UCSBASE está definida como UNIVERSAL.

    $UCSORTHOREF

    2

    Si el SCP en el espacio modelo es ortogonal (UCSORTHOVIEW es distinto de 0), éste es el nombre del SCP al que se refiere el SCP ortogonal. Si está en blanco, el SCP se refiere a UNIVERSAL.

    $UCSORTHOVIEW

    70

    Tipo de vista ortogonal del SCP en el espacio modelo:
    0 = El SCP no es ortogonal;
    1 = Superior; 2 = Inferior;
    3 = Frontal; 4 = Posterior;
    5 = Izquierda; 6 = Derecha

    $UCSXDIR

    10, 20, 30

    Dirección del eje X del SCP actual (en SCU)

    $UCSYDIR

    10, 20, 30

    Dirección del eje Y del SCP actual (en SCU)

    $UNITMODE

    70

    Conjunto de bits menos significativos = Muestra los ángulos fraccionarios, en pies y pulgadas, y topográficos en formato de entrada.

    $USERI1 – 5

    70

    Cinco variables (números enteros) para que las utilicen desarrolladores de otros fabricantes

    $USERR1 – 5

    40

    Cinco variables (números reales) para que las utilicen desarrolladores de otros fabricantes

    $USRTIMER

    70

    0 = Cronómetro desactivado; 1 = Cronómetro activado

    $VERSIONGUID

    2

    Identifica de forma exclusiva la versión concreta de un dibujo. Se actualiza cuando se modifica el dibujo.

    $VISRETAIN

    70

    0 = No mantener los parámetros de visibilidad dependientes de referencias externas
    1 = Mantener los parámetros de visibilidad dependientes de referencias externas

    $WORLDVIEW

    70

    1 = Establece el SCP en SCU durante las operaciones de VISTADIN/PTOVISTA
    0 = No cambia el SCP

    $XCLIPFRAME

    290

    Controla la visibilidad de los contornos delimitadores de referencias externas:
    0 = El contorno delimitador no es visible
    1 = El contorno delimitador es visible

    $XEDIT

    290

    Controla si el dibujo actual puede modificarse in situ cuando es objeto de referencia de otro dibujo.
    0 = No se puede utilizar la edición de referencia in situ
    1 = Se puede utilizar la edición de referencia in situ

    Temas de esta sección:

    • Variables de encabezamiento VPORT revisadas
    • Gestión especial de variables de fecha y hora


Variables de encabezamiento VPORT revisadas [Manual de referencia de DXF: DXF]

Códigos de grupo de la sección HEADER
Variables de encabezamiento VPORT revisadas

    • Si bien las siguientes variables de la sección HEADER existían ya antes de AutoCAD® Release 11, ahora disponen de parámetros independientes para cada ventana gráfica activa. ABRE muestra estas variables cuando se leen desde archivos DXF™. Si hay una tabla de símbolos VPORT con entradas marcadas como *ACTIVE (como ocurre con todos los archivos DXF producidos por la versión R11 o versiones posteriores), los valores de las entradas de la tabla VPORT sustituyen a los valores de estas variables de encabezamiento.
    Variables de encabezamiento VPORT revisadas
Variable | Código de grupo | Descripción
$FASTZOOM | 70 | Zoom rápido activado si su valor es distinto de cero
$GRIDMODE | 70 | Modo rejilla activado si su valor es distinto de cero
$GRIDUNIT | 10, 20 | Intervalo de rejilla X e Y
$SNAPANG | 50 | Ángulo de rotación de malla de resolución
$SNAPBASE | 10, 20 | Punto base de resolución/rejilla (en SCP)
$SNAPISOPAIR | 70 | Plano isométrico: 0 = Izquierdo; 1 = Superior; 2 = Derecho
$SNAPMODE | 70 | Modo Forzcursor activado si su valor es distinto de cero
$SNAPSTYLE | 70 | Estilo de resolución: 0 = Estándar; 1 = Isométrico
$SNAPUNIT | 10, 20 | Intervalo de rejilla de resolución X e Y
$VIEWCTR | 10, 20 | Valores XY del centro de la vista actual en la pantalla
$VIEWDIR | 10, 20, 30 | Línea de mira (desde el punto del motivo en el SCU)
$VIEWSIZE | 40 | Altura de la vista


Gestión especial de variables de fecha y hora [Manual de referencia de DXF: DXF]

Códigos de grupo de la sección HEADER
Gestión especial de variables de fecha y hora

    • Las variables de sistema CDATE y DATE proporcionan acceso a la fecha y hora actuales. Las variables de sistema TDCREATE, TDINDWG, TDUPDATE y TDUSRTIMER (y las variables de HEADER $TDCREATE, $TDUCREATE, $TDUPDATE y $TDUUPDATE DXF) proporcionan acceso a las horas y fechas asociadas con el dibujo actual. Los valores vienen representados por números reales con significados propios, tal como se describe más adelante.

    DATE es la fecha y hora actuales representadas como fecha juliana y las fracciones del día en números reales.

    <Fecha juliana>.<Fracción del día>

    Por ejemplo, para el día 31 de diciembre de 1999, a las 9:58:35 p.m. GMT, la variable DATE contendría el siguiente valor:

    2451544.91568287

    La fecha y hora se toman del reloj del equipo al leer la variable. La hora se representa como una fracción del día, de modo que las horas que devuelve DATE pueden sustraerse para calcular diferencias horarias. Para extraer los segundos transcurridos desde la medianoche a partir del valor devuelto por DATE, deben utilizarse expresiones de AutoLISP:

    (setq s (getvar "DATE"))
    (setq seconds (* 86400.0 (- s (fix s))))

    Tenga en cuenta que la variable de sistema DATE sólo devolverá una fecha juliana válida si el reloj del sistema está definido en UTC/Zulu (hora del meridiano de Greenwich). TDCREATE y TDUPDATE tienen el mismo formato que DATE, pero sus valores representan la hora de creación y la hora de la última actualización del dibujo actual.

    TDINDWG y TDUSRTIMER (y las variables de encabezamiento DXF $TDINDWG y $TDUSRTIMER) utilizan un formato similar al de DATE, pero sus valores representan tiempos transcurridos, como en:

    <Número de días>.<Fracción del día>

    CDATE es la fecha y hora actuales en formato de calendario y de reloj. El valor devuelto es un número real con la siguiente forma:

    AAAAMMDD.HHMMSScseg

    donde

    AAAA = año
    MM = mes (01-12)
    DD = día (01-31)
    HH = hora (00-23)
    MM = minuto (00-59)
    SS = segundo (00-59)
    cseg = centésimas de segundo (00-99)

    Por ejemplo, si la fecha actual fuese 31 de diciembre de 1999 a las 9:58:35.75 p.m., CDATE mostraría el siguiente valor:

    19991231.21583575

    Tenga presente que los valores de CDATE pueden compararse entre sí para obtener valores posteriores o previos, pero que su sustracción no dará lugar a ningún número significativo.


Sección CLASSES [Manual de referencia de DXF: DXF]

Sección CLASSES

    • Los códigos de grupo que se describen en esta sección se encuentran sólo en archivos DXF™. La sección CLASSES contiene la información de las clases definidas por aplicaciones que aparecen en las secciones BLOCKS, ENTITIES y OBJECTS de la base de datos. Se entiende que la definición de una clase está fija permanentemente en la jerarquía de clases. Son precisos todos los campos.

    Temas de esta sección:

    • Códigos de grupo de la sección CLASSES


Códigos de grupo de la sección CLASSES [Manual de referencia de DXF: DXF]

Sección CLASSES
Códigos de grupo de la sección CLASSES

    • Cada entrada de la sección CLASSES contiene los grupos que se describen en la siguiente tabla:
    Códigos de grupo de la sección CLASSES
Código de grupo | Descripción
0 | Tipo de registro (CLASS). Identifica el comienzo de un registro CLASS.
1 | Nombre de registro DXF CLASS; siempre nombre único
2 | Nombre de clase C++. Se utiliza para enlazar con el software que define el comportamiento de la clase de objeto; siempre es un nombre único.
3 | Nombre de aplicación. Aparece en un cuadro de advertencia cuando una definición de clase indicada en esta sección no se encuentra actualmente cargada.
90 | Indicador de funciones proxy. Valor en bits que indica las funciones de este objeto como proxy: 0 = No se permiten operaciones (0) 1 = Se permite borrar (0x1) 2 = Se permite transformar (0x2) 4 = Se permite cambiar el color (0x4) 8 = Se permite cambiar la capa (0x8) 16 = Se permite cambiar el tipo de línea (0x10) 32 = Se permite cambiar la escala del tipo de línea (0x20) 64 = Se permite cambiar la visibilidad (0x40) 128 = Se permite la clonación (0x80) 256 = Se permite cambiar el grosor de línea (0x100) 512 = Se permite cambiar el nombre del estilo de trazado (0x200) 895 = Se permiten todas las operaciones excepto la clonación (0x37F) 1023 = Se permiten todas las operaciones (0x3FF) 1024 = Desactiva el cuadro de diálogo de advertencia de proxy (0x400) 32768 = Proxy en formato de la versión R13 (0x8000)
91 | Número de apariciones para una clase personalizada
280 | Indicador de antiguo proxy. Se establece en 1 si la clase no se cargó al crear este archivo DXF; de lo contrario se establece en 0.
281 | Indicador de entidad. Se define en 1 si la clase proviene de la clase AcDbEntity y puede residir en la sección BLOCKS o ENTITIES. Si tiene valor 0, las apariciones sólo se verán en la sección OBJECTS.

    Temas de esta sección:

    • Valores de clase por defecto


Valores de clase por defecto [Manual de referencia de DXF: DXF]

Códigos de grupo de la sección CLASSES
Valores de clase por defecto

    • AutoCAD registra las clases indicadas en la tabla siguiente. (Puede que la lista de clases posibles en los archivos DXF no esté completa, pues depende de las aplicaciones que AutoCAD® esté utilizando en ese momento.)
    Valores de clase por defecto
Nombre de registro DXF código 1 | Nombre de clase C++ código 2 | Código 90 | Código 280 | Código 281
ACDBDICTIONARYWDFLT | AcDbDictionaryWithDefault | 0 | 0 | 0
ACDBPLACEHOLDER | AcDbPlaceHolder | 0 | 0 | 0
ARCALIGNEDTEXT | AcDbArcAlignedText | 0 | 0 | 1
DICTIONARYVAR | AcDbDictionaryVar | 0 | 0 | 0
HATCH | AcDbHatch | 0 | 0 | 1
IDBUFFER | AcDbIdBuffer | 0 | 0 | 0
IMAGE | AcDbRasterImage | 127 | 0 | 1
IMAGEDEF | AcDbRasterImageDef | 0 | 0 | 0
IMAGEDEF_REACTOR | AcDbRasterImageDefReactor | 1 | 0 | 0
LAYER_INDEX | AcDbLayerIndex | 0 | 0 | 0
LAYOUT | AcDbLayout | 0 | 0 | 0
LWPOLYLINE | AcDbPolyline | 0 | 0 | 1
OBJECT_PTR | CAseDLPNTableRecord | 1 | 0 | 0
OLE2FRAME | AcDbOle2Frame | 0 | 0 | 1
PLOTSETTINGS | AcDbPlotSettings | 0 | 0 | 0
RASTERVARIABLES | AcDbRasterVariables | 0 | 0 | 0
TEXTOR | RText | 0 | 0 | 1
SORTENTSTABLE | AcDbSortentsTable | 0 | 0 | 0
SPATIAL_INDEX | AcDbSpatialIndex | 0 | 0 | 0
SPATIAL_FILTER | AcDbSpatialFilter | 0 | 0 | 0
WIPEOUT | AcDbWipeout | 127 | 0 | 1
WIPEOUTVARIABLES | AcDbWipeoutVariables | 0 | 0 | 0


Sección TABLES [Manual de referencia de DXF: DXF]

Sección TABLES

    • Los códigos de grupo que se describen en esta sección se encuentran en archivos DXF™ y los utilizan las aplicaciones. La sección TABLES contiene varias tablas, las cuales a su vez pueden contener un número variable de entradas. Las aplicaciones AutoLISP® y ObjectARX™ también emplean estos códigos en las listas de definición de entidades.

    Temas de esta sección:

    • Códigos de grupo de tabla de símbolos
    • Códigos de grupo comunes de tabla de símbolos
    • APPID
    • BLOCK_RECORD
    • DIMSTYLE
    • LAYER
    • LTYPE
    • STYLE
    • UCS
    • VIEW
    • VPORT


Códigos de grupo de tabla de símbolos [Manual de referencia de DXF: DXF]

Sección TABLES
Códigos de grupo de tabla de símbolos

    • El orden de las tablas puede variar, pero la tabla LTYPE precede siempre a la tabla LAYER. Cada tabla viene introducida por un grupo 0 con el identificador TABLE. A continuación, aparece un código de grupo 2 que identifica la tabla en cuestión (APPID, DIMSTYLE, LAYER, LTYPE, STYLE, UCS, VIEW, VPORT o BLOCK_RECORD), un código de grupo 5 (un identificador), un código de grupo 100 (marcador Subclass AcDbSymbolTable) y un código de grupo 70 que especifica el número máximo de entradas de tabla que pueden seguir. Los nombres de las tablas aparecen en mayúsculas. El identificador DIMSTYLE es un código de grupo 105, y no un código de grupo 5.

    Las tablas de un dibujo pueden tener elementos suprimidos, aunque dichos elementos no se escriben en el archivo DXF. Como resultado, tras el encabezamiento de la tabla, aparecen menos entradas de las indicadas en el código de grupo 70, por lo que no se debe utilizar la cantidad especificada en este grupo como índice para leer la tabla. Este grupo se proporciona de manera que el programa que lea los archivos DXF pueda asignar una matriz lo suficientemente grande como para contener todas las entradas de la tabla que siguen.

    Tras el encabezamiento de cada tabla, siguen sus entradas. Cada elemento de la tabla consta de un grupo 0 que identifica el tipo de elemento (al igual que el nombre de la tabla, como LTYPE o LAYER), un grupo 2 que proporciona el nombre de la entrada de la tabla, un grupo 70 que precisa los indicadores relevantes para la entrada de la tabla (definidos para cada tabla que sigue) y grupos adicionales que indican el valor de la entrada. El final de cada tabla viene indicado por un grupo 0 con el valor ENDTAB.

    Tanto los registros de tabla de símbolos como las tablas de símbolos son objetos de la base de datos. Como mínimo, con un uso preferente en AutoCAD®, esto implica que hay un identificador presente ubicado tras los códigos de grupo 2 tanto para los objetos de registro de tabla de símbolos como para los de tabla de símbolos.

    Debido a su uso anterior del código de grupo 5, la tabla DIMSTYLE es el único tipo de registro en el sistema con un código identificador 105. Como norma, los programadores no deberían preocuparse por esta excepción salvo en el contexto de la sección de la tabla DIMSTYLE. Este es el único contexto en el que se daría esta excepción.


Códigos de grupo comunes de tabla de símbolos [Manual de referencia de DXF: DXF]

Sección TABLES
Códigos de grupo comunes de tabla de símbolos

    • La siguiente tabla muestra los códigos de grupo aplicables a todas las tablas de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo aplicables a todas las tablas de símbolos
Código de grupo | Descripción
–1 | APL: nombre de entidad (cambia cada vez que se abre un dibujo)
0 | Tipo de objeto (TABLA)
2 | Nombre de tabla
5 | Identificador
102 | "{ACAD_XDICTIONARY" indica el inicio de un grupo de diccionario de extensiones. Este grupo sólo existe si se han asociado reactivos permanentes al objeto (opcional).
360 | Identificador/ID duro del diccionario propietario (opcional)
102 | Fin del grupo, "}" (opcional)
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario
100 | Marcador Subclass (AcDbSymbolTable)
70 | Número máximo de entradas en una tabla

    Temas de esta sección:

    • Códigos de grupo comunes para entradas de tabla de símbolos


Códigos de grupo comunes para entradas de tabla de símbolos [Manual de referencia de DXF: DXF]

Códigos de grupo comunes de tabla de símbolos
Códigos de grupo comunes para entradas de tabla de símbolos

    • La siguiente tabla muestra los códigos de grupo de todas las entradas de tabla de símbolos. Cuando haga referencia a la tabla de códigos de grupo por tipo de entidad, la cual enumera los códigos asociados a entidades concretas, tenga en cuenta que los códigos aquí enumerados también pueden estar presentes en ella. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo aplicables a todas las entradas de tabla de símbolos
Código de grupo | Descripción
–1 | APL: nombre de entidad (cambia cada vez que se abre un dibujo)
0 | Tipo de entidad (nombre de tabla)
5 | Identificador (todos excepto DIMSTYLE)
105 | Identificador (tabla DIMSTYLE solamente)
102 | Inicio del grupo definido por la aplicación "{nombre_aplicación". Por ejemplo, "{ACAD_REACTORS" indica el inicio del grupo de reactivos permanentes de AutoCAD (opcional).
códigos definidos por la aplicación | Los códigos y valores contenidos en los grupos 102 son definidos por la aplicación (opcional)
102 | Fin del grupo, "}" (opcional)
102 | "{ACAD_REACTORS" indica el inicio del grupo de reactivos permanentes de AutoCAD. Este grupo sólo existe si se han asociado reactivos permanentes al objeto (opcional).
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario (opcional)
102 | Fin del grupo, "}" (opcional)
102 | "{ACAD_XDICTIONARY" indica el inicio de un grupo de diccionario de extensiones. Este grupo sólo existe si se han asociado reactivos permanentes al objeto (opcional).
360 | Identificador/ID duro del diccionario propietario (opcional)
102 | Fin del grupo, "}" (opcional)
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario
100 | Marcador Subclass (AcDbSymbolTableRecord)


APPID [Manual de referencia de DXF: DXF]

Sección TABLES
APPID

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos APPID. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo APPID
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbRegAppTableRecord)
2 | Nombre de la aplicación (para datos extendidos) proporcionado por el usuario (o por la aplicación). Estas entradas de tabla mantienen un conjunto de nombres para todas las aplicaciones registradas.
70 | Valores de indicador estándar (valores en bits): 1 = Si se establece, los datoseX asociados con esta APPID no se escriben cuando se ejecuta GUARDCOMO12. 16 = Si se establece, la entrada de tabla es dependiente externamente de una refX. 32 = Si se establecen este bit y el bit 16, se resuelve de manera satisfactoria la refX dependiente externamente. 64 = Si se establece, al menos una entidad del dibujo hizo referencia a la entrada de tabla la última vez que se editó el dibujo. (Este indicador sirve en beneficio de la mejora de los comandos de AutoCAD. Puede ignorarse en la mayoría de los programas que leen archivos DXF y no necesita definirse en los que escriben archivos DXF.)


BLOCK_RECORD [Manual de referencia de DXF: DXF]

Sección TABLES
BLOCK_RECORD

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos BLOCK_RECORD. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.

    Códigos de grupo BLOCK_RECORD

    Códigos de grupo

    Descripción

    100

    Marcador Subclass (AcDbBlockTableRecord)

    2

    Nombre de bloque

    340

    Identificador/ID de dispositivo señalador duro para objeto LAYOUT asociado

    310

    DXF: datos binarios para imagen preliminar de mapa de bits (opcional)

    1001

    Nombre de aplicación de datoseX "ACAD" (opcional)

    1000

    Datos de cadena de datoseX "Datos de DesignCenter" (opcional)

    1002

    Inicio de datoseX "{" (opcional)

    1070

    Número de versión de Autodesk Design Center

    1070

    Unidades de inserción:
    0 = Sin unidad; 1 = Pulgadas; 2 = Pies; 3 = Millas; 4 = Milímetros;
    5 = Centímetros; 6 = Metros; 7 = Kilómetros; 8 = Micropulgadas;
    9 = Milipulgadas; 10 = Yardas; 11 = Angstroms; 12 = Nanómetros;
    13 = Micrómetros; 14 = Decímetros; 15 = Decámetros;
    16 = Hectómetros; 17 = Gigámetros; 18 = Unidades astronómicas;
    19 = Años luz; 20 = Parsecs

    1002

    Fin de datoseX "}"


DIMSTYLE [Manual de referencia de DXF: DXF]

Sección TABLES
DIMSTYLE

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos DIMSTYLE. Las variables de sistema DIMSTYLE se describen en "Variable de sistema" en Lista de comandos de AutoCAD. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo DIMSTYLE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbDimStyleTableRecord)
2 | Nombre de estilo de cota
70 | Valores de indicador estándar (valores en bits): 16 = Si se establece, la entrada de tabla es dependiente externamente de una refX. 32 = Si se establecen este bit y el bit 16, se resuelve de manera satisfactoria la refX dependiente externamente. 64 = Si se establece, al menos una entidad del dibujo hizo referencia a la entrada de tabla la última vez que se editó el dibujo. (Este indicador sirve para mejorar los comandos de AutoCAD® . Puede ignorarse en la mayoría de los programas que leen archivos DXF™ y no necesita definirse en los que escriben archivos DXF.)
3 | DIMPOST
4 | DIMAPOST
5 | DIMBLK (obsoleto, ahora ID de objeto)
6 | DIMBLK1 (obsoleto, ahora ID de objeto)
7 | DIMBLK2 (obsoleto, ahora ID de objeto)
40 | DIMSCALE
41 | DIMASZ
42 | DIMEXO
43 | DIMDLI
44 | DIMEXE
45 | DIMRND
46 | DIMDLE
47 | DIMTP
48 | DIMTM
140 | DIMTXT
141 | DIMCEN
142 | DIMTSZ
143 | DIMALTF
144 | DIMLFAC
145 | DIMTVP
146 | DIMTFAC
147 | DIMGAP
148 | DIMALTRND
71 | DIMTOL
72 | DIMLIM
73 | DIMTIH
74 | DIMTOH
75 | DIMSE1
76 | DIMSE2
77 | DIMTAD
78 | DIMZIN
79 | DIMAZIN
170 | DIMALT
171 | DIMALTD
172 | DIMTOFL
173 | DIMSAH
174 | DIMTIX
175 | DIMSOXD
176 | DIMCLRD
177 | DIMCLRE
178 | DIMCLRT
179 | DIMADEC
270 | DIMUNIT (obsoleto, utilice DIMLUNIT y DIMFRAC)
271 | DIMDEC
272 | DIMTDEC
273 | DIMALTU
274 | DIMALTTD
275 | DIMAUNIT
276 | DIMFRAC
277 | DIMLUNIT
278 | DIMDSEP
279 | DIMTMOVE
280 | DIMJUST
281 | DIMSD1
282 | DIMSD2
283 | DIMTOLJ
284 | DIMTZIN
285 | DIMALTZ
286 | DIMALTTZ
287 | DIMFIT (obsoleto, utilice DIMATFIT y DIMTMOVE)
288 | DIMUPT
289 | DIMATFIT
340 | DIMTXSTY (indicador de ESTILO referenciado)
341 | DIMLDRBLK (indicador de BLOQUE referenciado)
342 | DIMALTZ (indicador de BLOQUE referenciado)
343 | DIMBLK1 (indicador de BLOQUE referenciado)
344 | DIMBLK2 (indicador de BLOQUE referenciado)
371 | DIMLWD (valor de enumeración de grosor de línea)
372 | DIMLWE (valor de enumeración de grosor de línea)


LAYER [Manual de referencia de DXF: DXF]

Sección TABLES
LAYER

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos LAYER. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo LAYER
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbLayerTableRecord)
2 | Nombre de capa
70 | Indicadores estándar (valores en bits): 1 = La capa está inutilizada; en cualquier otro caso, la capa está reutilizada. 2 = La capa está inutilizada por defecto en las nuevas ventanas gráficas. 4 = La capa está bloqueada. 16 = Si se establece, la entrada de tabla es dependiente externamente de una refX. 32 = Si se establecen este bit y el bit 16, se resuelve de manera satisfactoria la refX dependiente externamente. 64 = Si se establece, al menos una entidad del dibujo hizo referencia a la entrada de tabla la última vez que se editó el dibujo. (Este indicador sirve en beneficio de la mejora de los comandos de AutoCAD. Puede ignorarse en la mayoría de los programas que leen archivos DXF y no necesita definirse en los que escriben archivos DXF.)
62 | Número de color (si es negativo, la capa está desactivada)
6 | Nombre de tipo de línea
290 | Indicador de impresión. Si se establece en 0, esta capa no se imprime.
370 | Valor de enumeración de grosor de línea
390 | Identificador/ID de dispositivo señalador duro del objeto PlotStyleName

    Las capas dependientes de referencias externas se generan durante la ejecución del comando GUARDARCOMO. En estas capas, el nombre de tipo de línea asociado en el archivo DXF siempre es CONTINUOUS.


LTYPE [Manual de referencia de DXF: DXF]

Sección TABLES
LTYPE

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos LTYPE. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo LTYPE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbLinetypeTableRecord)
2 | Nombre de tipo de línea
70 | Valores de indicador estándar (valores en bits): 16 = Si se establece, la entrada de tabla es dependiente externamente de una refX. 32 = Si se establecen este bit y el bit 16, se resuelve de manera satisfactoria la refX dependiente externamente. 64 = Si se establece, al menos una entidad del dibujo hizo referencia a la entrada de tabla la última vez que se editó el dibujo. (Este indicador sirve en beneficio de la mejora de los comandos de AutoCAD. Puede ignorarse en la mayoría de los programas que leen archivos DXF y no necesita definirse en los que escriben archivos DXF.)
3 | Texto descriptivo para el tipo de línea
72 | Código de alineación; el valor es siempre 65, el código ASCII para la letra A
73 | Número de elementos de tipo de línea
40 | Longitud total de patrón
49 | Longitud de trazo, punto o espacio (una entrada por elemento)
74 | Tipo de elemento de tipo de línea complejo (uno por elemento). El valor por defecto es 0 (sin forma/texto incrustado). Los códigos siguientes son valores en bits: 1 = Si se establece, el código 50 especifica una rotación absoluta; si no, una relativa. 2 = El elemento incrustado es una cadena de texto. 4 = El elemento incrustado es una forma.
75 | Número de formas (una por elemento) si el código 74 especifica una forma incrustada. Si el código 74 especifica una cadena de texto incrustada, este valor se establecerá en 0. Si el código 74 se establece en 0, se omitirá el código 75.
340 | Dispositivo señalador para el objeto STYLE (uno por elemento si código 74 > 0)
46 | S = Valor de escala (opcional); puede haber varias entradas
50 | Valor de rotación R = (relativa) o A = (absoluta) en radianes de forma o texto incrustados; uno por elemento si el código 74 especifica una forma o cadena de texto incrustada.
44 | X = Valor de desfase X (opcional); pueden existir varias entradas
45 | Y = Valor de desfase Y (opcional); pueden existir varias entradas
9 | Cadena de texto (uno por elemento si el código es 74 = 2)

    Las funciones tblsearch y tblnext no devuelven los códigos de grupo 74, 75, 340, 46, 50, 44, 45 y 9. Para recuperar estos valores dentro de una aplicación, deberá utilizar tblobjname.


STYLE [Manual de referencia de DXF: DXF]

Sección TABLES
STYLE

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos STYLE. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo STYLE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbTextStyleTableRecord)
2 | Nombre de estilo.
70 | Valores de indicador estándar (valores en bits): 1 = Si se establece, esta entrada describe una forma. 4 = Texto vertical. 16 = Si se establece, la entrada de tabla es dependiente externamente de una refX. 32 = Si se establecen este bit y el bit 16, se resuelve de manera satisfactoria la refX dependiente externamente. 64 = Si se establece, al menos una entidad del dibujo hizo referencia a la entrada de tabla la última vez que se editó el dibujo. (Este indicador sirve en beneficio de la mejora de los comandos de AutoCAD®. Puede ignorarse en la mayoría de los programas que leen archivos DXF y no necesita definirse en los que escriben archivos DXF.)
40 | Altura de texto fija; 0 si no es fija
41 | Factor de anchura.
50 | Ángulo oblicuo
71 | Indicadores de generación de texto: 2 = El texto aparece de derecha a izquierda (reflejado en X) 4 = El texto se muestra cabeza abajo (reflejado en Y)
42 | Última altura utilizada
3 | Nombre de archivo del tipo de letra principal
4 | Nombre de archivo de tipos de letra grandes; vacío si no hay ninguno.

    También se utiliza un elemento de la tabla STYLE para registrar las solicitudes del comando CARGA en el archivo de forma. En este caso, el primer bit (1) se define en los indicadores de grupo 70 y sólo es significativo el grupo 3 (nombre de archivo de forma); no obstante, se generan todos los demás grupos.


UCS [Manual de referencia de DXF: DXF]

Sección TABLES
UCS

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos UCS. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo UCS
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbUCSTableRecord)
2 | Nombre de SCP
70 | Valores de indicador estándar (valores en bits): 16 = Si se establece, la entrada de tabla es dependiente externamente de una refX. 32 = Si se establecen este bit y el bit 16, se resuelve de manera satisfactoria la refX dependiente externamente. 64 = Si se establece, al menos una entidad del dibujo hizo referencia a la entrada de tabla la última vez que se editó el dibujo. (Este indicador sirve en beneficio de la mejora de los comandos de AutoCAD. Puede ignorarse en la mayoría de los programas que leen archivos DXF y no necesita definirse en los que escriben archivos DXF.)
10 | Origen (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z de origen (en el SCU)
11 | Dirección del eje X (en el SCU) DXF: valor X; APL: vector 3D
21, 31 | DXF: valores Y y Z de la dirección del eje X (en el SCU)
12 | Dirección del eje Y (en el SCU) DXF: valor X; APL: vector 3D
22, 32 | DXF: valores Y y Z de la dirección del eje Y (en el SCU)
79 | Siempre 0
146 | Elevación
346 | ID/identificador del SCP base si éste es ortogonal. Este código no estará presente si el valor del código 79 es 0. Si no está presente pero el valor del código 79 es distinto de cero, entonces se entiende que el SCP es UNIVERSAL.
71 | Tipo ortogonal (opcional; siempre se muestra en pares con los códigos 13, 23 y 33): 1 = Superior; 2 = Inferior 3 = Frontal; 4 = Posterior 5 = Izquierda; 6 = Derecha
13 | Origen de este tipo ortogonal relativo a este SCP DXF: valor X del punto de origen; APL: punto 3D
23, 33 | DXF: valores Y y Z del punto de origen

    Cada par 71/13,23,33 define el origen del SCP para un tipo ortogonal determinado en relación con ese SCP. Por ejemplo, si está presente el siguiente par, al ejecutar el comando SCP/IZQUIERDA cuando UCSBASE esté definido en ese SCP, el valor del nuevo origen del SCP será (1,2,3).

    71: 513: 1.023: 2.033: 3.0

    Si este par no se encuentra presente al ejecutar el comando SCP/IZQUIERDA, el nuevo origen de SCP se definirá en el punto de origen del SCP.


VIEW [Manual de referencia de DXF: DXF]

Sección TABLES
VIEW

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos VIEW. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo VIEW
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbViewTableRecord)
2 | Nombre de la vista
70 | Valores de indicador estándar (valores en bits): 1 = Si se establece, ésta es una vista del espacio papel. 16 = Si se establece, la entrada de tabla es dependiente externamente de una refX. 32 = Si se establecen este bit y el bit 16, se resuelve de manera satisfactoria la refX dependiente externamente. 64 = Si se establece, al menos una entidad del dibujo hizo referencia a la entrada de tabla la última vez que se editó el dibujo. (Este indicador sirve en beneficio de la mejora de los comandos de AutoCAD. Puede ignorarse en la mayoría de los programas que leen archivos DXF y no necesita definirse en los que escriben archivos DXF.)
40 | Altura de la vista (en SCV)
10 | Punto central de la vista (en el SCV) DXF: valor X; APL: punto 2D
20 | DXF: valor Y del punto central de la vista (en el SCV)
41 | Anchura de la vista (en SCV)
11 | Dirección de la vista desde el motivo (en el SCU) DXF: valor X; APL: vector 3D
21, 31 | DXF: valores Y y Z de la dirección de la vista desde el motivo (en el SCU)
12 | Punto del motivo (en el SCU) DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z del punto del motivo (en el SCU)
42 | Distancia focal
43 | Plano delimitador frontal (desfase desde el punto del motivo)
44 | Plano delimitador posterior (desfase desde el punto del motivo)
50 | Ángulo de ladeo
71 | Modo de visualización (véase la variable de sistema VIEWMODE)
281 | Modo de modelizado: 0 = Optimización 2D (2D clásico) 1 = Estructura alámbrica 2 = Línea oculta 3 = Sombreado plano 4 = Sombreado Gouraud 5 = Sombreado plano con estructura alámbrica 6 = Sombreado Gouraud con estructura alámbrica Todos los modos de modelizado salvo Optimización 2D utilizan el nuevo proyecto de gráficos 3D. Estos valores se corresponden directamente con el comando MODOSOMBRA y la enumeración AcDbAbstractViewTableRecord::RenderMode.
72 | 1 si hay un SCP asociado a esta vista, 0 si no lo hay.

    Los siguientes códigos sólo aparecen si el código 72 tiene el valor 1. Definen el SCP asociado a esta vista. Este SCP se convertirá en el SCP actual siempre que se restablezca la vista (si el código 72 tiene el valor 0, el SCP no se modifica).

    VIEW con códigos de grupo SCP

    Códigos de grupo

    Descripción

    110

    Origen del SCP (sólo aparece si el código 72 tiene el valor 1)
    DXF: valor X; APL: punto 3D

    120, 130

    DXF: valores Y y Z del origen del SCP

    111

    Eje X de SCP (sólo aparece si el código 72 tiene el valor 1)
    DXF: valor X; APL: vector 3D

    121, 131

    DXF: valores Y y Z del eje X del SCP

    112

    Eje Y de SCP (sólo aparece si el código 72 tiene el valor 1)
    DXF: valor X; APL: vector 3D

    122, 132

    DXF: valores Y y Z del eje Y del SCP

    79

    Tipo ortogonal de SCP (sólo aparece si el código 72 tiene el valor 1)
    0 = El SCP no es ortogonal;
    1 = Superior; 2 = Inferior;
    3 = Frontal; 4 = Posterior;
    5 = Izquierda; 6 = Derecha

    146

    Elevación de SCP (sólo aparece si el código 72 tiene el valor 1)

    345

    Identificador/ID de AcDbUCSTableRecord si el SCP es un SCP guardado. Si no existe, el SCP no se habrá guardado (sólo aparece si el código 72 está establecido en 1).

    346

    Identificador/ID de AcDbUCSTableRecord del SCP base si el SCP es ortogonal (el código 79 es distinto de cero). Si no existe y el código 79 es distinto de cero, se entiende que el SCP base es UNIVERSAL (sólo aparece si el código 72 está establecido en 1).


VPORT [Manual de referencia de DXF: DXF]

Sección TABLES
VPORT

    • Los siguientes códigos de grupo se aplican a las entradas de la tabla de símbolos VPORT. La tabla VPORT es exclusiva: puede contener varias entradas con el mismo nombre (lo que indica una configuración de múltiples ventanas gráficas). Las entradas que corresponden a la configuración de la ventana gráfica activa tienen todas el nombre *ACTIVE. La primera de estas entradas describe la ventana gráfica en uso. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entradas de tabla de símbolos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo VPORT
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbViewportTableRecord)
2 | Nombre de ventana gráfica
70 | Valores de indicador estándar (valores en bits): 16 = Si se establece, la entrada de tabla es dependiente externamente de una refX. 32 = Si se establecen este bit y el bit 16, se resuelve de manera satisfactoria la refX dependiente externamente. 64 = Si se establece, al menos una entidad del dibujo hizo referencia a la entrada de tabla la última vez que se editó el dibujo. (Este indicador sirve en beneficio de la mejora de los comandos de AutoCAD. Puede ignorarse en la mayoría de los programas que leen archivos DXF y no necesita definirse en los que escriben archivos DXF.)
10 | Esquina inferior izquierda de la ventana gráfica DXF: valor X; APL: punto 2D
20 | DXF: valor Y de la esquina inferior izquierda de la ventana gráfica
11 | Esquina superior derecha de la ventana gráfica DXF: valor X; APL: punto 2D
21 | DXF: valor Y de la esquina superior derecha de la ventana gráfica
12 | Punto central de la vista (en el SCV) DXF: valor X; APL: punto 2D
22 | DXF: valor Y del punto central de la vista (en el SCV)
13 | Punto base de resolución DXF: valor X; APL: punto 2D
23 | DXF: valor Y del punto base de resolución
14 | Distancia de resolución X e Y DXF: valor X; APL: punto 2D
24 | DXF: valor Y de la distancia de resolución X e Y
15 | Intervalo de rejilla X e Y DXF: valor X; APL: punto 2D
25 | DXF: valor Y del intervalo de la rejilla X e Y
16 | Dirección de la vista desde el punto del motivo (en el SCU) DXF: valor X; APL: punto 3D
26, 36 | DXF: valores Y y Z de la dirección de la vista desde el punto del motivo (en el SCU)
17 | Punto del motivo de la vista (en el SCU) DXF: valor X; APL: punto 3D
27, 37 | DXF: valores Y y Z del punto del motivo de la vista (en el SCU)
40 | Altura de la vista
41 | Relación de altura y anchura de la ventana gráfica
42 | Distancia focal
43 | Plano delimitador frontal (desfase desde el punto del motivo)
44 | Plano delimitador posterior (desfase desde el punto del motivo)
50 | Ángulo de rotación de resolución
51 | Angulo de ladeo de la vista
68 | APL: campo de estado (nunca se guarda en DXF)
69 | APL: ID (nunca se guarda en DXF)
71 | Modo de visualización (véase la variable de sistema VIEWMODE)
72 | Porcentaje de zoom del círculo
73 | Parámetro de zoom rápido
74 | Parámetro SIMBSCP
75 | Forzcursor activado o desactivado
76 | Rejilla activada o desactivada
77 | Estilo de resolución
78 | Isopar de resolución
281 | Modo de modelizado: 0 = Optimización 2D (2D clásico) 1 = Estructura alámbrica 2 = Línea oculta 3 = Sombreado plano 4 = Sombreado Gouraud 5 = Sombreado plano con estructura alámbrica 6 = Sombreado Gouraud con estructura alámbrica Todos los modos de modelizado salvo Optimización 2D utilizan el nuevo proyecto de gráficos 3D. Estos valores se corresponden directamente con el comando MODOSOMBRA y la enumeración AcDbAbstractViewTableRecord::RenderMode.
65 | Valor de UCSVP para esta ventana gráfica. Si tiene el valor 1, la ventana gráfica guarda el SCP que se convertirá en el SCP actual siempre que la ventana gráfica esté activa. Si se establece en 0, el SCP no cambiará cuando la ventana gráfica esté activa.
110 | SCP, origen DXF: valor X; APL: punto 3D
120, 130 | DXF: valores Y y Z del origen del SCP
111 | Eje X del SCP DXF: valor X; APL: vector 3D
121, 131 | DXF: valores Y y Z del eje X del SCP
112 | Eje Y del SCP DXF: valor X; APL: vector 3D
122, 132 | DXF: valores Y y Z del eje Y del SCP
79 | Tipo ortogonal del SCP 0 = El SCP no es ortogonal; 1 = Superior; 2 = Inferior 3 = Frontal; 4 = Posterior 5 = Izquierda; 6 = Derecha
146 | Elevación
345 | Identificador/ID de AcDbUCSTableRecord si el SCP es un SCP guardado. Si no existe, el SCP no se ha guardado.
346 | Identificador/ID de AcDbUCSTableRecord del SCP base si el SCP es ortogonal (el código 79 es distinto de cero). Si no existe y el código 79 es distinto de cero, se entiende que el SCP base es UNIVERSAL.


Sección BLOCKS [Manual de referencia de DXF: DXF]

Sección BLOCKS

    • Los códigos de grupo que se describen en este capítulo se encuentran en archivos DXF™ y los utilizan las aplicaciones. La sección BLOCKS contiene una entrada para cada una de las referencias a un bloque del dibujo.

    Temas de esta sección:

    • Códigos de grupo de la sección BLOCKS
    • BLOCK
    • ENDBLK


Códigos de grupo de la sección BLOCKS [Manual de referencia de DXF: DXF]

Sección BLOCKS
Códigos de grupo de la sección BLOCKS

    • La sección BLOCKS del archivo DXF contiene todas las definiciones de bloque, incluidos los bloques sin nombre generados por el comando SOMBREA y por las cotas asociativas. Cada definición de bloque contiene las entidades que conforman dicho bloque tal como se utiliza en el dibujo. El formato de las entidades de esta sección es idéntico al de las entidades de la sección ENTITIES. Todas las entidades de la sección BLOCKS aparecen entre las entidades BLOCK y ENDBLK. Las entidades BLOCK y ENDBLK aparecen sólo en la sección BLOCKS. Las definiciones de bloque no aparecen nunca anidadas (es decir, nunca aparece una entidad BLOCK y ENDBLK dentro de otro par BLOCK-ENDBLK), aunque sí pueden contener entidades insertadas.

    Las referencias externas se escriben en el archivo DXF como definiciones de bloque, excepto que incluyen también una cadena (código de grupo 1) que especifica la ruta y el nombre de archivo de la referencia externa.

    El identificador de la tabla de bloques, junto con los datoseX y los reactivos permanentes, aparece en cada definición de bloque inmediatamente después del registro BLOCK, el cual contiene toda la información específica almacenada por un registro de la tabla de bloques.


BLOCK [Manual de referencia de DXF: DXF]

Sección BLOCKS
BLOCK

    • Los siguientes son los códigos de grupo aplicables a las entidades de bloque. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo BLOCK
Códigos de grupo | Descripción
0 | Tipo de entidad (BLOCK)
5 | Identificador
102 | Inicio del grupo definido por la aplicación "{nombre_aplicación". Por ejemplo, "{ACAD_REACTORS" indica el inicio del grupo de reactivos permanentes de AutoCAD (opcional).
códigos definidos por la aplicación | Los códigos y valores contenidos en los grupos 102 son definidos por la aplicación (opcional)
102 | Fin del grupo, "}" (opcional)
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario
100 | Marcador Subclass (AcDbEntity)
8 | Nombre de capa
100 | Marcador Subclass (AcDbBlockBegin)
2 | Nombre de bloque
70 | Indicadores de tipo de bloque (valores en bits; pueden ser combinados): 0 = Indica que no se aplica ninguno de los siguientes indicadores 1 = Éste es un bloque sin nombre generado por sombreado, cotas asociativas, otras operaciones internas o una aplicación 2 = Este bloque tiene definiciones de atributos no constantes (este bit no se establece si el bloque tiene cualquier definición de atributos constante o si no tiene ninguna definición de atributos) 4 = Este bloque es una referencia externa (refX) 8 = Este bloque es una superposición de refX 16 = Este bloque es dependiente externamente 32 = Este bloque es una referencia externa resuelta, o bien dependiente de una referencia externa (ignorado en la entrada) 64 = Esta definición es una referencia externa referenciada (ignorado en la entrada)
10 | Punto base DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto base
3 | Nombre de bloque
1 | Nombre de ruta de refX
4 | Descripción del bloque (opcional)

    Cuando se crea una definición de bloque, el SCP activo se convierte en el SCU para todas las entidades de la definición de bloque. El nuevo origen de estas entidades cambia para ajustarse al punto base definido para la definición de bloque. Todos los datos de las entidades se convierten para adaptarse al nuevo SCU.

    Definiciones de bloque en el espacio modelo y el espacio papel

    La sección BLOCKS muestra siempre tres definiciones vacías que se titulan *Model_Space, *Paper_Space y *Paper_Space0. Estas definiciones manifiestan las representaciones del espacio modelo y el espacio papel como definiciones de bloque internamente. El nombre interno de la primera presentación en el espacio papel es *Paper_Space, el de la segunda *Paper_Space0, el de la tercera *Paper_Space1 y así sucesivamente.

    Segregación de entidades del espacio modelo y el espacio papel

    El intercalado entre el espacio papel y el espacio modelo ya no se produce. En lugar de ello, todas las entidades del espacio papel aparecen seguidas por las entidades del espacio modelo. El indicador que las distingue es el código de grupo 67.


ENDBLK [Manual de referencia de DXF: DXF]

Sección BLOCKS
ENDBLK

    • Los siguientes son los códigos de grupo aplicables a los objetos endblk. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ENDBLK
Códigos de grupo | Descripción
0 | Tipo de entidad (ENDBLK)
5 | Identificador
102 | Inicio del grupo definido por la aplicación "{nombre_aplicación". Por ejemplo, "{ACAD_REACTORS" indica el inicio del grupo de reactivos permanentes de AutoCAD (opcional).
códigos definidos por la aplicación | Los códigos y valores contenidos en los grupos 102 son definidos por la aplicación (opcional)
102 | Fin del grupo, "}" (opcional)
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario
100 | Marcador Subclass (AcDbEntity)
8 | Nombre de capa
100 | Marcador Subclass (AcDbBlockEnd)


Sección ENTITIES [Manual de referencia de DXF: DXF]

Sección ENTITIES

    • En este capítulo se presentan los códigos de grupo aplicables a los objetos gráficos. Estos códigos se encuentran en la sección ENTITIES de un archivo DXF™; las aplicaciones AutoLISP® y ObjectARX™ también emplean estos códigos en las listas de definición de entidades.

    Temas de esta sección:

    • Códigos de grupo comunes para entidades
    • 3DFACE
    • 3DSOLID
    • ACAD_PROXY_ENTITY
    • ARC
    • ATTDEF
    • ATTRIB
    • BODY
    • CIRCLE
    • DIMENSION
    • ELLIPSE
    • HATCH
    • IMAGE
    • INSERT
    • LEADER
    • LINE
    • LWPOLYLINE
    • MLINE
    • MTEXT
    • OLEFRAME
    • OLE2FRAME
    • POINT
    • POLYLINE
    • RAY
    • REGION
    • SEQEND
    • SHAPE
    • SOLID
    • SPLINE
    • TEXT
    • TOLERANCE
    • TRACE
    • VERTEX
    • VIEWPORT
    • XLINE


Códigos de grupo comunes para entidades [Manual de referencia de DXF: DXF]

Sección ENTITIES
Códigos de grupo comunes para entidades

    • La siguiente tabla muestra los códigos de grupo aplicables a casi la totalidad de objetos gráficos. Algunos de éstos aparecen junto con una definición de entidad cuando la entidad no dispone de valores por defecto como propiedad. Tenga en cuenta que, al hacer referencia a códigos de grupo por tipo de entidad (listas de códigos asociados a entidades específicas), los códigos que aquí se muestran estarán también presentes.

    Nota No desarrolle programas que dependan del orden indicado en estas tablas de códigos DXF. Aunque estas tablas muestran el orden en el que los códigos de grupo suelen aparecer, éste puede variar bajo determinadas condiciones o en versiones futuras de AutoCAD®. El código que controla una entidad deberá controlarse mediante un conmutador o una tabla de manera que pueda procesar cada grupo correctamente, incluso si el orden es distinto al habitual.

    Cuando se omite un grupo, su valor por defecto en la entrada (al utilizar el comando ABRE) se indicará en la tercera columna. Si el valor de un código de grupo es igual al valor por defecto, se omitirá al realizar la salida (cuando se utiliza GUARDARCOMO). Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo aplicables a todos los objetos gráficos
Código de grupo | Descripción | Si se omite, se utiliza por defecto...
–1 | APL: nombre de entidad (cambia cada vez que se abre un dibujo) | no se omite
0 | Tipo de entidad | no se omite
5 | Identificador | no se omite
102 | Inicio del grupo definido por la aplicación "{nombre_aplicación" (opcional) | valores no por defecto
códigos definidos por la aplicación | Los códigos y valores contenidos en los grupos 102 están definidos por la aplicación (opcional) | valores no por defecto
102 | Fin del grupo, "}" (opcional) | valores no por defecto
102 | "{ACAD_REACTORS" indica el inicio del grupo de reactivos permanentes de AutoCAD. Este grupo sólo existe si se han asociado reactivos permanentes a este objeto (opcional). | valores no por defecto
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario (opcional) | valores no por defecto
102 | Fin del grupo, "}" (opcional) | valores no por defecto
102 | "{ACAD_XDICTIONARY" indica el inicio de un grupo de diccionario de extensión. Este grupo sólo existe si se ha asociado un diccionario de extensión al objeto (opcional). | valores no por defecto
360 | Identificador/ID duro del diccionario propietario (opcional) | valores no por defecto
102 | Fin del grupo, "}" (opcional) | valores no por defecto
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario BLOCK_RECORD | no se omite
100 | Marcador Subclass (AcDbEntity) | no se omite
67 | Si se omite o si su valor es cero, indica que la entidad está en espacio modelo. El valor 1 indica que se encuentra en espacio papel (opcional). | 0
410 | APL: nombre de ficha de presentación | no se omite
8 | Nombre de capa | no se omite
6 | Nombre del tipo de línea (presente si no es BYLAYER). El nombre especial BYBLOCK indica un tipo de línea flotante (opcional). | BYLAYER
62 | Número de color (presente si no es BYLAYER); cero indica el color BYBLOCK (flotante); 256 indica BYLAYER; un valor negativo indica que la capa está desactivada (opcional) | BYLAYER
370 | Valor de enumeración de grosor de línea. Se guarda y se mueve como número entero de 16 bits. | no se omite
48 | Escala del tipo de línea (opcional) | 1.0
60 | Visibilidad del objeto (opcional): 0 = Visible; 1 = Invisible | 0
92 | Número de bytes en los gráficos de entidad proxy representados en los grupos 310 subsiguientes, que son registros de bloques binarios (opcional). | valores no por defecto
310 | Datos gráficos de entidad proxy (varias líneas; máximo 256 caracteres por línea) (opcional) | valores no por defecto
420 | Valor de color de 24 bits que se debería tratar en términos de bytes con valores entre 0 y 255. El byte menos significativo representa el valor de azul, el siguiente el valor de verde y el tercero el valor de rojo. El byte más significativo siempre es 0. Las entidades personalizadas no pueden utilizar el código de grupo para sus propios datos, ya que el código de grupo está reservado para datos de color a nivel de clase de AcDbEntity y datos de transparencia a nivel de clase de AcDbEntity. | valores no por defecto
430 | Nombre del color. Las entidades personalizadas no pueden utilizar el código de grupo para sus propios datos, ya que el código de grupo está reservado para datos de color a nivel de clase de AcDbEntity y datos de transparencia a nivel de clase de AcDbEntity. | valores no por defecto
440 | Valor de la transparencia. Las entidades personalizadas no pueden utilizar el código de grupo para sus propios datos, ya que el código de grupo está reservado para datos de color a nivel de clase de AcDbEntity y datos de transparencia a nivel de clase de AcDbEntity. | valores no por defecto


3DFACE [Manual de referencia de DXF: DXF]

Sección ENTITIES
3DFACE

    • Los siguientes son los códigos de grupo aplicables a las entidades de cara 3D. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo 3DFACE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbFace)
10 | Primera esquina (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z de la primera esquina (en el SCU)
11 | Segunda esquina (en el SCU) DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z de la segunda esquina (en el SCU)
12 | Tercera esquina (en el SCU) DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z de la tercera esquina (en el SCU)
13 | Cuarta esquina (en el SCU) Si sólo se introducen tres esquinas, ésta es igual a la tercera. DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z de la cuarta esquina (en el SCU)
70 | Indicadores de aristas no visibles (opcional; por defecto = 0): 1 = Primera arista no visible 2 = Segunda arista no visible 4 = Tercera arista no visible 8 = Cuarta arista no visible


3DSOLID [Manual de referencia de DXF: DXF]

Sección ENTITIES
3DSOLID

    • Los siguientes son los códigos de grupo aplicables a las entidades de sólido 3D. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo 3DSOLID
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbModelerGeometry)
70 | Número de versión de formato del modelador (actualmente = 1)
1 | Datos de propiedad (varias líneas < 255 caracteres cada una)
3 | Líneas adicionales de datos de propiedad (si la cadena del grupo 1 anterior tiene más de 255 caracteres) (opcional)


ACAD_PROXY_ENTITY [Manual de referencia de DXF: DXF]

Sección ENTITIES
ACAD_PROXY_ENTITY

    • Los siguientes son los códigos de grupo aplicables a las entidades proxy. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ACAD_PROXY_ENTITY
Códigos de grupo | Descripción
100 | DXF™: AcDbProxyEntity
90 | DXF: ID de clase de entidad proxy (siempre 498)
91 | DXF: Identificador de clase de entidad de la aplicación. Los identificadores de clase se basan en el orden de clases de la sección CLASSES. A la primera clase se le asigna el ID 500, a la siguiente el 501, y así sucesivamente.
92 | DXF: tamaño de los datos gráficos en bytes
310 | DXF: datos gráficos binarios (pueden aparecer varias entradas) (opcional)
93 | DXF: tamaño de datos de la entidad en bits
310 | DXF: datos de entidad binarios (pueden aparecer varias entradas) (opcional)
330 o 340 o 350 o 360 | DXF: un ID de objeto (pueden aparecer varias entradas) (opcional)
94 | DXF: 0 (indica el final de la sección de ID de objetos)
95 | DXF: formato de dibujo de objetos cuando se convierten en proxy (un número entero sin signo de 32 bits): La palabra baja es AcDbDwgVersion La palabra alta es MaintenanceReleaseVersion
70 | DXF: formato de datos de objeto personalizado original: 0 = Formato DWG 1 = Formato DXF


ARC [Manual de referencia de DXF: DXF]

Sección ENTITIES
ARC

    • Los siguientes son los códigos de grupo aplicables a las entidades de arco. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ARC
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbCircle)
39 | Altura de objeto (opcional; valor por defecto = 0)
10 | Punto central (en el SCO) DXF™: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto central (en el SCO)
40 | Radio
100 | Marcador Subclass (AcDbArc)
50 | Ángulo inicial
51 | Ángulo final
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)


ATTDEF [Manual de referencia de DXF: DXF]

Sección ENTITIES
ATTDEF

    • Los siguientes son los códigos de grupo aplicables a las entidades de definición de atributos. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ATTDEF
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbText)
39 | Altura de objeto (opcional; valor por defecto = 0)
10 | Primer punto de alineación (en el SCO) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto inicial del texto (en el SCO)
40 | Altura de texto
1 | Valor por defecto (cadena)
100 | Marcador Subclass (AcDbAttributeDefinition)
50 | Rotación del texto (opcional; valor por defecto = 0)
41 | Factor de escala X relativa (anchura) (opcional; por defecto = 1). Este valor se ajusta también cuando se utiliza texto ajustado.
51 | Ángulo oblicuo (opcional; valor por defecto = 0)
7 | Nombre de estilo de texto (opcional; por defecto = STANDARD)
71 | Indicadores de generación de texto (opcional; por defecto = 0); véase códigos de grupo TEXT.
72 | Tipo de justificación de texto horizontal (opcional; por defecto = 0); véase códigos de grupo TEXT.
11 | Segundo punto de alineación (en el SCO) (opcional) DXF: valor X; APL: punto 3D Significativo sólo si los valores del grupo 72 o 74 son distintos de cero
21, 31 | DXF: valores Y y Z del segundo punto de alineación (en el SCO) (opcional)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de dirección de extrusión
100 | Marcador Subclass (AcDbAttributeDefinition)
3 | Cadena de solicitud
2 | Cadena de identificador
70 | Indicadores de atributo: 1 = Atributo no visible (no se muestra) 2 = Éste es un atributo de constante 4 = Se requiere verificación en la entrada de este atributo 8 = Atributo predefinido (no hay solicitud durante la inserción)
73 | Longitud de campo (opcional; por defecto = 0) (no utilizada actualmente)
74 | Tipo de justificación de texto vertical (opcional, por defecto = 0); véase el código de grupo 73 en TEXT.

    Si los valores de los grupos 72 o 74 son distintos de cero, se ignoran los valores del primer punto de alineación y AutoCAD calcula nuevos valores basados en el segundo punto de alineación, así como la longitud y la altura de la propia cadena de texto (tras aplicar el estilo de texto). Si estos grupos no tienen valores o su valor es cero, no se tiene en cuenta el segundo punto de alineación.


ATTRIB [Manual de referencia de DXF: DXF]

Sección ENTITIES
ATTRIB

    • Los siguientes son los códigos de grupo aplicables a las entidades de atributo. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ATTRIB
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbText)
39 | Altura de objeto (opcional; valor por defecto = 0)
10 | Punto inicial del texto (en el SCO) DXF™: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto inicial del texto (en el SCO)
40 | Altura de texto
1 | Valor por defecto (cadena)
100 | Marcador Subclass (AcDbAttribute)
2 | Indicador de atributo (cadena)
70 | Indicadores de atributo: 1 = Atributo no visible (no se muestra) 2 = Éste es un atributo de constante 4 = Se requiere verificación en la entrada de este atributo 8 = Atributo predefinido (no hay solicitud durante la inserción)
73 | Longitud de campo (opcional; por defecto = 0) (no utilizada actualmente)
50 | Rotación del texto (opcional; valor por defecto = 0)
41 | Factor de escala X relativa (anchura) (opcional; por defecto = 1). Este valor se ajusta también cuando se utiliza texto ajustado.
51 | Ángulo oblicuo (opcional; valor por defecto = 0)
7 | Nombre de estilo de texto (opcional; por defecto = STANDARD)
71 | Indicadores de generación del texto (opcional; por defecto = 0). Véase códigos de grupo TEXT.
72 | Tipo de justificación del texto horizontal (opcional, por defecto = 0). Véase códigos de grupo TEXT.
74 | Tipo de justificación del texto vertical (opcional, por defecto = 0). Véase el código de grupo 73 en TEXT.
11 | Punto de alineación (en el SCO) (opcional) DXF: valor X; APL: punto 3D Sólo si el grupo 72 o el 74 está presente y es distinto de cero
21, 31 | DXF: valores Y y Z del punto de alineación (en el SCO) (opcional)
210 | Dirección de extrusión. Presente sólo si la dirección de extrusión de la entidad no es paralela al eje Z en el SCU (opcional; por defecto = 0, 0, 1). DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)

    Si los valores de los grupos 72 y 74 son distintos de cero, se ignoran los valores del punto de inserción del texto y se calculan en AutoCAD nuevos valores basados en el punto de alineación del texto y la longitud de la propia cadena de texto (tras aplicar el estilo de texto). Si los valores 72 y 74 son cero o no están, se ignora el punto de alineación del texto y se vuelve a calcular de acuerdo con el punto de inserción del texto y la longitud de la cadena de texto en sí (tras aplicar el estilo de texto).


BODY [Manual de referencia de DXF: DXF]

Sección ENTITIES
BODY

    • Los siguientes son los códigos de grupo aplicables a las entidades de cuerpo. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo BODY
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbModelerGeometry)
70 | Número de versión de formato del modelador (actualmente = 1)
1 | Datos de propiedad (varias líneas < 255 caracteres cada una)
3 | Líneas adicionales de datos de propiedad (si la cadena del grupo 1 anterior tiene más de 255 caracteres) (opcional)


CIRCLE [Manual de referencia de DXF: DXF]

Sección ENTITIES
CIRCLE

    • Los siguientes son los códigos de grupo aplicables a las entidades de círculo. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo CIRCLE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbCircle)
39 | Altura de objeto (opcional; valor por defecto = 0)
10 | Punto central (en el SCO) DXF™: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto central (en el SCO)
40 | Radio
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)


DIMENSION [Manual de referencia de DXF: DXF]

Sección ENTITIES
DIMENSION

    • Las definiciones de entidades de cota están constituidas por códigos de grupo comunes a todos los tipos de cota seguidos de los códigos específicos de cada tipo.

    Temas de esta sección:

    • Códigos de grupo comunes de cota
    • Códigos de grupo de cota alineada
    • Códigos de grupo de cota lineal y girada
    • Códigos de grupo de cota radial y de diámetro
    • Códigos de grupo de cota angular
    • Códigos de grupo de cota por coordenadas
    • Sustituciones de estilos de cota


Códigos de grupo comunes de cota [Manual de referencia de DXF: DXF]

DIMENSION
Códigos de grupo comunes de cota

    • Los siguientes son los códigos de grupo aplicables a todos los tipos de entidades de cota. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo comunes de cota
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbDimension)
2 | Nombre del bloque que contiene las entidades que constituyen la imagen de cota
10 | Punto de definición (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto de definición (en el SCU)
11 | Punto medio de texto de cota (en el SCO) DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z del punto medio de texto de cota (en el SCO)
70 | Tipo de cota: Los valores 0–6 son valores enteros que representan el tipo de cota. Los valores 32, 64 y 128 son valores en bits que se añaden a los valores enteros (en las versiones R13 y posteriores, el valor siempre está definido en 32). 0 = Girada, horizontal o vertical; 1 = Alineada 2 = Angular; 3 = Diámetro; 4 = Radio 5 = Angular de 3 puntos; 6 = Coordenada 32 = Indica que la referencia a bloque (código de grupo 2) sólo está referenciada por esta cota. 64 = Tipo de coordenada. Es un valor de bit (bit 7) utilizado sólo con el valor entero 6. Si se establece, la coordenada es del tipo X; si no, es del tipo Y. 128 = Es un valor de bit (bit 8) añadido a los demás valores del grupo 70, si el texto de cota se ha ubicado en una posición definida por el usuario en lugar de ubicarse en la posición por defecto.
71 | Punto de enlace: 1 = Superior izquierda; 2 = Superior centro; 3 = Superior derecha 4 = Medio izquierda; 5 = Medio centro; 6 = Medio derecha 7 = Inferior izquierda; 8 = Inferior centro; 9 = Inferior derecha
72 | Estilo de interlineado de texto de cota (opcional): 1 (o falta) = Mínimo (se sustituirán los caracteres más altos) 2 = Exacto (no se sustituirán los caracteres más altos)
41 | Factor de interlineado de texto de cota (opcional): Porcentaje de interlineado por defecto (3-en-5) que se va a aplicar. Rango de valores válido de 0.25 a 4.00.
42 | Medida real (opcional; valor de sólo lectura)
1 | Texto de cota introducido explícitamente por el usuario. Opcional; el valor por defecto es la medida. Si es nulo o "<>", la medida de cota se dibuja como el texto; si es un espacio en blanco " ", se suprime el texto. Todo lo demás se dibuja como el texto.
53 | El código de grupo 53 opcional es el ángulo de rotación de un texto de cota desde su orientación por defecto (la dirección de la línea de cota) (opcional)
51 | Todos los tipos de cota tienen un código de grupo 51 opcional que indica la dirección horizontal para la entidad de cota. La entidad de cota determina la orientación del texto y las líneas de cota para las cotas lineales horizontales, verticales y giradas. Este valor de grupo es el valor negativo del ángulo entre el eje X del SCO y el eje X del SCP. Está siempre en el plano XY del SCO.
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)
3 | Nombre de estilo de cota

    Los datoseX pertenecientes al ID de aplicación "ACAD" siguen una entidad de cota en el caso de que se haya aplicado cualquier sustitución de cota a esta entidad. Véase Sustituciones de estilos de cota.

    En cualquier tipo de cota, los siguientes códigos de grupo representan puntos 3D en el SCU:

    • (10, 20, 30)
    • (13, 23, 33)
    • (14, 24, 34)
    • (15, 25, 35)

    En cualquier tipo de cota, los siguientes códigos de grupo representan puntos 3D en el SCO:

    • (11, 21, 31)
    • (12, 22, 32)
    • (16, 26, 36)


Códigos de grupo de cota alineada [Manual de referencia de DXF: DXF]

DIMENSION
Códigos de grupo de cota alineada

    • Los siguientes son los códigos de grupo aplicables a las cotas alineadas. Además de los códigos que se describen aquí, también pueden estar presentes los incluidos en Códigos de grupo comunes para entidades y Códigos de grupo comunes de cota. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo de cota alineada
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbAlignedDimension)
12 | Punto de inserción para los clones de una cota: línea base y continua (en el SCO) DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z del punto de inserción para los clones de una cota: línea base y continua (en el SCO)
13 | Punto de definición para las cotas lineales y angulares (en el SCU) DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z del punto de definición para las cotas lineales y angulares (en el SCU)
14 | Punto de definición para las cotas lineales y angulares (en el SCU) DXF: valor X; APL: punto 3D
24, 34 | DXF: valores Y y Z del punto de definición para las cotas lineales y angulares (en el SCU)

    El punto (13,23,33) precisa el punto de inicio de la primera línea de referencia y el punto (14,24,34) precisa el punto de inicio de la segunda línea de referencia. El punto (10,20,30) precisa la ubicación de la línea de cota. El punto (11,21,31) precisa el punto medio del texto de cota.


Códigos de grupo de cota lineal y girada [Manual de referencia de DXF: DXF]

DIMENSION
Códigos de grupo de cota lineal y girada

    • Los siguientes son los códigos de grupo aplicables a las cotas lineales y giradas (tenga en cuenta que las cotas lineales y giradas forman parte de la subclase AcDbAlignedDimension). Además de los códigos que se describen aquí, también pueden estar presentes los incluidos en Códigos de grupo comunes para entidades y Códigos de grupo comunes de cota. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo de cota lineal y girada
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbAlignedDimension)
12 | Punto de inserción para los clones de una cota: línea base y continua (en el SCO) DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z del punto de inserción para los clones de una cota: línea base y continua (en el SCO)
13 | Punto de definición para las cotas lineales y angulares (en el SCU) DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z del punto de definición para las cotas lineales y angulares (en el SCU)
14 | Punto de definición para las cotas lineales y angulares (en el SCU) DXF: valor X; APL: punto 3D
24, 34 | DXF: valores Y y Z del punto de definición para las cotas lineales y angulares (en el SCU)
50 | Ángulo de cota girada, horizontal o vertical
52 | Los tipos de cota lineales con un ángulo oblicuo llevan el código de grupo opcional 52. Cuando se añade al ángulo de rotación de la cota lineal (código de grupo 50), se obtiene el ángulo de las líneas de cota.
100 | Marcador Subclass (AcDbRotatedDimension)


Códigos de grupo de cota radial y de diámetro [Manual de referencia de DXF: DXF]

DIMENSION
Códigos de grupo de cota radial y de diámetro

    • Los siguientes son los códigos de grupo aplicables a las cotas radiales y de diámetro. Además de los códigos que se describen aquí, también pueden estar presentes los incluidos en Códigos de grupo comunes para entidades y Códigos de grupo comunes de cota. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo de cota radial y de diámetro
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbRadialDimension o AcDbDiametricDimension)
15 | Punto de definición para las cotas de diámetro, radio y angulares (en el SCU) DXF: valor X; APL: punto 3D
25, 35 | DXF: valores Y y Z del punto de definición para las cotas de diámetro, radiales y angulares (en el SCU)
40 | Longitud de la directriz en cotas radiales y de diámetro

    El punto (15,25,35) precisa el primer punto de línea de cota en el círculo/arco y el punto (10,20,30) precisa el punto opuesto al primero. El punto (11,21,31) precisa el punto medio del texto de cota.

    El punto (15,25,35) precisa el primer punto de la línea de cota en el círculo/arco y el punto (10,20,30) precisa el centro del círculo/arco. El punto (11,21,31) precisa el punto medio del texto de cota.


Códigos de grupo de cota angular [Manual de referencia de DXF: DXF]

DIMENSION
Códigos de grupo de cota angular

    • Los siguientes son los códigos de grupo aplicables a las cotas angulares. Además de los códigos que se describen aquí, también pueden estar presentes los incluidos en Códigos de grupo comunes para entidades y Códigos de grupo comunes de cota. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo de cota angular
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDb3PointAngularDimension)
13 | Punto de definición para las cotas lineales y angulares (en el SCU) DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z del punto de definición para las cotas lineales y angulares (en el SCU)
14 | Punto de definición para las cotas lineales y angulares (en el SCU) DXF: valor X; APL: punto 3D
24, 34 | DXF: valores Y y Z del punto de definición para las cotas lineales y angulares (en el SCU)
15 | Punto de definición para las cotas de diámetro, radiales y angulares (en el SCU) DXF: valor X; APL: punto 3D
25, 35 | DXF: valores Y y Z del punto de definición para las cotas de diámetro, radiales y angulares (en el SCU)
16 | Punto que define el arco de cota en las cotas angulares (en el SCO) DXF: valor X; APL: punto 3D
26, 36 | DXF: valores Y y Z del punto que define el arco de cota en las cotas angulares (en el SCO)

    Los puntos (13,23,33) y (14,24,34) precisan los puntos finales de la línea que se utiliza para determinar la primera línea de referencia. Los puntos (10,20,30) y (15,25,35) precisan los puntos finales de la línea que se utiliza para determinar la segunda línea de referencia. El punto (16,26,36) precisa la ubicación del arco de la línea de cota. El punto (11,21,31) precisa el punto medio del texto de cota.

    El punto (15,25,35) precisa el vértice del ángulo. Los puntos (13,23,33) y (14,24,34) precisan los puntos finales de las líneas de referencia. El punto (10,20,30) precisa la ubicación del arco de la línea de cota y el punto (11,21,31) el punto medio del texto de cota.


Códigos de grupo de cota por coordenadas [Manual de referencia de DXF: DXF]

DIMENSION
Códigos de grupo de cota por coordenadas

    • Los siguientes son los códigos de grupo aplicables a las cotas por coordenadas. Además de los códigos que se describen aquí, también pueden estar presentes los incluidos en Códigos de grupo comunes para entidades y Códigos de grupo comunes de cota. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo de cota por coordenadas
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbOrdinateDimension)
13 | Punto de definición para las cotas lineales y angulares (en el SCU) DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z del punto de definición para las cotas lineales y angulares (en el SCU)
14 | Punto de definición para las cotas lineales y angulares (en el SCU) DXF: valor X; APL: punto 3D
24, 34 | DXF: valores Y y Z del punto de definición para las cotas lineales y angulares (en el SCU)

    El punto (13,23,33) precisa la ubicación del punto y el punto (14,24,34) indica el extremo de la directriz. El punto (11,21,31) precisa el punto medio del texto de cota. El punto (10,20,30) se encuentra en el origen del SCP utilizado al crear la cota.


Sustituciones de estilos de cota [Manual de referencia de DXF: DXF]

DIMENSION
Sustituciones de estilos de cota

    • Las sustituciones de estilos de cota se pueden aplicar a las entidades de cota, de directriz y de tolerancia. Las sustituciones que se apliquen a dichas entidades se almacenan en la entidad como datoseX. Los códigos de grupo para las variables de cota sustituidas y los valores relacionados se emparejan dentro de cadenas de control de grupo 1002. En el ejemplo siguiente se muestran los datoseX de una entidad de cota en la que han sido sustituidas las variables DIMTOL y DIMCLRE.

    (setq diment (car (entsel)))          ; Seleccionar entidad de cota
    (setq elst (entget diment '("ACAD"))) ; Obtener lista de definición de entidades
    (assoc -3 elst)                       ; Extraer únicamente datoseX

    Este código devuelve lo siguiente:

    (-3 ("ACAD"                      Inicio de la sección ACAD APPID de datoseX
      (1000 . "DSTYLE") (1002 . "{") Inicio de la subsección DIMSTYLE
      (1070 . 177) (1070 . 3)        Sustitución de DIMCLRE (código 177) + valor (3)
      (1070 . 71) (1070 . 1)         Sustitución de DIMTOL (código 71) + valor (1)
      (1002 . "}") ))                Fin de la subsección DIMSTYLE y de la sección ACAD


ELLIPSE [Manual de referencia de DXF: DXF]

Sección ENTITIES
ELLIPSE

    • Los siguientes son los códigos de grupo aplicables a las entidades elipse. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ELLIPSE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbEllipse)
10 | Punto central (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto central (en el SCU)
11 | Punto final del eje mayor respecto al centro (en el SCU) DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z de punto final del eje mayor respecto al centro (en el SCU)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)
40 | Radio del eje menor respecto al eje mayor
41 | Parámetro inicial (este valor es 0,0 en elipses completas)
42 | Parámetro final (este valor es 2pp en elipses completas)


HATCH [Manual de referencia de DXF: DXF]

Sección ENTITIES
HATCH

    • Los siguientes son los códigos de grupo aplicables a las entidades de sombreado y de polígonoM. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo HATCH
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbHatch)
10 | Punto de elevación (en el SCO) DXF: valor X = 0; APL: punto 3D (X e Y siempre equivalen a 0; Z representa la elevación)
20, 30 | DXF: valores Y y Z del punto de elevación (en el SCO) valor Y = 0; Z representa la elevación
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de dirección de extrusión
2 | Nombre del patrón de sombreado
70 | Indicador de relleno sólido (relleno sólido = 1; relleno de patrón = 0); para polígonoM, la versión de polígonoM
63 | Para polígonoM, color de relleno de patrón como ACI
71 | Indicador de asociatividad (asociativo = 1; no asociativo = 0); para polígonoM, indicador de relleno sólido (con relleno sólido = 1; sin relleno sólido = 0)
91 | Número de rutas de contorno (bucles)
varía | Datos de ruta de contorno. Se repite el número de veces que indique el código 91. Véase Datos de ruta de contorno.
75 | Estilo de sombreado: 0 = Sombrear área de "paridad impar" (estilo Normal) 1 = Sombrear sólo las áreas más externas (estilo Exterior) 2 = Sombrear el área completa (estilo Ignorar)
76 | Tipo de patrón de sombreado: 0 = Definido por el usuario; 1 = Predefinido; 2 = Personalizado
52 | Ángulo de patrón de sombreado (sólo relleno de patrón)
41 | Escala o intervalo de patrón de sombreado (sólo relleno de patrón)
73 | Para polígonoM, indicador de anotación de contorno (el contorno es un contorno anotado = 1; el contorno no es un contorno anotado = 0)
77 | Indicador de patrón de sombreado doble (sólo relleno de patrón): 0 = No doble; 1 = Doble
78 | El número de líneas de definición de patrón
varía | Datos de líneas de patrón. Se repite el número de veces que indique el código 78. Véase Datos de patrón.
47 | Tamaño en píxeles utilizado para determinar la densidad al efectuar diversas operaciones de intersección y proyección de rayos en el cálculo de patrones de sombreado, tanto para los sombreados asociativos como para los creados con el método de sombreado denominado Inundación
98 | Número de puntos base
11 | Para polígonoM, vector de desfase
99 | Para polígonoM, número de rutas de contorno degeneradas (bucles), donde una ruta de contorno degenerada es un borde omitido por el sombreado
10 | Punto seed (en el SCO) DXF: valor X; APL: punto 2D (varias entradas)
20 | DXF: valor Y del punto seed (en el SCO) (varias entradas)
450 | Indica un sombreado sólido o de gradiente; si es sólido, se ignorarán los valores del resto de los códigos, aunque deben estar presentes. Opcional; si el archivo incluye el código 450, también deberá disponer de los códigos siguientes: 451, 452, 453, 460, 461, 462 y 470. Si el código 450 no se incluye en el archivo, tampoco es necesario que tenga los siguientes: 451, 452, 453, 460, 461, 462 y 470. 0 = Sombreado sólido 1 = Gradiente
451 | El cero está reservado para su posterior utilización.
452 | Registra el modo de definición de los colores y sólo lo utiliza el código de diálogo: 0 = Gradiente de dos colores 1 = Gradiente de un color
453 | Número de colores: 0 = Sombreado sólido 2 = Gradiente
460 | Ángulo de rotación en radianes para gradientes (por defecto = 0, 0)
461 | Definición de gradiente; se corresponde con la opción Centrado de la ficha Gradiente del cuadro de diálogo Sombreado por contornos y relleno. Cada gradiente dispone de dos definiciones, convertida y no convertida. Un valor de conversión describe la combinación de las dos definiciones que se debería utilizar. Un valor 0.0 significa que sólo se debería utilizar la versión no convertida, mientras que un valor 1.0 significa que sólo se debería emplear la versión convertida.
462 | Valor de tinte de color utilizado por el código de diálogo (por defecto = 0, 0; el rango es de 0.0 a 1.0). El valor de tinte de color es un color gradiente; controla la proporción de tinte en el diálogo cuando el código de grupo HATCH 452 se establece en 1.
463 | Reservado para su posterior utilización: 0 = Primer valor 1 = Segundo valor
470 | Cadena (por defecto = LINEAR)

    Temas de esta sección:

    • Datos de ruta de contorno
    • Datos de patrón


Datos de ruta de contorno [Manual de referencia de DXF: DXF]

HATCH
Datos de ruta de contorno

    • El contorno de cada objeto de sombreado está definido por una ruta (o bucle) con uno o varios segmentos. Los datos de segmento de ruta varían dependiendo del tipo o tipos de entidad que conformen la ruta. Cada segmento viene definido por su propio conjunto de códigos de grupo. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo de datos de ruta de contorno de sombreado
Códigos de grupo | Descripción
92 | Indicador de tipo de ruta de contorno (codificado en bits): 0 = Por defecto; 1 = Externa; 2 = Polilínea 4 = Derivada; 8 = Cuadro de texto; 16 = Exterior
varía | Datos de tipo de contorno de polilínea (sólo si contorno = polilínea). Véase la tabla de datos de contorno de polilínea incluida a continuación.
93 | Número de lados de esta ruta de contorno (sólo si el contorno no es una polilínea)
72 | Tipo de arista (sólo si el contorno no es una polilínea): 1 = Línea; 2 = Arco circular; 3 = Arco elíptico; 4 = Spline
varía | Datos del tipo de arista (sólo si el contorno no es una polilínea). Véase la tabla de datos de arista correspondiente incluida a continuación.
97 | Número de objetos de contorno de origen
330 | Referencia a objetos de contorno de origen (varias entradas)
    Códigos de grupo de datos de contorno de polilínea
Códigos de grupo | Descripción
72 | Indicador de curvatura
73 | Indicador de cerrada
93 | Número de vértices de la polilínea
10 | Ubicación del vértice (en el SCO) DXF: valor X; APL: punto 2D (varias entradas)
20 | DXF: valor Y de la ubicación del vértice (en el SCO) (varias entradas)
42 | Curvatura (opcional, por defecto = 0)
    Códigos de grupo de datos de arista de línea
Códigos de grupo | Descripción
10 | Punto inicial (en el SCO) DXF: valor X; APL: punto 2D
20 | DXF: valor Y del punto inicial (en el SCO)
11 | Punto final (en el SCO) DXF: valor X; APL: punto 2D
21 | DXF: valor Y del punto final (en el SCO)
    Códigos de grupo de datos de arista de arco
Códigos de grupo | Descripción
10 | Punto central (en el SCO) DXF: valor X; APL: punto 2D
20 | DXF: valor Y del punto central (en el SCO)
40 | Radio
50 | Ángulo inicial
51 | Ángulo final
73 | Indicador de sentido contrario a las agujas del reloj
    Códigos de grupo de datos de arista de elipse
Códigos de grupo | Descripción
10 | Punto central (en el SCO) DXF: valor X; APL: punto 2D
20 | DXF: valor Y del punto central (en el SCO)
11 | Punto final del eje mayor respecto al punto central (en el SCO) DXF: valor X; APL: punto 2D
21 | DXF: valor Y del punto final del eje mayor (en el SCO)
40 | Longitud del eje menor (porcentaje de la longitud del eje mayor)
50 | Ángulo inicial
51 | Ángulo final
73 | Indicador de sentido contrario a las agujas del reloj
    Códigos de grupo de datos de arista de spline
Códigos de grupo | Descripción
94 | Grado
73 | Racional
74 | Periódica
95 | Número de nudos
96 | Número de puntos de apoyo
40 | Valores de nudo (varias entradas)
10 | Punto de apoyo (en el SCO) DXF: valor X; APL: punto 2D
20 | DXF: valor Y del punto de apoyo (en el SCO)
42 | Grosores (opcional, por defecto = 1)


Datos de patrón [Manual de referencia de DXF: DXF]

HATCH
Datos de patrón

    • Los códigos de datos de patrón siguientes se repiten en cada línea de definición de patrón. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo de datos de patrón de sombreado
Códigos de grupo | Descripción
53 | Ángulo de línea de patrón
43 | Punto base de línea de patrón, componente X
44 | Punto base de línea de patrón, componente Y
45 | Desfase de línea de patrón, componente X
46 | Desfase de línea de patrón, componente Y
79 | Número de elementos de longitud del trazo
49 | Longitud del trazo (varias entradas)


IMAGE [Manual de referencia de DXF: DXF]

Sección ENTITIES
IMAGE

    • Los siguientes son los códigos de grupo aplicables a las entidades de imagen. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo IMAGE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbRasterImage)
90 | Versión de la clase
10 | Punto de inserción (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto de inserción (en el SCU)
11 | Vector U de un píxel (puntos a lo largo de la parte inferior visual de la imagen, empezando en el punto de inserción) (en el SCU) DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z del vector U (en el SCU)
12 | Vector V de un píxel (puntos a lo largo de la parte izquierda visual de la imagen, empezando en el punto de inserción) (en el SCU) DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z del vector V (en el SCU)
13 | Tamaño de la imagen en píxeles DXF: valor U; APL: punto 2D (valores U y V)
23 | DXF: valor V del tamaño de la imagen en píxeles
340 | Referencia dura a objeto imagedef
70 | Propiedades de visualización de las imágenes: 1 = Mostrar imagen 2 = Mostrar imagen si no está alineada con la pantalla 4 = Utilizar contorno delimitador 8 = Transparencia activada
280 | Estado de delimitación: 0 = Desactivado; 1 = Activado
281 | Valor de brillo (0 -100; por defecto = 50)
282 | Valor de contraste (0 -100; por defecto = 50)
283 | Valor de difuminado (0 -100; por defecto = 0)
360 | Referencia dura a objeto imagedef_reactor
71 | Tipo de contorno delimitador. 1 = Rectangular; 2 = Poligonal
91 | Número de vértices del contorno de delimitación que siguen
14 | Vértice del contorno delimitador (en el SCO) DXF: valor X; APL: punto 2D (varias entradas) NOTA 1) Para el tipo de contorno delimitador rectangular, se deben precisar dos esquinas opuestas. Los valores por defecto son (–0.5,–0.5), (tamaño.x–0.5, tamaño.y–0.5). 2) Para el tipo de contorno delimitador poligonal, se deben precisar tres o más vértices. Los vértices poligonales deben incluirse secuencialmente.
24 | DXF: valor Y de vértice del contorno delimitador (en el SCO) (varias entradas)


INSERT [Manual de referencia de DXF: DXF]

Sección ENTITIES
INSERT

    • Los siguientes son los códigos de grupo aplicables a las entidades insertadas (referencia a bloque). Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo INSERT
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbBlockReference)
66 | Indicador de que siguen atributos variables (opcional; valor por defecto = 0); si el valor de este indicador es 1, se espera que la inserción, terminada por la entidad SEQEND, vaya seguida de una serie de entidades atributos.
2 | Nombre de bloque
10 | Punto de inserción (en el SCO) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto de inserción (en el SCO)
41 | Factor de escala X (opcional; por defecto = 1)
42 | Factor de escala Y (opcional; por defecto = 1)
43 | Factor de escala Z (opcional; por defecto = 1)
50 | Ángulo de rotación (opcional; valor por defecto = 0)
70 | Número de columnas (opcional; valor por defecto = 1)
71 | Número de filas (opcional; valor por defecto = 1)
44 | Intervalo de columnas (opcional; valor por defecto = 0)
45 | Intervalo de filas (opcional; valor por defecto = 0)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)


LEADER [Manual de referencia de DXF: DXF]

Sección ENTITIES
LEADER

    • Los siguientes códigos de grupo se aplican a directrices. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo LEADER
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbLeader)
3 | Nombre de estilo de cota
71 | Indicador de extremo de cota: 0 = Desactivado; 1 = Activado
72 | Tipo de ruta de directriz: 0 = Segmentos de línea recta; 1 = Spline
73 | Indicador de creación de directriz (por defecto = 3): 0 = Creada con anotación de texto 1 = Creada con anotación de tolerancia 2 = Creada con anotación de referencia a bloque 3 = Creada sin ninguna anotación
74 | Indicador de dirección de línea de conexión: 0 = Línea de conexión (o extremo de la tangente de una directriz en spline) en dirección opuesta a la del vector horizontal 1 = Línea de conexión (o extremo de la tangente de una directriz en spline) en la misma dirección que el vector horizontal (véase código 75)
75 | Indicador de línea de conexión: 0 = Sin línea de conexión; 1 = Con línea de conexión
40 | Altura de la anotación de texto
41 | Anchura de la anotación de texto
76 | Número de vértices en la directriz (se ignora para ABRE)
10 | Coordenadas de vértice (una entrada para cada vértice) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z de las coordenadas de vértice
77 | Color que se debe utilizar si el valor de la variable DIMCLRD de la directriz = BYBLOCK
340 | Referencia dura a anotación asociada (entidad textom, tolerancia o insertada)
210 | Vector normal DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z del vector normal
211 | Dirección "horizontal" de la directriz DXF: valor X; APL: vector 3D
221, 231 | DXF: valores Y y Z de la dirección "horizontal" de la directriz
212 | Desfase del último vértice de directriz desde el punto de inserción de la referencia a bloque DXF: valor X; APL: vector 3D
222, 232 | DXF: valores Y y Z del desfase
213 | Desfase del último vértice de la directriz desde el punto de ubicación de la anotación DXF: valor X; APL: vector 3D
223, 233 | DXF: valores Y y Z del desfase

    Los datoseX pertenecientes al identificador de la aplicación "ACAD" siguen a una directriz en el caso de que se haya aplicado cualquier sustitución de cota a esta entidad. Véase Sustituciones de estilos de cota.


LINE [Manual de referencia de DXF: DXF]

Sección ENTITIES
LINE

    • Los siguientes son los códigos de grupo aplicables a las entidades de línea. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo LINE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbLine)
39 | Altura de objeto (opcional; valor por defecto = 0)
10 | Punto inicial (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto inicial (en el SCU)
11 | Punto final (en el SCU) DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z del punto final (en el SCU)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)


LWPOLYLINE [Manual de referencia de DXF: DXF]

Sección ENTITIES
LWPOLYLINE

    • Los siguientes son los códigos de grupo aplicables a las entidades de polilínea optimizada. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo LWPOLYLINE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbPolyline)
90 | Número de vértices
70 | Indicador de polilínea (codificado en bits); el valor por defecto es 0: 1 = Cerrada; 128 = Plinegen
43 | Grosor constante (opcional; por defecto = 0) No se utiliza si se ha definido el grosor variable (códigos 40 o 41).
38 | Elevación (opcional; valor por defecto = 0)
39 | Altura de objeto (opcional; valor por defecto = 0)
10 | Coordenadas de vértice (en el SCO), varias entradas; una entrada para cada vértice DXF: valor X; APL: punto 2D
20 | DXF: valor Y de las coordenadas de vértice (en el SCO), varias entradas; una entrada para cada vértice
40 | Grosor inicial (varias entradas; una entrada para cada vértice) (opcional; por defecto = 0; varias entradas). No se utiliza si se ha establecido un grosor constante (código 43).
41 | Grosor final (varias entradas; una entrada para cada vértice) (opcional; valor por defecto = 0; varias entradas). No se utiliza si se ha establecido un grosor constante (código 43).
42 | Curvatura (varias entradas; una entrada para cada vértice) (opcional; valor por defecto = 0)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)


MLINE [Manual de referencia de DXF: DXF]

Sección ENTITIES
MLINE

    • Los siguientes son los códigos de grupo aplicables a las entidades de línea múltiple. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo MLINE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbMline)
2 | Cadena de hasta 32 caracteres. Nombre del estilo utilizado para esta MLINE. Debe haber una entrada para este estilo en el diccionario MLINESTYLE. Este campo no se debe modificar sin actualizar también la entrada asociada en el diccionario MLINESTYLE.
340 | Identificador/ID del dispositivo señalador del objeto MLINESTYLE.
40 | Factor de escala
70 | Justificación: 0 = Superior; 1 = Cero; 2 = Inferior
71 | Indicadores (valores en bits): 1 = Tiene al menos un vértice (el código 72 es mayor que 0) 2 = Cerrada 4 = Suprime remates iniciales 8 = Suprime remates finales
72 | Número de vértices
73 | Número de elementos de la definición MLINESTYLE
10 | Punto inicial (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto inicial (en el SCU)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)
11 | Coordenadas de vértice (varias entradas; una entrada para cada vértice) DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z de las coordenadas de vértice
12 | Vector de dirección del segmento que comienza en este vértice (varias entradas; una para cada vértice) DXF: valor X; APL: vector 3D
22, 32 | DXF: valores Y y Z del vector de dirección del segmento que comienza en este vértice
13 | Vector de dirección del inglete de este vértice (varias entradas: una para cada vértice) DXF: valor X; APL: vector 3D
23, 33 | DXF: valores Y y Z del vector de dirección del inglete
74 | Número de parámetros para este elemento (se repite para todos los elementos de un segmento)
41 | Parámetros del elemento (se repite según lo indicado en el código 74 anterior)
75 | Número de parámetros de área de relleno para este elemento (se repite para todos los elementos de un segmento)
42 | Parámetros del área de relleno (se repite según lo indicado en el código 75 anterior)

    Los parámetros del código de grupo 41 constituyen una lista de valores reales, uno para cada código de grupo 41. Esta lista puede contener cero o más elementos. El primer valor del código de grupo 41 es la distancia desde el vértice del segmento a lo largo del vector del inglete hasta el punto donde la ruta del elemento de línea interseca el vector del inglete. El siguiente valor del código de grupo 41 es la distancia a lo largo de la ruta del elemento de línea desde el punto definido por el primer grupo 41 hasta el inicio real de este el elemento de línea. El siguiente es la distancia desde el inicio del elemento de línea hasta la primera ruptura (o corte) en él. Los valores sucesivos del código de grupo 41 continúan enumerando los puntos de inicio y de parada del elemento de línea en este segmento de la MLINE. El tipo de línea no afecta a las enumeraciones del grupo 41.

    Los parámetros del código de grupo 42 constituyen también una lista de valores reales. similar a la del código de grupo 41 y que describe la parametrización del área de relleno para este segmento MLINE. Los valores se interpretan de manera idéntica a los parámetros del grupo 41 y, cuando se toman como un todo para todos los elementos de línea del segmento MLINE, definen el contorno del área de relleno para el segmento MLINE.

    Un ejemplo común del uso del código de grupo 42 se produce cuando una líneam (línea múltiple) sin relleno cruza otra líneam con relleno y se utiliza editarlm para que la líneam con relleno aparezca sin rellenar en el área de cruce. El resultado sería dos grupos 42 para cada elemento de línea en el segmento de línea múltiple afectado, uno para detener el relleno y otro para iniciarlo.

    Los códigos de grupo 2 de las entidades líneam y los objetos estilolm son campos redundantes. Estos grupos no deben modificarse bajo ninguna circunstancia, aunque no hay ningún inconveniente en leerlos y utilizar sus valores. Los campos modificables son los siguientes:

    Mline

    Grupo 340 del mismo objeto, que indica el propio objeto MLINESTYLE.

    Mlinestyle

    Valor de grupo 3 del diccionario MLINESTYLE que precede al grupo 350, que es el que posee el identificador o el nombre de entidad del MLINESTYLE actual.


MTEXT [Manual de referencia de DXF: DXF]

Sección ENTITIES
MTEXT

    • Los siguientes son los códigos de grupo aplicables a las entidades de textoM. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo MTEXT
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbMText)
10 | Punto de inserción DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto de inserción
40 | Altura de texto nominal (inicial)
41 | Anchura del rectángulo de referencia
71 | Punto de enlace: 1 = Superior izquierda; 2 = Superior centro; 3 = Superior derecha 4 = Medio izquierda; 5 = Medio centro; 6 = Medio derecha 7 = Inferior izquierda; 8 = Inferior centro; 9 = Inferior derecha
72 | Dirección de dibujo: 1 = De izquierda a derecha 3 = De arriba a abajo 5 = Por estilo (la dirección se hereda del estilo del texto asociado)
1 | Cadena de texto. Si la cadena de texto tiene menos de 250 caracteres, todos ellos aparecen en el grupo 1. Si tiene más de 250 caracteres, la cadena se divide en bloques de 250 caracteres que aparecen en uno o más códigos de grupo 3. Si se utilizan códigos de grupo 3, el último es un grupo 1 y tiene menos de 250 caracteres.
3 | Texto adicional (siempre en bloques de 250 caracteres) (opcional)
7 | Nombre del estilo de texto (STANDARD si no se proporciona) (opcional)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)
11 | Vector de dirección del eje X (en el SCU) DXF: valor X; APL: vector 3D Un código de grupo 50 (ángulo de rotación en radianes) transferido como una entrada DXF se convierte al vector de dirección equivalente (si se transfiere un código 50 y los códigos 11, 21, 31, prevalece el último). Esta opción resulta útil para las conversiones de objetos de texto.
21, 31 | DXF: valores Y y Z del vector de dirección del eje X (en el SCU)
42 | Anchura horizontal de los caracteres que componen la entidad de textoM. Este valor siempre será igual o menor que el valor del código de grupo 41 (sólo lectura, se omite si se facilita).
43 | Altura vertical de la entidad TEXTOM (sólo lectura, se ignora si se facilita)
50 | Ángulo de rotación en radianes
73 | Estilo de interlineado de textoM (opcional): 1 = Mínimo (se sustituirán los caracteres más altos) 2 = Exacto (no se sustituirán los caracteres más altos)
44 | Factor de interlineado de textoM (opcional): Porcentaje de interlineado por defecto (3-en-5) que se va a aplicar. Rango de valores válido de 0.25 a 4.00.

    Los datoseX con el identificador de aplicación "DCO15" pueden seguir a una entidad textom y proporcionar información relacionada con la función Conexión BD.


OLEFRAME [Manual de referencia de DXF: DXF]

Sección ENTITIES
OLEFRAME

    • Los siguientes son los códigos de grupo aplicables a las entidades de oleframe. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo OLEFRAME
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbOleFrame)
70 | Número de versión de OLE
90 | Longitud de los datos binarios
310 | Datos binarios (varias líneas)
1 | Fin de datos OLE (la cadena "OLE")


OLE2FRAME [Manual de referencia de DXF: DXF]

Sección ENTITIES
OLE2FRAME

    • Los siguientes son los códigos de grupo aplicables a las entidades de ole2frame. Esta información es de sólo lectura. Durante las operaciones de ABRE, los valores no se tienen en cuenta porque forman parte del objeto binario OLE y se obtienen a través de funciones de acceso. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo OLE2FRAME
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbOle2Frame)
70 | Número de versión de OLE
3 | Longitud de los datos binarios
10 | Esquina superior izquierda (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z de la esquina superior izquierda (en el SCU)
11 | Esquina inferior derecha (en el SCU) DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z de la esquina inferior derecha (en el SCU)
71 | Tipo de objeto OLE, 1 = Vinculado; 2 = Incrustado; 3 = Estático
72 | Descriptor del modo mosaico: 0 = El objeto reside en el espacio modelo 1 = El objeto reside en el espacio papel
90 | Longitud de los datos binarios
310 | Datos binarios (varias líneas)
1 | Fin de datos OLE (la cadena "OLE")

    Salida DXF de muestra:

        OLE2FRAME
          5
        2D
        100
        AcDbEntity
         67
             1
          8
        0
        100
        AcDbOle2Frame
         70
             2
          3
        Imagen Paintbrush
         10
        4.43116
         20
        5.665992
         30
        0.0
         11
        6.4188
         21
        4.244939
         31
        0.0
         71
             2
         72
             1
         90
            23680
        310   0155764BD60082B91140114B08C8F9A916400000000000000000506DC0D0D9AC

        310

        1940114B08C8F9A916400000000000000000506DC0D0D9AC194002303E5CD1FA

        310

        10400000000000000000764BD60082B9114002303E5CD1FA1040000000000000

        ...

        ...

    Salida de muestra de la función entnext de AutoLISP:

    Comando:  (setq e (entget e3))

        ((-1 . <Nombre de entidad: 7d50428>) (0 . "OLE2FRAME") (5 . "2D")

        (100 . "AcDbEntity") (67 . 1) (8 . "0") (100 . "AcDbOle2Frame")

        (70 . 2) (3 "Imagen Paintbrush") (10 4.43116 5.66599 0.0)

        (11 6.4188 4.24494 0.0) (71 . 2) (72 . 1))


POINT [Manual de referencia de DXF: DXF]

Sección ENTITIES
POINT

    • Los siguientes son los códigos de grupo aplicables a las entidades de punto. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo POINT
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbPoint)
10 | Ubicación del punto (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z de la ubicación del punto (en el SCU)
39 | Altura de objeto (opcional; valor por defecto = 0)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)
50 | Ángulo del eje X para el SCP en uso cuando se dibujó el punto (opcional; valor por defecto = 0). Se utiliza cuando el valor de PDMODE es distinto de cero.


POLYLINE [Manual de referencia de DXF: DXF]

Sección ENTITIES
POLYLINE

    • Los siguientes son los códigos de grupo aplicables a las entidades de polilínea. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo POLYLINE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDb2dPolyline o AcDb3dPolyline)
66 | Obsoleto; anteriormente un "indicador de que las entidades siguen" (opcional, ignorar si aparece)
10 | DXF: siempre 0 APL: un punto "ficticio"; los valores X e Y son siempre 0 y el valor Z es la elevación de la polilínea (en el SCO en 2D y en el SCU en 3D).
20 | DXF: siempre 0
30 | DXF: elevación de la polilínea (en el SCO en 2D y en el SCU en 3D)
39 | Altura de objeto (opcional; valor por defecto = 0)
70 | Indicador de polilínea (codificado en bits; por defecto = 0): 1 = Polilínea cerrada (o malla poligonal cerrada en la dirección M) 2 = Se han añadido vértices de ajuste de curva 4 = Se ha añadido vértices de ajuste de spline 8 = Polilínea 3D 16 = Malla poligonal 3D 32 = Malla poligonal cerrada en la dirección N 64 = La polilínea es una malla policara 128 = El patrón de tipo de línea se genera continuamente alrededor de los vértices de esta polilínea
40 | Grosor inicial por defecto (opcional; valor por defecto = 0)
41 | Grosor final por defecto (opcional; valor por defecto = 0)
71 | Número de vértices M de malla poligonal (opcional; valor por defecto = 0)
72 | Número de vértices N de malla poligonal (opcional; valor por defecto = 0)
73 | Densidad M de superficie suave (opcional; valor por defecto = 0)
74 | Densidad N de superficie suave (opcional; valor por defecto = 0)
75 | Curvas y tipo de superficie suave (opcional; por defecto = 0); códigos de números enteros, no codificado en bits: 0 = Ninguna superficie suave ajustada 5 = Superficie B-spline cuadrática 6 = Superficie B-spline cúbica 8 = Superficie Bezier
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)

    Los datoseX con el identificador de la aplicación "AUTOCAD_POSTSCRIPT_FIGURE" pueden seguir a una polilínea. Estos datos contienen información relativa a las imágenes y el relleno PostScript.

    Temas de esta sección:

    • Mallas policara


Mallas policara [Manual de referencia de DXF: DXF]

POLYLINE
Mallas policara

    • Las mallas policara aparecen representadas en los archivos DXF como variantes de entidades de polilínea. El encabezamiento de las polilíneas se identifica conforme se introduce una malla policara con la presencia de los 64 bits del grupo de indicadores de polilínea (70). El grupo 71 precisa el número de vértices de la malla, y el grupo 72 el número de caras. Aunque estas cifras son correctas para todas las mallas creadas con el comando PCARA, no es necesario que las aplicaciones incluyan valores correctos en estos campos. Tras el encabezamiento de la polilínea, hay una secuencia de entidades de vértice que precisan las coordenadas del vértice, seguidas por las caras que componen la malla.

    La estructura de entidad de AutoCAD impone un límite en el número de vértices que puede precisar una determinada cara. Para representar polígonos más complejos, divídalos en cuñas triangulares. Los bordes deben ocultarse para evitar que se modifiquen artefactos visibles de la subdivisión. El comando PCARA realiza esta subdivisión de forma automática, pero cuando las aplicaciones generan mallas policara directamente, deben realizar la subdivisión ellas mismas. El número de vértices por cara es el parámetro clave de este proceso de subdivisión. La variable de sistema PFACEVMAX ofrece una aplicación con el número de vértices por entidad de cara. Este valor es de sólo lectura y está establecido en 4.

    Las mallas policaras creadas con el comando PCARA se generan siempre en primer lugar en todas las entidades de coordenadas de vértice seguidas por las entidades de definición de cara. El código de AutoCAD que procesa mallas policara exige el mismo orden. Los programas que generan mallas policara en DXF deben generar primero todos los vértices y, a continuación, todas las caras. No obstante, los programas que leen mallas policara desde DXF deben ser tolerantes con los órdenes de vértices y de caras impares.


RAY [Manual de referencia de DXF: DXF]

Sección ENTITIES
RAY

    • Los siguientes son los códigos de grupo aplicables a las entidades de rayo. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo RAY
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbRay)
10 | Punto inicial (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto inicial (en el SCU)
11 | Vector de dirección de unidad (en el SCU) DXF: valor X; APL: vector 3D
21, 31 | DXF: valores Y y Z del vector de dirección de unidad (en el SCU)


REGION [Manual de referencia de DXF: DXF]

Sección ENTITIES
REGION

    • Los siguientes son los códigos de grupo aplicables a las entidades de región. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo REGION
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbModelerGeometry)
70 | Número de versión de formato del modelador (actualmente = 1)
1 | Datos de propiedad (varias líneas < 255 caracteres cada una)
3 | Líneas adicionales de datos de propiedad (si la cadena del grupo 1 anterior tiene más de 255 caracteres) (opcional)


SEQEND [Manual de referencia de DXF: DXF]

Sección ENTITIES
SEQEND

    • Los siguientes son los códigos de grupo aplicables a las entidades de seqend. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo SEQEND
Códigos de grupo | Descripción
–2 | APL: nombre de la entidad que inicia la secuencia. Esta entidad marca el final del vértice (nombre de tipo de vértice) de una polilínea o el final de entidades de atributo (nombre de tipo de atributo) de una entidad insertada que tiene atributos (indicado por la presencia del grupo 66 con valor distinto de cero en dicha entidad insertada). Este código no se guarda en un archivo DXF.


SHAPE [Manual de referencia de DXF: DXF]

Sección ENTITIES
SHAPE

    • Los siguientes son los códigos de grupo aplicables a las entidades de forma. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo SHAPE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbShape)
39 | Altura de objeto (opcional; valor por defecto = 0)
10 | Punto de inserción (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto de inserción (en el SCU)
40 | Tamaño
2 | Nombre de forma
50 | Ángulo de rotación (opcional; valor por defecto = 0)
41 | Factor de escala X relativa (opcional; valor por defecto = 1)
51 | Ángulo oblicuo (opcional; valor por defecto = 0)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)


SOLID [Manual de referencia de DXF: DXF]

Sección ENTITIES
SOLID

    • Los siguientes son los códigos de grupo aplicables a las entidades de sólido. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo SOLID
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbTrace)
10 | Primera esquina DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z de la primera esquina
11 | Segunda esquina DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z de la segunda esquina
12 | Tercera esquina DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z de la tercera esquina
13 | Cuarta esquina. Si sólo se introducen tres esquinas para definir el sólido, la coordenada de la cuarta esquina es igual a la tercera. DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z de la cuarta esquina
39 | Altura de objeto (opcional; valor por defecto = 0)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)


SPLINE [Manual de referencia de DXF: DXF]

Sección ENTITIES
SPLINE

    • Los siguientes son los códigos de grupo aplicables a las entidades de spline. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo SPLINE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbSpline)
210 | Vector normal (se omite si la spline no es plana) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z del vector normal (opcional)
70 | Indicador de spline (codificado en bits): 1 = Spline cerrada 2 = Spline periódica 4 = Spline racional 8 = Plana 16 = Lineal (el bit de plana también está establecido)
71 | Grado de la curva spline
72 | Número de nudos
73 | Número de puntos de apoyo
74 | Número de puntos de ajuste (si los hay)
42 | Tolerancia de nudo (valor por defecto = 0.0000001)
43 | Tolerancia de los puntos de apoyo (valor por defecto = 0.0000001)
44 | Tolerancia de ajuste (valor por defecto = 0.0000000001)
12 | Tangente inicial; puede omitirse (en el SCU) DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z de la tangente inicial; pueden omitirse (en el SCU)
13 | Tangente final; puede omitirse (en el SCU) DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z de la tangente final; pueden omitirse (en el SCU)
40 | Valor de nudo (una entrada por nudo)
41 | Grosor (si no es 1); con varios pares de grupos, están presenten si todos son distintos de 1.
10 | Puntos de apoyo (en el SCU); una entrada por punto de apoyo DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z de los puntos de apoyo (en el SCU); una entrada por punto de apoyo
11 | Puntos de ajuste (en el SCU); una entrada por punto de ajuste DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z de los puntos de ajuste (en el SCU); una entrada por punto de ajuste


TEXT [Manual de referencia de DXF: DXF]

Sección ENTITIES
TEXT

    • Los siguientes son los códigos de grupo aplicables a las entidades de texto. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo TEXT
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbText)
39 | Altura de objeto (opcional; valor por defecto = 0)
10 | Primer punto de alineación (en el SCO) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del primer punto de alineación (en el SCO)
40 | Altura de texto
1 | Valor por defecto (la cadena en sí)
50 | Rotación del texto (opcional; valor por defecto = 0)
41 | Factor de escala X relativa; anchura (opcional; por defecto = 1) Este valor se ajusta también cuando se utiliza texto ajustado.
51 | Ángulo oblicuo (opcional; valor por defecto = 0)
7 | Nombre del estilo de texto (opcional, valor por defecto = STANDARD)
71 | Indicadores de generación del texto (opcional, por defecto = 0): 2 = El texto está de derecha a izquierda (reflejado en X) 4 = El texto está cabeza abajo (reflejado en Y)
72 | Tipo de justificación de texto horizontal (opcional, por defecto = 0); códigos de números enteros (no codificado en bits) 0 = Izquierda; 1= Centro; 2 = Derecha 3 = Alineado (si la alineación vertical = 0) 4 = Medio (si la alineación vertical = 0) 5 = Ajustar (si la alineación vertical = 0) Para obtener más información, véase la tabla de códigos de números enteros de los grupos 72 y 73.
11 | Segundo punto de alineación (en el SCO) (opcional) DXF: valor X; APL: punto 3D Este valor sólo tiene sentido si el valor del grupo 72 o 73 es distinto de cero (si la justificación es distinta de línea base/izquierda).
21, 31 | DXF: valores Y y Z del segundo punto de alineación (en el SCO) (opcional)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)
100 | Marcador Subclass (AcDbText)
73 | Tipo de justificación del texto vertical (opcional, por defecto = 0): códigos de números enteros (no codificado en bits): 0 = Línea base; 1 = Inferior; 2 = Medio; 3 = Superior Para obtener más información, véase la tabla de códigos de números enteros de los grupos 72 y 73.

    En la siguiente tabla se describen los códigos de grupo 72 (alineación horizontal) y 73 (alineación vertical) de manera pormenorizada.
    Códigos de números enteros de los grupos 72 y 73
Grupo 73 | Grupo 72 0 | 1 | 2 | 3 | 4 | 5
3 (superior) | Superior izquierda | Superior medio | Superior derecha |  |  |
2 (medio) | Medio izquierda | Medio central | Medio derecha |  |  |
1 (inferior) | Inferior izquierda | Inferior medio | Inferior derecha |  |  |
0 (línea base) | Izquierdo | Centro | Derecho | Alineada | Medio | Ajustar

    Si los valores de los grupos 72 y 73 son distintos de cero, se ignoran los valores del primer punto de alineación y se calculan en AutoCAD nuevos valores basados en el segundo punto de alineación, así como la longitud y la altura de la propia cadena de texto (tras aplicar el estilo de texto). Si estos grupos no tienen valores o su valor es cero, no se tiene en cuenta el segundo punto de alineación.


TOLERANCE [Manual de referencia de DXF: DXF]

Sección ENTITIES
TOLERANCE

    • Los siguientes son los códigos de grupo aplicables a las entidades de tolerancia. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo TOLERANCE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbFcf)
3 | Nombre de estilo de cota
10 | Punto de inserción (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto de inserción (en el SCU)
1 | Cadena que contiene la representación visual de la tolerancia
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)
11 | Vector de dirección del eje X (en el SCU) DXF: valor X; APL: vector 3D
21, 31 | DXF: valores Y y Z del vector de dirección del eje X (en el SCU)


TRACE [Manual de referencia de DXF: DXF]

Sección ENTITIES
TRACE

    • Los siguientes son los códigos de grupo aplicables a las entidades de trazo. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo TRACE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbTrace)
10 | Primera esquina (en el SCO) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z de la primera esquina (en el SCO)
11 | Segunda esquina (en el SCO) DXF: valor X; APL: punto 3D
21, 31 | DXF: valores Y y Z de la segunda esquina (en el SCO)
12 | Tercera esquina (en el SCO) DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z de la tercera esquina (en el SCO)
13 | Cuarta esquina (en el SCO) DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z de la cuarta esquina (en el SCO)
39 | Altura de objeto (opcional; valor por defecto = 0)
210 | Dirección de extrusión (opcional; por defecto = 0, 0, 1) DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de la dirección de extrusión (opcional)


VERTEX [Manual de referencia de DXF: DXF]

Sección ENTITIES
VERTEX

    • Los siguientes son los códigos de grupo aplicables a las entidades de vértice. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo VERTEX
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbVertex)
100 | Marcador Subclass (AcDb2dVertex o AcDb3dPolylineVertex)
10 | Punto de ubicación (en el SCO en 2D y en el SCU en 3D) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del punto de ubicación (en el SCO en 2D y en el SCU en 3D)
40 | Grosor inicial (opcional; valor por defecto = 0)
41 | Grosor final (opcional; valor por defecto = 0)
42 | Curvatura (opcional; el valor por defecto es 0) La curvatura es la tangente de la cuarta parte del ángulo incluido en un segmento de arco, expresada en números negativos si éste se dibuja en sentido de las agujas del reloj desde el punto inicial al final. Una curvatura 0 indica un segmento recto y una curvatura 1 indica un semicírculo.
70 | Indicadores de vértice: 1 = Vértice adicional creado por ajuste de curva 2 = Tangente de ajuste de curva definida por este vértice Se puede omitir una dirección de tangente de ajuste de curva 0 en la salida DXF, pero resulta significativa si se define este bit 4 = No utilizado 8 = Vértice de spline creado por ajuste de spline 16 = Punto de apoyo de armadura spline 32 = Vértice de polilínea 3D 64 = Malla poligonal 3D 128 = Vértice de malla policara
50 | Dirección de tangente de ajuste de curva
71 | Índice de vértice de malla policara (opcional; sólo presente si su valor es distinto de cero)
72 | Índice de vértice de malla policara (opcional; sólo presente si su valor es distinto de cero)
73 | Índice de vértice de malla policara (opcional; sólo presente si su valor es distinto de cero)
74 | Índice de vértice de malla policara (opcional; sólo presente si su valor es distinto de cero)

    Cada vértice que forma parte de una malla policara tiene definido su bit 128 de indicador de vértice. Si la entidad proporciona la coordenada de un vértice de la malla, su bit 64 se define también y los grupos 10, 20, 30 dan la coordenada del vértice. Los valores de índice de vértice se determinan en el orden en el que aparecen las entidades de vértice en la polilínea; el primero tiene el número 1.

    Si el vértice define una cara de la malla, su grupo de indicadores de vértice tendrá definido el bit 128, pero no el 64. En este caso, los grupos 10, 20, 30 (de ubicación) de la entidad cara son irrelevantes y siempre se escriben como 0 en el archivo DXF. Los índices de vértice que definen la malla vienen proporcionados por los códigos de grupo 71, 72, 73, y 74, cuyos valores precisan uno de los vértices definidos anteriormente mediante un índice. Si el índice es negativo, la arista que comienza con ese vértice es invisible. El primer vértice 0 marca el final de los vértices de la cara.


VIEWPORT [Manual de referencia de DXF: DXF]

Sección ENTITIES
VIEWPORT

    • Los siguientes son los códigos de grupo aplicables a las entidades de ventana gráfica. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.

    Códigos de grupo VIEWPORT

    Códigos de grupo

    Descripción

    100

    Marcador Subclass (AcDbViewport)

    10

    Punto central (en el SCU)
    DXF: valor X; APL: punto 3D

    20, 30

    DXF: valores Y y Z del punto central (en el SCU)

    40

    Anchura en unidades del espacio papel

    41

    Altura en unidades del espacio papel

    68

    Campo de estado de ventana gráfica:
    –1 = Activada, aunque no se ve en pantalla, o bien es una de las ventanas gráficas que no están activas porque actualmente se ha excedido el total $MAXACTVP.
    0 = Desactivada
    <valor positivo > = Activada y activa. El valor indica el orden de apilamiento de las ventanas gráficas, donde 1 es la ventana gráfica activa, 2 la siguiente, etc.

    69

    Identificador de ventana gráfica

    12

    Punto central de la vista (en el SCV)
    DXF: valor X; APL: punto 2D

    22

    DXF: valor Y de punto central de la vista (en el SCV)

    13

    Punto base de resolución
    DXF: valor X; APL: punto 2D

    23

    DXF: valor Y del punto base de resolución

    14

    Distancia de resolución
    DXF: valor X; APL: punto 2D

    24

    DXF: valor Y de la distancia de resolución

    15

    Intervalo de rejilla
    DXF: valor X; APL: punto 2D

    25

    DXF: valor Y del intervalo de rejilla

    16

    Vector de dirección de vista (en el SCU)
    DXF: valor X; APL: vector 3D

    26, 36

    DXF: valores Y y Z del vector de dirección de vista (en el SCU)

    17

    Punto del motivo de la vista (en el SCU)
    DXF: valor X; APL: vector 3D

    27, 37

    DXF: valores Y y Z del punto del motivo de la vista (en el SCU)

    42

    Distancia focal de perspectiva

    43

    Valor Z del plano de delimitación frontal

    44

    Valor Z del plano de delimitación posterior

    45

    Altura de la vista (en unidades de espacio modelo)

    50

    Ángulo de resolución

    51

    Angulo de ladeo de la vista

    72

    Porcentaje de zoom del círculo

    331

    Identificador/ID de objeto de capa inutilizada (puede haber varias capas) (opcional)

    90

    Indicadores de estado codificados en bits de ventana gráfica:
    1 (0x1) = Activa el modo de perspectiva
    2 (0x2) = Activa la delimitación frontal
    4 (0x4) = Activa la delimitación posterior
    8 (0x8) = Activa UCSfollow
    16 (0x10) = Activa la delimitación frontal no a la vista
    32 (0x20) = Activa la visibilidad del icono SCP
    64 (0x40) = Activa el icono SCP en el origen
    128 (0x80) = Activa el zoom rápido
    256 (0x100) = Activa el modo Forzcursor
    512 (0x200) = Activa el modo de rejilla
    1024 (0x400) = Activa el estilo de resolución isométrica
    2048 (0x800) = Activa el modo de ocultar al trazar
    4096 (0x1000) = kIsoPairTop. Si está definido y kIsoPairRight no está definido, se activa el isoplano superior. Si tanto kIsoPairTop como kIsoPairRight están definidos, se activa el isoplano izquierdo.
    8192 (0x2000) = kIsoPairRight. Si está definido y kIsoPairTop no está definido, se activa el isoplano derecho.
    16384 (0x4000) = Activa el bloqueo del zoom de la ventana gráfica
    32768 (0x8000) = Actualmente siempre está activado
    65536 (0x10000) = Activa la delimitación no rectangular
    131072 (0x20000) = Desactiva la ventana gráfica

    340

    Identificador/ID de dispositivo señalador duro para entidad que sirve como el contorno de delimitación de la ventana gráfica (sólo está presente si la ventana no es rectangular)

    1

    Nombre de hoja de estilos de trazado asignada a esta ventana

    281

    Modo de modelizado:
    0 = Optimización 2D (2D clásico)
    1 = Estructura alámbrica
    2 = Línea oculta
    3 = Sombreado plano
    4 = Sombreado Gouraud
    5 = Sombreado plano con estructura alámbrica
    6 = Sombreado Gouraud con estructura alámbrica

    Todos los modos de modelizado salvo Optimización 2D utilizan el nuevo proyecto de gráficos 3D. Estos valores se corresponden directamente con el comando MODOSOMBRA y la enumeración AcDbAbstractViewTableRecord::RenderMode.

    71

    Indicador de SCP por ventana gráfica:
    0 = El SCP no cambiará cuando la ventana gráfica se active.
    1 = Esta ventana gráfica guarda su propio SCP, que se convertirá en el actual siempre que se active dicha ventana.

    74

    Muestra el icono del SCP en el indicador de origen del SCP:
    Controla si el icono del SCP representa el SCP de la ventana gráfica o el SCP actual (serán distintos si UCSVP es 1 y la ventana gráfica no está activa). Sin embargo, este campo no se tiene en cuenta en la actualidad y el icono representa siempre el SCP de la ventana gráfica.

    110

    SCP, origen
    DXF: valor X; APL: punto 3D

    120, 130

    DXF: valores Y y Z del origen del SCP

    111

    Eje X del SCP
    DXF: valor X; APL: vector 3D

    121, 131

    DXF: valores Y y Z del eje X del SCP

    112

    Eje Y del SCP
    DXF: valor X; APL: vector 3D

    122, 132

    DXF: valores Y y Z del eje Y del SCP

    345

    Identificador/ID de AcDbUCSTableRecord si el SCP es un SCP guardado. Si no existe, el SCP no se ha guardado.

    346

    Identificador/ID de AcDbUCSTableRecord del SCP base si el SCP es ortogonal (el código 79 es distinto de cero). Si no existe y el código 79 es distinto de cero, se entiende que el SCP base es UNIVERSAL.

    79

    Tipo ortogonal del SCP:
    0 = SCP no es ortogonal
    1 = Superior; 2 = Inferior
    3 = Frontal; 4 = Posterior
    5 = Izquierda; 6 = Derecha

    146

    Elevación

    170

    Modo de trazado sombreado:

    0 = Como se muestra
    1 = Estructura alámbrica
    2 = Oculto
    3 = Modelizado

    Nota El factor de ZOOM XP se calcula mediante la siguiente fórmula: grupo_41 / grupo_45 (o altura_espacio_papel / altura_espacio_modelo).


XLINE [Manual de referencia de DXF: DXF]

Sección ENTITIES
XLINE

    • Los siguientes son los códigos de grupo aplicables a las entidades de líneaX. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para entidades. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo XLINE
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbXline)
10 | Primer punto (en el SCU) DXF: valor X; APL: punto 3D
20, 30 | DXF: valores Y y Z del primer punto (en el SCU)
11 | Vector de dirección de unidad (en el SCU) DXF: valor X; APL: vector 3D
21, 31 | DXF: valores Y y Z del vector de dirección de unidad (en el SCU)


Sección OBJECTS [Manual de referencia de DXF: DXF]

Sección OBJECTS

    • En este capítulo se presentan los códigos de grupo aplicables a los objetos no gráficos. Estos códigos se encuentran en la sección OBJECTS de un archivo DXF™ y los utilizan las aplicaciones AutoLISP® y ObjectARX™ en las listas de definición de entidades.

    Temas de esta sección:

    • Códigos de grupo de la sección OBJECTS
    • Códigos de grupo comunes para los objetos
    • ACAD_PROXY_OBJECT
    • ACDBDICTIONARYWDFLT
    • ACDBPLACEHOLDER
    • DICTIONARY
    • DICTIONARYVAR
    • DIMASSOC
    • GROUP
    • IDBUFFER
    • IMAGEDEF
    • IMAGEDEF_REACTOR
    • LAYER_INDEX
    • LAYER_FILTER
    • LAYOUT
    • MATERIAL
    • MLINESTYLE
    • OBJECT_PTR
    • PLOTSETTINGS
    • RASTERVARIABLES
    • SPATIAL_INDEX
    • SPATIAL_FILTER
    • SORTENTSTABLE
    • VBA_PROJECT
    • XRECORD


Códigos de grupo de la sección OBJECTS [Manual de referencia de DXF: DXF]

Sección OBJECTS
Códigos de grupo de la sección OBJECTS

    • Los objetos son parecidos a las entidades, pero no tienen ningún significado gráfico o geométrico. En esta sección es donde se almacenan todos los objetos que no sean entidades ni registros de la tabla de símbolos. Esta sección representa un conjunto homogéneo de objetos con un orden topológico establecido según su propiedad, de tal forma que los propietarios siempre aparecen delante de los objetos que les pertenecen.

    Temas de esta sección:

    • Propiedad de los objetos


Propiedad de los objetos [Manual de referencia de DXF: DXF]

Códigos de grupo de la sección OBJECTS
Propiedad de los objetos

    • El propietario raíz de la mayoría de los objetos que aparecen en la sección OBJECTS es el diccionario de objetos guardados, que es siempre el primer objeto que aparece en esta sección. Los objetos que no son propiedad del diccionario de objetos guardados son propiedad de otras entidades, objetos o entradas de tabla de símbolos. Los objetos contenidos en esta sección pueden haber sido definidos por AutoCAD® o por otras aplicaciones con acceso a API de ObjectARX™. Los nombres DXF de los tipos de objetos definidos por las aplicaciones siempre deben asociarse con un nombre de clase en la sección CLASS del archivo DXF o, de no hacerse esto, el registro del objeto no podrá unirse a la aplicación que deba interpretarlo.

    Al igual que otros diccionarios, el registro del diccionario de objetos guardados consta únicamente de pares asociados de nombres de entradas y referencias duras del dispositivo señalador de propiedad al objeto asociado.

    Para evitar conflictos en los nombres, los desarrolladores deberán utilizar siempre el prefijo de desarrollador registrado que les corresponda para las entradas.


Códigos de grupo comunes para los objetos [Manual de referencia de DXF: DXF]

Sección OBJECTS
Códigos de grupo comunes para los objetos

    • La siguiente tabla muestra los códigos de grupo que se aplican a casi la totalidad de objetos no gráficos. Cuando haga referencia a una tabla de códigos de grupo por tipo de objeto, una lista de los códigos asociados a un objeto especifico, tenga en cuenta que los códigos aquí enumerados también pueden estar presentes en ella. Algunos de los códigos de grupo se incluirán con un objeto únicamente si el objeto tiene valores no por defecto correspondientes a propiedades de códigos de grupo. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo comunes de objetos
Códigos de grupo | Descripción
0 | Tipo de objeto
5 | Identificador
102 | Inicio del grupo definido por la aplicación "{nombre_aplicación" (opcional)
códigos definidos por la aplicación | Los códigos y valores contenidos en los grupos 102 son definidos por la aplicación (opcional)
102 | Fin del grupo, "}" (opcional)
102 | "{ACAD_REACTORS" indica el inicio del grupo de reactivos permanentes de AutoCAD®. Este grupo sólo existe si se han asociado reactivos permanentes al objeto (opcional).
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario (opcional)
102 | Fin del grupo, "}" (opcional)
102 | "{ACAD_XDICTIONARY" indica el inicio de un grupo de diccionario de extensiones. Este grupo sólo existe si se han asociado reactivos permanentes al objeto (opcional).
360 | Identificador/ID duro del diccionario propietario (opcional)
102 | Fin del grupo, "}" (opcional)
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario


ACAD_PROXY_OBJECT [Manual de referencia de DXF: DXF]

Sección OBJECTS
ACAD_PROXY_OBJECT

    • Los siguientes son los códigos de grupo aplicables a los objetos ACAD_PROXY_OBJECT. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ACAD_PROXY_OBJECT
Códigos de grupo | Descripción
100 | DXF™: marcador Subclass (AcDbProxyObject)
90 | DXF: ID de clase de objeto proxy (siempre es 499)
91 | DXF: ID de clase de objeto de la aplicación. Los ID de clase se basan en el orden de clases de la sección CLASSES. A la primera clase se le asigna el ID 500, a la siguiente el 501, y así sucesivamente.
93 | DXF: tamaño de los datos del objeto expresado en bits
310 | DXF: datos binarios del objeto (puede haber varias entradas) (opcional)
330 o 340 o 350 o 360 | DXF: un ID de objeto (pueden aparecer varias entradas) (opcional)
94 | DXF: 0 (indica el final de la sección de ID de objetos)
95 | DXF: formato de dibujo de objetos cuando se convierten en proxy (un número entero sin signo de 32 bits): La palabra baja es AcDbDwgVersion La palabra alta es MaintenanceReleaseVersion
70 | DXF: formato de datos de objeto personalizado original: 0 = formato DWG 1 = formato DXF

    El campo 92 no se utiliza para AcDbProxyObject. Los objetos de esta clase nunca tienen gráficos.


ACDBDICTIONARYWDFLT [Manual de referencia de DXF: DXF]

Sección OBJECTS
ACDBDICTIONARYWDFLT

    • Los objetos ACDBDICTIONARYWDFLT utilizan los códigos de grupo que siguen. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ACDBDICTIONARYWDFLT
Códigos de grupo | Descripción
0 | Nombre del objeto (ACDBDICTIONARYWDFLT)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
330 | Identificador/ID suave para un objeto propietario
100 | Marcador Subclass (AcDbDictionary)
281 | Indicador de clonación de registro repetido (determina el modo de combinar entradas repetidas): 0 = No aplicable 1 = Mantener 2 = Utilizar clon 3 = <refX>$0$<nombre> 4 = $0$<nombre> 5 = Nombre no deteriorado
3 | Nombre de la entrada (uno para cada entrada)
350 | Identificador/ID suave para un objeto de entrada (uno para cada entrada)
100 | Marcador Subclass (AcDbDictionaryWithDefault)
340 | Dispositivo señalador duro para identificador/ID de objeto por defecto (actualmente sólo se utiliza para entradas por defecto del diccionario de estilos de trazado "Normal")


ACDBPLACEHOLDER [Manual de referencia de DXF: DXF]

Sección OBJECTS
ACDBPLACEHOLDER

    • Los objetos ACDBPLACEHOLDER utilizan los códigos de grupo que siguen. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo ACDBPLACEHOLDER
Códigos de grupo | Descripción
0 | Nombre del objeto (ACDBPLACEHOLDER)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario


DICTIONARY [Manual de referencia de DXF: DXF]

Sección OBJECTS
DICTIONARY

    • Los objetos DICTIONARY utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo DICTIONARY
Códigos de grupo | Descripción
0 | Nombre del objeto (DICTIONARY)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario
100 | Marcador Subclass (AcDbDictionary)
280 | Identificador duro de propietario. Si se establece en 1, indica que los elementos del diccionario se van a tratar como identificadores duros de propietario.
281 | Indicador de clonación de registro repetido (determina el modo de combinar entradas repetidas): 0 = No aplicable 1 = Mantener 2 = Utilizar clon 3 = <refX>$0$<nombre> 4 = $0$<nombre> 5 = Nombre no deteriorado
3 | Nombre de la entrada (uno para cada entrada) (opcional)
350 | Identificador/ID suave para un objeto de entrada (uno para cada entrada) (opcional)

    AutoCAD® mantiene algunos elementos, tales como los estilos de línea múltiple (líneaM) y las definiciones de grupo, como objetos contenidos en los diccionarios. En las secciones siguientes se describen los códigos de grupo de objetos de AutoCAD incluidos en diccionarios; sin embargo, otras aplicaciones pueden crear y utilizar libremente sus propios diccionarios como mejor convenga. El prefijo "ACAD_" se reserva para su uso con aplicaciones de AutoCAD.


DICTIONARYVAR [Manual de referencia de DXF: DXF]

Sección OBJECTS
DICTIONARYVAR

    • Los objetos DICTIONARYVAR utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo DICTIONARYVAR
Códigos de grupo | Descripción
0 | Nombre del objeto (DICTIONARYVAR)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario (ACDBVARIABLEDICTIONARY)
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (DictionaryVariables)
280 | Número de proyecto de objeto (actualmente establecido en 0)
1 | Valor de variable

    AutoCAD utiliza los objetos DICTIONARYVAR para almacenar valores guardados en la base de datos con funciones de setvar/getvar sin necesidad de añadir entradas a la sección HEADER del archivo DXF™. Actualmente, las variables de sistema que se almacenan como objetos DICTIONARYVAR son: DIMADEC, DIMDSEP, INDEXCTL, PROJECTNAME y XCLIPFRAME.


DIMASSOC [Manual de referencia de DXF: DXF]

Sección OBJECTS
DIMASSOC

    • Los objetos DIMASSOC utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo DIMASSOC
Códigos de grupo | Descripción
0 | Nombre del objeto (DIMASSOC)
5 | Identificador
102 | Grupo de reactivos permanentes; siempre es "{ACAD_REACTORS}"
330 | ID suave del dispositivo señalador
100 | Marcador Subclass (AcDbDimAssoc)
330 | ID del objeto de cota
90 | Indicador de asociatividad 1 = Referencia de primer punto 2 = Referencia de segundo punto 4 = Referencia de tercer punto 8 = Referencia de cuarto punto
70 | Indicador modelo/papel (verdadero/falso)
71 | Tipo de cota girada (paralela, perpendicular)
1 | Nombre de clase (AcDbOsnapPointRef)
72 | Tipo de punto de referencia a objetos (Inicio, Fin, Med, Cen, etc.)
331 | ID del objeto principal (geometría)
73 | SubentType de objeto principal (arista, cara)
91 | GsMarker del objeto principal (índice)
301 | Identificador (cadena) de objeto refX
40 | Parámetro de geometría del punto de referencia a objetos cercano
10 | Punto de referencia a objetos en el SCU; valor X
20 | Punto de referencia a objetos en el SCU; valor Y
30 | Punto de referencia a objetos en el SCU; valor Z
332 | ID del objeto de intersección (geometría)
74 | SubentType de objeto de intersección (arista/cara)
92 | GsMarker de objeto de intersección (índice)
302 | Identificador (cadena) de objeto refX de intersección
75 | Indicador hasLastPointRef (verdadero/falso)

    Los objetos DIMASSOC implementan cotas asociativas mediante la especificación de una asociación entre un objeto de cota y objetos de geometría del dibujo. Una cota asociativa es aquélla que se actualiza de forma automática cuando se modifica el objeto geométrico asociado.


GROUP [Manual de referencia de DXF: DXF]

Sección OBJECTS
GROUP

    • Los objetos GROUP utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo GROUP
Códigos de grupo | Descripción
0 | Nombre del objeto (GROUP)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS" (el grupo de reactivos permanentes aparece en todos los diccionarios menos en el principal).
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario. Para los objetos GROUP, siempre es la entrada ACAD_GROUP del diccionario de objetos guardados.
102 | Fin del grupo de reactivos permanentes; siempre es "}"
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario
100 | Marcador Subclass (AcDbGroup)
300 | Descripción del grupo
70 | Indicador "Sin nombre": 1 = Sin nombre; 0 = Con nombre
71 | Indicador de elegibilidad: 1 = Seleccionable; 0 = No seleccionable
340 | Identificador de la entidad en el grupo (una entrada por objeto)


IDBUFFER [Manual de referencia de DXF: DXF]

Sección OBJECTS
IDBUFFER

    • Los objetos IDBUFFER utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo IDBUFFER
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbIdBuffer)
330 | Referencia de dispositivo señalador suave a la entidad (pueden existir múltiples entradas)

    IDBUFFER es un objeto de utilidad que consiste simplemente en una lista de referencias a objetos.


IMAGEDEF [Manual de referencia de DXF: DXF]

Sección OBJECTS
IMAGEDEF

    • Los objetos IMAGEDEF utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo IMAGEDEF
Códigos de grupo | Descripción
0 | Nombre del objeto (IMAGEDEF)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para el diccionario ACAD_IMAGE_DICT
330 | Identificador/ID suave del dispositivo señalador para el objeto IMAGEDEF_REACTOR (múltiples entradas; una para cada muestra)
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbRasterImageDef)
90 | Versión de la clase 0
1 | Nombre de archivo de la imagen
10 | Tamaño de imagen en píxeles DXF: valor U; APL: punto 2D (valores U y V)
20 | DXF: valor V del tamaño de la imagen en píxeles
11 | Tamaño por defecto de un píxel en unidades de AutoCAD DXF: valor U; APL: punto 2D (valores U y V)
12 | DXF: valor V del tamaño de píxel
280 | Indicador de carga de la imagen. 0 = Descargada; 1 = Cargada
281 | Unidades de resolución. 0 = Ninguna unidad; 2 = Centímetros; 5 = Pulgadas


IMAGEDEF_REACTOR [Manual de referencia de DXF: DXF]

Sección OBJECTS
IMAGEDEF_REACTOR

    • Los objetos IMAGEDEF_REACTOR utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo IMAGEDEF_REACTOR
Códigos de grupo | Descripción
0 | Nombre del objeto (IMAGEDEF_REACTOR)
5 | Identificador
100 | Marcador Subclass (AcDbRasterImageDefReactor)
90 | Versión de la clase 2
330 | ID de objeto para un objeto de imagen asociado


LAYER_INDEX [Manual de referencia de DXF: DXF]

Sección OBJECTS
LAYER_INDEX

    • Los objetos LAYER_INDEX utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo LAYER_INDEX
Códigos de grupo | Descripción
0 | Nombre del objeto (LAYER_INDEX)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbIndex)
40 | Marca informativa de hora (fecha juliana)
100 | Marcador Subclass (AcDbLayerIndex)
8 | Nombre de capa (pueden existir múltiples entradas)
360 | Referencia dura de propietario para IDBUFFER (pueden existir varias entradas)
90 | Número de entradas de la lista IDBUFFER (pueden existir múltiples entradas)


LAYER_FILTER [Manual de referencia de DXF: DXF]

Sección OBJECTS
LAYER_FILTER

    • Los objetos LAYER_FILTER utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo LAYER_FILTER
Códigos de grupo | Descripción
0 | Nombre del objeto (LAYER_FILTER)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbFilter)
100 | Marcador Subclass (AcDbLayerFilter)
8 | Nombre de capa (pueden existir múltiples entradas)


LAYOUT [Manual de referencia de DXF: DXF]

Sección OBJECTS
LAYOUT

    • Los objetos LAYOUT utilizan los códigos de grupo que siguen. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo LAYOUT
Códigos de grupo | Descripción
0 | Nombre del objeto (LAYOUT)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario
100 | Marcador Subclass (AcDbPlotSettings)
códigos de grupo de objetos PLOTSETTINGS | Para obtener los códigos de grupo y descripciones del marcador AcDbPlotSettings, véase PLOTSETTINGS.
100 | Marcador Subclass (AcDbLayout)
1 | Nombre de presentación
70 | Indicador (codificado en bits) para controlar los elementos siguientes: 1 = Indica el valor PSLTSCALE para esta presentación cuando es la actual 2 = Indica el valor LIMCHECK para esta presentación cuando es la actual
71 | Orden de tabulación. Se trata de un número ordinal que indica el orden de presentación de los controles de tabulación asociados a la ventana de marcos de dibujo de AutoCAD. Téngase en cuenta que la ficha "Modelo" aparece siempre en primer lugar independientemente del orden de tabulación.
10 | Límites mínimos para esta presentación (definidos por LIMMIN mientras esta presentación sea la actual) DXF: valor X; APL: punto 2D
20 | DXF: valor Y de límites mínimos
11 | Límites máximos para esta presentación (definidos por LIMMAX mientras esta presentación sea la actual): DXF: valor X; APL: punto 2D
21 | DXF: valor Y de límites máximos
12 | Punto de inserción base para esta presentación (definido por INSBASE mientras esta presentación sea la actual): DXF: valor X; APL: punto 3D
22, 32 | DXF: valores Y y Z del punto de base de inserción
14 | Extensión mínima para esta presentación (definida por EXTMIN mientras esta presentación sea la actual): DXF: valor X; APL: punto 3D
24, 34 | DXF: valores Y y Z de la extensión mínima
15 | Extensión máxima para esta presentación (definidos por EXTMAX mientras esta presentación sea la actual): DXF: valor X; APL: punto 3D
25, 35 | DXF: valores Y y Z de la extensión máxima
146 | Elevación
13 | SCP, origen DXF: valor X; APL: punto 3D
23, 33 | DXF: valores Y y Z del origen del SCP
16 | Eje X del SCP DXF: valor X; APL: vector 3D
26, 36 | DXF: valores Y y Z del eje X del SCP
17 | Eje Y del SCP DXF: valor X; APL: vector 3D
27, 37 | DXF: valores Y y Z del eje Y del SCP
76 | Tipo ortogonal del SCP 0 = SCP no ortogonal 1 = Superior; 2 = Inferior 3 = Frontal; 4 = Posterior 5 = Izquierda; 6 = Derecha
330 | Identificador/ID para el registro de tabla de bloques de espacio papel asociado a esta presentación
331 | Identificador/ID para la última ventana gráfica activa de esta presentación cuando dicha presentación era la actual
345 | Identificador/ID de AcDbUCSTableRecord si el SCP es un SCP guardado. Si no existe, el SCP no se ha guardado.
346 | Identificador/ID de AcDbUCSTableRecord del SCP base si el SCP es ortogonal (el código 76 es distinto de cero). Si no existe y el código 76 es distinto de cero, se entiende que el SCP base es UNIVERSAL.


MATERIAL [Manual de referencia de DXF: DXF]

Sección OBJECTS
MATERIAL

    • Los objetos MATERIAL utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo MATERIAL
Códigos de grupo | Descripción
0 | Nombre del objeto (MATERIAL)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS" (el grupo de reactivos permanentes aparece en todos los diccionarios menos en el principal).
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario. Para los objetos MATERIAL, siempre es la entrada ACAD_MATERIAL del diccionario de objetos guardados.
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbMaterial)
1 | Nombre del material (cadena)
2 | Descripción (cadena, sin cadena por defecto)
70 | Método de color ambiental (por defecto = 0): 0 = Utilizar color actual 1 = Sustituir color actual
40 | Factor de color ambiental (número real, por defecto = 1.0, el rango válido es de 0.0 a 1.0)
90 | Valor de color ambiental (número entero de 32 bits sin signo que representa un AcCmEntityColor)
71 | Método de color difuso (por defecto = 0): 0 = Utilizar color actual 1 = Sustituir color actual
41 | Factor de color difuso (número real, por defecto = 1.0, el rango válido es de 0.0 a 1.0)
91 | Valor de color difuso (número entero de 32 bits sin signo que representa un AcCmEntityColor)
42 | Factor de combinación de mapa difuso (número real, por defecto = 1.0)
72 | Origen de mapa difuso (por defecto = 1): 0 = Utilizar escena actual 1 = Utilizar archivo de imagen (especificado por el nombre de archivo; la ausencia de un nombre de archivo no especifica ningún mapa)
3 | Nombre de archivo de mapa difuso (cadena, por defecto = sin cadena)
73 | Método de proyección del mapeador de mapa difuso (por defecto = 1): 1 = Plano 2 = Cuadrado 3 = Cilindro 4 = Esfera
74 | Método de mosaico del mapeador de mapa difuso (por defecto = 1): 1 = Mosaico 2 = Recortar 3 = Fijar
75 | Método de transformación automática del mapeador de mapa difuso (conjunto de bits; por defecto = 1): 1= Sin transformación automática 2 = Escalar mapeador a la extensión de entidad actual; convertir mapeador al origen de entidad 4 = Incluir transformación de bloque actual en transformación del mapeador
43 | Matriz de transformación del mapeador de mapa difuso (16 números reales; formato principal de fila; por defecto = matriz de identidad)
44 | Factor de brillo especular (número real, por defecto = 0.5)
76 | Método de color especular (por defecto = 0): 0 = Utilizar color actual 1 = Sustituir color actual
45 | Factor de color especular (número real, por defecto = 1.0; el rango válido es de 0.0 a 1.0)
92 | Valor de color especular (número entero de 32 bits sin signo que representa un AcCmEntityColor)
46 | Factor de combinación de mapa especular (número real; por defecto = 1.0)
77 | Origen de mapa especular (por defecto = 1): 0 = Utilizar escena actual 1 = Utilizar archivo de imagen (especificado por el nombre de archivo; la ausencia de un nombre de archivo no especifica ningún mapa)
4 | Nombre de archivo del mapa especular (cadena; por defecto = sin cadena)
78 | Método de proyección del mapeador de mapa especular (por defecto = 1): 1 = Plano 2 = Cuadrado 3 = Cilindro 4 = Esfera
79 | Método de mosaico del mapeador de mapa especular (por defecto = 1): 1 = Mosaico 2 = Recortar 3 = Fijar
170 | Método de transformación automática del mapeador de mapa especular (conjunto de bits; por defecto = 1): 1= Sin transformación automática 2 = Escalar mapeador a la extensión de entidad actual; convertir mapeador al origen de entidad 4 = Incluir transformación de bloque actual en transformación del mapeador
47 | Matriz de transformación del mapeador de mapa especular (16 números reales; formato principal de fila; por defecto = matriz de identidad)
48 | Factor de combinación de mapa de reflexión (número real, por defecto = 1.0)
171 | Origen de mapa de reflexión (por defecto = 1): 0 = Utilizar escena actual 1 = Utilizar archivo de imagen (especificado por el nombre de archivo; la ausencia de un nombre de archivo no especifica ningún mapa)
6 | Nombre de archivo del mapa de reflexión (cadena; por defecto = sin cadena)
172 | Método de proyección del mapeador de mapa de reflexión (por defecto = 1): 1 = Plano 2 = Cuadrado 3 = Cilindro 4 = Esfera
173 | Método de mosaico del mapeador de mapa de reflexión (por defecto = 1): 1 = Mosaico 2 = Recortar 3 = Fijar
174 | Método de transformación automática del mapeador de mapa de reflexión (conjunto de bits; por defecto = 1): 1= Sin transformación automática 2 = Escalar mapeador a la extensión de entidad actual; convertir mapeador al origen de entidad 4 = Incluir transformación de bloque actual en transformación del mapeador
49 | Matriz de transformación del mapeador de mapa de reflexión (16 números reales; formato principal de fila; por defecto = matriz de identidad)
140 | Porcentaje de opacidad (número real; por defecto = 1.0)
141 | Factor de combinación de mapa de opacidad (número real, por defecto = 1.0)
175 | Origen de mapa de opacidad (por defecto = 1): 0 = Utilizar escena actual 1 = Utilizar archivo de imagen (especificado por el nombre de archivo; la ausencia de un nombre de archivo no especifica ningún mapa)
7 | Nombre de archivo del mapa de opacidad (cadena; por defecto = sin cadena)
176 | Método de proyección del mapeador de mapa de opacidad (por defecto = 1): 1 = Plano 2 = Cuadrado 3 = Cilindro 4 = Esfera
177 | Método de mosaico del mapeador de mapa de opacidad (por defecto = 1): 1 = Mosaico 2 = Recortar 3 = Fijar
178 | Método de transformación automática del mapeador de mapa de opacidad (conjunto de bits; por defecto = 1): 1= Sin transformación automática 2 = Escalar mapeador a la extensión de entidad actual; convertir mapeador al origen de entidad 4 = Incluir transformación de bloque actual en transformación del mapeador
142 | Matriz de transformación del mapeador de mapa de opacidad (16 números reales; formato principal de fila; por defecto = matriz de identidad)
143 | Factor de combinación de relieve (número real, por defecto = 1.0)
179 | Origen de relieve (por defecto = 1): 0 = Utilizar escena actual 1 = Utilizar archivo de imagen (especificado por el nombre de archivo; la ausencia de un nombre de archivo no especifica ningún mapa)
8 | Nombre de archivo del relieve (cadena; por defecto = sin cadena)
270 | Método de proyección del mapeador de relieve (por defecto = 1): 1 = Plano 2 = Cuadrado 3 = Cilindro 4 = Esfera
271 | Método de mosaico del mapeador de relieve (por defecto = 1): 1 = Mosaico 2 = Recortar 3 = Fijar
272 | Método de transformación automática del mapeador de relieve (conjunto de bits; por defecto = 1): 1= Sin transformación automática 2 = Escalar mapeador a la extensión de entidad actual; convertir mapeador al origen de entidad 4 = Incluir transformación de bloque actual en transformación del mapeador
144 | Matriz de transformación del mapeador de relieve (16 números reales; formato principal de fila; por defecto = matriz de identidad)
145 | Índice de refracción (número real; por defecto = 1.0)
146 | Factor de combinación de mapa de refracción (número real, por defecto = 1.0)
273 | Origen de mapa de refracción (por defecto = 1): 0 = Utilizar escena actual 1 = Utilizar archivo de imagen (especificado por el nombre de archivo; la ausencia de un nombre de archivo no especifica ningún mapa)
9 | Nombre de archivo del mapa de refracción (cadena; por defecto = sin cadena)
274 | Método de proyección del mapeador de mapa de refracción (por defecto = 1): 1 = Plano 2 = Cuadrado 3 = Cilindro 4 = Esfera
275 | Método de mosaico del mapeador de mapa de refracción (por defecto = 1): 1 = Mosaico 2 = Recortar 3 = Fijar
276 | Método de transformación automática del mapeador de mapa de refracción (conjunto de bits; por defecto = 1): 1= Sin transformación automática 2 = Escalar mapeador a la extensión de entidad actual; convertir mapeador al origen de entidad 4 = Incluir transformación de bloque actual en transformación del mapeador
147 | Matriz de transformación del mapeador de mapa de refracción (16 números reales; formato principal de fila; por defecto = matriz de identidad)


MLINESTYLE [Manual de referencia de DXF: DXF]

Sección OBJECTS
MLINESTYLE

    • Los objetos MLINESTYLE utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo MLINESTYLE
Códigos de grupo | Descripción
0 | Nombre del objeto (MLINESTYLE)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS" (el grupo de reactivos permanentes aparece en todos los diccionarios menos en el principal).
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario. Para los objetos MLINESTYLE, siempre es la entrada ACAD_MLINESTYLE del diccionario de objetos guardados.
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbMlineStyle)
2 | Nombre de estilo de MLINE
70 | Indicadores (codificado en bits): 1 = Relleno activado 2 = Visualizar ingletes 16 = Iniciar extremos (línea) cuadrados 32 = Iniciar extremo de arcos internos 64 = Iniciar extremo de redondeo (arcos externos) 256 = Extremo cuadrado final (línea) 512 = Extremo de arcos internos final 1024 =Extremo de redondeo final (arcos externos)
3 | Descripción del estilo (cadena, máximo 255 caracteres)
62 | Color de relleno (número entero, por defecto = 256)
51 | Ángulo inicial (número real, por defecto es 90 grados)
52 | Ángulo final (número real, por defecto es 90 grados)
71 | Número de elementos
49 | Desfase del elemento (número real, no hay valor por defecto). Puede haber varias entradas; una por cada elemento.
62 | Color del elemento (número entero, por defecto = 0). Puede haber varias entradas; una por cada elemento.
6 | Tipo de línea por elemento (cadena, por defecto = BYLAYER). Puede haber varias entradas; una por cada elemento.

    Los códigos de grupo 2 de las entidades LINEAM y los objetos MLINESTYLE son campos redundantes. Estos grupos no deben modificarse bajo ninguna circunstancia, aunque no hay ningún inconveniente en leerlos y utilizar sus valores. Los campos que se pueden modificar son los siguientes:

    Mline

    Grupo 340 del mismo objeto, que indica el propio objeto MLINESTYLE.

    Mlinestyle

    Valor de grupo 3 del diccionario MLINESTYLE que precede al grupo 350, que es el que posee el identificador o el nombre de entidad del MLINESTYLE actual.


OBJECT_PTR [Manual de referencia de DXF: DXF]

Sección OBJECTS
OBJECT_PTR

    • Los objetos OBJECT_PTR utilizan los códigos de grupo que siguen. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo OBJECT_PTR
Códigos de grupo | Descripción
0 | Nombre del objeto (OBJECT_PTR)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
1001 | Inicio de datoseX ASE (DC015)


PLOTSETTINGS [Manual de referencia de DXF: DXF]

Sección OBJECTS
PLOTSETTINGS

    • Los objetos PLOTSETTINGS utilizan los códigos de grupo que siguen. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo PLOTSETTINGS
Códigos de grupo | Descripción
0 | Nombre del objeto (PLOTSETTINGS)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
330 | Identificador/ID suave del dispositivo señalador para un objeto propietario
100 | Marcador Subclass (AcDbPlotSettings)
1 | Nombre de configuración de página
2 | Nombre de la impresora del sistema o del archivo de configuración de impresión
4 | Tamaño del papel
6 | Nombre de la vista de impresión
40 | Tamaño (en milímetros) del margen no imprimible de la parte izquierda del papel
41 | Tamaño (en milímetros) del margen no imprimible de la parte inferior del papel
42 | Tamaño (en milímetros) del margen no imprimible de la parte derecha del papel
43 | Tamaño (en milímetros) del margen no imprimible de la parte superior del papel
44 | Tamaño del papel de impresión: anchura física del papel en milímetros
45 | Tamaño del papel de impresión: altura física del papel en milímetros
46 | Punto de origen del trazado: valor X del desfase de origen en milímetros
47 | Punto de origen del trazado: valor Y del desfase de origen en milímetros
48 | Área de la ventana de trazado: valor X de la esquina inferior izquierda de la ventana
49 | Área de la ventana de trazado: valor Y de la esquina superior derecha de la ventana
140 | Área de la ventana de trazado: valor X de la esquina inferior izquierda de la ventana
141 | Área de la ventana de trazado: valor Y de la esquina superior derecha de la ventana
142 | Numerador de la escala de impresión personalizada: unidades reales (del papel)
143 | Denominador de la escala de impresión personalizada: unidades de dibujo
70 | Indicador de presentación del trazado: 1 = PlotViewportBorders 2 = ShowPlotStyles 4 = PlotCentered 8 = PlotHidden 16 = UseStandardScale 32 = PlotPlotStyles 64 = ScaleLineweights 128 = PrintLineweights 512 = DrawViewportsFirst 1024 = ModelType 2048 = UpdatePaper 4096 = ZoomToPaperOnUpdate 8192 = Initializing 16384 = PrevPlotInit
72 | Unidades del papel de trazado: 0 = Trazado en pulgadas 1 = Trazado en milímetros 2 = Trazado en píxeles
73 | Rotación del trazado: 0 = Sin rotación 1 = 90 grados en sentido antihorario 2 = Girado 180 grados 3 = 90 grados en sentido horario
74 | Tipo de trazado (porción de espacio papel que se imprimirá en el medio de soporte): 0 = Última visualización en pantalla 1 = Extensión del dibujo 2 = Límites del dibujo 3 = Vista especificada por el código 6 4 = Ventana especificada por los códigos 48, 49, 140 y 141 5 = Información de presentación
7 | Hoja de estilos actual
75 | Tipo de escala estándar: 0 = Ajustar escala 1 = 1/128"=1'; 2 = 1/64"=1'; 3 = 1/32"=1' 4 = 1/16"=1'; 5 = 3/32"=1'; 6 = 1/8"=1' 7 = 3/16"=1'; 8 = 1/4"=1'; 9 = 3/8"=1' 10 = 1/2"=1'; 11 = 3/4"=1'; 12 = 1"=1' 13 = 3"=1'; 14 = 6"=1'; 15 = 1'=1' 16= 1:1 ; 17= 1:2; 18 = 1:4; 19 = 1:8; 20 = 1:10; 21= 1:16 22 = 1:20; 23 = 1:30; 24 = 1:40; 25 = 1:50; 26 = 1:100 27 = 2:1; 28 = 4:1; 29 = 8:1; 30 = 10:1; 31 = 100:1; 32 = 1000:1
76 | Modo de trazado sombreado: 0 = Como se muestra 1 = Estructura alámbrica 2 = Oculto 3 = Modelizado
77 | Nivel de resolución del trazado sombreado: 0 = Borrador 1 = Vista preliminar 2 = Normal 3 = Presentación 4 = Máximo 5 = Personalizado
78 | PPP personalizado de trazado sombreado: Rango válido: 100 a 32767 Sólo se aplica cuando el nivel de resolución del trazado sombreado está establecido en 5 (Personalizado).
147 | Factor de escala de coma flotante que representa el valor de escala estándar especificado en el código 75.
148 | Origen de imagen de papel: valor X
149 | Origen de imagen de papel: valor Y


RASTERVARIABLES [Manual de referencia de DXF: DXF]

Sección OBJECTS
RASTERVARIABLES

    • Los objetos RASTERVARIABLES utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo RASTERVARIABLES
Códigos de grupo | Descripción
0 | Nombre del objeto (RASTERVARIABLES)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario. En el caso de los objetos RASTERVARIABLES, siempre es la entrada ACAD_IMAGE_VARS del diccionario de objetos guardados.
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbRasterVariables)
90 | Versión de la clase 0
70 | Indicador de visualización de marcos de imágenes: 0 = Sin marcos; 1 = Visualizar marcos
71 | Calidad de visualización de imágenes (sólo en pantalla): 0 = Borrador; 1 = Alta
72 | Unidades de AutoCAD para insertar imágenes. Equivalencia de una unidad de AutoCAD para insertar y ajustar la escala de imágenes con una resolución asociada: 0 = Ninguna; 1 = Milímetro; 2 = Centímetro 3 = Metro; 4 = Kilómetro; 5 = Pulgada 6 = Pie; 7 = Yarda; 8 = Milla


SPATIAL_INDEX [Manual de referencia de DXF: DXF]

Sección OBJECTS
SPATIAL_INDEX

    • Los objetos SPATIAL_INDEX utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo SPATIAL_INDEX
Códigos de grupo | Descripción
0 | Nombre del objeto (SPATIAL_INDEX)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbIndex)
40 | Marca informativa de hora (fecha juliana)
100 | Marcador Subclass (AcDbSpatialIndex)

    El objeto SPATIAL_INDEX se registra siempre vacío en un archivo DXF. Este objeto puede ignorarse.


SPATIAL_FILTER [Manual de referencia de DXF: DXF]

Sección OBJECTS
SPATIAL_FILTER

    • Los objetos SPATIAL_FILTER utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo SPATIAL_FILTER
Códigos de grupo | Descripción
0 | Nombre del objeto (SPATIAL_FILTER)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario (SPATIAL)
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbFilter)
100 | Marcador Subclass (AcDbSpatialFilter)
70 | Número de puntos en el contorno delimitador 2 = Contorno delimitador rectangular (inferior izquierda y superior derecha) Mayor que 2 = Contorno delimitador de polilínea
10 | Punto de definición de contorno delimitador (en el SCO) (siempre 2 o superior) basado en una escala de referencia externa de 1. DXF: valor X; APL: punto 2D
20 | DXF: valor Y del punto de definición de contorno (siempre 2 o superior)
210 | Normal al plano que contiene el contorno delimitador: DXF: valor X; APL: vector 3D
220, 230 | DXF: valores Y y Z de dirección de extrusión
11 | Origen utilizado para definir el sistema de coordenadas locales del contorno delimitador. DXF: valor X; APL: punto 3D
21, 31 | Origen utilizado para definir el sistema de coordenadas locales del contorno delimitador. DXF: valores Y y Z
71 | Indicador de activación de la visualización del contorno delimitador 0 = Desactivado; 1 = Activado
72 | Indicador de plano de delimitación frontal; 0 = No; 1 = Sí
40 | Distancia de plano de delimitación frontal (si el código 72 = 1)
73 | Indicador de plano de delimitación posterior; 0 = No; 1 = Sí
41 | Distancia de plano de delimitación posterior (si el código 73 = 1)
40 | Matriz de transformación 4x3 registrada en el orden de clasificación principal de las columnas. Esta matriz es la inversa de la transformación de referencia a bloque original (insertar entidad). La transformación de referencia a bloque original es la que se aplica a todas las entidades del bloque cuando se regenera la referencia a bloque (siempre 12 entradas).
40 | Matriz de transformación 4x3 registrada en el orden de clasificación principal de las columnas. Esta matriz transforma puntos en el sistema de coordenadas del contorno delimitador (12 entradas).


SORTENTSTABLE [Manual de referencia de DXF: DXF]

Sección OBJECTS
SORTENTSTABLE

    • Los objetos SORTENTSTABLE utilizan los códigos de grupo siguientes. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo SORTENTSTABLE
Códigos de grupo | Descripción
0 | Nombre del objeto (SORTENTSTABLE)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario (ACAD_SORTENTS)
102 | Fin del grupo de reactivos permanentes; siempre es "}"
100 | Marcador Subclass (AcDbSortentsTable)
330 | Identificador/ID suave del dispositivo señalador para propietario (actualmente sólo los bloques *MODEL_SPACE o *PAPER_SPACE)
331 | Identificador/ID suave del dispositivo señalador para una entidad (pueden existir cero o varias entradas)
5 | Identificador de clasificación (pueden existir cero o varias entradas)

    Si se ha establecido el indicador de regeneración SORTENTS (valor 16 codificado en bits), las entidades se regenerarán en orden de identificación ascendente en AutoCAD. Si se utiliza el comando ORDENAOBJETOS, el objeto SORTENTSTABLE se enlaza con un diccionario de extensión de bloque en *Model_Space o *Paper_Space con el nombre de ACAD_SORTENTS. El objeto SORTENTSTABLE relacionado con este diccionario asocia identificadores distintos a cada entidad, lo que cambia el orden en el que se regeneran las entidades.


VBA_PROJECT [Manual de referencia de DXF: DXF]

Sección OBJECTS
VBA_PROJECT

    • Los objetos VBA_PROJECT utilizan los códigos de grupo que se describen a continuación. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo VBA_PROJECT
Códigos de grupo | Descripción
0 | Nombre del objeto (VBA_PROJECT)
5 | Identificador
102 | Inicio del grupo de reactivos permanentes; siempre es "{ACAD_REACTORS"
330 | Identificador/ID suave del dispositivo señalador para un diccionario propietario
102 | Fin del grupo de reactivos permanentes; siempre es "}"
330 | Identificador/ID suave para un objeto propietario
100 | Marcador Subclass (AcDbVbaProject)
90 | Número de bytes de los datos de la sección binaria (contenidos en los registros del código de grupo 310, que se describe a continuación).
310 | DXF™: Datos binarios del objeto (varias entradas con datos del proyecto VBA)


XRECORD [Manual de referencia de DXF: DXF]

Sección OBJECTS
XRECORD

    • Los siguientes códigos de grupo son comunes para todos los objetos XRECORD. Además de los códigos de grupo aquí descritos, véase Códigos de grupo comunes para los objetos. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo XRECORD
Códigos de grupo | Descripción
100 | Marcador Subclass (AcDbXrecord)
280 | Indicador de clonación de registro repetido (determina el modo de combinar entradas repetidas): 0 = No aplicable 1 = Mantener 2 = Utilizar clon 3 = <refX>$0$<nombre> 4 = $0$<nombre> 5 = Nombre no deteriorado
1–369 (salvo 5 y 105) | Las aplicaciones pueden servirse como quieran de estos valores.

    Los objetos XRECORD se utilizan para almacenar y gestionar datos arbitrarios. Se componen de códigos de grupo DXF con grupos de "objetos normales" (es decir, códigos de grupo que no son datoseX), que van de 1 a 369 para los rangos admitidos. Estos objetos son similares en concepto a datoseX, pero no están limitados por el tamaño y el orden.

    Los objetos XRECORD están diseñados para funcionar de manera que no ocasionen problemas en las versiones 13c0 a 13c3. No obstante, si se leen en versiones de AutoCAD® anteriores a la R13c4, dichos objetos desaparecerán.


Sección THUMBNAILIMAGE [Manual de referencia de DXF: DXF]

Sección THUMBNAILIMAGE

    • En este capítulo se presentan los códigos de grupo incluidos en la sección THUMBNAILIMAGE de un archivo DXF™. Esta sección sólo existe si se ha guardado previamente una imagen preliminar con el archivo DXF.

    Temas de esta sección:

    • Códigos de grupo de la sección THUMBNAILIMAGE


Códigos de grupo de la sección THUMBNAILIMAGE [Manual de referencia de DXF: DXF]

Sección THUMBNAILIMAGE
Códigos de grupo de la sección THUMBNAILIMAGE

    • Los siguientes son los códigos de grupo que se incluyen en la sección THUMBNAILIMAGE. Para obtener información sobre las abreviaturas y el formato que se utilizan en esta tabla, véase Convenciones de formato de este manual de referencia.
    Códigos de grupo de THUMBNAILIMAGE
Códigos de grupo | Descripción
90 | Número de bytes de la imagen (y de los posteriores registros de bloques binarios)
310 | Datos de imagen preliminar (varias líneas; como máximo 256 caracteres por línea)


Formatos de archivo de intercambio de dibujos [Manual de referencia de DXF: DXF]

Formatos de archivo de intercambio de dibujos

    • En este apéndice se describen los distintos formatos de archivo que AutoCAD® utiliza para intercambiar datos de dibujo con otras aplicaciones. Los formatos que se presentan son los siguientes: archivo de intercambio de dibujos (DXF™ ), archivo DXF binario, archivo de foto (SLD) y archivo de fototeca (SLB).

    El formato de los archivos DXF puede ser tanto ASCII como binario. Debido a que los archivos DXF ASCII son más comunes que los de formato binario, se emplea el término archivo DXF para referirse a los archivos DXF ASCII y archivo DXF binario para el formato binario.

    Temas de esta sección:

    • Archivos DXF ASCII
    • Archivos DXF binarios
    • Archivos de fotos
    • Archivos de fototeca


Archivos DXF ASCII [Manual de referencia de DXF: DXF]

Formatos de archivo de intercambio de dibujos
Archivos DXF ASCII

    • En esta sección se describe el formato de los archivos DXF ASCII y contiene la información necesaria para que los usuarios creen sus propios programas para procesar archivos DXF o trabajen con la información de entidades obtenidas de las aplicaciones AutoLISP® y ObjectARX™.

    Temas de esta sección:

    • Estructura general del archivo DXF
    • Códigos de grupo en archivos DXF
    • Códigos de grupo HEADER en archivos DXF
    • Códigos de grupo CLASSES en archivos DXF
    • Códigos de grupo de tabla de símbolos en archivos DXF
    • Códigos de grupo BLOCKS en archivos DXF
    • Códigos de grupo ENTITIES en archivos DXF
    • Códigos de grupo OBJECTS en archivos DXF
    • Creación de un programa de interfaz para DXF


Estructura general del archivo DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Estructura general del archivo DXF

    • Los archivos DXF se componen fundamentalmente de pares de códigos y valores asociados. Los códigos, denominados códigos de grupo, indican el tipo de valor que les sigue. Mediante estos pares de códigos de grupo y valores, los archivos DXF se organizan en secciones compuestas de registros que constan de un código de grupo y un elemento de datos. Cada código de grupo y su valor ocupan su propia línea en el archivo DXF.

    Cada sección comienza con un código de grupo 0 seguido de la cadena SECTION. A continuación aparece un código de grupo 2 y una cadena que indica el nombre de la sección (por ejemplo, HEADER). Cada sección se compone de códigos de grupo y valores que definen sus elementos y termina con un 0 seguido de la cadena ENDSEC.

    Para entender mejor esta estructura, puede resultar de utilidad generar un archivo DXF a partir de un dibujo pequeño, imprimirlo y tomarlo como referencia mientras lee la información que se proporciona en esta sección.

    La organización general de los archivos DXF es la siguiente:

    • Sección HEADER (encabezamiento): contiene información general sobre el dibujo. Se compone de un número de versión de base de datos de AutoCAD y de una serie de variables de sistema. Cada uno de los parámetros contiene un nombre de variable y su valor asociado.
    • Sección CLASSES (clases): contiene información de las clases definidas por la aplicación, cuyas apariciones se incluyen en las secciones BLOCKS, ENTITIES y OBJECTS de la base de datos. Las definiciones de clase se fijan en la jerarquía de clases de forma permanente.
    • Sección TABLES (tablas): contiene las definiciones de las siguientes tablas de símbolos:

    APPID (tabla de identificación de las aplicaciones)

    BLOCK_RECORD (tabla de referencia a bloques)

    DIMSTYLE (tabla de estilos de cota)

    LAYER (tabla de capas)

    LTYPE (tabla de tipos de línea)

    STYLE (tabla de estilos de texto)

    UCS (tabla del sistema de coordenadas personales)

    VIEW (tabla de visualización)

    VPORT (tabla de configuración de la ventana gráfica)

    • Sección BLOCKS (bloques): contiene definiciones de bloques y entidades de dibujo que constituyen cada referencia a bloque del dibujo.
    • Sección ENTITIES (entidades): contiene los objetos gráficos (entidades) del dibujo, incluidas las referencias a bloques (entidades insertadas).
    • Sección OBJECTS (objetos): contiene los objetos no gráficos del dibujo. En esta sección es donde se almacenan todos los objetos que no sean entidades ni registros de la tabla de símbolos. Los diccionarios que contienen los estilos de MLINE y los grupos son ejemplos de entrada que aparecen en la sección OBJECTS.
    • Sección THUMBNAILIMAGE (imagen en miniatura): contiene los datos de imagen de vista preliminar del dibujo. Esta sección es opcional.

    Si utiliza la opción Designar objetos de los comandos GUARDAR o GUARDARCOMO, la sección ENTITIES del archivo DXF resultante sólo contendrá las entidades que seleccione.


Códigos de grupo en archivos DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Códigos de grupo en archivos DXF

    • Los códigos de grupo y sus valores asociados definen un aspecto concreto de un objeto o entidad. La línea inmediatamente posterior al código de grupo es el valor asociado, que puede ser una cadena, un número entero o un valor de coma flotante, como la coordenada X de un punto. Las líneas que siguen a la segunda línea del grupo, en caso de que exista alguna, vienen determinadas por la definición del grupo y por los datos asociados al mismo.

    Los códigos especiales de grupos se utilizan como separadores del archivo, como pueden ser los marcadores de principio y fin de las secciones, las tablas y el propio código de final de archivo.

    Las entidades, los objetos, las clases, las tablas y las entradas de tabla, así como los separadores de los archivos se introducen con un código de grupo 0 seguido de un nombre que describe el grupo.

    La longitud máxima de las cadenas de los archivos DXF es de 256 caracteres. Si el dibujo de AutoCAD contiene cadenas que exceden dicho número de caracteres, dichas cadenas se truncarán durante la ejecución de GUARDAR, GUARDARCOMO y BLOQUEDISC. Si el archivo DXF contiene cadenas con una longitud superior a la mencionada, los comandos ABRE e INSERT no se podrán ejecutar.

    Temas de esta sección:

    • Caracteres de control ASCII en archivos DXF


Caracteres de control ASCII en archivos DXF [Manual de referencia de DXF: DXF]

Códigos de grupo en archivos DXF
Caracteres de control ASCII en archivos DXF

    • El comando GUARDARCOMO expande los caracteres de control ASCII de las cadenas de texto en un signo de intercalación (^) seguido de la letra adecuada. Por ejemplo, un carácter ASCII Control-G (BEL, código decimal 7) se escribirá como ^G. Si el propio texto contiene un signo de intercalación, se expandirá como un signo de intercalación seguido de un espacio (^ ). ABRE e INSERT realizan una conversión complementaria.


Códigos de grupo HEADER en archivos DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Códigos de grupo HEADER en archivos DXF

    • Las aplicaciones pueden recuperar los valores de estas variables con la función getvar de AutoLISP.

    El siguiente es un ejemplo de la sección HEADER de un archivo DXF™:
    0 SECTION 2 HEADER | Inicio de la sección HEADER
9 $<variable> <código grupo> <valor> | Se repite para cada variable de encabezamiento
0 ENDSEC | Fin de la sección HEADER


Códigos de grupo CLASSES en archivos DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Códigos de grupo CLASSES en archivos DXF

    • El siguiente es un ejemplo de la sección CLASSES de un archivo DXF:
    0 SECTION 2 CLASSES | Inicio de la sección CLASSES
0 CLASS 1 <registro dxf de clase> 2 <nombre clase> 3 <nombre aplicación> 90 <indicador> 280 <indicador> 281 <indicador> | Se repite en cada entrada
0 ENDSEC | Fin de la sección CLASSES


Códigos de grupo de tabla de símbolos en archivos DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Códigos de grupo de tabla de símbolos en archivos DXF

    • El siguiente es un ejemplo de la sección TABLES de un archivo DXF:
    0 SECTION 2 TABLES | Inicio de la sección TABLES
0 TABLE 2 <tipo tabla> 5 <identificador> 100 AcDbSymbolTable 70 <entradas máx.> | Códigos de grupo comunes para tablas; se repiten por cada entrada
0 <tipo tabla> 5 <identificador> 100 AcDbSymbolTableRecord . . <datos> . | Datos de entrada de tabla; se repiten por cada registro de tabla
0 ENDTAB | Fin de la tabla
0 ENDSEC | Fin de la sección TABLES

    Temas de esta sección:

    • Ejemplo de tabla de símbolos


Ejemplo de tabla de símbolos [Manual de referencia de DXF: DXF]

Códigos de grupo de tabla de símbolos en archivos DXF
Ejemplo de tabla de símbolos

    • Esta secuencia de DXF representa tres objetos completos: la propia tabla de símbolos más dos entradas.
    0 |
TABLE | Indica una entrada de tabla de símbolos
2 |
STYLE | Entrada de tabla de símbolos para estilo de texto. Es una excepción a la regla de que el código 0 define completamente el tipo
5 |
1C | Identificador de tabla STYLE; igual que para entidades y otros objetos
70 |
3 | Número máximo de registros de la tabla STYLE que van a seguir (campo anterior a la versión R13)
1001 |
APP_X | APP_X ha introducido datoseX en una tabla de símbolos
1040 |
42.0 | Simplemente un número de coma flotante
0 |
STYLE | Comienzo del primer elemento de la tabla de símbolos STYLE
5 |
3A | El primer identificador de la entrada (las entradas DIMSTYLE serán aquí 105)
2 |
ENTRY_1 | Texto del nombre de la primera entrada
70 |
64 | Valores de indicador estándar
40 |
.4 | Altura de texto
41 |
1.0 | Factor de escala de anchura
50 |
0.0 | Ángulo oblicuo
71 |
0 | Indicadores de generación de texto
42 |
0.4 | Última altura utilizada
3 |
BUFONTS.TXT | Nombre de archivo del tipo de letra principal
0 |
STYLE | Comienzo de la segunda entrada. No hay datoseX ni reactivos permanentes en la primera entrada
5 |
C2 | Identificador de la segunda entrada
2 |
ENTRY_2 | Texto del nombre de la segunda entrada
... |
... | Otros campos que se extienden hasta el código de grupo 3
3 |
BUFONTS.TXT | Nombre de archivo de tipo de letra primario y último tipo de objeto específico del grupo
102 |
{ACAD_REACTORS | Esta entrada tiene dos reactivos permanentes
330 |
3C2 | ID suave para el primer objeto reactivo
330 |
41B | ID suave para el primer objeto reactivo
102 |
} | Indica el final del conjunto de reactivos
1001 |
APP_1 | DatoseX enlazados con esta entrada
1070 |
45 |
1001 |
APP_2 |
1004 |
18A5B3EF2C199A |
0 |
UCS | Comienzo de la tabla UCS (y final de la tabla y el registro anteriores)


Códigos de grupo BLOCKS en archivos DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Códigos de grupo BLOCKS en archivos DXF

    • El siguiente es un ejemplo de la sección BLOCKS de un archivo DXF:
    0 SECTION 2 BLOCKS | Inicio de la sección BLOCKS
0 BLOCK 5 <identificador> 100 AcDbEntity 8 <capa> 100 AcDbBlockBegin 2 <nombre bloque> 70 <indicador> 10 <valor X> 20 <valor Y> 30 <valor Z> 3 <nombre bloque> 1 <ruta refX> | Inicio de cada entrada de bloque (una definición de entidad block)
0 <tipo entidad> . . <datos> . | Una entrada para cada definición de entidad dentro del bloque
0 ENDBLK 5 <identificador> 100 AcDbBlockEnd | Fin de cada entrada de bloque (una definición de entidad endblk)
0 ENDSEC | Fin de la sección BLOCKS


Códigos de grupo ENTITIES en archivos DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Códigos de grupo ENTITIES en archivos DXF

    • El siguiente es un ejemplo de la sección ENTITIES de un archivo DXF:
    0 SECTION 2 ENTITIES | Inicio de la sección ENTITIES
0 <tipo entidad> 5 <identificador> 330 <puntero a propietario> 100 AcDbEntity 8 <capa> 100 AcDb<nombre clase> . . <datos> . | Una entrada por cada definición de entidad
0 ENDSEC | Fin de la sección ENTITIES


Códigos de grupo OBJECTS en archivos DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Códigos de grupo OBJECTS en archivos DXF

    • El siguiente es un ejemplo de la sección OBJECTS de un archivo DXF:
    0 SECTION 2 OBJECTS | Inicio de la sección OBJECTS
0 DICTIONARY 5 <identificador> 100 AcDbDictionary | Inicio de diccionario de objetos guardados (objeto de diccionario raíz)
3 <nombre diccionario> 350 <identificador de subordinado> | Se repite en cada entrada
0 <tipo objeto> . . <datos> . | Grupos de datos de objetos
0 ENDSEC | Fin de la sección OBJECTS


Creación de un programa de interfaz para DXF [Manual de referencia de DXF: DXF]

Archivos DXF ASCII
Creación de un programa de interfaz para DXF

    • Escribir un programa que se comunique con AutoCAD mediante el archivo DXF puede parecer más difícil de lo que es en realidad. El formato DXF ayuda a pasar por alto la información que no se necesita mientras lee la información que sí es necesaria.

    Temas de esta sección:

    • Lectura de un archivo DXF
    • Escritura de un archivo DXF


Lectura de un archivo DXF [Manual de referencia de DXF: DXF]

Creación de un programa de interfaz para DXF
Lectura de un archivo DXF

    • El ejemplo siguiente es un programa sencillo de Visual Basic para leer archivos DXF y extraer códigos y valores específicos de un objeto concreto perteneciente a una sección determinada.

    ' ReadDXF extrae pares de códigos/valores específicos del archivo DXF.
    ' Esta función requiere cuatro parámetros de cadena, un nombre de archivo
    ' DXF válido, un nombre de sección DXF, el nombre de un objeto en dicha
    ' sección y una lista de códigos delimitada por comas.
    '
    Function ReadDXF( _
            ByVal dxfFile As String, ByVal strSection As String, _
            ByVal strObject As String, ByVal strCodeList As String)
        Dim tmpCode, lastObj As String
        Open dxfFile For Input As #1
        ' Obtener primer par código/valor
        codes = ReadCodes
        ' Bucle en archivo hasta llegar a la línea "EOF"
        While codes(1) <> "EOF"
            ' Si el código del grupo es '0' y el valor es 'SECTION' ..
            If codes(0) = "0" And codes(1) = "SECTION" Then
                ' Tiene que ser una nueva sección; obtener el siguiente
                ' par de código/valor.
                codes = ReadCodes()
                ' Si esta sección es la correcta ..
                If codes(1) = strSection Then
                    ' Obtener siguiente par de código/valor y ..
                    codes = ReadCodes
                    ' Bucle en esta sección hasta encontrar 'ENDSEC'
                    While codes(1) <> "ENDSEC"
                        ' Mientras se esté en esta sección, todos los códigos '0' indican
                        ' un objeto. Si se encuentra un '0', almacenar el
                        ' nombre del objeto para su uso futuro.
                        If codes(0) = "0" Then lastObj = codes(1)
                        ' Si éste es el objeto que le interesa ..
                        If lastObj = strObject Then
                            ' Acotar el código mediante comas.
                            tmpCode = "," & codes(0) & ","
                            ' Si este código está en la lista de códigos ..
                            If InStr(strCodeList, tmpCode) Then
                                ' Añadir el valor de devolución.
                                ReadDXF = ReadDXF & _
                                    codes(0) & "=" & codes(1) & vbCrLf
                            End If
                        End If
                        ' Leer otro par de código/valor
                        codes = ReadCodes
                    Wend
                End If
            Else
                codes = ReadCodes
            End If
        Wend
        Close #1
    End Function

    ' ReadCodes lee dos líneas de un archivo abierto y devuelve una matriz de dos

    ' elementos, un código de grupo y su valor. Siempre y cuando un archivo DXF lea

    ' dos líneas al mismo tiempo, todo será correcto. Sin embargo, para que el código

    ' sea más fiable, debe añadir una comprobación rutinaria adicional de

    ' errores y funcionamiento.

    '

    Function ReadCodes() As Variant

        Dim codeStr, valStr As String

        Line Input #1, codeStr

        Line Input #1, valStr

        ' Recortar el espacio a la izquierda y a la derecha del código

        ReadCodes = Array(Trim(codeStr), valStr)

    End Function


Escritura de un archivo DXF [Manual de referencia de DXF: DXF]

Creación de un programa de interfaz para DXF
Escritura de un archivo DXF

    • Elaborar un programa que cree un archivo DXF puede ser más difícil que crear uno que lo lea, ya que siempre es necesario mantener la coherencia dentro del dibujo para que AutoCAD encuentre aceptable el archivo. AutoCAD permite omitir muchos elementos de los archivos DXF y aún así obtener un dibujo utilizable.

    • Se puede omitir la sección HEADER entera si no se definen variables de encabezamiento.
    • Cualquier tabla de la sección TABLES puede omitirse si no es necesario realizar entradas, e incluso la sección completa si no es necesario incluir nada en ella.
    • Si define cualquier tipo de línea en la tabla LTYPE, esta tabla debe preceder a la tabla LAYER.
    • Si en el dibujo no se utilizan definiciones de bloques, se puede omitir la sección BLOCKS.
    • Si existe, la sección BLOCKS debe figurar antes de la sección ENTITIES.
    • Dentro de la sección ENTITIES, puede hacer referencia a nombres de capas aunque éstas no se hayan definido en la tabla LAYER. Estas capas se crean automáticamente con color 7 y el tipo de línea CONTINUA.
    • El elemento EOF debe figurar al final del archivo.

    La siguiente subrutina de Visual Basic crea un archivo DXF que representa un polígono.

    ' WriteDXFPolygon crea un archivo DXF que sólo contiene
    ' la sección ENTITIES. Esta subrutina requiere cinco parámetros,
    ' el nombre del archivo DXF, el número de lados del polígono, las
    ' coordenadas X e Y del extremo inferior del lado situado más a la derecha
    ' (comienza en dirección vertical) y la longitud de cada
    ' lado. Observe que, debido a que sólo se requieren puntos 2D,
    ' no se incluyen coordenadas Z (códigos 30 y 31). Las líneas se
    ' sitúan en la capa "Polígono".
    '
    Sub WriteDXFPolygon( _
            dxfFile As String, iSides As Integer, _
            dblX As Double, dblY As Double, dblLen As Double)
        Dim i As Integer
        Dim dblA1, dblA, dblPI, dblNX, dblNY As Double
        Open dxfFile For Output As #1
        Print #1, 0
        Print #1, "SECTION"
        Print #1, 2
        Print #1, "ENTITIES"
        dblPI = Atn(1) * 4
        dblA1 = (2 * dblPI) / iSides
        dblA = dblPI / 2
        For i = 1 To iSides
            Print #1, 0
            Print #1, "LINE"
            Print #1, 8
            Print #1, "Polygon"
            Print #1, 10
            Print #1, dblX
            Print #1, 20
            Print #1, dblY
            dblNX = dblLen * Cos(dblA) + dblX
            dblNY = dblLen * Sin(dblA) + dblY
            Print #1, 11
            Print #1, dblNX
            Print #1, 21
            Print #1, dblNY
            dblX = dblNX
            dblY = dblNY
            dblA = dblA + dblA1
        Next i
        Print #1, 0
        Print #1, "ENDSEC"
        Print #1, 0
        Print #1, "EOF"
        Close #1
    End Sub

    Siempre y cuando un elemento con formato correcto aparezca en la línea en la que deben estar los datos, CARGADXF lo aceptará. Por supuesto, los elementos de cadena no deben tener espacios a la izquierda a menos que éstos deban formar parte de la cadena. Este programa BASIC aprovecha la flexibilidad del formato de entrada de AutoCAD y no genera un archivo exactamente igual que los generados por AutoCAD.

    En caso de que se produjera un error al utilizar CARGADXF para efectuar la carga, AutoCAD mostrará un mensaje de error indicando su naturaleza, así como la última línea procesada en el archivo DXF antes de la detección del error. Puede ocurrir que dicha línea no sea la misma en la cual se ha producido el error, especialmente en los casos de errores provocados por la omisión de grupos necesarios.


Archivos DXF binarios [Manual de referencia de DXF: DXF]

Formatos de archivo de intercambio de dibujos
Archivos DXF binarios

    • El formato de archivo DXF ASCII es una representación completa en forma de texto ASCII de los dibujos de AutoCAD y se puede procesar fácilmente mediante otros programas. Además, AutoCAD puede crear o leer una forma binaria de la totalidad del archivo DXF y aceptar, con limitaciones, una entrada en otro formato de archivo binario.

    Los comandos GUARDAR y GUARDARCOMO proporcionan una opción Binario para crear archivos DXF binarios. Dichos archivos contienen toda la información presente en el archivo DXF ASCII pero de una forma más compacta, lo que representa un 25 por ciento menos de espacio en disco. AutoCAD los lee y escribe más rápidamente (normalmente, cinco veces más rápido). A diferencia de los archivos DXF ASCII, que conllevan una falta de coordinación entre el tamaño y la precisión de la coma flotante, los archivos DXF binarios mantienen intacta la precisión de la base de datos del dibujo. (AutoCAD Release 10 fue la primera versión que admitía esta forma de archivo DXF. Las versiones anteriores no podían leer este formato.)

    Los archivos DXF binarios comienzan con un centinela de 22 bytes que consta de lo siguiente:

    DXF binario de AutoCAD <CR><LF><SUB><NULL>

    A continuación del centinela figuran los mismos pares (grupo, valor) que en los archivos DXF ASCII, pero en forma binaria. El código de grupo es un valor binario de dos bytes (un byte en los archivos DXF anteriores a la versión R14) y el valor que le sigue puede ser uno de los expuestos a continuación:

    • Un valor entero de 2 bytes con el bit menos significativo en primer lugar y el más significativo a continuación.
    • Un número IEEE de coma flotante de doble precisión con 8 bytes almacenado con el bit menos significativo en primer lugar y el más significativo en último.
    • Una cadena ASCII terminada con un byte 0 (NULO)

    El tipo de datos que figura después de un grupo viene determinado a partir del código de grupo por las mismas reglas utilizadas al decodificar archivos DXF ASCII. En los archivos binarios se realiza una traducción de los ángulos en grados y de las fechas en representaciones de fechas julianas fraccionarias, como ocurre con los archivos DXF ASCII. El grupo de comentarios 999 no se utiliza en los archivos DXF binarios.

    Los códigos de grupos de datos extendidos se representan en el formato DXF binario como un solo byte con el valor 255 seguido por un valor entero de 2 bytes que contiene el código de grupo en sí, precediendo al propio valor.

    Los valores largos de datos extendidos (código de grupo 1071) ocupan 4 bytes de datos. Los bloques binarios de datos extendidos (código de grupo 1004) se representan como un solo byte (longitud de entero sin signo) seguido del número de bytes especificado de datos de bloque. Por ejemplo, para transferir un grupo largo de datos extendidos, aparecerían los siguientes valores, que ocuparían 1, 2 y 4 bytes respectivamente.

    255         Código de grupo de escape
    1071        Código de grupo real
    999999      Valor del código del grupo 1071

    GUARDARCOMO escribe los archivos DXF binarios con el mismo tipo de archivo (.dxf) que los DXF ASCII. Los comandos ABRE e INSERT reconocen automáticamente los archivos binarios gracias a la cadena del centinela. No tiene que identificarlo como un archivo binario.

    Si los comandos ABRE o INSERT detectan un error en un archivo DXF binario, AutoCAD indica la dirección del byte dentro del archivo donde se ha detectado el error.


Archivos de fotos [Manual de referencia de DXF: DXF]

Formatos de archivo de intercambio de dibujos
Archivos de fotos

    • Nota Esta información está dirigida a programadores con experiencia y está sujeta a modificación sin previo aviso.

    Los archivos de fotos de AutoCAD son imágenes de la pantalla creadas mediante el comando SACAFOTO que se pueden leer mediante el comando MIRAFOTO. En esta sección se describe el formato de los archivos de fotos para que los desarrolladores puedan incorporar en sus programas el soporte necesario para las fotos.

    Los archivos de fotos se componen de un encabezamiento (de 31 bytes) y uno o más registros de datos de longitud variable. Todas las coordenadas y tamaños contenidos en el archivo de foto reflejan el área de dibujo del dispositivo de visualización desde el que se ha creado dicha foto, con el punto (0,0) situado en la esquina inferior izquierda del área de dibujo. En AutoCAD Release 9 y versiones posteriores, el encabezamiento de los archivos de fotos consta de los campos siguientes:
    Encabezamiento del archivo de foto
Campo | Bytes | Descripción
Cadena de ID | 17 | "Foto de AutoCAD" CR LF ^Z NUL
Indicador de tipo | 1 | Establecido actualmente en 56 (decimal)
Indicador de nivel | 1 | Establecido actualmente en 2
Punto X máximo | 2 | Anchura del área gráfica: 1, en píxeles
Punto Y máximo | 2 | Altura del área gráfica: 1, en píxeles
Relación anchura/altura | 4 | Relación anchura/altura del área de dibujo (tamaño horizontal/tamaño vertical en pulgadas) a la cual se aplica una escala de 10.000.000. Este valor siempre se escribe con el byte menos significativo en primer lugar.
Relleno duro | 2 | Puede ser 0 o 2 (el valor carece de importancia)
Número de prueba | 2 | Un número (1234 hexadecimal) utilizado para determinar si todos los valores de 2bytes de la foto se han escrito con el byte más significativo en primer lugar (CPU de la familia Intel 8086) o con el byte menos significativo en primer lugar (CPU de la familia Motorola 68000).

    Los registros de datos siguen al encabezamiento. Cada registro de datos comienza con un campo de 2 bytes cuyo byte más significativo es el tipo de registro. El resto del registro puede estar formado por campos de 1 o 2 bytes tal y como se describe en la tabla siguiente. Para determinar si los campos de 2 bytes se escriben en primer lugar con el byte más significativo o con el byte menos significativo, examine el campo Número de prueba del encabezamiento descrito en la tabla anterior.
    Registros de datos del archivo de foto
Tipo de registro (hex) | Bytes | Significado | Descripción
00-7F | 8 | Vector | Coordenada desde-X de un vector ordinario. Le siguen desde-Y, hasta-X y hasta-Y (en ese orden) como valores de 2bytes. El punto desde- se guarda como último punto.
80-FA | — | No definido | Reservado para su posterior utilización
FB | 5 | Vector de desfase | El byte menos significativo y los tres bytes siguientes especifican los puntos finales (desde-X, desde-Y, hasta-X y hasta-Y) de un vector en términos de desfase (–128 a +127) desde el último punto almacenado. El punto desde- ajustado se guarda como último punto para su utilización con los vectores subsiguientes.
FC | 2 | Fin de archivo | El byte menos significativo es 00
FD | 6 | Relleno sólido | El byte menos significativo siempre es cero. Los dos valores de 2 bytes siguientes especifican las coordenadas X e Y de un vértice de un polígono que se debe rellenar con relleno sólido. A continuación sigue una secuencia de entre tres y diez registros de este tipo. Un registro de relleno sólido cuya coordenada Y es negativa indica el comienzo o el fin de dicha secuencia. En el registro inicial, la coordenada X indica el número de registros de vértice que siguen.
FE | 3 | Vector común de punto final | Se trata de un vector que comienza en el último punto. El byte menos significativo y el siguiente especifican los valores hasta-X y hasta-Y en términos de desfase (–128 a +127) desde el último punto almacenado. El punto hasta- ajustado se guarda como último punto para su utilización con los vectores subsiguientes.
FF | 2 | Nuevo color | Los vectores siguientes deben dibujarse utilizando el número del color indicado por el byte menos significativo

    Si alguna foto contiene vectores, el primer registro de datos será el de Nuevo color. El orden de los vectores de una foto y el de los puntos finales de dichos vectores puede variar.

    El ejemplo siguiente es un volcado con notación hexadecimal de un archivo de foto sencillo creado en un equipo PC/AT de IBM equipado con un adaptador de gráficos acelerado (EGA) de IBM. La foto está formada por una línea diagonal blanca que se extiende desde la esquina inferior izquierda a la esquina superior derecha del área de dibujo, una línea vertical verde cercana a la esquina inferior izquierda y un pequeño rectángulo rojo situado en la esquina inferior izquierda.

    41 75 74 6F 43 41            Cadena de ID ("Foto de AutoCAD" CR LF ^Z NUL)
    44 20 53 6C 69 64
    65 0D 0A 1A 00
    56                           Indicador de tipo (56)
    02                           Indicador de nivel (2)
    3C 02                        Punto X máximo (572)
    24 01                        Punto Y máximo (292)
    0B 80 DF 00                  Relación anchura/altura (14,647,307 / 10,000,000 = 1.46)
    02 00                        Relleno duro (2)
    34 12                        Número de prueba (1234 hexadecimal)
    07 FF                        Nuevo color (7 = blanco)
    3C 02 24 01 00 00 00 00      Vector desde 572,292 hasta 0,0. 572,292 se convierte en el "último" punto
    3 FF                         Nuevo color (3 = verde)
    0F 00 32 00 0F 00 13 00      Vector desde 15,50 hasta 15,19. \x1115,50 se convierte en el
                                 "último" punto
    01 FF                        Nuevo color (1 = rojo)
    12 FB E7 12 CE               Vector de desfase desde 15+18,50-25 (33,25) hasta 15+18,
                                 50-50 (33,0). 33,25 se convierte en el "último" punto
    DF FE 00                     Vector de punto final común desde 33,25 hasta 33-33,25+0
                                 (0,25). 0,25 se convierte en el "último" punto
    00 FE E7                     Vector de punto final común desde (0,25) hasta 0+0,25-25
                                 (0,0). 0,0 se convierte en el "último" punto
    21 FE 00                     Vector de punto final común desde (0,0) hasta 0+33,0+0
                                 (33,0).33,0 se convierte en el "último" punto
    00 FC                        Fin de archivo

    Temas de esta sección:

    • Antiguo encabezamiento de foto


Antiguo encabezamiento de foto [Manual de referencia de DXF: DXF]

Archivos de fotos
Antiguo encabezamiento de foto

    • AutoCAD Release 9 y las versiones posteriores producen el formato de foto descrito en la sección anterior. Este formato puede abrirse en todos los equipos que tengan instalada alguna de dichas versiones. En las versiones anteriores de AutoCAD (así como en AutoShade® 1.0 y AutoSketch® 1.02), las fotos se generaban con un encabezamiento algo diferente, como se muestra en la siguiente tabla:
    Antiguo encabezamiento de archivo de foto
Campo | Bytes | Descripción
Cadena de ID | 17 | "Foto de AutoCAD" CR LF ^Z NUL
Indicador de tipo | 1 | 56 (decimal)
Indicador de nivel | 1 | 1 (formato antiguo)
Punto X máximo | 2 | Anchura del área de dibujo: 1, en píxeles
Punto Y máximo | 2 | Altura del área de dibujo: 1, en píxeles
Relación anchura/altura | 8 | Relación anchura/altura del área de dibujo (tamaño horizontal/tamaño vertical en pulgadas); se escribe como un punto de coma flotante
Relleno duro | 2 | Puede ser 0 o 2 (el valor carece de importancia)
Byte de relleno | 1 | No se utiliza

    Observe que la cabecera de formato antiguo no contiene el campo de número de prueba. El valor de la relación anchura/altura de coma flotante y todos los números enteros de 2 bytes se escriben en el formato original de la CPU utilizada para crear el archivo (para CPU de la familia 8086, doble precisión de IEEE y byte menos significativo en primer lugar). Los archivos de fotos con formato antiguo no pueden leerse en todos los equipos, pero sí en cualquier versión de AutoCAD que se ejecute en el mismo tipo de CPU que en el que se creó la foto.


Archivos de fototeca [Manual de referencia de DXF: DXF]

Formatos de archivo de intercambio de dibujos
Archivos de fototeca

    • En esta sección se describe el formato de las fototecas de AutoCAD (R9 y versiones posteriores) para información de los desarrolladores que deseen incorporar soporte para fototecas en sus programas.

    El formato general de una fototeca es el siguiente:

    "Fototeca de AutoCAD 1.0" CR LF ^Z NUL NUL NUL NUL  Encabezamiento (32 bytes)
    Una o más entradas de directorios de fotos (36 bytes cada una)
    Una o más fotos (longitud variable)

    Las entradas de directorios de fotos presentan el siguiente formato:

    Nombre de foto (terminado en NUL) (32 bytes)
    Dirección de la foto dentro del archivo de biblioteca (4 bytes)

    La dirección de la foto siempre se escribe con el byte menos significativo en primer lugar. Cada foto designada por el directorio es un archivo de foto completo, tal y como se ha descrito en la sección anterior. El final del directorio de fotos se señala mediante una entrada con un nombre de foto nulo (el primer byte es NUL). Las fototecas pueden contener una mezcla de fotos con formato antiguo y nuevo.


Conceptos avanzados de DXF [Manual de referencia de DXF: DXF]

Conceptos avanzados de DXF

    • En este apéndice se abordan los conceptos avanzados relativos a los códigos de grupo de DXF™.

    Temas de esta sección:

    • Objetos de base de datos
    • Identificadores permanentes de referencias entre objetos
    • Marcadores Subclass
    • Diccionario de extensiones y reactivos permanentes
    • Datos extendidos
    • Sistema de coordenadas de objeto (SCO)
    • Algoritmo de ejes arbitrarios


Objetos de base de datos [Manual de referencia de DXF: DXF]

Conceptos avanzados de DXF
Objetos de base de datos

    • Los dibujos de AutoCAD® constan de contenedores altamente estructurados de objetos de base de datos. Cada objeto de base de datos dispone de las siguientes características:

    • Un identificador con valor exclusivo en el archivo de dibujo/DXF y constante para toda la existencia del dibujo. Este formato existe desde AutoCAD Release 10, y en lo que concierne a AutoCAD Release 13, los identificadores siempre se encuentran activados.
    • Una tabla de datoseX opcional, tal como la han tenido las entidades a partir de AutoCAD Release 11.
    • Una tabla opcional de reactivos permanentes.
    • Un dispositivo señalador opcional de propiedad a un diccionario de extensiones que, a su vez, posee subobjetos colocados en él por una aplicación.

    Las tablas de símbolos y sus registros son objetos de base de datos y, como tales, poseen un identificador. Asimismo, en sus registros DXF pueden disponer de datoseX y reactivos permanentes.


Identificadores permanentes de referencias entre objetos [Manual de referencia de DXF: DXF]

Conceptos avanzados de DXF
Identificadores permanentes de referencias entre objetos

    • Un conjunto de rangos de códigos de grupo permite a los objetos especificar directamente referencias a otros objetos contenidos en el mismo archivo de dibujo/DXF. Se facilitan cuatro rangos para los cuatro tipos de identificadores de referencia que pueden especificarse:

    • Identificador suave de dispositivo señalador
    • Identificador duro de dispositivo señalador
    • Identificador suave de propietario
    • Identificador duro de propietario

    Estos tipos de identificadores se muestran como nombres de entidad de AutoLISP®, como valores nombre_ads de ObjectARX™ y como clases con nombres similares derivadas de ObjectARX. Estos valores se mantienen siempre en las operaciones de inserción, refX y bloquedisc, de tal forma que las referencias establecidas entre objetos en un conjunto que se esté copiando se actualizan para que señalen a los objetos copiados, mientras que las referencias establecidas con otros objetos permanecen inalteradas.

    Asimismo, se define un rango de códigos de grupo para identificadores "arbitrarios" con el fin de permitir un almacenamiento adecuado de valores de identificación que no se convierten en nombres de entidades para después traducirse en operadores de inserción, refX o bloquedisc.

    Nota Si utiliza códigos de grupo de datoseX 1005 para almacenar identificadores, se tratarán como identificadores suaves de dispositivo señalador, lo que significa que cuando se copien o inserten grupos de objetos en otro dibujo, se traducirán las referencias entre los objetos involucrados. Pese a que los elementos de datoseX 1005 siempre se devuelven como identificadores de AutoLISP y ObjectARX, todos los rangos de códigos de grupo de los identificadores de referencia se representan como "nombres de entidad" en AutoLISP y como estructuras "nombre_ads" en ObjectARX.

    Temas de esta sección:

    • Referencias de dispositivo señalador y de propietario
    • Referencias duras y suaves
    • Indicadores arbitrarios
    • Códigos de grupo 1005


Referencias de dispositivo señalador y de propietario [Manual de referencia de DXF: DXF]

Identificadores permanentes de referencias entre objetos
Referencias de dispositivo señalador y de propietario

    • Un dispositivo señalador es una referencia que indica uso, pero no posesión ni responsabilidad, sobre otro objeto. Una referencia de dispositivo señalador significa que el objeto utiliza de alguna manera el otro objeto y comparte el acceso al mismo.

    Una referencia de propiedad significa que el objeto propietario es responsable de los objetos para los cuales posee identificador de propiedad. Las referencias de propiedad dirigen la escritura de la totalidad de los archivos DWG y DXF de forma genérica como, por ejemplo, comenzar a partir de unos pocos objetos raíz de clave.

    Un objeto puede tener cualquier número de referencias de dispositivo señalador asociadas, pero sólo puede contar con un propietario.


Referencias duras y suaves [Manual de referencia de DXF: DXF]

Identificadores permanentes de referencias entre objetos
Referencias duras y suaves

    • Las referencias duras, ya sean de dispositivo señalador o de propietario, impiden que los objetos sean depurados. Las referencias suaves no procuran tal impedimento.

    En AutoCAD, las definiciones de bloque y las entidades complejas son propietarios duros de sus elementos. Por su parte, las tablas de símbolos y los diccionarios son propietarios suaves de sus elementos. Las entidades de polilínea son propietarios duros de sus entidades de VERTEX y SEQEND. Las entidades de inserción son propietarios duros de sus entidades de ATTRIB y SEQEND.

    Cuando se esté estableciendo una referencia a otro objeto, es recomendable que se considere si la referencia debería proteger al objeto contra el comando LIMPIA.


Indicadores arbitrarios [Manual de referencia de DXF: DXF]

Identificadores permanentes de referencias entre objetos
Indicadores arbitrarios

    • Los identificadores arbitrarios son distintos, puesto que no se traducen internamente a identificadores de sesión permanentes, a nombres de entidad de AutoLISP, etc. Se almacenan como identificadores. Cuando los valores de identificador se traducen en operaciones de fusión de dibujos, se ignoran los identificadores arbitrarios.

    En todos los entornos, los identificadores arbitrarios pueden intercambiarse por nombres de entidad del dibujo actual mediante las funciones handent. Es habitual utilizar los identificadores arbitrarios para referirse a los objetos contenidos en archivos DXF y DWG externos.


Códigos de grupo 1005 [Manual de referencia de DXF: DXF]

Identificadores permanentes de referencias entre objetos
Códigos de grupo 1005

    • Los códigos de grupo de datoseX 1005 tienen el mismo comportamiento y poseen la misma semántica que los dispositivos señaladores suaves, lo que significa que se traducen cada vez que el objeto principal se fusiona en un dibujo distinto. Sin embargo, los elementos 1005 no se traducen a identificadores permanentes de la sesión ni a nombres de entidad internos de AutoLISP y ObjectARX. Se almacenan como identificadores.


Marcadores Subclass [Manual de referencia de DXF: DXF]

Conceptos avanzados de DXF
Marcadores Subclass

    • Cuando se archiva una serie de datos de grupo, un único objeto puede estar compuesto por varios miembros archivadores, uno por cada nivel de herencia donde se realiza el archivado. Dado que las clases y niveles de herencia derivados pueden evolucionar por separado, los datos de cada miembro de archivador de clase deben separarse de los demás miembros. Esto se consigue utilizando marcadores Subclass.

    Se espera que todos los miembros de archivadores de clase precedan a la parte específica de su clase de datos de muestra con un marcador de "subclase" (es decir, un código de grupo 100 seguido de una cadena con el nombre real de la clase). Esto no afecta al estado necesario para definir el estado del objeto, pero proporciona un medio para que los analizadores de archivos DXF dirijan los códigos de grupo al software de aplicación que corresponda.

    Por ejemplo, un objeto que posea datos de distintas clases derivadas se representaría de la siguiente forma:

    999
    FOOGRANDCHILD, definido por la clase AcDbSonOfSonOfFoo, donde
    999
     se deriva de AcDbSonOfFoo
      0
    FOOGRANDCHILD
      5
    C2
    100
    AcDbFoo
    999
    Utiliza códigos de grupo 10/20/30
     10
    1.1
     20
    2.3
     30
    7.3
    100
    AcDbSonOfFoo
    999
    También utiliza códigos de grupo 10/20/30, para un propósito diferente
     10
    1.1
     20
    2.3
     30
    7.3
    100
    AcDbSonOfSonOfFoo
    999
    También utiliza códigos de grupo 10/20/30, para otro propósito
     10
    13.2
     20
    23.1
     30
    31.2
    999
    Ahora para los datoseX
    1001
    APP_1
    1070
    45
    1001
    APP_2
    1004
    18A5B3EF2C199A


Diccionario de extensiones y reactivos permanentes [Manual de referencia de DXF: DXF]

Conceptos avanzados de DXF
Diccionario de extensiones y reactivos permanentes

    • El diccionario de extensiones es una secuencia opcional que almacena el identificador de un objeto de diccionario perteneciente al objeto actual, el cual, por su parte, puede contener entradas. Esta función permite el enlace de objetos arbitrarios de base de datos con cualquier objeto de base de datos. Cualquier objeto o entidad puede contar con esta sección.

    Los reactivos permanentes son una secuencia opcional que almacena los identificadores de objetos que se registran a sí mismos como reactivos en el objeto actual. Cualquier objeto o entidad puede contar con esta sección.


Datos extendidos [Manual de referencia de DXF: DXF]

Conceptos avanzados de DXF
Datos extendidos

    • Los datos extendidos (datoseX) se crean con las aplicaciones AutoLISP y ObjectARX. Si una entidad contiene datos extendidos, figurarán a continuación de los de definición normal de la entidad. Los códigos de grupo comprendidos entre 1000 y 1071 describen los datos extendidos. El siguiente es un ejemplo de entidad con datos extendidos en formato DXF.

    Datos de definición de entidad normales:

      0
    INSERT
      5
    F11
    100
    AcDbEntity
      8
    TOP
    100
    AcDbBlockReference
     2
    BLOCK_A
     10
    0.0
     20
    0.0
     30
    0.0

    Datos de definición de entidad extendidos:

    1001
    AME_SOL
    1002
    {
    1070
     0
    1071
     1.95059E+06
    1070
     519
    1010
    2.54717
    1020
    2.122642
    1030
    2.049201
    1005
    ECD
    1005
    EE9
    1005
    0
    1040
    0.0
    1040
    1.0
    1000
    MILD_STEEL

    El código de grupo 1001 indica el comienzo de los datos extendidos. Frente a los datos de entidad normales, en el caso de datos extendidos un mismo código de grupo puede aparecer varias veces y el orden es significativo.

    Los datos extendidos se agrupan por el nombre registrado de la aplicación. Cada grupo de aplicación registrada comienza con un código de grupo 1001, con el nombre de aplicación como valor de la cadena. Los nombres de registro de las aplicaciones corresponden a las entradas de la tabla de símbolos APPID.

    Una aplicación puede utilizar tantos nombres de APPID como sean necesarios. Los nombres APPID son permanentes, aunque pueden suprimirse cuando no se utilicen en el dibujo. Cada nombre APPID no puede tener más de un grupo de datos enlazado con cada entidad. Dentro de un grupo de aplicación, es la propia aplicación la que define la secuencia de grupos de datos extendidos y su significado.

    La siguiente tabla muestra los códigos de grupos de datos extendidos.

    Códigos de grupo de datos extendidos y sus descripciones

    Nombre de entidad

    Código de grupo

    Descripción

    Cadena

    1000

    Las cadenas de datos extendidos pueden tener hasta 255 bytes de longitud (estando reservado el byte 256 para el carácter nulo)

    Nombre de aplicación

    1001
    también un valor de cadena

    Los nombres de aplicación pueden tener hasta 31 bytes de longitud (el byte 32 está reservado para el carácter nulo).

    Nota No añada un grupo 1001 a los datos extendidos porque AutoCAD interpretará que es el comienzo de un nuevo grupo de datos extendidos de la aplicación.

    Cadena de control

    1002

    Las cadenas de control de datos extendidos pueden ser "{"o "}". Estas llaves permiten a la aplicación distribuir los datos en listas. La llave de apertura marca el inicio de una lista y la de cierre termina la última lista. Las listas pueden estar anidadas.

    Cuando AutoCAD lee los datos extendidos para una aplicación concreta, comprueba que todas las llaves de apertura tengan su correspondiente llave de cierre.

    Nombre de capa

    1003

    Nombre de la capa asociada con los datos extendidos

    Datos binarios

    1004

    Los datos binarios se organizan en bloques de longitud variable. La longitud máxima de cada bloque es de 127 bytes. En los archivos DXF ASCII, los datos binarios se representan como una cadena de dígitos hexadecimales, dos por byte binario.

    Identificador de base de datos

    1005

    Identificadores de entidades en la base de datos de dibujo

    Nota Cuando un dibujo con identificadores e identificadores de datos extendidos se importa en otro dibujo con INSERT, INSERT *, Unir REFX, UNIRX o ABRE parcialmente, los identificadores de datos extendidos se traducen de la misma manera que sus identificadores de entidades correspondientes, conservando así su unión. Esto también se hace en la operación de descomposición de bloques o en cualquier otra operación de AutoCAD. Cuando REVISION detecta un identificador de datos extendidos que no coincide con el identificador de una entidad del archivo de dibujo, se considera un error. Si REVISION fija las entidades, establece el identificador en 0.

    3 valores reales

    1010, 1020, 1030

    Tres valores reales, en el orden X, Y, Z. Pueden tomarse como registro de punto o vector. AutoCAD nunca modifica sus valores.

    Posición universal

    1011, 1021, 1031

    A diferencia de un simple punto 3D, las coordenadas universales se mueven, se giran, se les aplican escalas o se reflejan junto con la entidad original a la cual pertenecen los datos extendidos. La posición universal también se puede estirar cuando se aplica el comando ESTIRA a la entidad original y este punto se encuentra dentro de la ventana de selección.

    Desplazamiento universal

    1012, 1022, 1032

    También un punto 3D al que se aplica una escala, que se gira y que se refleja junto con la entidad original (pero no se mueve ni se estira)

    Dirección real

    1013, 1023, 1033

    Es también un punto 3D que se gira y se refleja junto con la entidad original (pero no se mueve ni se estira ni se le aplica ninguna escala)

    Real

    1040

    Un valor real.

    Distancia

    1041

    Valor real al que se aplica una escala junto con la entidad original

    Factor de escala

    1042

    También un valor real al que se aplica una escala junto con la entidad original. La diferencia entre una distancia y un factor de escala la define la aplicación.

    Entero

    1070

    Valor entero de 16 bits (con signo o sin él)

    Largo

    1071

    Valor entero de 32 bits con signo (largo)


Sistema de coordenadas de objeto (SCO) [Manual de referencia de DXF: DXF]

Conceptos avanzados de DXF
Sistema de coordenadas de objeto (SCO)

    • Para ahorrar espacio en la base de datos de dibujo (así como en el archivo DXF), los puntos asociados con cada entidad se expresan según el propio sistema de coordenadas de objeto de la entidad (SCO). Mediante el SCO, la única información adicional necesaria para describir la posición de la entidad en el espacio tridimensional es el vector 3D que describe el eje Z del SCO y el valor de elevación.

    Para una dirección (o extrusión) determinada del eje Z, existe un número infinito de sistemas de coordenadas que se definen traduciendo el origen en el espacio tridimensional y girando los ejes X e Y en torno al eje Z. Sin embargo, para la misma dirección del eje Z sólo existe un sistema de coordenadas de objeto. Dicho sistema tiene las siguientes propiedades:

    • Su origen coincide con el del SCU.
    • La orientación de los ejes X e Y en el plano XY se calcula mediante un procedimiento arbitrario pero coherente. AutoCAD realiza este cálculo utilizando el algoritmo de ejes arbitrarios (véase Algoritmo de ejes arbitrarios).

    En algunas entidades, el SCO es equivalente al SCU y todos los puntos (grupos DXF 10–37) se expresan en coordenadas universales. Véase la tabla siguiente.
    Sistemas de coordenadas asociados a un tipo de entidad
Entidades | Notas
Entidades 3D como líneas, puntos, caras 3D, polilíneas 3D, vértices 3D, mallas 3D y vértices de mallas 3D | Estas entidades no residen en un plano determinado. Todos los puntos se expresan en coordenadas universales. De estas entidades sólo pueden extruirse las líneas y los puntos. Su dirección de extrusión puede ser distinta del eje Z universal.
Entidades 2D, como círculos, arcos, sólidos, trazos, texto, atributos, definiciones de atributo, formas, inserciones, polilíneas 2D, vértices 2D, polilíneas optimizadas, sombreados e imágenes | Estas entidades son planas por naturaleza. Todos los puntos se expresan en coordenadas de objeto. Estas entidades pueden extruirse. Su dirección de extrusión puede ser distinta del eje Z universal.
Cotas | Algunos de los puntos de las cotas se expresan en el SCU y otros en el SCO.
Ventana gráfica | Expresada en coordenadas universales

    Una vez que AutoCAD haya establecido el SCO para una entidad determinada, este sistema funciona del modo siguiente: El valor de elevación almacenado con la entidad indica hasta dónde debe desplazarse el plano XY a lo largo del eje Z (desde el origen del SCU) para hacerlo coincidir con el plano que contiene la entidad. Es del todo irrelevante saber qué parte se debe a la intervención del usuario al definir esta elevación.

    Todos los puntos bidimensionales especificados a través del SCP se convierten en los puntos 2D correspondientes del SCO, el cual se desplaza y gira con respecto al SCP.

    Existen algunas ramificaciones de este proceso:

    • No es posible conocer con exactitud qué SCP estaba en vigor cuando se obtuvo la entidad.
    • Cuando se indican las coordenadas XY de una entidad en un SCP determinado y posteriormente se realiza una operación GUARDARCOMO, probablemente no se podrán reconocer dichas coordenadas en el archivo DXF. Es necesario conocer el método utilizado por AutoCAD para calcular los ejes X e Y para poder trabajar con estos valores.
    • El valor de elevación almacenado con una entidad y una salida en los archivos DXF es la suma de la diferencia de la coordenada Z entre el plano XY del SCP, el plano XY del SCO y el valor de elevación especificado por el usuario cuando se dibujó la entidad.


Algoritmo de ejes arbitrarios [Manual de referencia de DXF: DXF]

Conceptos avanzados de DXF
Algoritmo de ejes arbitrarios

    • AutoCAD utiliza el algoritmo de ejes arbitrarios internamente para llevar a cabo la generación arbitraria pero coherente de sistemas de coordenadas de objeto para todas las entidades que utilizan este tipo de coordenadas.

    Ante un vector de longitud de unidad que se utiliza como eje Z de un sistema de coordenadas, el algoritmo de ejes arbitrarios generará el eje X correspondiente del sistema de coordenadas. El eje Y se define según la regla de la mano derecha.

    El método se utiliza para examinar el eje Z dado (también denominado vector normal). Si está próximo al eje Z universal positivo o negativo, interseque el eje Y universal con el eje Z dado para llegar hasta el eje X arbitrario. En caso contrario, interseque el eje Z universal con el eje Z dado para llegar hasta el eje X arbitrario. El límite en el que se toma la decisión se eligió de forma que fuera sencillo de calcular y totalmente transferible entre máquinas. Esto se consigue utilizando una especie de casquete polar "cuadrado", con unos límites de 1/64, que pueden especificarse de forma precisa en fracciones decimales de seis dígitos y en fracciones binarias de seis bits.

    El algoritmo realiza lo siguiente (se da por supuesto que todos los vectores están en espacio tridimensional y precisados en el sistema de coordenadas universales):

    Sea N el vector normal especificado.
    Sea Wy el eje Y universal, que siempre es (0,1,0).
    Sea Wz el eje Z universal, que siempre es (0,0,1).

    Lo que se pretende es que los ejes arbitrarios X e Y vayan con la normal N. Estos ejes se denominarán Ax y Ay. N también podría llamarse Az (el eje Z arbitrario), según se indica a continuación:

    Si (abs (Nx) < 1/64) y (abs (Ny) < 1/64)  entonces
         Ax = Wy X N  (donde "X" es el operador entre productos).
    En caso contrario,
         Ax = Wz X N.
    Atribuir una escala a Ax en la longitud de la unidad.

    El método para obtener el vector Ay es como se indica a continuación:

    Ay = N X Ax.  Atribuir una escala a Ay en la longitud de la unidad.


Comentarios

Mediante este formulario podrá enviar sus comentarios al grupo Autodesk Technical Publications, responsable de la publicación de esta documentación.

Título del tema y ubicación (sin modificar):
Nombre (opcional):
         Correo electrónico (opcional):
Comentarios:

Nota: este formulario no se ha creado para que usted reciba comentarios o asistencia técnica. La información que nos proporcione se utilizará para mejorar las próximas actualizaciones que se lleven a cabo en la documentación. ¡Gracias!


Consejos para las búsquedas

Los siguientes consejos le pueden ayudar a obtener resultados más útiles en sus consultas.

  • Filtre la búsqueda seleccionando sólo aquellos componentes de la documentación en los que haya más probabilidades de que se encuentre el tipo de información que esté buscando. Seleccione un libro o un conjunto de libros de la lista de elementos de documentación para buscar.
  • Asegúrese de que la pregunta no contiene errores tipográficos. Es posible que las palabras más importantes se pasen por alto si éstas no se pueden reconocer.
  • Escriba su consulta en forma de pregunta (¿Cómo se desactivan los cuadros de diálogo?), de locución (desactivación de diálogos) o de palabra clave (diálogos). En cada uno de estos casos se obtendrán resultados ligeramente distintos.
  • Escriba menos palabras. Con frecuencia, al emplear menos palabras se obtienen mejores resultados.
    Por ejemplo, máximo de ventanas dará como resultado una lista de temas diferentes a los encontrados con ¿Cómo se puede incrementar el número máximo de ventanas visibles?
  • Ordene las palabras de modo distinto. El orden de las palabras puede influir en los resultados.
    Por ejemplo, número máximo de ventanas se interpreta de forma distinta a número de ventanas máximo.
  • Utilice palabras o términos diferentes, aunque relacionados, en las consultas.
    Por ejemplo, dibujar círculos mostrará temas ligeramente diferentes a los que encontrará crear círculos.
    Del mismpo modo, si busca cuadros de diálogo, encontrará temas distintos que si busca diálogos.
  • No utilice signos de puntuación. Use la ficha Búsqueda si necesita encontrar términos que incluyan signos de puntuación.
    Por ejemplo, al introducir nombres de archivos tales como acad.pat, se podrían obtener resultados poco fiables.
  • No escriba palabras que contengan números.
    Por ejemplo, si incluye 3D en un término, los resultados pueden ser poco fiables. La búsqueda será más precisa si desarrolla el término con la palabra tridimensional.
  • No escriba palabras que aparezcan con mucha frecuencia en los temas de ayuda.
    Por ejemplo, si introduce dibujo o línea, probablemente desviará los resultados. Elimine estas palabras de la consulta o combínelas con otras más específicas.


zz [Tema en blanco]

Tema en blanco

Este tema se dejó en blanco intencionadamente.